]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
7a9fe7f5a12ca0eba7315b2f613363dd682d0abd
[packages/inkscape.git] / inkscape.spec
1 #
2 # Conditional build
3 %bcond_with     dbus            # DBus interface
4 %bcond_with     gtk3            # GTK+ 3 interface [experimental]
5 %bcond_without  gnomevfs        # Don't use gnome vfs for loading files
6 %bcond_with     relocation      # Enable binary relocation support
7 #
8
9 Summary:        Scalable vector graphics editor
10 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
11 Name:           inkscape
12 Version:        0.92.4
13 Release:        1
14 License:        GPL v2+, LGPL v2.1+
15 Group:          X11/Applications/Graphics
16 # download: follow https://inkscape.org/release/
17 Source0:        https://media.inkscape.org/dl/resources/file/%{name}-%{version}.tar.bz2
18 # Source0-md5:  ac30f6d5747fd9c620c00dad500f414f
19 Patch0:         %{name}-man.patch
20 Patch1:         %{name}-gtk3.patch
21 # https://gitlab.com/inkscape/inkscape/commit/e831b034746f8dc3c3c1b88372751f6dcb974831.patch
22 Patch2:         %{name}-poppler0.76.patch
23 # https://gitlab.com/inkscape/inkscape/merge_requests/986.patch
24 Patch3:         %{name}-poppler0.82.patch
25 Patch4:         %{name}-poppler0.83.patch
26 URL:            https://inkscape.org/
27 BuildRequires:  ImageMagick-c++-devel
28 BuildRequires:  aspell-devel
29 BuildRequires:  autoconf >= 2.64
30 BuildRequires:  automake >= 1:1.9.4-2
31 BuildRequires:  boost-devel >= 1.36
32 BuildRequires:  cairo-devel >= 1.10
33 BuildRequires:  cairomm-devel >= 1.9.8
34 %{?with_dbus:BuildRequires:     dbus-glib-devel}
35 BuildRequires:  freetype-devel >= 2.0
36 BuildRequires:  gc-devel >= 7.2
37 BuildRequires:  gettext-tools >= 0.17
38 BuildRequires:  glib2-devel >= 1:2.28
39 BuildRequires:  glibmm-devel >= 2.28
40 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.15.2}
41 BuildRequires:  gsl-devel
42 BuildRequires:  intltool >= 0.40.0
43 BuildRequires:  lcms2-devel >= 2
44 BuildRequires:  libcdr-devel >= 0.1
45 BuildRequires:  libexif-devel
46 BuildRequires:  libgomp-devel
47 BuildRequires:  libjpeg-devel
48 BuildRequires:  libpng-devel >= 1.2
49 BuildRequires:  librevenge-devel
50 BuildRequires:  libsigc++-devel >= 2.0.17
51 BuildRequires:  libstdc++-devel >= 6:4.7
52 BuildRequires:  libtool >= 2:2.2
53 BuildRequires:  libvisio-devel >= 0.1
54 BuildRequires:  libwpd-devel >= 0.9
55 BuildRequires:  libwpg-devel >= 0.3
56 BuildRequires:  libxml2-devel >= 1:2.6.26
57 BuildRequires:  libxslt-devel >= 1.1.17
58 BuildRequires:  pango-devel >= 1:1.24
59 BuildRequires:  pkgconfig
60 BuildRequires:  poppler-glib-devel >= 0.29.0
61 BuildRequires:  popt-devel
62 BuildRequires:  potrace-devel
63 BuildRequires:  rpm-pythonprov
64 BuildRequires:  sed >= 4.0
65 BuildRequires:  zlib-devel
66 %if %{with gtk3}
67 BuildRequires:  gdl-devel >= 3.6
68 BuildRequires:  gtk+3-devel >= 3.8
69 BuildRequires:  gtkmm3-devel >= 3.10
70 BuildRequires:  gtkspell3-devel >= 3.0
71 %else
72 BuildRequires:  gtk+2-devel >= 2:2.24
73 BuildRequires:  gtkmm-devel >= 2.24
74 BuildRequires:  gtkspell-devel >= 2.0.11
75 %endif
76 Requires(post,postun):  desktop-file-utils
77 Requires:       cairo >= 1.10
78 Requires:       cairomm >= 1.9.8
79 Requires:       gc >= 7.2
80 Requires:       glib2 >= 1:2.28
81 Requires:       glibmm >= 2.28
82 %{?with_gnomevfs:Requires:      gnome-vfs2 >= 2.15.2}
83 Requires:       libsigc++ >= 2.0.17
84 Requires:       libxml2 >= 1:2.6.26
85 Requires:       libxslt >= 1.1.17
86 Requires:       pango >= 1:1.24
87 Requires:       perl-XML-XQL
88 Requires:       poppler-glib >= 0.29.0
89 %if %{with gtk3}
90 Requires:       gdl >= 3.6
91 Requires:       gtk+3 >= 3.8
92 Requires:       gtkmm3 >= 3.10
93 %else
94 Requires:       gtk+2 >= 2:2.24
95 Requires:       gtkmm >= 2.24
96 Requires:       gtkspell >= 2.0.11
97 %endif
98 Suggests:       python-lxml
99 # sr@Latn vs. sr@latin
100 Conflicts:      glibc-misc < 6:2.7
101 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103 %description
104 Inkscape is a program for viewing, making, and editing two-dimensional
105 vector drawings.
106
107 %description -l pl.UTF-8
108 Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
109 dwuwymiarowej grafiki wektorowej.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114 %patch1 -p1
115 %patch2 -p1
116 %patch3 -p1
117 %patch4 -p1
118
119 %{__sed} -i -e 's,po/Makefile.in,,' configure.ac
120
121
122 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
123       CMakeScripts/cmake_consistency_check.py \
124       buildtools/msys2checkdeps.py \
125       cxxtest/cxxtestgen.py \
126       packaging/scripts/lp-mark-bugs-released \
127       packaging/wix/*.py \
128       share/extensions/*.py \
129       share/extensions/*/*.py \
130       share/*/i18n.py
131
132 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+ruby(\s|$),#!%{__ruby}\1,' \
133       share/extensions/*.rb
134
135 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+perl(\s|$),#!%{__perl}\1,' \
136       share/attributes/genMapDataCSS.pl \
137       share/attributes/genMapDataSVG.pl
138
139 %build
140 %{__libtoolize}
141 %{__gettextize}
142 %{__intltoolize}
143 %{__aclocal}
144 %{__autoconf}
145 %{__autoheader}
146 %{__automake}
147 # deprecated TimeVal API is used, so --disable-strict-build is needed
148 %configure \
149         %{?with_relocation:--enable-binreloc} \
150         %{?with_dbus:--enable-dbusapi} \
151         %{?with_gtk3:--enable-gtk3-experimental} \
152         --disable-silent-rules \
153         --disable-strict-build \
154         %{!?with_gnomevfs:--without-gnome-vfs}
155
156 %{__make}
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 # localized manuals cleanup
165 for manlang in de el fr ja sk zh_TW ; do
166         %{__mv} $RPM_BUILD_ROOT%{_mandir}/${manlang}/man1/{inkscape.${manlang}.1,inkscape.1}
167         %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/inkscape.${manlang}.1
168 done
169
170 # unify locale name, overwrite outdated bn
171 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{bn_BD,bn}/LC_MESSAGES/inkscape.mo
172 # joke language, unsupported
173 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en_US@piglatin
174 # unify names
175 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{ks@aran,ks}
176 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{ks@deva,ks@devanagari}
177 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sd@deva,sd@devanagari}
178 # unsupported variants
179 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{kok@latin,mni@beng,sat@deva}
180
181 %find_lang %{name}
182
183 %clean
184 rm -rf $RPM_BUILD_ROOT
185
186 %post
187 %update_desktop_database_post
188
189 %postun
190 %update_desktop_database_postun
191
192 %files -f %{name}.lang
193 %defattr(644,root,root,755)
194 %doc AUTHORS ChangeLog NEWS README TRANSLATORS doc/HACKING.txt
195 %lang(ca) %doc README.ca.txt
196 %lang(de) %doc README.de.txt doc/HACKING.de.txt
197 %lang(es) %doc README.es.txt
198 %lang(fr) %doc README.fr.txt doc/HACKING.fr.txt
199 %lang(it) %doc README.it.txt doc/HACKING.it.txt
200 %lang(pt_BR) %doc README.pt_BR.txt doc/HACKING.pt_BR.txt
201 %lang(sk) %doc README.sk.txt
202 %lang(sr) %doc README.sr.txt
203 %attr(755,root,root) %{_bindir}/inkscape
204 %attr(755,root,root) %{_bindir}/inkview
205 %dir %{_datadir}/inkscape
206 %{_datadir}/inkscape/[!e]*
207 %{_datadir}/inkscape/examples
208 %dir %{_datadir}/inkscape/extensions
209 %dir %{_datadir}/inkscape/extensions/Barcode
210 %attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
211 %{_datadir}/inkscape/extensions/Poly3DObjects
212 %{_datadir}/inkscape/extensions/alphabet_soup
213 %dir %{_datadir}/inkscape/extensions/ink2canvas
214 %attr(755,root,root) %{_datadir}/inkscape/extensions/ink2canvas/*.py
215 %{_datadir}/inkscape/extensions/test
216 %{_datadir}/inkscape/extensions/xaml2svg
217 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
218 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
219 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
220 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
221 %{_datadir}/inkscape/extensions/*.inx
222 %{_datadir}/inkscape/extensions/*.js
223 %{_datadir}/inkscape/extensions/*.svg
224 %{_datadir}/inkscape/extensions/*.xml
225 %{_datadir}/inkscape/extensions/*.xsl
226 %{_datadir}/inkscape/extensions/*.xslt
227 %{_datadir}/inkscape/extensions/fontfix.conf
228 %{_datadir}/inkscape/extensions/inkscape.extension.rng
229 %{_datadir}/appdata/inkscape.appdata.xml
230 %{_iconsdir}/hicolor/*/apps/inkscape.png
231 %{_desktopdir}/inkscape.desktop
232 %{_mandir}/man1/inkscape.1*
233 %{_mandir}/man1/inkview.1*
234 %lang(de) %{_mandir}/de/man1/inkscape.1*
235 %lang(el) %{_mandir}/el/man1/inkscape.1*
236 %lang(fr) %{_mandir}/fr/man1/inkscape.1*
237 %lang(ja) %{_mandir}/ja/man1/inkscape.1*
238 %lang(sk) %{_mandir}/sk/man1/inkscape.1*
239 %lang(zh_TW) %{_mandir}/zh_TW/man1/inkscape.1*
This page took 0.050229 seconds and 2 git commands to generate.