]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
6c57dc0de8dbfe36174f8f4b854d327fa1e27993
[packages/inkscape.git] / inkscape.spec
1 #
2 # Conditional build
3 %bcond_with     dbus            # DBus interface
4 %bcond_with     relocation      # Enable binary relocation support
5 %bcond_with     imagick         # ImageMagick 6.x instead of GraphicsMagick
6 #
7
8 Summary:        Scalable vector graphics editor
9 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
10 Name:           inkscape
11 Version:        1.0.1
12 Release:        1
13 License:        GPL v2+, LGPL v2.1+
14 Group:          X11/Applications/Graphics
15 # download: follow https://inkscape.org/release/
16 Source0:        https://media.inkscape.org/dl/resources/file/%{name}-%{version}.tar.xz
17 # Source0-md5:  daefc5212b72e49eff41a7681fd5e993
18 URL:            https://inkscape.org/
19 %{!?with_imagick:BuildRequires: GraphicsMagick-c++-devel}
20 %{?with_imagick:BuildRequires:  ImageMagick6-c++-devel < 7}
21 BuildRequires:  aspell-devel
22 BuildRequires:  boost-devel >= 1.36
23 BuildRequires:  cairo-devel >= 1.10
24 BuildRequires:  cairomm-devel >= 1.9.8
25 BuildRequires:  cmake >= 3.1.0
26 %if %{with dbus}
27 BuildRequires:  dbus-devel
28 BuildRequires:  dbus-glib-devel
29 %endif
30 BuildRequires:  double-conversion-devel
31 BuildRequires:  fontconfig-devel
32 BuildRequires:  freetype-devel >= 2.0
33 BuildRequires:  gc-devel >= 7.2
34 BuildRequires:  gdl-devel >= 3.6
35 BuildRequires:  gettext-tools >= 0.17
36 BuildRequires:  glib2-devel >= 1:2.28
37 BuildRequires:  glibmm-devel >= 2.28
38 BuildRequires:  gsl-devel
39 BuildRequires:  gtk+3-devel >= 3.22
40 BuildRequires:  gtkmm3-devel >= 3.22
41 BuildRequires:  gtkspell3-devel >= 3.0
42 BuildRequires:  harfbuzz-devel
43 BuildRequires:  lcms2-devel >= 2
44 BuildRequires:  libcdr-devel >= 0.1
45 BuildRequires:  libexif-devel
46 BuildRequires:  libgomp-devel
47 BuildRequires:  libjpeg-devel
48 BuildRequires:  libpng-devel >= 1.2
49 BuildRequires:  librevenge-devel
50 BuildRequires:  libsoup-devel >= 2.42
51 BuildRequires:  libsigc++-devel >= 2.0.17
52 BuildRequires:  libstdc++-devel >= 6:4.7
53 BuildRequires:  libvisio-devel >= 0.1
54 BuildRequires:  libwpd-devel >= 0.9
55 BuildRequires:  libwpg-devel >= 0.3
56 BuildRequires:  libxml2-devel >= 1:2.6.26
57 BuildRequires:  libxslt-devel >= 1.1.17
58 BuildRequires:  pango-devel >= 1:1.24
59 BuildRequires:  pkgconfig
60 BuildRequires:  poppler-glib-devel >= 0.29.0
61 BuildRequires:  popt-devel
62 BuildRequires:  potrace-devel
63 BuildRequires:  rpm-pythonprov
64 BuildRequires:  rpmbuild(macros) >= 1.752
65 BuildRequires:  sed >= 4.0
66 BuildRequires:  xorg-lib-libX11-devel
67 BuildRequires:  zlib-devel
68 Requires(post,postun):  desktop-file-utils
69 Requires:       cairo >= 1.10
70 Requires:       cairomm >= 1.9.8
71 Requires:       gc >= 7.2
72 Requires:       gdl >= 3.6
73 Requires:       glib2 >= 1:2.28
74 Requires:       glibmm >= 2.28
75 Requires:       gtk+3 >= 3.22
76 Requires:       gtkmm3 >= 3.22
77 Requires:       libsigc++ >= 2.0.17
78 Requires:       libxml2 >= 1:2.6.26
79 Requires:       libxslt >= 1.1.17
80 Requires:       pango >= 1:1.24
81 Requires:       perl-XML-XQL
82 Requires:       poppler-glib >= 0.29.0
83 Suggests:       python-lxml
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %description
87 Inkscape is a program for viewing, making, and editing two-dimensional
88 vector drawings.
89
90 %description -l pl.UTF-8
91 Inkscape jest programem do przeglądania, tworzenia i edycji
92 dwuwymiarowej grafiki wektorowej.
93
94 %package -n bash-completion-inkscape
95 Summary:        Bash completion for inkscape arguments
96 Summary(pl.UTF-8):      Bashowe dopełnianie argumentów programu inkscape
97 Group:          Applications/Shells
98 Requires:       %{name} = %{version}-%{release}
99 Requires:       bash-completion >= 2.0
100 %{?noarchpackage}
101
102 %description -n bash-completion-inkscape
103 Bash completion for inkscape arguments.
104
105 %description -n bash-completion-inkscape -l pl.UTF-8
106 Bashowe dopełnianie argumentów programu inkscape.
107
108 %prep
109 %setup -q -n %{name}-%{version}_2020-09-07_3bc2e813f5
110
111 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
112       CMakeScripts/cmake_consistency_check.py \
113       buildtools/msys2checkdeps.py \
114       packaging/scripts/lp-mark-bugs-released \
115       packaging/wix/*.py \
116       share/extensions/*.py \
117       share/extensions/*/*.py \
118       share/*/i18n.py
119
120 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+perl(\s|$),#!%{__perl}\1,' \
121       share/attributes/genMapDataCSS.pl \
122       share/attributes/genMapDataSVG.pl
123
124 %build
125 mkdir -p build
126 cd build
127
128 %cmake .. \
129         -DBUILD_SHARED_LIBS:BOOL=OFF \
130         %{cmake_on_off relocation ENABLE_BINRELOC} \
131         %{cmake_on_off dbus WITH_DBUS} \
132         %{cmake_on_off imagick WITH_IMAGE_MAGICK}
133
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %{__make} -C build install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 # unify locale name, overwrite outdated bn
143 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{bn_BD,bn}/LC_MESSAGES/inkscape.mo
144 # unify names
145 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{ks@aran,ks}
146 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{ks@deva,ks@devanagari}
147 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sd@deva,sd@devanagari}
148 # unsupported variants
149 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{kok@latin,mni@beng,sat@deva}
150
151 %{__rm} $RPM_BUILD_ROOT%{_datadir}/inkscape/extensions/{.pylintrc,LICENSE.txt,MANIFEST.in,README.md,STYLEGUIDE.md,doxygen-main.dox,setup.cfg,setup.py,tox.ini}
152
153 %find_lang %{name}
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post
159 %update_desktop_database_post
160
161 %postun
162 %update_desktop_database_postun
163
164 %files -f %{name}.lang
165 %defattr(644,root,root,755)
166 %doc AUTHORS CONTRIBUTING.md NEWS.md README.md
167 %attr(755,root,root) %{_bindir}/inkscape
168 %attr(755,root,root) %{_bindir}/inkview
169 %dir %{_datadir}/inkscape
170 %{_datadir}/inkscape/[!e]*
171 %{_datadir}/inkscape/examples
172 %dir %{_datadir}/inkscape/extensions
173 %{_datadir}/inkscape/extensions/Poly3DObjects
174 %{_datadir}/inkscape/extensions/alphabet_soup
175 %{_datadir}/inkscape/extensions/barcode
176 %{_datadir}/inkscape/extensions/ink2canvas_lib
177 %{_datadir}/inkscape/extensions/inkex
178 %{_datadir}/inkscape/extensions/svg_fonts
179 %{_datadir}/inkscape/extensions/tools
180 %{_datadir}/inkscape/extensions/xaml2svg
181 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
182 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
183 %{_datadir}/inkscape/extensions/dxf14_*.txt
184 %{_datadir}/inkscape/extensions/*.inx
185 %{_datadir}/inkscape/extensions/*.js
186 %{_datadir}/inkscape/extensions/*.svg
187 %{_datadir}/inkscape/extensions/*.xml
188 %{_datadir}/inkscape/extensions/*.xsl
189 %{_datadir}/inkscape/extensions/*.xslt
190 %{_datadir}/inkscape/extensions/fontfix.conf
191 %{_datadir}/inkscape/extensions/inkscape.extension.rng
192 %{_datadir}/metainfo/org.inkscape.Inkscape.appdata.xml
193 %{_iconsdir}/hicolor/*/apps/org.inkscape.Inkscape.png
194 %{_desktopdir}/org.inkscape.Inkscape.desktop
195 %{_mandir}/man1/inkscape.1*
196 %{_mandir}/man1/inkview.1*
197 %lang(de) %{_mandir}/de/man1/inkscape.1*
198 %lang(fr) %{_mandir}/fr/man1/inkscape.1*
199 %lang(hr) %{_mandir}/hr/man1/inkscape.1*
200 %lang(hu) %{_mandir}/hu/man1/inkscape.1*
201 %lang(de) %{_mandir}/de/man1/inkview.1*
202 %lang(es) %{_mandir}/es/man1/inkview.1*
203 %lang(fr) %{_mandir}/fr/man1/inkview.1*
204 %lang(hr) %{_mandir}/hr/man1/inkview.1*
205 %lang(hu) %{_mandir}/hu/man1/inkview.1*
206 %lang(pt_BR) %{_mandir}/pt_BR/man1/inkview.1*
207
208 %files -n bash-completion-inkscape
209 %defattr(644,root,root,755)
210 %{bash_compdir}/inkscape
This page took 0.029092 seconds and 2 git commands to generate.