]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- up to 1.0.2
[packages/inkscape.git] / inkscape.spec
1 #
2 # Conditional build
3 %bcond_with     dbus            # DBus interface
4 %bcond_with     relocation      # Enable binary relocation support
5 %bcond_with     imagick         # ImageMagick 6.x instead of GraphicsMagick
6 #
7
8 Summary:        Scalable vector graphics editor
9 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
10 Name:           inkscape
11 Version:        1.0.2
12 Release:        1
13 License:        GPL v2+, LGPL v2.1+
14 Group:          X11/Applications/Graphics
15 # download: follow https://inkscape.org/release/
16 Source0:        https://media.inkscape.org/dl/resources/file/%{name}-%{version}.tar.xz
17 # Source0-md5:  ec90e0c1e4c7e3dba8f46b16c73462b3
18 Patch0:         gcc11.patch
19 Patch1:         glib-extern.patch
20 Patch2:         missing-atomic.patch
21 URL:            https://inkscape.org/
22 %{!?with_imagick:BuildRequires: GraphicsMagick-c++-devel}
23 %{?with_imagick:BuildRequires:  ImageMagick6-c++-devel < 7}
24 BuildRequires:  aspell-devel
25 BuildRequires:  boost-devel >= 1.36
26 BuildRequires:  cairo-devel >= 1.10
27 BuildRequires:  cairomm-devel >= 1.9.8
28 BuildRequires:  cmake >= 3.1.0
29 %if %{with dbus}
30 BuildRequires:  dbus-devel
31 BuildRequires:  dbus-glib-devel
32 %endif
33 BuildRequires:  double-conversion-devel
34 BuildRequires:  fontconfig-devel
35 BuildRequires:  freetype-devel >= 2.0
36 BuildRequires:  gc-devel >= 7.2
37 BuildRequires:  gdl-devel >= 3.6
38 BuildRequires:  gettext-tools >= 0.17
39 BuildRequires:  glib2-devel >= 1:2.28
40 BuildRequires:  glibmm-devel >= 2.28
41 BuildRequires:  gsl-devel
42 BuildRequires:  gtk+3-devel >= 3.22
43 BuildRequires:  gtkmm3-devel >= 3.22
44 BuildRequires:  gtkspell3-devel >= 3.0
45 BuildRequires:  harfbuzz-devel
46 BuildRequires:  lcms2-devel >= 2
47 BuildRequires:  libcdr-devel >= 0.1
48 BuildRequires:  libexif-devel
49 BuildRequires:  libgomp-devel
50 BuildRequires:  libjpeg-devel
51 BuildRequires:  libpng-devel >= 1.2
52 BuildRequires:  librevenge-devel
53 BuildRequires:  libsoup-devel >= 2.42
54 BuildRequires:  libsigc++-devel >= 2.0.17
55 BuildRequires:  libstdc++-devel >= 6:4.7
56 BuildRequires:  libvisio-devel >= 0.1
57 BuildRequires:  libwpd-devel >= 0.9
58 BuildRequires:  libwpg-devel >= 0.3
59 BuildRequires:  libxml2-devel >= 1:2.6.26
60 BuildRequires:  libxslt-devel >= 1.1.17
61 BuildRequires:  pango-devel >= 1:1.24
62 BuildRequires:  pkgconfig
63 BuildRequires:  poppler-glib-devel >= 0.29.0
64 BuildRequires:  popt-devel
65 BuildRequires:  potrace-devel
66 BuildRequires:  rpm-pythonprov
67 BuildRequires:  rpmbuild(macros) >= 1.752
68 BuildRequires:  sed >= 4.0
69 BuildRequires:  xorg-lib-libX11-devel
70 BuildRequires:  zlib-devel
71 Requires(post,postun):  desktop-file-utils
72 Requires:       cairo >= 1.10
73 Requires:       cairomm >= 1.9.8
74 Requires:       gc >= 7.2
75 Requires:       gdl >= 3.6
76 Requires:       glib2 >= 1:2.28
77 Requires:       glibmm >= 2.28
78 Requires:       gtk+3 >= 3.22
79 Requires:       gtkmm3 >= 3.22
80 Requires:       libsigc++ >= 2.0.17
81 Requires:       libxml2 >= 1:2.6.26
82 Requires:       libxslt >= 1.1.17
83 Requires:       pango >= 1:1.24
84 Requires:       perl-XML-XQL
85 Requires:       poppler-glib >= 0.29.0
86 Suggests:       python-lxml
87 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88
89 %description
90 Inkscape is a program for viewing, making, and editing two-dimensional
91 vector drawings.
92
93 %description -l pl.UTF-8
94 Inkscape jest programem do przeglądania, tworzenia i edycji
95 dwuwymiarowej grafiki wektorowej.
96
97 %package -n bash-completion-inkscape
98 Summary:        Bash completion for inkscape arguments
99 Summary(pl.UTF-8):      Bashowe dopełnianie argumentów programu inkscape
100 Group:          Applications/Shells
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       bash-completion >= 2.0
103 BuildArch:      noarch
104
105 %description -n bash-completion-inkscape
106 Bash completion for inkscape arguments.
107
108 %description -n bash-completion-inkscape -l pl.UTF-8
109 Bashowe dopełnianie argumentów programu inkscape.
110
111 %prep
112 %setup -q -n %{name}-%{version}_2021-01-15_e86c870879
113 %patch0 -p1
114 %patch1 -p1
115 %patch2 -p1
116
117 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
118       CMakeScripts/cmake_consistency_check.py \
119       buildtools/msys2checkdeps.py \
120       packaging/scripts/lp-mark-bugs-released \
121       packaging/wix/*.py \
122       share/extensions/*.py \
123       share/extensions/*/*.py \
124       share/*/i18n.py
125
126 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+perl(\s|$),#!%{__perl}\1,' \
127       share/attributes/genMapDataCSS.pl \
128       share/attributes/genMapDataSVG.pl
129
130 %build
131 mkdir -p build
132 cd build
133
134 %cmake .. \
135         -DBUILD_SHARED_LIBS:BOOL=OFF \
136         %{cmake_on_off relocation ENABLE_BINRELOC} \
137         %{cmake_on_off dbus WITH_DBUS} \
138         %{cmake_on_off imagick WITH_IMAGE_MAGICK}
139
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144
145 %{__make} -C build install \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 # unify locale name, overwrite outdated bn
149 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{bn_BD,bn}/LC_MESSAGES/inkscape.mo
150 # unify names
151 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{ks@aran,ks}
152 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{ks@deva,ks@devanagari}
153 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sd@deva,sd@devanagari}
154 # unsupported variants
155 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{kok@latin,mni@beng,sat@deva}
156
157 %{__rm} $RPM_BUILD_ROOT%{_datadir}/inkscape/extensions/{.pylintrc,LICENSE.txt,MANIFEST.in,README.md,STYLEGUIDE.md,doxygen-main.dox,setup.cfg,setup.py,tox.ini}
158
159 %find_lang %{name}
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %post
165 %update_desktop_database_post
166
167 %postun
168 %update_desktop_database_postun
169
170 %files -f %{name}.lang
171 %defattr(644,root,root,755)
172 %doc AUTHORS CONTRIBUTING.md NEWS.md README.md
173 %attr(755,root,root) %{_bindir}/inkscape
174 %attr(755,root,root) %{_bindir}/inkview
175 %dir %{_datadir}/inkscape
176 %{_datadir}/inkscape/[!e]*
177 %{_datadir}/inkscape/examples
178 %dir %{_datadir}/inkscape/extensions
179 %{_datadir}/inkscape/extensions/Poly3DObjects
180 %{_datadir}/inkscape/extensions/alphabet_soup
181 %{_datadir}/inkscape/extensions/barcode
182 %{_datadir}/inkscape/extensions/ink2canvas_lib
183 %{_datadir}/inkscape/extensions/inkex
184 %{_datadir}/inkscape/extensions/svg_fonts
185 %{_datadir}/inkscape/extensions/tools
186 %{_datadir}/inkscape/extensions/xaml2svg
187 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
188 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
189 %{_datadir}/inkscape/extensions/dxf14_*.txt
190 %{_datadir}/inkscape/extensions/*.inx
191 %{_datadir}/inkscape/extensions/*.js
192 %{_datadir}/inkscape/extensions/*.svg
193 %{_datadir}/inkscape/extensions/*.xml
194 %{_datadir}/inkscape/extensions/*.xsl
195 %{_datadir}/inkscape/extensions/*.xslt
196 %{_datadir}/inkscape/extensions/fontfix.conf
197 %{_datadir}/inkscape/extensions/inkscape.extension.rng
198 %{_datadir}/metainfo/org.inkscape.Inkscape.appdata.xml
199 %{_iconsdir}/hicolor/*/apps/org.inkscape.Inkscape.png
200 %{_desktopdir}/org.inkscape.Inkscape.desktop
201 %{_mandir}/man1/inkscape.1*
202 %{_mandir}/man1/inkview.1*
203 %lang(de) %{_mandir}/de/man1/inkscape.1*
204 %lang(fr) %{_mandir}/fr/man1/inkscape.1*
205 %lang(hr) %{_mandir}/hr/man1/inkscape.1*
206 %lang(hu) %{_mandir}/hu/man1/inkscape.1*
207 %lang(de) %{_mandir}/de/man1/inkview.1*
208 %lang(es) %{_mandir}/es/man1/inkview.1*
209 %lang(fr) %{_mandir}/fr/man1/inkview.1*
210 %lang(hr) %{_mandir}/hr/man1/inkview.1*
211 %lang(hu) %{_mandir}/hu/man1/inkview.1*
212 %lang(pt_BR) %{_mandir}/pt_BR/man1/inkview.1*
213
214 %files -n bash-completion-inkscape
215 %defattr(644,root,root,755)
216 %{bash_compdir}/inkscape
This page took 0.083033 seconds and 3 git commands to generate.