]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
1eadba47e576102b751411b3192ae6b9c26bb32a
[packages/inkscape.git] / inkscape.spec
1 #
2 # Conditional build
3 %bcond_with     dbus            # DBus interface
4 %bcond_with     gtk3            # GTK+ 3 interface [experimental]
5 %bcond_without  gnomevfs        # Don't use gnome vfs for loading files
6 %bcond_with     relocation      # Enable binary relocation support
7 #
8
9 Summary:        Scalable vector graphics editor
10 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
11 Name:           inkscape
12 Version:        0.92.4
13 Release:        1
14 License:        GPL v2+, LGPL v2.1+
15 Group:          X11/Applications/Graphics
16 # download: follow https://inkscape.org/release/
17 Source0:        https://media.inkscape.org/dl/resources/file/%{name}-%{version}.tar.bz2
18 # Source0-md5:  ac30f6d5747fd9c620c00dad500f414f
19 Patch0:         %{name}-man.patch
20 Patch1:         %{name}-gtk3.patch
21 # https://gitlab.com/inkscape/inkscape/commit/e831b034746f8dc3c3c1b88372751f6dcb974831.patch
22 Patch2:         %{name}-poppler0.76.patch
23 # https://gitlab.com/inkscape/inkscape/merge_requests/986.patch
24 Patch3:         %{name}-poppler0.82.patch
25 URL:            https://inkscape.org/
26 BuildRequires:  ImageMagick-c++-devel
27 BuildRequires:  aspell-devel
28 BuildRequires:  autoconf >= 2.64
29 BuildRequires:  automake >= 1:1.9.4-2
30 BuildRequires:  boost-devel >= 1.36
31 BuildRequires:  cairo-devel >= 1.10
32 BuildRequires:  cairomm-devel >= 1.9.8
33 %{?with_dbus:BuildRequires:     dbus-glib-devel}
34 BuildRequires:  freetype-devel >= 2.0
35 BuildRequires:  gc-devel >= 7.2
36 BuildRequires:  gettext-tools >= 0.17
37 BuildRequires:  glib2-devel >= 1:2.28
38 BuildRequires:  glibmm-devel >= 2.28
39 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.15.2}
40 BuildRequires:  gsl-devel
41 BuildRequires:  intltool >= 0.40.0
42 BuildRequires:  lcms2-devel >= 2
43 BuildRequires:  libcdr-devel >= 0.1
44 BuildRequires:  libexif-devel
45 BuildRequires:  libgomp-devel
46 BuildRequires:  libjpeg-devel
47 BuildRequires:  libpng-devel >= 1.2
48 BuildRequires:  librevenge-devel
49 BuildRequires:  libsigc++-devel >= 2.0.17
50 BuildRequires:  libstdc++-devel >= 6:4.7
51 BuildRequires:  libtool >= 2:2.2
52 BuildRequires:  libvisio-devel >= 0.1
53 BuildRequires:  libwpd-devel >= 0.9
54 BuildRequires:  libwpg-devel >= 0.3
55 BuildRequires:  libxml2-devel >= 1:2.6.26
56 BuildRequires:  libxslt-devel >= 1.1.17
57 BuildRequires:  pango-devel >= 1:1.24
58 BuildRequires:  pkgconfig
59 BuildRequires:  poppler-glib-devel >= 0.29.0
60 BuildRequires:  popt-devel
61 BuildRequires:  potrace-devel
62 BuildRequires:  rpm-pythonprov
63 BuildRequires:  sed >= 4.0
64 BuildRequires:  zlib-devel
65 %if %{with gtk3}
66 BuildRequires:  gdl-devel >= 3.6
67 BuildRequires:  gtk+3-devel >= 3.8
68 BuildRequires:  gtkmm3-devel >= 3.10
69 BuildRequires:  gtkspell3-devel >= 3.0
70 %else
71 BuildRequires:  gtk+2-devel >= 2:2.24
72 BuildRequires:  gtkmm-devel >= 2.24
73 BuildRequires:  gtkspell-devel >= 2.0.11
74 %endif
75 Requires(post,postun):  desktop-file-utils
76 Requires:       cairo >= 1.10
77 Requires:       cairomm >= 1.9.8
78 Requires:       gc >= 7.2
79 Requires:       glib2 >= 1:2.28
80 Requires:       glibmm >= 2.28
81 %{?with_gnomevfs:Requires:      gnome-vfs2 >= 2.15.2}
82 Requires:       libsigc++ >= 2.0.17
83 Requires:       libxml2 >= 1:2.6.26
84 Requires:       libxslt >= 1.1.17
85 Requires:       pango >= 1:1.24
86 Requires:       perl-XML-XQL
87 Requires:       poppler-glib >= 0.29.0
88 %if %{with gtk3}
89 Requires:       gdl >= 3.6
90 Requires:       gtk+3 >= 3.8
91 Requires:       gtkmm3 >= 3.10
92 %else
93 Requires:       gtk+2 >= 2:2.24
94 Requires:       gtkmm >= 2.24
95 Requires:       gtkspell >= 2.0.11
96 %endif
97 Suggests:       python-lxml
98 # sr@Latn vs. sr@latin
99 Conflicts:      glibc-misc < 6:2.7
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %description
103 Inkscape is a program for viewing, making, and editing two-dimensional
104 vector drawings.
105
106 %description -l pl.UTF-8
107 Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
108 dwuwymiarowej grafiki wektorowej.
109
110 %prep
111 %setup -q
112 %patch0 -p1
113 %patch1 -p1
114 %patch2 -p1
115 %patch3 -p1
116
117 %{__sed} -i -e 's,po/Makefile.in,,' configure.ac
118
119 %build
120 %{__libtoolize}
121 %{__gettextize}
122 %{__intltoolize}
123 %{__aclocal}
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 # deprecated TimeVal API is used, so --disable-strict-build is needed
128 %configure \
129         %{?with_relocation:--enable-binreloc} \
130         %{?with_dbus:--enable-dbusapi} \
131         %{?with_gtk3:--enable-gtk3-experimental} \
132         --disable-silent-rules \
133         --disable-strict-build \
134         %{!?with_gnomevfs:--without-gnome-vfs}
135
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 # localized manuals cleanup
145 for manlang in de el fr ja sk zh_TW ; do
146         %{__mv} $RPM_BUILD_ROOT%{_mandir}/${manlang}/man1/{inkscape.${manlang}.1,inkscape.1}
147         %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/inkscape.${manlang}.1
148 done
149
150 # unify locale name, overwrite outdated bn
151 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{bn_BD,bn}/LC_MESSAGES/inkscape.mo
152 # joke language, unsupported
153 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en_US@piglatin
154 # unify names
155 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{ks@aran,ks}
156 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{ks@deva,ks@devanagari}
157 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{sd@deva,sd@devanagari}
158 # unsupported variants
159 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{kok@latin,mni@beng,sat@deva}
160
161 %find_lang %{name}
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
165
166 %post
167 %update_desktop_database_post
168
169 %postun
170 %update_desktop_database_postun
171
172 %files -f %{name}.lang
173 %defattr(644,root,root,755)
174 %doc AUTHORS ChangeLog NEWS README TRANSLATORS doc/HACKING.txt
175 %lang(ca) %doc README.ca.txt
176 %lang(de) %doc README.de.txt doc/HACKING.de.txt
177 %lang(es) %doc README.es.txt
178 %lang(fr) %doc README.fr.txt doc/HACKING.fr.txt
179 %lang(it) %doc README.it.txt doc/HACKING.it.txt
180 %lang(pt_BR) %doc README.pt_BR.txt doc/HACKING.pt_BR.txt
181 %lang(sk) %doc README.sk.txt
182 %lang(sr) %doc README.sr.txt
183 %attr(755,root,root) %{_bindir}/inkscape
184 %attr(755,root,root) %{_bindir}/inkview
185 %dir %{_datadir}/inkscape
186 %{_datadir}/inkscape/[!e]*
187 %{_datadir}/inkscape/examples
188 %dir %{_datadir}/inkscape/extensions
189 %dir %{_datadir}/inkscape/extensions/Barcode
190 %attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
191 %{_datadir}/inkscape/extensions/Poly3DObjects
192 %{_datadir}/inkscape/extensions/alphabet_soup
193 %dir %{_datadir}/inkscape/extensions/ink2canvas
194 %attr(755,root,root) %{_datadir}/inkscape/extensions/ink2canvas/*.py
195 %{_datadir}/inkscape/extensions/test
196 %{_datadir}/inkscape/extensions/xaml2svg
197 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
198 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
199 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
200 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
201 %{_datadir}/inkscape/extensions/*.inx
202 %{_datadir}/inkscape/extensions/*.js
203 %{_datadir}/inkscape/extensions/*.svg
204 %{_datadir}/inkscape/extensions/*.xml
205 %{_datadir}/inkscape/extensions/*.xsl
206 %{_datadir}/inkscape/extensions/*.xslt
207 %{_datadir}/inkscape/extensions/fontfix.conf
208 %{_datadir}/inkscape/extensions/inkscape.extension.rng
209 %{_datadir}/appdata/inkscape.appdata.xml
210 %{_iconsdir}/hicolor/*/apps/inkscape.png
211 %{_desktopdir}/inkscape.desktop
212 %{_mandir}/man1/inkscape.1*
213 %{_mandir}/man1/inkview.1*
214 %lang(de) %{_mandir}/de/man1/inkscape.1*
215 %lang(el) %{_mandir}/el/man1/inkscape.1*
216 %lang(fr) %{_mandir}/fr/man1/inkscape.1*
217 %lang(ja) %{_mandir}/ja/man1/inkscape.1*
218 %lang(sk) %{_mandir}/sk/man1/inkscape.1*
219 %lang(zh_TW) %{_mandir}/zh_TW/man1/inkscape.1*
This page took 0.080675 seconds and 2 git commands to generate.