]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
1117f538e7928389967809535c8b99d72eb5d069
[packages/inkscape.git] / inkscape.spec
1 #
2 # TODO: check why build requires libselinux-devel (because of some gnome* stuff)
3 #
4 # Conditional build
5 %bcond_without  xft             # Don't use xft scalable font database
6 %bcond_without  gnomevfs        # Don't use gnome vfs for loading files
7 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
8 %bcond_with     inkboard        # Enable inkboard support
9 %bcond_with     relocation      # Enable binary relocation support
10 #
11
12 # just set it nil when non-preview arrives
13 %define beta %{nil}
14
15 Summary:        Scalable vector graphics editor
16 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
17 Name:           inkscape
18 Version:        0.91
19 Release:        1
20 License:        GPL v2+, LGPL v2.1+
21 Group:          X11/Applications/Graphics
22 #Source0:       http://downloads.sourceforge.net/inkscape/%{name}-%{version}%{beta}.tar.bz2
23 Source0:        https://inkscape.org/en/gallery/item/3860/%{name}-%{version}%{beta}.tar.bz2
24 # Source0-md5:  278dfa4514adcde23546370ec2c84581
25 # workaround for https://bugs.launchpad.net/inkscape/+bug/487038
26 Patch0:         %{name}-ldl.patch
27 Patch1:         %{name}-0.48.2-types.patch
28 URL:            http://www.inkscape.org/
29 BuildRequires:  ImageMagick-c++-devel
30 BuildRequires:  aspell-devel
31 BuildRequires:  autoconf >= 2.59-3
32 BuildRequires:  automake >= 1:1.9.4-2
33 BuildRequires:  boost-devel >= 1.36
34 BuildRequires:  cairo-devel >= 1.8.0
35 BuildRequires:  freetype-devel >= 2.0
36 BuildRequires:  gc-devel >= 6.4
37 BuildRequires:  gettext-tools
38 BuildRequires:  glibmm-devel >= 2.16.0
39 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.15.2}
40 BuildRequires:  gsl-devel
41 BuildRequires:  gtk+2-devel >= 2:2.14.0
42 BuildRequires:  gtkmm-devel >= 2.10.0
43 BuildRequires:  gtkspell-devel >= 2.0.11
44 BuildRequires:  intltool >= 0.35.0
45 BuildRequires:  lcms2-devel >= 2
46 BuildRequires:  libgomp-devel
47 BuildRequires:  libpng-devel >= 1.2
48 BuildRequires:  libsigc++-devel >= 2.0.17
49 BuildRequires:  libstdc++-devel >= 6:4.2.2-2
50 BuildRequires:  libtool
51 BuildRequires:  libwpd-devel >= 0.9
52 BuildRequires:  libwpg-devel >= 0.2
53 BuildRequires:  libxml2-devel >= 1:2.6.26
54 BuildRequires:  libxslt-devel >= 1.1.17
55 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0.3}
56 BuildRequires:  pkgconfig
57 BuildRequires:  poppler-glib-devel >= 0.20.0
58 BuildRequires:  popt-devel
59 BuildRequires:  rpm-pythonprov
60 BuildRequires:  sed >= 4.0
61 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
62 BuildRequires:  zlib-devel
63 Requires(post,postun):  desktop-file-utils
64 Requires:       cairo >= 1.8.0
65 Requires:       gc >= 6.4
66 Requires:       glibmm >= 2.16.0
67 %{?with_gnomevfs:Requires:      gnome-vfs2 >= 2.15.2}
68 Requires:       gtk+2 >= 2:2.14.0
69 Requires:       gtkmm >= 2.24.0
70 Requires:       gtkspell >= 2.0.11
71 Requires:       libsigc++ >= 2.0.17
72 Requires:       libxml2 >= 1:2.6.26
73 Requires:       libxslt >= 1.1.17
74 Requires:       perl-XML-XQL
75 Requires:       poppler-glib >= 0.20.0
76 Suggests:       python-lxml
77 # sr@Latn vs. sr@latin
78 Conflicts:      glibc-misc < 6:2.7
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %description
82 Inkscape is a program for viewing, making, and editing two-dimensional
83 vector drawings.
84
85 %description -l pl.UTF-8
86 Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
87 dwuwymiarowej grafiki wektorowej.
88
89 %prep
90 %setup -q -n %{name}-%{version}%{beta}
91 %patch0 -p1
92 %patch1 -p1
93
94 %build
95 %{__libtoolize}
96 %{__glib_gettextize}
97 %{__intltoolize}
98 %{__aclocal}
99 %{__autoheader}
100 %{__automake}
101 %{__autoconf}
102 %configure \
103         --disable-silent-rules \
104         %{!?with_xft: --without-xft} \
105         %{!?with_gnomevfs:--without-gnome-vfs} \
106         %{!?with_mmx:--disable-mmx} \
107         %{?with_relocation:--enable-binreloc} \
108         %{?with_inkboard:--enable-inkboard}
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 %find_lang %{name}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123
124 %post
125 %update_desktop_database_post
126
127 %postun
128 %update_desktop_database_postun
129
130 %files -f %{name}.lang
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog NEWS README TRANSLATORS doc/HACKING.txt
133 %lang(ca) %doc README.ca.txt
134 %lang(de) %doc README.de.txt
135 %lang(es) %doc README.es.txt
136 %lang(fr) %doc README.fr.txt
137 %lang(it) %doc README.it.txt
138 %lang(pt_BR) %doc README.it.txt
139 %lang(sk) %doc README.it.txt
140 %lang(sr) %doc README.it.txt
141 %lang(de) %doc doc/HACKING.de.txt
142 %lang(fr) %doc doc/HACKING.fr.txt
143 %lang(it) %doc doc/HACKING.it.txt
144 %lang(pt_BR) %doc doc/HACKING.it.txt
145 %attr(755,root,root) %{_bindir}/inkscape
146 %attr(755,root,root) %{_bindir}/inkview
147 %dir %{_datadir}/inkscape
148 %{_datadir}/inkscape/[!e]*
149 %{_datadir}/inkscape/examples
150 %dir %{_datadir}/inkscape/extensions
151 %{_datadir}/inkscape/extensions/Poly3DObjects/
152 %{_datadir}/inkscape/extensions/alphabet_soup/
153 %{_datadir}/inkscape/extensions/*.inx
154 %{_datadir}/inkscape/extensions/*.js
155 %{_datadir}/inkscape/extensions/*.xml
156 %{_datadir}/inkscape/extensions/*.xsl
157 %{_datadir}/inkscape/extensions/*.xslt
158 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
159 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
160 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
161 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
162 %dir %{_datadir}/inkscape/extensions/ink2canvas
163 %attr(755,root,root) %{_datadir}/inkscape/extensions/ink2canvas/*.py
164 %dir %{_datadir}/inkscape/extensions/Barcode
165 %attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
166 %dir %{_datadir}/inkscape/extensions/xaml2svg
167 %{_datadir}/inkscape/extensions/xaml2svg/*.xsl
168 %{_datadir}/inkscape/extensions/fontfix.conf
169 %{_datadir}/inkscape/extensions/inkscape.extension.rng
170 %{_datadir}/inkscape/extensions/jessyInk_video.svg
171 %{_mandir}/man1/*.1*
172 %lang(el) %{_mandir}/el/man1/*.1*
173 %lang(fr) %{_mandir}/fr/man1/*.1*
174 %lang(ja) %{_mandir}/ja/man1/*.1*
175 %lang(sk) %{_mandir}/sk/man1/*.1*
176 %lang(zh_TW) %{_mandir}/zh_TW/man1/*.1*
177 %{_iconsdir}/hicolor/*/apps/inkscape.png
178 %{_desktopdir}/inkscape.desktop
This page took 0.043477 seconds and 2 git commands to generate.