]> git.pld-linux.org Git - packages/inkscape.git/blob - inkscape.spec
- updated BRs, added more versioned install time dependencies
[packages/inkscape.git] / inkscape.spec
1 #
2 # TODO: check why build requires libselinux-devel (because of some gnome* stuff)
3 #
4 # Conditional build
5 %bcond_without  xft             # Don't use xft scalable font database
6 %bcond_without  gnomevfs        # Don't use gnome vfs for loading files
7 %bcond_without  mmx             # Force building without MMX optimazation (Default: auto-detect)
8 %bcond_with     inkboard        # Enable inkboard support
9 %bcond_with     relocation      # Enable binary relocation support
10 #
11
12 # just set it nil when non-preview arrives
13 %define beta %{nil}
14
15 Summary:        Scalable vector graphics editor
16 Summary(pl.UTF-8):      Edytor skalowalnej grafiki wektorowej
17 Name:           inkscape
18 Version:        0.48.4
19 Release:        0.1
20 License:        GPL v2+, LGPL v2.1+
21 Group:          X11/Applications/Graphics
22 Source0:        http://downloads.sourceforge.net/inkscape/%{name}-%{version}%{beta}.tar.bz2
23 # Source0-md5:  47bd8546e42ba396624eef9eb66b9b6c
24 # workaround for https://bugs.launchpad.net/inkscape/+bug/487038
25 Patch0:         %{name}-ldl.patch
26 Patch1:         %{name}-0.48.2-types.patch
27 Patch2:         %{name}-build.patch
28 URL:            http://www.inkscape.org/
29 BuildRequires:  ImageMagick-c++-devel
30 BuildRequires:  aspell-devel
31 BuildRequires:  autoconf >= 2.59-3
32 BuildRequires:  automake >= 1:1.9.4-2
33 BuildRequires:  boost-devel >= 1.36
34 BuildRequires:  cairo-devel >= 1.8.0
35 BuildRequires:  freetype-devel >= 2.0
36 BuildRequires:  gc-devel >= 6.4
37 BuildRequires:  gettext-devel
38 BuildRequires:  glibmm-devel >= 2.16.0
39 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.15.2}
40 BuildRequires:  gsl-devel
41 BuildRequires:  gtk+2-devel >= 2:2.14.0
42 BuildRequires:  gtkmm-devel >= 2.10.0
43 BuildRequires:  gtkspell-devel >= 2.0.11
44 BuildRequires:  intltool >= 0.35.0
45 BuildRequires:  lcms2-devel >= 2
46 BuildRequires:  libgomp-devel
47 BuildRequires:  libpng-devel >= 1.2
48 BuildRequires:  libsigc++-devel >= 2.0.17
49 BuildRequires:  libstdc++-devel >= 6:4.2.2-2
50 BuildRequires:  libtool
51 BuildRequires:  libwpd-devel >= 0.9
52 BuildRequires:  libwpg-devel >= 0.2
53 BuildRequires:  libxml2-devel >= 1:2.6.26
54 BuildRequires:  libxslt-devel >= 1.1.17
55 %{?with_inkboard:BuildRequires: loudmouth-devel >= 1.0.3}
56 BuildRequires:  pkgconfig
57 BuildRequires:  poppler-glib-devel >= 0.20.0
58 BuildRequires:  popt-devel
59 BuildRequires:  rpm-pythonprov
60 BuildRequires:  sed >= 4.0
61 %{?with_xft:BuildRequires:      xorg-lib-libXft-devel}
62 BuildRequires:  zlib-devel
63 Requires(post,postun):  desktop-file-utils
64 Requires:       cairo >= 1.8.0
65 Requires:       gc >= 6.4
66 Requires:       glibmm >= 2.16.0
67 %{?with_gnomevfs:Requires:      gnome-vfs2 >= 2.15.2}
68 Requires:       gtk+2 >= 2:2.14.0
69 Requires:       gtkmm >= 2.10.0
70 Requires:       gtkspell >= 2.0.11
71 Requires:       libsigc++ >= 2.0.17
72 Requires:       libxml2 >= 1:2.6.26
73 Requires:       libxslt >= 1.1.17
74 Requires:       perl-XML-XQL
75 Requires:       poppler-glib >= 0.20.0
76 Suggests:       python-lxml
77 # sr@Latn vs. sr@latin
78 Conflicts:      glibc-misc < 6:2.7
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %description
82 Inkscape is a program for viewing, making, and editing two-dimensional
83 vector drawings.
84
85 %description -l pl.UTF-8
86 Inkscape jest programem do przeglÄ…dania, tworzenia i edycji
87 dwuwymiarowej grafiki wektorowej.
88
89 %prep
90 %setup -q -n %{name}-%{version}%{beta}
91 %patch0 -p1
92 %patch1 -p1
93 %patch2 -p1
94
95 %{__rm} po/en_US@piglatin.po
96 %{__sed} -i -e 's|en_US@piglatin||' configure.ac
97
98 mv po/te_IN.po po/te.po
99 %{__sed} -i -e 's|te_IN|te|' configure.ac
100
101 %build
102 %{__libtoolize}
103 %{__glib_gettextize}
104 %{__intltoolize}
105 %{__aclocal}
106 %{__autoheader}
107 %{__automake}
108 %{__autoconf}
109 %configure \
110         --disable-silent-rules \
111         %{!?with_xft: --without-xft} \
112         %{!?with_gnomevfs:--without-gnome-vfs} \
113         %{!?with_mmx:--disable-mmx} \
114         %{?with_relocation:--enable-binreloc} \
115         %{?with_inkboard:--enable-inkboard}
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 %find_lang %{name}
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130
131 %post
132 %update_desktop_database_post
133
134 %postun
135 %update_desktop_database_postun
136
137 %files -f %{name}.lang
138 %defattr(644,root,root,755)
139 %doc AUTHORS ChangeLog NEWS README TRANSLATORS doc/HACKING.txt
140 %lang(ca) %doc README.ca.txt
141 %lang(de) %doc README.de.txt
142 %lang(es) %doc README.es.txt
143 %lang(fr) %doc README.fr.txt
144 %lang(it) %doc README.it.txt
145 %lang(pt_BR) %doc README.it.txt
146 %lang(sk) %doc README.it.txt
147 %lang(sr) %doc README.it.txt
148 %lang(de) %doc doc/HACKING.de.txt
149 %lang(fr) %doc doc/HACKING.fr.txt
150 %lang(it) %doc doc/HACKING.it.txt
151 %lang(pt_BR) %doc doc/HACKING.it.txt
152 %attr(755,root,root) %{_bindir}/inkscape
153 %attr(755,root,root) %{_bindir}/inkview
154 %dir %{_datadir}/inkscape
155 %{_datadir}/inkscape/[!e]*
156 %{_datadir}/inkscape/examples
157 %dir %{_datadir}/inkscape/extensions
158 %{_datadir}/inkscape/extensions/Poly3DObjects/
159 %{_datadir}/inkscape/extensions/alphabet_soup/
160 %{_datadir}/inkscape/extensions/*.inx
161 %{_datadir}/inkscape/extensions/*.js
162 %{_datadir}/inkscape/extensions/*.xml
163 %{_datadir}/inkscape/extensions/*.xsl
164 %{_datadir}/inkscape/extensions/*.xslt
165 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pl
166 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.pm
167 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
168 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.rb
169 %attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
170 %dir %{_datadir}/inkscape/extensions/Barcode
171 %attr(755,root,root) %{_datadir}/inkscape/extensions/Barcode/*.py
172 %dir %{_datadir}/inkscape/extensions/xaml2svg
173 %{_datadir}/inkscape/extensions/xaml2svg/*.xsl
174 %{_mandir}/man1/*.1*
175 %lang(el) %{_mandir}/el/man1/*.1*
176 %lang(fr) %{_mandir}/fr/man1/*.1*
177 %lang(ja) %{_mandir}/ja/man1/*.1*
178 %lang(sk) %{_mandir}/sk/man1/*.1*
179 %lang(zh_TW) %{_mandir}/zh_TW/man1/*.1*
180 %{_iconsdir}/hicolor/*/apps/inkscape.png
181 %{_desktopdir}/inkscape.desktop
This page took 0.046558 seconds and 3 git commands to generate.