]> git.pld-linux.org Git - packages/inkscape.git/blame_incremental - inkscape.spec
Release 4 (by relup.sh)
[packages/inkscape.git] / inkscape.spec
... / ...
CommitLineData
1#
2# Conditional build
3%bcond_with dbus # DBus interface
4%bcond_with relocation # Enable binary relocation support
5%bcond_with imagick # ImageMagick 6.x instead of GraphicsMagick
6#
7
8Summary: Scalable vector graphics editor
9Summary(pl.UTF-8): Edytor skalowalnej grafiki wektorowej
10Name: inkscape
11Version: 1.1
12Release: 4
13License: GPL v2+, LGPL v2.1+
14Group: X11/Applications/Graphics
15# download: follow https://inkscape.org/release/
16Source0: https://media.inkscape.org/dl/resources/file/%{name}-%{version}.tar.xz
17# Source0-md5: 45e38e25fb93c7c91c51b84b9e4cf0ee
18URL: https://inkscape.org/
19%{!?with_imagick:BuildRequires: GraphicsMagick-c++-devel}
20%{?with_imagick:BuildRequires: ImageMagick6-c++-devel < 7}
21BuildRequires: aspell-devel
22BuildRequires: boost-devel >= 1.36
23BuildRequires: cairo-devel >= 1.10
24BuildRequires: cairomm-devel >= 1.9.8
25BuildRequires: cmake >= 3.1.0
26%if %{with dbus}
27BuildRequires: dbus-devel
28BuildRequires: dbus-glib-devel
29%endif
30BuildRequires: double-conversion-devel
31BuildRequires: fontconfig-devel
32BuildRequires: freetype-devel >= 2.0
33BuildRequires: gc-devel >= 7.2
34BuildRequires: gdl-devel >= 3.6
35BuildRequires: gettext-tools >= 0.17
36BuildRequires: glib2-devel >= 1:2.28
37BuildRequires: glibmm-devel >= 2.28
38BuildRequires: gsl-devel
39BuildRequires: gtk+3-devel >= 3.22
40BuildRequires: gtkmm3-devel >= 3.22
41BuildRequires: gtkspell3-devel >= 3.0
42BuildRequires: harfbuzz-devel
43BuildRequires: lcms2-devel >= 2
44BuildRequires: libcdr-devel >= 0.1
45BuildRequires: libexif-devel
46BuildRequires: libgomp-devel
47BuildRequires: libjpeg-devel
48BuildRequires: libpng-devel >= 1.2
49BuildRequires: librevenge-devel
50BuildRequires: libsigc++-devel >= 2.0.17
51BuildRequires: libsoup-devel >= 2.42
52BuildRequires: libstdc++-devel >= 6:4.7
53BuildRequires: libvisio-devel >= 0.1
54BuildRequires: libwpd-devel >= 0.9
55BuildRequires: libwpg-devel >= 0.3
56BuildRequires: libxml2-devel >= 1:2.6.26
57BuildRequires: libxslt-devel >= 1.1.17
58BuildRequires: pango-devel >= 1:1.24
59BuildRequires: pkgconfig
60BuildRequires: poppler-glib-devel >= 0.29.0
61BuildRequires: popt-devel
62BuildRequires: potrace-devel
63BuildRequires: rpm-pythonprov
64BuildRequires: rpmbuild(macros) >= 1.752
65BuildRequires: sed >= 4.0
66BuildRequires: xorg-lib-libX11-devel
67BuildRequires: zlib-devel
68Requires(post,postun): desktop-file-utils
69Requires: cairo >= 1.10
70Requires: cairomm >= 1.9.8
71Requires: gc >= 7.2
72Requires: gdl >= 3.6
73Requires: glib2 >= 1:2.28
74Requires: glibmm >= 2.28
75Requires: gtk+3 >= 3.22
76Requires: gtkmm3 >= 3.22
77Requires: libsigc++ >= 2.0.17
78Requires: libxml2 >= 1:2.6.26
79Requires: libxslt >= 1.1.17
80Requires: pango >= 1:1.24
81Requires: perl-XML-XQL
82Requires: poppler-glib >= 0.29.0
83Suggests: python-lxml
84BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86%description
87Inkscape is a program for viewing, making, and editing two-dimensional
88vector drawings.
89
90%description -l pl.UTF-8
91Inkscape jest programem do przeglądania, tworzenia i edycji
92dwuwymiarowej grafiki wektorowej.
93
94%package -n bash-completion-inkscape
95Summary: Bash completion for inkscape arguments
96Summary(pl.UTF-8): Bashowe dopełnianie argumentów programu inkscape
97Group: Applications/Shells
98Requires: %{name} = %{version}-%{release}
99Requires: bash-completion >= 2.0
100BuildArch: noarch
101
102%description -n bash-completion-inkscape
103Bash completion for inkscape arguments.
104
105%description -n bash-completion-inkscape -l pl.UTF-8
106Bashowe dopełnianie argumentów programu inkscape.
107
108%prep
109%setup -q -n %{name}-%{version}_2021-05-24_c4e8f9ed74
110
111%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python2(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python}\1,' -e '1s,#!\s*/usr/bin/python(\s|$),#!%{__python}\1,' \
112 CMakeScripts/cmake_consistency_check.py \
113 buildtools/msys2checkdeps.py \
114 packaging/scripts/lp-mark-bugs-released \
115 share/extensions/*.py \
116 share/extensions/*/*.py \
117 share/*/i18n.py
118
119%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+perl(\s|$),#!%{__perl}\1,' \
120 share/attributes/genMapDataCSS.pl \
121 share/attributes/genMapDataSVG.pl
122
123%build
124mkdir -p build
125cd build
126
127%cmake .. \
128 -DBUILD_SHARED_LIBS:BOOL=OFF \
129 %{cmake_on_off relocation ENABLE_BINRELOC} \
130 %{cmake_on_off dbus WITH_DBUS} \
131 %{cmake_on_off imagick WITH_IMAGE_MAGICK}
132
133%{__make}
134
135%install
136rm -rf $RPM_BUILD_ROOT
137
138%{__make} -C build install \
139 DESTDIR=$RPM_BUILD_ROOT
140
141# unify locale name, overwrite outdated bn
142%{__mv} $RPM_BUILD_ROOT%{_localedir}/{bn_BD,bn}/LC_MESSAGES/inkscape.mo
143# unify names
144%{__mv} $RPM_BUILD_ROOT%{_localedir}/{ks@aran,ks}
145%{__mv} $RPM_BUILD_ROOT%{_localedir}/{ks@deva,ks@devanagari}
146%{__mv} $RPM_BUILD_ROOT%{_localedir}/{sd@deva,sd@devanagari}
147# unsupported variants
148%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{kok@latin,mni@beng,sat@deva}
149
150%{__rm} $RPM_BUILD_ROOT%{_datadir}/inkscape/extensions/{.pylintrc,LICENSE.txt,MANIFEST.in,README.md,STYLEGUIDE.md,doxygen-main.dox,setup.cfg,setup.py,tox.ini}
151
152%find_lang %{name}
153
154%clean
155rm -rf $RPM_BUILD_ROOT
156
157%post
158%update_desktop_database_post
159
160%postun
161%update_desktop_database_postun
162
163%files -f %{name}.lang
164%defattr(644,root,root,755)
165%doc AUTHORS CONTRIBUTING.md NEWS.md README.md
166%attr(755,root,root) %{_bindir}/inkscape
167%attr(755,root,root) %{_bindir}/inkview
168%dir %{_datadir}/inkscape
169%{_datadir}/inkscape/[!e]*
170%{_datadir}/inkscape/examples
171%dir %{_datadir}/inkscape/extensions
172%{_datadir}/inkscape/extensions/Poly3DObjects
173%{_datadir}/inkscape/extensions/alphabet_soup
174%{_datadir}/inkscape/extensions/barcode
175%{_datadir}/inkscape/extensions/ink2canvas_lib
176%{_datadir}/inkscape/extensions/inkex
177%{_datadir}/inkscape/extensions/svg_fonts
178%{_datadir}/inkscape/extensions/tools
179%{_datadir}/inkscape/extensions/xaml2svg
180%attr(755,root,root) %{_datadir}/inkscape/extensions/*.py
181%attr(755,root,root) %{_datadir}/inkscape/extensions/*.sh
182%{_datadir}/inkscape/extensions/dxf14_*.txt
183%{_datadir}/inkscape/extensions/*.inx
184%{_datadir}/inkscape/extensions/*.js
185%{_datadir}/inkscape/extensions/*.svg
186%{_datadir}/inkscape/extensions/*.xml
187%{_datadir}/inkscape/extensions/*.xsl
188%{_datadir}/inkscape/extensions/*.xslt
189%{_datadir}/inkscape/extensions/fontfix.conf
190%{_datadir}/inkscape/extensions/inkscape.extension.rng
191%{_datadir}/metainfo/org.inkscape.Inkscape.appdata.xml
192%{_iconsdir}/hicolor/*/apps/org.inkscape.Inkscape.png
193%{_iconsdir}/hicolor/scalable/apps/org.inkscape.Inkscape.svg
194%{_iconsdir}/hicolor/symbolic/apps/org.inkscape.Inkscape-symbolic.svg
195%{_desktopdir}/org.inkscape.Inkscape.desktop
196%{_mandir}/man1/inkscape.1*
197%{_mandir}/man1/inkview.1*
198%lang(de) %{_mandir}/de/man1/inkscape.1*
199%lang(fr) %{_mandir}/fr/man1/inkscape.1*
200%lang(hr) %{_mandir}/hr/man1/inkscape.1*
201%lang(hu) %{_mandir}/hu/man1/inkscape.1*
202%lang(zh_TW) %{_mandir}/zh_TW/man1/inkscape.1*
203%lang(de) %{_mandir}/de/man1/inkview.1*
204%lang(es) %{_mandir}/es/man1/inkview.1*
205%lang(fr) %{_mandir}/fr/man1/inkview.1*
206%lang(hr) %{_mandir}/hr/man1/inkview.1*
207%lang(hu) %{_mandir}/hu/man1/inkview.1*
208%lang(pt_BR) %{_mandir}/pt_BR/man1/inkview.1*
209%lang(zh_TW) %{_mandir}/zh_TW/man1/inkview.1*
210
211%files -n bash-completion-inkscape
212%defattr(644,root,root,755)
213%{bash_compdir}/inkscape
This page took 0.085921 seconds and 4 git commands to generate.