]> git.pld-linux.org Git - packages/imsettings.git/commitdiff
- updated to 1.8.1 auto/th/imsettings-1.8.1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 20 May 2019 19:03:43 +0000 (21:03 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 20 May 2019 19:03:43 +0000 (21:03 +0200)
- updated patches

imsettings-constraint-of-language.patch
imsettings-no-bash.patch
imsettings.spec

index f14a35ff9a20fdbb3989255f73892f9d3cebeaa9..965e451f2d8e6c80b1f55f7b515db625326ae247 100644 (file)
@@ -1,9 +1,9 @@
---- imsettings-1.2.8/data/xinput.sh.in.in.orig 2012-02-10 03:25:18.000000000 +0100
-+++ imsettings-1.2.8/data/xinput.sh.in.in      2012-02-17 21:14:57.666422719 +0100
-@@ -266,8 +266,34 @@
+--- imsettings-1.8.1/data/xinput.sh.in.in.orig 2019-05-20 20:37:47.213623978 +0200
++++ imsettings-1.8.1/data/xinput.sh.in.in      2019-05-20 20:39:10.716504938 +0200
+@@ -57,8 +57,34 @@
        SHORT_DESC="User Specific"
      fi
- elif [ -r "$SYS_XINPUTRC" ]; then
+ elif [ -r "$SYS_XINPUTRC" -a "x$IMSETTINGS_DISABLE_SYS_XINPUTRC" = "xno" ]; then
 -    source "$SYS_XINPUTRC"
 -    READ_XINPUTRC=$SYS_XINPUTRC
 +    # FIXME: This hardcoded list has to be gone in the future.
@@ -36,4 +36,4 @@
 +    fi
  fi
  
- [ -z "$IMSETTINGS_INTEGRATE_DESKTOP" ] && IMSETTINGS_INTEGRATE_DESKTOP=yes
+ [ -z "${IMSETTINGS_INTEGRATE_DESKTOP-}" ] && IMSETTINGS_INTEGRATE_DESKTOP=yes
index 8895092521f836b0a5fd5a77e24928016835abbb..5b0c53d45664f0b64c2e0c40930a644b9496c97d 100644 (file)
@@ -1,5 +1,5 @@
---- imsettings-1.7.0/data/imsettings-functions.in.orig 2016-02-22 07:30:18.000000000 +0100
-+++ imsettings-1.7.0/data/imsettings-functions.in      2016-02-28 15:24:33.962090210 +0100
+--- imsettings-1.8.1/data/imsettings-functions.in.orig 2019-02-20 05:57:23.000000000 +0100
++++ imsettings-1.8.1/data/imsettings-functions.in      2019-05-20 20:46:25.377483510 +0200
 @@ -23,7 +23,7 @@
  LOGDIR="${XDG_CACHE_HOME:-$HOME/.cache}/imsettings"
  LOGFILE="$LOGDIR/log"
  
 -function get_desktop() {
 +get_desktop() {
-     if [ -n "$IMSETTINGS_DESKTOP" ]; then
-       GUESS_DESKTOP="\$IMSETTINGS_DESKTOP"
-       echo "$IMSETTINGS_DESKTOP"
-@@ -114,7 +114,7 @@
+     if [ -n "$XDG_CURRENT_DESKTOP" ]; then
+       GUESS_DESKTOP="\$XDG_CURRENT_DESKTOP"
+       echo "$XDG_CURRENT_DESKTOP"
+@@ -117,7 +117,7 @@
      fi
  }
  
@@ -61,7 +61,7 @@
      [ -n "$IMSETTINGS_DISABLE_DESKTOP_CHECK" ] && return 0
      case "$(get_desktop|tr '[A-Z]' '[a-z]')" in
        cinnamon*)
-@@ -149,7 +149,7 @@
+@@ -152,7 +152,7 @@
      return 1
  }
  
@@ -70,7 +70,7 @@
      [ -n "$IMSETTINGS_DISABLE_DESKTOP_CHECK" ] && return 0
      case "$(get_desktop|tr '[A-Z]' '[a-z]')" in
        *)
-@@ -162,7 +162,7 @@
+@@ -165,7 +165,7 @@
      return 1
  }
  
      [ -n "$IMSETTINGS_DISABLE_DESKTOP_CHECK" ] && return 0
      if check_imsettings_capability xim; then
        return 0
-@@ -171,7 +171,7 @@
+@@ -174,12 +174,12 @@
      return 1
  }
  
+-function is_desktop_supported() {
++is_desktop_supported() {
+     @libexecdir[@]/imsettings-check --check-desktop $(get_desktop) >/dev/null
+     [ $? -eq 0 ]
+ }
 -function setup_gtk_immodule() {
 +setup_gtk_immodule() {
      if is_imsettings_enabled && is_gtk_supported; then
        # Ensure GTK_IM_MODULE is empty. otherwise GTK+ doesn't pick up immodule through XSETTINGS
        unset GTK_IM_MODULE
-@@ -181,7 +181,7 @@
+@@ -189,7 +189,7 @@
      fi
  }
  
      if is_imsettings_enabled && is_qt_supported; then
        # FIXME: Qt doesn't support XSETTINGS for immodule yet.
        #        We still need to go with the older way.
-@@ -191,7 +191,7 @@
+@@ -199,7 +199,7 @@
      fi
  }
  
      if is_imsettings_enabled && is_xim_supported; then
        # setup XMODIFIERS
        XMODIFIERS="@im=imsettings"
-@@ -202,7 +202,7 @@
+@@ -210,7 +210,7 @@
      fi
  }
  
      print_info
      if [ -n "$DRY_RUN" ]; then
        log "*** DRY RUN MODE: running IM through imsettings"
-@@ -217,7 +217,7 @@
+@@ -225,7 +225,7 @@
      fi
  }
  
      print_info
      if [ -n "$DRY_RUN" ]; then
        log "*** DRY RUN MODE: running IM without imsettings"
-@@ -230,7 +230,7 @@
+@@ -238,7 +238,7 @@
      fi
  }
  
      $1
      if [ $? -eq 0 ]; then
        log yes
-@@ -239,7 +239,7 @@
+@@ -247,7 +247,7 @@
      fi
  }
  
      fi
  fi
  
---- imsettings-1.2.4/data/xinputinfo.sh.in.orig        2011-03-08 07:39:32.000000000 +0100
-+++ imsettings-1.2.4/data/xinputinfo.sh.in     2011-07-17 22:57:52.000000000 +0200
+--- imsettings-1.8.1/data/xinputinfo.sh.in.orig        2019-02-20 05:32:55.000000000 +0100
++++ imsettings-1.8.1/data/xinputinfo.sh.in     2019-05-20 20:47:06.287261883 +0200
 @@ -1,4 +1,4 @@
 -#!/bin/bash
 +#!/bin/sh
  # xinputinfo.sh
- # Copyright (C) 2008 Red Hat, Inc. All rights reserved.
- #
+ # Copyright (C) 2008-2012 Red Hat, Inc. All rights reserved.
 @@ -20,7 +20,7 @@
- # Foundation, Inc., 59 Temple Place - Suite 330,
- # Boston, MA 02111-1307, USA.
+ # Free Software Foundation, Inc., 51 Franklin Street, Fifth
+ # Floor, Boston, MA  02110-1301  USA
  
 -function is_script() {
 +is_script() {
      if [ "x$(sed -re '/^[     ]?*[a-zA-Z0-9_]+=.*/{d};/[      ]?*#.*/{d}' $1)" = "x" ]; then
        return 1
      else
-@@ -36,13 +36,13 @@
+@@ -37,13 +37,13 @@
  unset TERM
  if [ -r /etc/profile.d/lang.sh ]; then
      # for Fedora etc
  fi
  [ -n "$oldterm" ] && export TERM=$oldterm
  
-@@ -52,16 +52,16 @@
- unset AUXILIARY_PROGRAM AUXILIARY_ARGS GTK_IM_MODULE ICON IMSETTINGS_IGNORE_ME LONG_DESC PREFERENCE_PROGRAM PREFERENCE_ARGS QT_IM_MODULE SHORT_DESC XIM XIM_PROGRAM XIM_ARGS IS_XIM
+@@ -53,17 +53,17 @@
+ unset AUXILIARY_PROGRAM AUXILIARY_ARGS GTK_IM_MODULE ICON IMSETTINGS_IGNORE_ME LONG_DESC NOT_RUN PREFERENCE_PROGRAM PREFERENCE_ARGS QT_IM_MODULE SHORT_DESC XIM XIM_PROGRAM XIM_ARGS IS_XIM
  
  if [ $# -gt 0 ]; then
 -    source $1
 +    . $1
      IMSETTINGS_FILENAME=$1
  else
-     [ -z "$IMSETTINGS_DISABLE_USER_XINPUTRC" ] && IMSETTINGS_DISABLE_USER_XINPUTRC=no
+     [ -z "${IMSETTINGS_DISABLE_USER_XINPUTRC-}" ] && IMSETTINGS_DISABLE_USER_XINPUTRC=no
+     [ -z "${IMSETTINGS_DISABLE_SYS_XINPUTRC-}" ] && IMSETTINGS_DISABLE_SYS_XINPUTRC=no
  
      if [ -r "$USER_XINPUTRC" -a "x$IMSETTINGS_DISABLE_USER_XINPUTRC" = "xno" ]; then
 -      source "$USER_XINPUTRC"
 +      . "$USER_XINPUTRC"
        IMSETTINGS_FILENAME=$USER_XINPUTRC
-     elif [ -r "$SYS_XINPUTRC" ]; then
+     elif [ -r "$SYS_XINPUTRC" -a "x$IMSETTINGS_DISABLE_SYS_XINPUTRC" = "xno" ]; then
 -      source "$SYS_XINPUTRC"
 +      . "$SYS_XINPUTRC"
        IMSETTINGS_FILENAME=$SYS_XINPUTRC
index 077e78109103ed7a27d0617a9b48ff6b76c50a65..8538d93f8f593663032e6f5aead0293aa7c7cd76 100644 (file)
@@ -1,5 +1,6 @@
 #
 # Conditional build:
+%bcond_without gconf           # GNOME 2.x (GConf) support module
 %bcond_without mateconf        # MATE <= 1.4 (MateConf) support module
 %bcond_without xfce            # Xfce support module
 %bcond_without static_libs     # static library
@@ -7,19 +8,19 @@
 Summary:       Delivery framework for general Input Method configuration
 Summary(pl.UTF-8):     Szkielet do ogólnej konfiguracji method wprowadzania znaków
 Name:          imsettings
-Version:       1.7.0
-Release:       3
+Version:       1.8.1
+Release:       1
 License:       LGPL v2+
 Group:         Applications/System
 Source0:       https://bitbucket.org/tagoh/imsettings/downloads/%{name}-%{version}.tar.bz2
-# Source0-md5: decc1e438da81bcf84fa4156529475e4
+# Source0-md5: c04341a008d8c60e1532f033f4020f44
 Patch0:                %{name}-constraint-of-language.patch
 Patch1:                %{name}-no-bash.patch
 URL:           https://tagoh.bitbucket.org/imsettings/
-BuildRequires: GConf2-devel >= 2.0
+%{?with_gconf:BuildRequires:   GConf2-devel >= 2.0}
 BuildRequires: dbus-devel
 BuildRequires: desktop-file-utils
-BuildRequires: gettext-tools
+BuildRequires: gettext-tools >= 0.19.8
 BuildRequires: glib2-devel >= 1:2.32.0
 BuildRequires: gobject-introspection-devel >= 1.30.0
 # for fallback support in GTK+
@@ -377,14 +378,14 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libimsettings.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libimsettings.so.5
-%{_libdir}/girepository-1.0/IMSettings-1.7.typelib
+%{_libdir}/girepository-1.0/IMSettings-1.8.typelib
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libimsettings.so
 %{_pkgconfigdir}/imsettings.pc
 %{_includedir}/imsettings
-%{_datadir}/gir-1.0/IMSettings-1.7.gir
+%{_datadir}/gir-1.0/IMSettings-1.8.gir
 %{_gtkdocdir}/imsettings
 
 %if %{with static_libs}
@@ -397,9 +398,11 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/libimsettings-cinnamon-gsettings.so
 
+%if %{with gconf}
 %files gnome2
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/libimsettings-gconf.so
+%endif
 
 %files gnome3
 %defattr(644,root,root,755)
This page took 0.122179 seconds and 4 git commands to generate.