]> git.pld-linux.org Git - packages/igb.git/commitdiff
- fix incorrect timespec usage
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 29 Jun 2015 06:07:09 +0000 (08:07 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 29 Jun 2015 06:07:09 +0000 (08:07 +0200)
igb.spec
timespec64.patch [new file with mode: 0644]

index 45bd1dfa366dd1f1bacedaa2661b368ea2f8dd7d..7c3a463dd1d3eef1dbc27c4c9d7b8098cf5ca25a 100644 (file)
--- a/igb.spec
+++ b/igb.spec
@@ -17,6 +17,7 @@ License:      GPL v2
 Group:         Base/Kernel
 Source0:       http://downloads.sourceforge.net/e1000/%{pname}-%{version}.tar.gz
 # Source0-md5: dbedbb2cefaf3fa09eb5a4912914cdac
+Patch0:                timespec64.patch
 URL:           http://sourceforge.net/projects/e1000/
 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
 BuildRequires: rpm-build-macros >= 1.701
@@ -80,6 +81,7 @@ EOF\
 
 %prep
 %setup -q -n %{pname}-%{version}
+%patch0 -p1
 
 cat > src/Makefile <<'EOF'
 obj-m := igb.o
diff --git a/timespec64.patch b/timespec64.patch
new file mode 100644 (file)
index 0000000..edc14cb
--- /dev/null
@@ -0,0 +1,56 @@
+--- igb-5.3.2/src/igb_ptp.c~   2015-05-26 23:59:51.000000000 +0200
++++ igb-5.3.2/src/igb_ptp.c    2015-06-29 08:05:18.930401431 +0200
+@@ -327,7 +327,7 @@
+ }
+ static int igb_ptp_gettime64_82576(struct ptp_clock_info *ptp,
+-                               struct timespec *ts64)
++                               struct timespec64 *ts64)
+ {
+       struct igb_adapter *igb = container_of(ptp, struct igb_adapter,
+                                              ptp_caps);
+@@ -350,7 +350,7 @@
+ }
+ static int igb_ptp_gettime64_i210(struct ptp_clock_info *ptp,
+-                              struct timespec *ts64)
++                              struct timespec64 *ts64)
+ {
+       struct igb_adapter *igb = container_of(ptp, struct igb_adapter,
+                                              ptp_caps);
+@@ -369,7 +369,7 @@
+ #ifdef HAVE_PTP_CLOCK_INFO_GETTIME64
+ static int igb_ptp_settime64_82576(struct ptp_clock_info *ptp,
+-                               const struct timespec *ts64)
++                               const struct timespec64 *ts64)
+ {
+       struct igb_adapter *igb = container_of(ptp, struct igb_adapter,
+                                              ptp_caps);
+@@ -392,7 +392,7 @@
+ #endif
+ static int igb_ptp_settime64_i210(struct ptp_clock_info *ptp,
+-                              const struct timespec *ts64)
++                              const struct timespec64 *ts64)
+ {
+       struct igb_adapter *igb = container_of(ptp, struct igb_adapter,
+                                              ptp_caps);
+@@ -411,7 +411,7 @@
+ #ifndef HAVE_PTP_CLOCK_INFO_GETTIME64
+ static int igb_ptp_gettime_82576(struct ptp_clock_info *ptp,
+-                               struct timespec *ts)
++                               struct timespec64 *ts)
+ {
+       struct timespec64 ts64;
+       int err;
+@@ -426,7 +426,7 @@
+ }
+ static int igb_ptp_gettime_i210(struct ptp_clock_info *ptp,
+-                              struct timespec *ts)
++                              struct timespec64 *ts)
+ {
+       struct timespec64 ts64;
+       int err;
This page took 0.065547 seconds and 4 git commands to generate.