]> git.pld-linux.org Git - packages/igb.git/commitdiff
- updated to 4.0.17
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 20 Dec 2012 12:54:28 +0000 (13:54 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Thu, 20 Dec 2012 12:54:28 +0000 (13:54 +0100)
- fix build with linux 3.7

igb.spec
linux-3.7.patch [new file with mode: 0644]

index 8607bcf8ff21f2b55449a834809e114e172dd2f3..cc1d15cd863274b04010e6d372a460e9f9203ede 100644 (file)
--- a/igb.spec
+++ b/igb.spec
 %undefine      with_userspace
 %endif
 
-%define                rel     18
+%define                rel     1
 %define                pname   igb
 Summary:       Intel(R) PRO/1000 driver for Linux
 Summary(pl.UTF-8):     Sterownik do karty Intel(R) PRO/1000
 Name:          %{pname}%{_alt_kernel}
-Version:       3.4.7
+Version:       4.0.17
 Release:       %{rel}
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       http://downloads.sourceforge.net/e1000/%{pname}-%{version}.tar.gz
-# Source0-md5: 4503a06412e10037b5f43b3cc151e886
+# Source0-md5: 0f8ffbe574ed20e508e891e92d733718
+Patch0:                linux-3.7.patch
 URL:           http://sourceforge.net/projects/e1000/
 %{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
 BuildRequires: rpmbuild(macros) >= 1.379
@@ -59,17 +60,18 @@ Intel(R) PRO/1000 opartych o układy 82575EB/GB lub 82576.
 
 %prep
 %setup -q -n %{pname}-%{version}
+%patch0 -p1
 cat > src/Makefile <<'EOF'
 obj-m := igb.o
-igb-objs := igb_main.o e1000_82575.o e1000_mac.o e1000_nvm.o e1000_phy.o \
-e1000_manage.o igb_param.o igb_ethtool.o kcompat.o e1000_api.o e1000_mbx.o igb_vmdq.o
+igb-objs := igb_main.o e1000_82575.o e1000_i210.o e1000_mac.o e1000_nvm.o e1000_phy.o \
+       e1000_manage.o igb_param.o igb_ethtool.o kcompat.o e1000_api.o \
+       e1000_mbx.o igb_vmdq.o igb_sysfs.o igb_procfs.o igb_ptp.o
 
-EXTRA_CFLAGS=-DDRIVER_IGB
+EXTRA_CFLAGS += -DDRIVER_IGB
+EXTRA_CFLAGS += -DDRIVER_NAME=igb
+EXTRA_CFLAGS += -DDRIVER_NAME_CAPS=IGB
 EOF
 
-# Large Receive Offload - Do Not Use LRO When Routing Packets
-# CFLAGS_EXTRA=-DIGB_LRO
-
 %build
 %build_kernel_modules -C src -m %{pname}
 
diff --git a/linux-3.7.patch b/linux-3.7.patch
new file mode 100644 (file)
index 0000000..7193673
--- /dev/null
@@ -0,0 +1,11 @@
+--- igb-4.0.17/src/igb_main.c~ 2012-10-08 17:37:31.000000000 +0200
++++ igb-4.0.17/src/igb_main.c  2012-12-20 13:47:16.403675607 +0100
+@@ -7833,7 +7833,7 @@
+               goto skip_bad_vf_detection;
+       bdev = pdev->bus->self;
+-      while (bdev && (bdev->pcie_type != PCI_EXP_TYPE_ROOT_PORT))
++      while (bdev && (pci_pcie_type(bdev) != PCI_EXP_TYPE_ROOT_PORT))
+               bdev = bdev->bus->self;
+       if (!bdev)
This page took 0.076817 seconds and 4 git commands to generate.