]> git.pld-linux.org Git - packages/icewm.git/commitdiff
- outdated
authorwolf <wolf@pld-linux.org>
Wed, 18 Aug 2004 11:24:37 +0000 (11:24 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    icewm-gcc34.patch -> 1.3
    icewm-link_with_g++.patch -> 1.3
    icewm-showdesktopkey.patch -> 1.2

icewm-gcc34.patch [deleted file]
icewm-link_with_g++.patch [deleted file]
icewm-showdesktopkey.patch [deleted file]

diff --git a/icewm-gcc34.patch b/icewm-gcc34.patch
deleted file mode 100644 (file)
index 4bfbaa7..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -ruN icewm-1.2.15pre1./src/base.h icewm-1.2.15pre1/src/base.h
---- icewm-1.2.15pre1./src/base.h       2004-07-06 22:05:46.914841864 +0200
-+++ icewm-1.2.15pre1/src/base.h        2004-07-06 22:05:32.211077176 +0200
-@@ -171,7 +171,6 @@
- int strpcmp(char const *str, char const *pfx, char const *delim = "=:");
- unsigned strtoken(const char *str, const char *delim = " \t");
- char const * strnxt(const char *str, const char *delim = " \t");
--extern "C" char *basename(const char *filename);
- bool strequal(const char *a, const char *b);
- int strnullcmp(const char *a, const char *b);
-diff -ruN icewm-1.2.15pre1./src/icesound.cc icewm-1.2.15pre1/src/icesound.cc
---- icewm-1.2.15pre1./src/icesound.cc  2004-07-06 22:07:53.000000000 +0200
-+++ icewm-1.2.15pre1/src/icesound.cc   2004-07-06 22:12:24.544392984 +0200
-@@ -190,7 +190,8 @@
-     virtual int init(int & argc, char **& argv);
-     
- private:
--    friend class CommandLine : public YCommandLine {
-+    friend class CommandLine;
-+    class CommandLine : public YCommandLine {
-     public:
-       CommandLine(int & argc, char **& argv, YOSSAudio & oss):
-           YCommandLine(argc, argv), oss(oss) {}
-@@ -326,7 +327,8 @@
-     virtual int init(int & argc, char **& argv);
- private:
--    friend class CommandLine : public YCommandLine {
-+    friend class CommandLine;
-+    class CommandLine : public YCommandLine {
-     public:
-       CommandLine(int & argc, char **& argv, YESDAudio & esd):
-           YCommandLine(argc, argv), esd(esd) {}
-@@ -502,7 +504,8 @@
-             Coefficient lVol = 1.0, Coefficient rVol = 1.0);
- private:
--    friend class CommandLine : public YCommandLine {
-+    friend class CommandLine;
-+    class CommandLine : public YCommandLine {
-     public:
-       CommandLine(int & argc, char **& argv, YY2Audio & yiff):
-           YCommandLine(argc, argv), yiff(yiff) {}
diff --git a/icewm-link_with_g++.patch b/icewm-link_with_g++.patch
deleted file mode 100644 (file)
index 22d88ff..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ruN icewm-1.2.15pre1./configure.in icewm-1.2.15pre1/configure.in
---- icewm-1.2.15pre1./configure.in     2004-06-27 22:02:01.000000000 +0200
-+++ icewm-1.2.15pre1/configure.in      2004-07-06 22:02:56.094810456 +0200
-@@ -21,7 +21,6 @@
- dnl ---------- Checking for a C compiler in hope that it understands C++ too ---
- dnl
--ICE_PROG_CXX_LIGHT
- AC_LANG_CPLUSPLUS
- AC_PROG_CXX
-@@ -29,9 +28,6 @@
- dnl ---- for linking. 
- if test x"$ac_cv_prog_gxx" = x; then
-   AC_PROG_CC
--  if test x"$ac_cv_prog_gcc" = x; then
--    CXX_LINK=${CC}
--  fi
- fi
- dnl ---------- Also check how to turn off RTTI and exception handling ---
diff --git a/icewm-showdesktopkey.patch b/icewm-showdesktopkey.patch
deleted file mode 100644 (file)
index 20e1420..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
---- icewm-1.2.14pre6.orig/src/wmmgr.cc 2003-12-30 22:40:04.000000000 +0100
-+++ icewm-1.2.14pre6/src/wmmgr.cc      2004-01-09 23:41:42.000000000 +0100
-@@ -188,6 +188,8 @@
-     GRAB_WMKEY(gKeySysMinimizeAll);
-     GRAB_WMKEY(gKeySysHideAll);
-+    GRAB_WMKEY(gKeySysShowDesktop);
-+
- #ifndef NO_CONFIGURE_MENUS
-     {
-         KProgram *k = keyProgs;
-@@ -428,6 +430,9 @@
-         ///        } else if (IS_WMKEY(k, vm, gKeySysRun)) {
-         ///            if (runDlgCommand && runDlgCommand[0])
-         ///                app->runCommand(runDlgCommand);
-+    } else if(IS_WMKEY(k, vm, gKeySysShowDesktop)) {
-+        wmapp->actionPerformed(actionShowDesktop, 0);
-+        return true;                          
-     } else {
- #ifndef NO_CONFIGURE_MENUS
-         KProgram *p = keyProgs;
---- icewm-1.2.14pre6.orig/src/bindkey.h        2003-12-30 22:40:04.000000000 +0100
-+++ icewm-1.2.14pre6/src/bindkey.h     2004-01-09 23:10:25.000000000 +0100
-@@ -73,6 +73,7 @@
- #define defgKeySysMinimizeAll           XK_F9, kfAlt+kfShift, "Alt+Shift+F9"
- #define defgKeySysHideAll               XK_F11, kfAlt+kfShift, "Alt+Shift+F11"
- #define defgKeySysUndoArrange           XK_F7, kfAlt+kfShift, "Alt+Shift+F7"
-+#define defgKeySysShowDesktop                 'd', kfAlt+kfCtrl, "Alt+Ctrl+d"
- #ifdef NO_KEYBIND
-@@ -173,6 +174,7 @@
- DEF_WMKEY(gKeySysMinimizeAll);
- DEF_WMKEY(gKeySysHideAll);
- DEF_WMKEY(gKeySysUndoArrange);
-+DEF_WMKEY(gKeySysShowDesktop);
- #undef DEF_WMKEY
---- icewm-1.2.14pre6.orig/src/default.h        2003-12-30 22:40:04.000000000 +0100
-+++ icewm-1.2.14pre6/src/default.h     2004-01-09 23:08:09.000000000 +0100
-@@ -421,6 +421,7 @@
-     OKV("KeySysMinimizeAll",                    gKeySysMinimizeAll,             ""),
-     OKV("KeySysHideAll",                        gKeySysHideAll,                 ""),
-     OKV("KeySysUndoArrange",                    gKeySysUndoArrange,             ""),
-+    OKV("KeySysShowDesktop",                    gKeySysShowDesktop,             ""),
- #endif
-     OKF("WorkspaceNames", addWorkspace, ""),
-     OK0()
This page took 0.248959 seconds and 4 git commands to generate.