]> git.pld-linux.org Git - packages/icewm.git/commitdiff
- replace wmstyle startup script with script run directly by icewm-session
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 27 Jul 2011 20:11:51 +0000 (20:11 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    IceWM.RunWM -> 1.4
    icewm-startup.sh -> 1.1
    icewm.spec -> 1.217

IceWM.RunWM [deleted file]
icewm-startup.sh [new file with mode: 0644]
icewm.spec

diff --git a/IceWM.RunWM b/IceWM.RunWM
deleted file mode 100644 (file)
index 6b2d1dc..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh
-#
-# RunWM - this is a script used to launch window manager
-#
-
-if [ -x /usr/bin/icewm-session ] ; then
-       if [ ! -d ~/.icewm ] ; then
-               mkdir -p ~/.icewm
-               install -m 644 /etc/X11/icewm/* ~/.icewm/
-       fi
-       eval "exec /usr/bin/icewm-session"
-else
-cat <<EOF
- WARNING: You selected IceWM as your window manager, but your
- installation of IceWM does not appear to be functional. Either
- /usr/bin/icewm-session was not found.
-EOF
-fi
diff --git a/icewm-startup.sh b/icewm-startup.sh
new file mode 100644 (file)
index 0000000..fc01ae7
--- /dev/null
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+if [ ! -d ~/.icewm ] ; then
+       mkdir -p ~/.icewm
+       install -m 644 /etc/X11/icewm/* ~/.icewm/
+fi
index 05d06e176ad1cf5016a8a2e42efb559d3d6db32b..dd4f889eb15a1e71f02887f90ecab6772324806a 100644 (file)
@@ -27,7 +27,7 @@ Source0:      http://dl.sourceforge.net/icewm/%{name}-%{version}.tar.gz
 Source1:       IceWM.desktop
 Source3:       http://dl.sourceforge.net/icewm/iceicons-%{_iceicons_ver}.tar.gz
 # Source3-md5: 53ed111a3c4d1e609bd1604ddccd4701
 Source1:       IceWM.desktop
 Source3:       http://dl.sourceforge.net/icewm/iceicons-%{_iceicons_ver}.tar.gz
 # Source3-md5: 53ed111a3c4d1e609bd1604ddccd4701
-Source4:       IceWM.RunWM
+Source4:       icewm-startup.sh
 Source6:       http://dl.sourceforge.net/icewm/netscapeicons-%{_netscapeicons_ver}.tar.gz
 # Source6-md5: 409aa9b02adc11309ed546c5120c01d2
 Source7:       %{name}-xsession.desktop
 Source6:       http://dl.sourceforge.net/icewm/netscapeicons-%{_netscapeicons_ver}.tar.gz
 # Source6-md5: 409aa9b02adc11309ed546c5120c01d2
 Source7:       %{name}-xsession.desktop
@@ -60,7 +60,6 @@ Suggests:     vfmg >= 0.9.95
 Conflicts:     filesystem < 3.0-20
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 Conflicts:     filesystem < 3.0-20
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _wmstyledir     /etc/sysconfig/wmstyle
 %define                _wmpropsdir     /usr/share/gnome/wm-properties
 %define                specflags_ia32  -fomit-frame-pointer
 
 %define                _wmpropsdir     /usr/share/gnome/wm-properties
 %define                specflags_ia32  -fomit-frame-pointer
 
@@ -161,14 +160,14 @@ cp -f /usr/share/automake/config.sub .
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_datadir}/xsessions,%{_pixmapsdir},%{_wmstyledir}} \
+install -d $RPM_BUILD_ROOT{%{_datadir}/xsessions,%{_pixmapsdir}} \
        $RPM_BUILD_ROOT{%{_wmpropsdir},%{_sysconfdir}/X11/%{name}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_wmpropsdir}
        $RPM_BUILD_ROOT{%{_wmpropsdir},%{_sysconfdir}/X11/%{name}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_wmpropsdir}
-install %{SOURCE4} $RPM_BUILD_ROOT%{_wmstyledir}/%{name}-session.sh
+install %{SOURCE4} $RPM_BUILD_ROOT%{_datadir}/icewm/startup
 install %{SOURCE7} $RPM_BUILD_ROOT%{_datadir}/xsessions/%{name}.desktop
 install lib/keys $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/keys
 sed 's|^# IconPath=""|IconPath="%{_datadir}/pixmaps:%{_datadir}/icons"|' < lib/preferences > $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/preferences
 install %{SOURCE7} $RPM_BUILD_ROOT%{_datadir}/xsessions/%{name}.desktop
 install lib/keys $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/keys
 sed 's|^# IconPath=""|IconPath="%{_datadir}/pixmaps:%{_datadir}/icons"|' < lib/preferences > $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/preferences
@@ -201,13 +200,13 @@ test -h %{_pixmapsdir}/icewm || rm -rf %{_pixmapsdir}/icewm
 %{_datadir}/icewm/icons
 %{_datadir}/icewm/ledclock
 %{_datadir}/icewm/mailbox
 %{_datadir}/icewm/icons
 %{_datadir}/icewm/ledclock
 %{_datadir}/icewm/mailbox
+%attr(755,root,root) %{_datadir}/icewm/startup
 %{_datadir}/icewm/taskbar
 %dir %{_datadir}/icewm/themes
 %{_datadir}/icewm/themes/Infadel2
 %{_datadir}/icewm/themes/icedesert
 %{_datadir}/xsessions/%{name}.desktop
 %{_wmpropsdir}/*
 %{_datadir}/icewm/taskbar
 %dir %{_datadir}/icewm/themes
 %{_datadir}/icewm/themes/Infadel2
 %{_datadir}/icewm/themes/icedesert
 %{_datadir}/xsessions/%{name}.desktop
 %{_wmpropsdir}/*
-%attr(755,root,root) %{_wmstyledir}/%{name}-session.sh
 
 %files themes-base
 %defattr(644,root,root,755)
 
 %files themes-base
 %defattr(644,root,root,755)
This page took 0.14133 seconds and 4 git commands to generate.