]> git.pld-linux.org Git - packages/icewm.git/blobdiff - icewm.spec
- remove duplicate locale (no -> nb)
[packages/icewm.git] / icewm.spec
index a033d9f34a850ae72503c3a816397479c4b5712c..d0ed18254078afe90e44495c51a6301b9c6c4534 100644 (file)
@@ -1,63 +1,79 @@
-#
-# Conditional build:
-%bcond_with    gradients       # enable gradients (implies with_antialiasing)
-%bcond_without antialiasing    # disable antialiasing
-%bcond_without freetype        # disable xfreetype support (implies !with_antialiasing)
-%bcond_without guievents       # disable guievents
-%bcond_without imlib           # disable imlib support
-#
 # TODO:
 # - make a PLD-theme - default :]
 #
+# Conditional build:
+%bcond_without gradients       # gradients (requires antialiasing which requires freetype)
+%bcond_without freetype        # xfreetype support (implies no antialiasing)
+%bcond_without guievents       # GUI events
+%bcond_without alsa            # ALSA sound for GUI events
+%bcond_with    esd             # EsounD sound for GUI events
+%bcond_without yiff            # YIFF sound for GUI events
+%bcond_with    gnome2          # support for GNOME2 menus and wm-properties
 
+%if %{without guievents}
+%undefine      with_alsa
+%undefine      with_esd
+%undefine      with_yiff
+%endif
 Summary:       IceWM X11 Window Manager
-Summary(es):   Administrador de Ventanas X11
-Summary(pl):   IceWM - zarz±dca okienek X11
-Summary(pt_BR):        Gerenciador de Janelas X11
-Summary(ru):   ïËÏÎÎÙÊ ÍÅÎÅÄÖÅÒ ÄÌÑ X11
-Summary(uk):   ÷¦ËÏÎÎÉÊ ÍÅÎÅÄÖÅÒ ÄÌÑ X11
+Summary(de.UTF-8):     IceWM ist ein Window Manager für X
+Summary(es.UTF-8):     Administrador de Ventanas X11
+Summary(pl.UTF-8):     IceWM - zarządca okienek X11
+Summary(pt_BR.UTF-8):  Gerenciador de Janelas X11
+Summary(ru.UTF-8):     Оконный менеджер для X11
+Summary(uk.UTF-8):     Віконний менеджер для X11
 Name:          icewm
-Version:       1.2.15
-%define _pre pre1
-Release:       1.%{_pre}.4
+Version:       1.4.2
+%define        iceicons_ver            0.6
+Release:       2
 Epoch:         2
-License:       LGPL
+License:       LGPL v2
 Group:         X11/Window Managers
-Source0:       http://dl.sourceforge.net/icewm/%{name}-%{version}%{_pre}.tar.gz
-# Source0-md5: 833578c36a47c70531f6c17f947d678d
+#Source0Download: https://github.com/ice-wm/icewm/releases
+Source0:       https://github.com/ice-wm/icewm/archive/%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: db9900056366adc163b2e501a5247bbc
 Source1:       IceWM.desktop
-Source3:       http://dl.sourceforge.net/icewm/iceicons-0.6.tar.gz
+Source3:       http://downloads.sourceforge.net/icewm/iceicons-%{iceicons_ver}.tar.gz
 # Source3-md5: 53ed111a3c4d1e609bd1604ddccd4701
-Source4:       IceWM.RunWM
-Source6:       http://dl.sourceforge.net/icewm/netscapeicons-0.2.tar.gz
-# Source6-md5: 409aa9b02adc11309ed546c5120c01d2
-Source7:       %{name}-xsession.desktop
-Patch0:                %{name}-broken-xrandr.patch
-Patch1:                %{name}-home_etc.patch
-Patch2:                %{name}-link_with_g++.patch
-Patch3:                %{name}-showdesktopkey.patch
-Patch4:                %{name}-gcc34.patch
-Patch5:                %{name}-helpbrowser.patch
-URL:           http://www.icewm.org/
-BuildRequires: XFree86-devel
-BuildRequires: autoconf >= 2.50
-BuildRequires: automake
-%{?with_guievents:BuildRequires:       esound-devel}
-BuildRequires: gettext-devel
-%{?with_gnome:BuildRequires:   gnome-desktop-devel}
-%{?with_imlib:BuildRequires:   imlib-devel}
+Source4:       icewm-startup.sh
+Patch0:                %{name}-build-fixes.patch
+URL:           https://ice-wm.org/
+%{?with_alsa:BuildRequires:    alsa-lib-devel}
+BuildRequires: asciidoc
+BuildRequires: autoconf >= 2.69
+BuildRequires: automake >= 1:1.13.4
+%{?with_esd:BuildRequires:     esound-devel}
+BuildRequires: fontconfig-devel
+BuildRequires: fribidi-devel >= 0.10.4
+BuildRequires: gdk-pixbuf2-xlib-devel >= 2.0
+BuildRequires: gettext-tools >= 0.19.6
+BuildRequires: glib2-devel >= 2.0
+%{?with_gnome2:BuildRequires:  gnome-desktop2-devel >= 2.0}
+%{?with_gnome2:BuildRequires:  gnome-vfs2-devel >= 2.0}
+%{?with_gnome2:BuildRequires:  libgnomeui-devel >= 2.0}
+%{?with_alsa:BuildRequires:    libsndfile-devel}
 BuildRequires: libstdc++-devel
-%{?with_freetype:BuildRequires:        xft-devel >= 2.1}
-BuildRequires: yiff-devel
-Requires(pre): fileutils
-Requires(pre): sh-utils
-Requires:      vfmg
+BuildRequires: libtool >= 2:2.4.2
+BuildRequires: pkgconfig
+BuildRequires: sed >= 4.0
+BuildRequires: xorg-lib-libICE-devel
+BuildRequires: xorg-lib-libSM-devel
+BuildRequires: xorg-lib-libX11-devel
+BuildRequires: xorg-lib-libXext-devel
+%{?with_freetype:BuildRequires:        xorg-lib-libXft-devel >= 2.1}
+BuildRequires: xorg-lib-libXinerama-devel
+BuildRequires: xorg-lib-libXrandr-devel
+%{?with_yiff:BuildRequires:    yiff-devel >= 2.14.7-3}
+Requires(pre): /bin/rm
+Requires(pre): /usr/bin/test
+Requires:      shared-mime-info
 Requires:      xinitrc-ng
+Suggests:      vfmg >= 0.9.95
+Conflicts:     filesystem < 3.0-20
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _wmstyledir     /etc/sysconfig/wmstyle
-%define                _wmpropsdir     /usr/share/wm-properties
-%define                specflags_ia32   -fomit-frame-pointer 
+%define                _wmpropsdir     /usr/share/gnome/wm-properties
+%define                specflags_ia32  -fomit-frame-pointer
 
 %description
 Window Manager for X Window System. Can emulate the look of
@@ -65,106 +81,126 @@ Windows'95, OS/2 Warp 3,4, Motif. Tries to take the best features of
 the above systems. Features multiple workspaces, opaque move/resize,
 task bar, window list, mailbox status, digital clock. Fast and small.
 
-%description -l es
+%description -l es.UTF-8
 Administrador de Ventanas para el X Window. Puede emular la apariencia
 del Windows'95, OS/2 Warp 3 y 4 y el Motif. Intenta usar las mejores
-características de los sistemas citados. Características: varios
+características de los sistemas citados. Características: varios
 ambientes de trabajo, movimiento/ redimensionamiento opaco, barra de
 tareas, lista de ventanas, estado de la caja de entrada del correo y
-reloj digital. Rápido y pequeño.
+reloj digital. Rápido y pequeño.
 
-%description -l pl
-Zarz±dca okienek pod X11. Mo¿e emulowaæ wygl±d Windows'95, OS/2 Warp
-3, 4, MWM. Zarz±dca ten próbuje przej±æ z powy¿szych ¶rodowisk ich
-najlepsze cechy, takie jak: wiele jednoczenie obecnych przestrzeni
-roboczych, paski narzêdziowe, status skrzynki z poczt±, cyfrowy zegar.
-Jest przy tym ma³y i szybki.
+%description -l pl.UTF-8
+Zarządca okienek pod X11. Może emulować wygląd Windows'95, OS/2 Warp
+3, 4, MWM. Zarządca ten próbuje przejąć z powyższych środowisk ich
+najlepsze cechy, takie jak: wiele jednocześnie obecnych przestrzeni
+roboczych, paski narzędziowe, status skrzynki z pocztą, cyfrowy zegar.
+Jest przy tym mały i szybki.
 
-%description -l pt_BR
-Gerenciador de Janelas para o X Window. Pode emular a aparência do
+%description -l pt_BR.UTF-8
+Gerenciador de Janelas para o X Window. Pode emular a aparência do
 Windows'95, OS/2 Warp 3 e 4 e o Motif. Tenta usar as melhores
-características dos sistemas citados. Características: vários
-ambientes de trabalho, movimentação/ redimensionamento opaco, barra de
+características dos sistemas citados. Características: vários
+ambientes de trabalho, movimentação/ redimensionamento opaco, barra de
 tarefas, lista de janelas, status da caixa de entrada do correio e
-relógio digital. É rápido e pequeno.
-
-%description -l ru
-ïËÏÎÎÙÊ ÍÅÎÅÄÖÅÒ ÄÌÑ X Window System. íÏÖÅÔ ÜÍÕÌÉÒÏ×ÁÔØ ×ÎÅÛÎÉÊ ×ÉÄ
-Windows'95, OS/2 Warp 3,4, Motif. óÔÁÒÁÅÔÓÑ ×ÚÑÔØ ÌÕÞÛÅÅ ÉÚ ÕÐÏÍÑÎÕÔÙÈ
-ÓÉÓÔÅÍ. ðÏÄÄÅÒÖÉ×ÁÅÔ ÎÅÓËÏÌØËÏ ÒÁÂÏÞÉÈ ÐÏ×ÅÒÈÎÏÓÔÅÊ, ÎÅÐÒÏÚÒÁÞÎÏÅ
-ÐÅÒÅÍÅÝÅÎÉÅ ÏËÏÎ, ÐÏÌÏÓËÕ ÚÁÄÁÎÉÊ, ÓÐÉÓÏË ÏËÏÎ, ÓÔÁÔÕÓ ÐÏÞÔÏ×ÏÇÏ
-ÑÝÉËÁ, ÃÉÆÒÏ×ÙÅ ÞÁÓÙ. âÙÓÔÒÙÊ É ËÏÍÐÁËÔÎÙÊ.
-
-%description -l uk
-÷¦ËÏÎÎÉÊ ÍÅÎÅÄÖÅÒ ÄÌÑ X Window System. íÏÖÅ ÅÍÕÌÀ×ÁÔÉ ÚÏ×ΦÛΦʠ×ÉÇÌÑÄ
-Windows'95, OS/2 Warp 3,4, Motif. îÁÍÁÇÁ¤ÔØÓÑ ×ÚÑÔÉ ÎÁÊËÒÁÝÅ ¦Ú
-ÚÇÁÄÁÎÉÈ ÓÉÓÔÅÍ. ð¦ÄÔÒÉÍÕ¤ Ë¦ÌØËÁ ÒÏÂÏÞÉÈ ÐÌÏÝÉÎ, ÎÅÐÒÏÚÏÒÅ
-ÐÅÒÅͦÝÅÎÎѠצËÏÎ, ÓÍÕÖËÕ ÚÁ×ÄÁÎØ, ÓÐÉÓÏˠצËÏÎ, ÓÔÁΠÐÏÛÔÏ×ϧ
-ÓËÒÉÎØËÉ, ÃÉÆÒÏ×ÉÊ ÇÏÄÉÎÎÉË. û×ÉÄËÉÊ ÔÁ ËÏÍÐÁËÔÎÉÊ.
+relógio digital. É rápido e pequeno.
+
+%description -l ru.UTF-8
+Оконный менеджер для X Window System. Может эмулировать внешний вид
+Windows'95, OS/2 Warp 3,4, Motif. Старается взять лучшее из упомянутых
+систем. Поддерживает несколько рабочих поверхностей, непрозрачное
+перемещение окон, полоску заданий, список окон, статус почтового
+ящика, цифровые часы. Быстрый и компактный.
+
+%description -l uk.UTF-8
+Віконний менеджер для X Window System. Може емулювати зовнішній вигляд
+Windows'95, OS/2 Warp 3,4, Motif. Намагається взяти найкраще із
+згаданих систем. Підтримує кілька робочих площин, непрозоре
+переміщення вікон, смужку завдань, список вікон, стан поштової
+скриньки, цифровий годинник. Швидкий та компактний.
+
+%description -l de.UTF-8
+IceWM ist ein in C++ programmierter, unter GPL stehender
+Fenstermanager für das X11-Fenstersystem. Ziel von IceWM ist
+Geschwindigkeit, Schlichtheit und Bedienerfreundlichkeit.
+
+In der Standardeinstellung erinnert das Design von IceWM stark an
+Microsoft Windows: Er verfügt über eine Taskleiste am unteren
+Bildrand, das aktive Fenster lässt sich mit der Tastenkombination
+ALT-TAB wechseln, etc.
 
 %package themes-base
 Summary:       Pack of themes for IceWM
-Summary(pl):   Zestaw motywów dla IceWM-a
+Summary(pl.UTF-8):     Zestaw motywów dla IceWM-a
 Group:         Themes
 Requires:      icewm
 
 %description themes-base
-Standard pack of themes delivered with IceWM. All of them made by
-Marko Macek: gtk2, metal2, motif, nice, nice2, warp3, warp4, win95.
+Standard pack of themes delivered with IceWM:
+- CrystalBlue by BlueScorpio
+- Helix by RudeSka and TigerT
+- NanoBlue by lion1810
+- metal2, motif, win32 by Marko Macek
+
+This package contains also old themes, no longer installed by default
+in IceWM 1.4:
+- gtk2, nice, nice2, warp3, warp4 by Marko Macek
+- yellowmotif by Andreas Leitgeb
 
-%description themes-base -l pl
-Standardowy zestaw motywów dla IceWM-a, dostarczany wraz z nim.
-Wszystkie stworzone przez Marko Macka: gtk2, metal2, motif, nice,
-nice2, warp3, warp4, win95.
+%description themes-base -l pl.UTF-8
+Standardowy zestaw motywów dla IceWM-a, dostarczany wraz z nim:
+- CrystalBlue autorstwa BlueScorpio
+- Helix autorstwa RudeSka i TigerT
+- NanoBlue autorstwa lion1810
+- metal2, motif, win32 autorstwa Marko Macka
+
+Pakiet zawiera także stare motywy, nie instalowane domyślnie wraz z
+IceWM-em 1.4:
+- gtk2, nice, nice2, warp3, warp4 autorstwa Marko Macka
+- yellowmotif autorstwa Andreasa Leitgeba
 
 %prep
-%setup -q -n %{name}-%{version}%{_pre}
+%setup -q
 %patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
-%patch5 -p1
 
-mv -f po/{no,nb}.po
-mv -f po/{zh_TW.Big5,zh_TW}.po
+tar -xzf %{SOURCE3} -C lib/icons
 
-cd lib/icons
-tar -xzf %{SOURCE3}
-tar -xzf %{SOURCE6}
+%{__sed} -i -e '/po\/Makefile.in/d' configure.ac
 
 %build
-cp -f /usr/share/automake/config.sub .
-%{__aclocal}
+%{__gettextize}
+%{__libtoolize}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
+%{__automake}
 %configure \
-       %{?with_gradients:--enable-gradients} \
-       %{?with_antialiasing:--enable-antialiasing} \
-       %{!?with_freetype:--disable-xfreetype} \
-       %{?with_guievents:--enable-guievents} \
-       %{?with_gnome:--enable-menus-gnome} \
-       %{!?with_imlib:--without-imlib} \
+       ASCIIDOC=/usr/bin/asciidoc \
+       %{!?with_gradients:--disable-gradients} \
+       %{?with_guievents:--enable-guievents --with-icesound=%{?with_alsa:ALSA,}OSS%{?with_yiff:,Y}%{?with_esd:,ESound}} \
+       %{!?with_gnome2:--disable-menus-gnome2} \
        --enable-shaped-decorations \
+       %{!?with_freetype:--disable-xfreetype --enable-corefonts} \
        --with-cfgdir=%{_sysconfdir}/X11/%{name} \
        --with-docdir=%{_docdir}
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_datadir}/xsessions,%{_pixmapsdir},%{_wmstyledir}} \
-       $RPM_BUILD_ROOT{%{_wmpropsdir},%{_sysconfdir}/X11/%{name}}
+install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_wmpropsdir},%{_sysconfdir}/X11/%{name}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install %{SOURCE1} $RPM_BUILD_ROOT%{_wmpropsdir}
-install %{SOURCE4} $RPM_BUILD_ROOT%{_wmstyledir}/%{name}-session.sh
-install %{SOURCE7} $RPM_BUILD_ROOT%{_datadir}/xsessions/%{name}.desktop
-install lib/keys $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/keys
-install lib/preferences $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/preferences
-install lib/toolbar $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/toolbar
-install lib/winoptions $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/winoptions
+%{__sed} -e 's|^# IconPath=""|IconPath="%{_datadir}/pixmaps:%{_datadir}/icons"|' -i $RPM_BUILD_ROOT%{_datadir}/icewm/preferences
+
+# packaged as %doc
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/icewm
+
+%{?with_gnome2:cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_wmpropsdir}}
+cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_datadir}/icewm/startup
+cp -p lib/keys $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/keys
+cp -p lib/toolbar $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/toolbar
+cp -p lib/winoptions $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/winoptions
 echo %{_bindir}/icewmbg > $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/startup
 :> $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/restart
 
@@ -172,6 +208,12 @@ ln -s %{_datadir}/icewm/icons $RPM_BUILD_ROOT%{_pixmapsdir}/icewm
 
 echo "menuprog \"Programs\" %{_datadir}/icewm/icons/folder_16x16.xpm vfmg -i -f -x -c -s icewm" > $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/menu
 
+# old themes, no longer installed
+cp -pr lib/themes/{gtk2,nice,nice2,warp3,warp4,yellowmotif} $RPM_BUILD_ROOT%{_datadir}/icewm/themes
+
+# duplicate locale
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/no
+
 %find_lang %{name}
 
 %clean
@@ -182,32 +224,60 @@ test -h %{_pixmapsdir}/icewm || rm -rf %{_pixmapsdir}/icewm
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS BUGS CHANGES PLATFORMS README* TODO icewm.lsm doc/*.html
-%attr(755,root,root) %{_bindir}/*
+%doc AUTHORS BUGS CHANGES ChangeLog NEWS PLATFORMS README.md THANKS TODO doc/*.html
+%attr(755,root,root) %{_bindir}/icehelp
+%attr(755,root,root) %{_bindir}/icesh
+%if %{with guievents}
+%attr(755,root,root) %{_bindir}/icesound
+%endif
+%attr(755,root,root) %{_bindir}/icewm
+%attr(755,root,root) %{_bindir}/icewm-menu-fdo
+%attr(755,root,root) %{_bindir}/icewm-session
+%attr(755,root,root) %{_bindir}/icewm-set-gnomewm
+%attr(755,root,root) %{_bindir}/icewmbg
+%attr(755,root,root) %{_bindir}/icewmhint
+%attr(755,root,root) %{_bindir}/icewmtray
 %dir %{_sysconfdir}/X11/%{name}
-%config(noreplace,missingok) %verify(not md5 size mtime) %{_sysconfdir}/X11/%{name}/[!rs]*
-%config(noreplace,missingok) %verify(not md5 size mtime) %attr(755,root,root) %{_sysconfdir}/X11/%{name}/[rs]*
+%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/X11/%{name}/keys
+%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/X11/%{name}/menu
+%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/X11/%{name}/toolbar
+%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/X11/%{name}/winoptions
+%config(noreplace,missingok) %verify(not md5 mtime size) %attr(755,root,root) %{_sysconfdir}/X11/%{name}/restart
+%config(noreplace,missingok) %verify(not md5 mtime size) %attr(755,root,root) %{_sysconfdir}/X11/%{name}/startup
 %{_pixmapsdir}/icewm
 %dir %{_datadir}/icewm
 %{_datadir}/icewm/icons
+%{_datadir}/icewm/keys
+%{_datadir}/icewm/menu
 %{_datadir}/icewm/ledclock
 %{_datadir}/icewm/mailbox
+%{_datadir}/icewm/preferences
+%{_datadir}/icewm/programs
+%attr(755,root,root) %{_datadir}/icewm/startup
+%{_datadir}/icewm/toolbar
 %{_datadir}/icewm/taskbar
+%{_datadir}/icewm/winoptions
 %dir %{_datadir}/icewm/themes
 %{_datadir}/icewm/themes/Infadel2
+%{_datadir}/icewm/themes/default
 %{_datadir}/icewm/themes/icedesert
-%{_datadir}/xsessions/%{name}.desktop
-%{_wmpropsdir}/*
-%attr(755,root,root) %{_wmstyledir}/%{name}-session.sh
+%{_datadir}/xsessions/icewm.desktop
+%{_datadir}/xsessions/icewm-session.desktop
+%{?with_gnome2:%{_wmpropsdir}/IceWM.desktop}
+%{_mandir}/man1/icewm.1*
 
 %files themes-base
 %defattr(644,root,root,755)
-%{_datadir}/icewm/themes/gtk2
+%{_datadir}/icewm/themes/CrystalBlue
+%{_datadir}/icewm/themes/Helix
+%{_datadir}/icewm/themes/NanoBlue
 %{_datadir}/icewm/themes/metal2
 %{_datadir}/icewm/themes/motif
+%{_datadir}/icewm/themes/win95
+# old themes, no longer installed in 1.4.x
+%{_datadir}/icewm/themes/gtk2
 %{_datadir}/icewm/themes/nice
 %{_datadir}/icewm/themes/nice2
 %{_datadir}/icewm/themes/warp3
 %{_datadir}/icewm/themes/warp4
-%{_datadir}/icewm/themes/win95
 %{_datadir}/icewm/themes/yellowmotif
This page took 0.066382 seconds and 4 git commands to generate.