]> git.pld-linux.org Git - packages/icewm.git/blobdiff - icewm.spec
- set IconPath
[packages/icewm.git] / icewm.spec
index 305484a296184ccad2ddb66b4a77eb90be5338d8..b8fdf20fae306f01d2787dc339c189bb205b4500 100644 (file)
@@ -1,11 +1,10 @@
 #
 # Conditional build:
-# _with_gradients      - enable gradients (implies _with_antialiasing)
-# _without_antialiasing        - disable antialiasing
-# _without_freetype    - disable xfreetype support (implies _without_antialiasing)
-# _without_guievents   - disable guievents
-# _with_gnome          - enable GNOME support
-# _without_imlib       - disable imlib support
+%bcond_with    gradients       # enable gradients (implies with_antialiasing)
+%bcond_without antialiasing    # disable antialiasing
+%bcond_without freetype        # disable xfreetype support (implies !with_antialiasing)
+%bcond_without guievents       # disable guievents
+%bcond_without imlib           # disable imlib support
 #
 # TODO:
 # - make a PLD-theme - default :]
@@ -18,41 +17,44 @@ Summary(pt_BR):     Gerenciador de Janelas X11
 Summary(ru):   ïËÏÎÎÙÊ ÍÅÎÅÄÖÅÒ ÄÌÑ X11
 Summary(uk):   ÷¦ËÏÎÎÉÊ ÍÅÎÅÄÖÅÒ ÄÌÑ X11
 Name:          icewm
-Version:       1.2.14
-Release:       0.2
+Version:       1.2.16
+#%define _pre pre1
+Release:       2
 Epoch:         2
 License:       LGPL
 Group:         X11/Window Managers
-Source0:       http://dl.sourceforge.net/icewm/%{name}-%{version}pre1.tar.gz
-# Source0-md5: 12dcbab8083a800354b1974c278581d9
+#Source0:      http://dl.sourceforge.net/icewm/%{name}-%{version}%{_pre}.tar.gz
+Source0:       http://dl.sourceforge.net/icewm/%{name}-%{version}.tar.gz
+# Source0-md5: 1aa92846cc516a2ac1d668d80c3ca5ea
 Source1:       IceWM.desktop
-Source2:       %{name}.directory
 Source3:       http://dl.sourceforge.net/icewm/iceicons-0.6.tar.gz
 # Source3-md5: 53ed111a3c4d1e609bd1604ddccd4701
 Source4:       IceWM.RunWM
-Source5:       IceWM.wm_style
 Source6:       http://dl.sourceforge.net/icewm/netscapeicons-0.2.tar.gz
 # Source6-md5: 409aa9b02adc11309ed546c5120c01d2
 Source7:       %{name}-xsession.desktop
 Patch0:                %{name}-broken-xrandr.patch
 Patch1:                %{name}-home_etc.patch
+Patch2:                %{name}-helpbrowser.patch
 URL:           http://www.icewm.org/
 BuildRequires: XFree86-devel
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.50
 BuildRequires: automake
-%{!?_without_guievents:BuildRequires:  esound-devel}
+%{?with_guievents:BuildRequires:       esound-devel}
 BuildRequires: gettext-devel
-%{?_with_gnome:BuildRequires:  gnome-desktop-devel}
-%{!?_without_imlib:BuildRequires:      imlib-devel}
+%{?with_imlib:BuildRequires:   imlib-devel}
 BuildRequires: libstdc++-devel
-%{!?_without_freetype:BuildRequires:   xft-devel >= 2.1}
+%{?with_freetype:BuildRequires:        xft-devel >= 2.1}
+BuildRequires: yiff-devel
 Requires(pre): fileutils
 Requires(pre): sh-utils
+Requires:      vfmg
+Requires:      xinitrc-ng
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _wmstyledir     /etc/sysconfig/wmstyle
 %define                _wmpropsdir     /usr/share/wm-properties
-%define                specflags_ia32  "-fomit-frame-pointer"
+%define                specflags_ia32   -fomit-frame-pointer 
 
 %description
 Window Manager for X Window System. Can emulate the look of
@@ -113,26 +115,31 @@ Wszystkie stworzone przez Marko Macka: gtk2, metal2, motif, nice,
 nice2, warp3, warp4, win95.
 
 %prep
-%setup -q -n %{name}-%{version}pre1
+#%setup -q -n %{name}-%{version}%{_pre}
+%setup -q
 %patch0 -p1
 %patch1 -p1
+#%patch2 -p1
+
+mv -f po/{no,nb}.po
+mv -f po/{zh_TW.Big5,zh_TW}.po
 
 cd lib/icons
 tar -xzf %{SOURCE3}
 tar -xzf %{SOURCE6}
 
 %build
-rm -f missing
+cp -f /usr/share/automake/config.sub .
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %configure \
-       %{?_with_gradients:--enable-gradients} \
-       %{!?_without_antialiasing:--enable-antialiasing} \
-       %{?_without_freetype:--disable-xfreetype} \
-       %{!?_without_guievents:--enable-guievents} \
-       %{?_with_gnome:--enable-menus-gnome} \
-       %{?_without_imlib:--without-imlib} \
+       %{?with_gradients:--enable-gradients} \
+       %{?with_antialiasing:--enable-antialiasing} \
+       %{!?with_freetype:--disable-xfreetype} \
+       %{?with_guievents:--enable-guievents} \
+       %{!?with_imlib:--without-imlib} \
+       --disable-menus-gnome \
        --enable-shaped-decorations \
        --with-cfgdir=%{_sysconfdir}/X11/%{name} \
        --with-docdir=%{_docdir}
@@ -141,18 +148,16 @@ rm -f missing
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_datadir}/xsessions,%{_pixmapsdir},%{_wmstyledir}} \
-       $RPM_BUILD_ROOT{%{_applnkdir}/Settings/IceWM,%{_wmpropsdir},%{_sysconfdir}/X11/%{name}}
+       $RPM_BUILD_ROOT{%{_wmpropsdir},%{_sysconfdir}/X11/%{name}}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_wmpropsdir}
-install %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Settings/IceWM/.directory
-install %{SOURCE4} $RPM_BUILD_ROOT%{_wmstyledir}/%{name}.sh
-install %{SOURCE5} $RPM_BUILD_ROOT%{_wmstyledir}/%{name}.names
+install %{SOURCE4} $RPM_BUILD_ROOT%{_wmstyledir}/%{name}-session.sh
 install %{SOURCE7} $RPM_BUILD_ROOT%{_datadir}/xsessions/%{name}.desktop
 install lib/keys $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/keys
-install lib/preferences $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/preferences
+sed 's|^# IconPath=""|IconPath="/usr/share/pixmaps:/usr/share/icons"|' < lib/preferences > $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/preferences
 install lib/toolbar $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/toolbar
 install lib/winoptions $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/winoptions
 echo %{_bindir}/icewmbg > $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/startup
@@ -160,11 +165,7 @@ echo %{_bindir}/icewmbg > $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/startup
 
 ln -s %{_datadir}/icewm/icons $RPM_BUILD_ROOT%{_pixmapsdir}/icewm
 
-%if 0%{?_with_gnome:1}
-echo "menuprog \"Programs\" %{_datadir}/icewm/icons/folder_16x16.xpm icewm-menu-gnome2 --list \"%{_applnkdir}\"" > $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/menu
-%else
-echo "menuprog \"Programs\" %{_datadir}/icewm/icons/folder_16x16.xpm wmconfig --output icewm" > $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/menu
-%endif
+echo "menuprog \"Programs\" %{_datadir}/icewm/icons/folder_16x16.xpm vfmg -i -f -x -c -s icewm" > $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/menu
 
 %find_lang %{name}
 
@@ -191,11 +192,8 @@ test -h %{_pixmapsdir}/icewm || rm -rf %{_pixmapsdir}/icewm
 %{_datadir}/icewm/themes/Infadel2
 %{_datadir}/icewm/themes/icedesert
 %{_datadir}/xsessions/%{name}.desktop
-%dir %{_applnkdir}/Settings/IceWM
-%{_applnkdir}/Settings/IceWM/.directory
 %{_wmpropsdir}/*
-%{_wmstyledir}/%{name}.names
-%attr(755,root,root) %{_wmstyledir}/%{name}.sh
+%attr(755,root,root) %{_wmstyledir}/%{name}-session.sh
 
 %files themes-base
 %defattr(644,root,root,755)
@@ -207,3 +205,4 @@ test -h %{_pixmapsdir}/icewm || rm -rf %{_pixmapsdir}/icewm
 %{_datadir}/icewm/themes/warp3
 %{_datadir}/icewm/themes/warp4
 %{_datadir}/icewm/themes/win95
+%{_datadir}/icewm/themes/yellowmotif
This page took 0.108439 seconds and 4 git commands to generate.