]> git.pld-linux.org Git - packages/icedove.git/blobdiff - icedove.spec
Revert "- up to 45.8.0"
[packages/icedove.git] / icedove.spec
index bd80ffdcaced9a276b9241025a4fa1814516eeac..c90efbd5b21fc34ff3250fec8d1d5dcdb579a512 100644 (file)
 %undefine      crashreporter
 %endif
 
-%define                nspr_ver        4.10.2
-%define                nss_ver         3.16.2.3
+%define                nspr_ver        4.10.6
+%define                nss_ver         3.19.2.1
 
-%define                xulrunner_ver   2:24.0
+%define                xulrunner_ver   2:31.3.0
 
 %if %{without xulrunner}
 # The actual sqlite version (see RHBZ#480989):
 Summary:       Icedove - email client
 Summary(pl.UTF-8):     Icedove - klient poczty
 Name:          icedove
-Version:       31.3.0
-Release:       0.1
+Version:       38.5.0
+Release:       5
 License:       MPL v2.0
 Group:         X11/Applications/Mail
 Source0:       http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
-# Source0-md5: 3781dfb541412c7f6b530a654b834ce5
-Source2:       %{name}-branding.tar.bz2
-# Source2-md5: d8e6897870bf288fdf264c0e9ef85f7d
-Source3:       %{name}-rm_nonfree.sh
+# Source0-md5: 516ddb66f788ea7db48ed0d76f7a7ebc
+Source2:       %{name}-branding.tar.xz
+# Source2-md5: 66753bc5c924d7492b6b5c9bdc3e4b5b
 Source4:       %{name}.desktop
 Source5:       %{name}.sh
 Patch0:                %{name}-branding.patch
-Patch3:                %{name}-fonts.patch
-Patch6:                %{name}-prefs.patch
-Patch7:                system-mozldap.patch
-Patch8:                %{name}-makefile.patch
-Patch10:       %{name}-extensiondir.patch
-Patch12:       no-subshell.patch
+Patch2:                %{name}-prefs.patch
+Patch3:                system-mozldap.patch
+Patch5:                %{name}-extensiondir.patch
+Patch6:                no-subshell.patch
 # Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
-Patch13:       system-virtualenv.patch
-Patch15:       enable-addons.patch
-Patch16:       bump-nss-req.patch
+Patch7:                system-virtualenv.patch
+Patch8:                enable-addons.patch
+Patch9:                bump-nss-req.patch
 URL:           http://www.pld-linux.org/Packages/Icedove
 BuildRequires: GConf2-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
@@ -65,6 +62,7 @@ BuildRequires:        gstreamer0.10-plugins-base-devel
 BuildRequires: hunspell-devel
 BuildRequires: libIDL-devel >= 0.8.0
 BuildRequires: libevent-devel
+BuildRequires: libicu-devel >= 50.1
 BuildRequires: libiw-devel
 # requires libjpeg-turbo implementing at least libjpeg 6b API
 BuildRequires: libjpeg-devel >= 6b
@@ -74,15 +72,16 @@ BuildRequires:      libstdc++-devel
 BuildRequires: mozldap-devel
 BuildRequires: nspr-devel >= 1:%{nspr_ver}
 BuildRequires: nss-devel >= 1:%{nss_ver}
-BuildRequires: pango-devel >= 1:1.14.0
+BuildRequires: pango-devel >= 1:1.22.0
 BuildRequires: perl-base >= 1:5.6
 BuildRequires: python-virtualenv
 BuildRequires: pkgconfig
 BuildRequires: python >= 1:2.5
 BuildRequires: sed >= 4.0
-BuildRequires: sqlite3-devel >= 3.7.17
+BuildRequires: sqlite3-devel >= 3.8.4.2
 BuildRequires: startup-notification-devel >= 0.8
-BuildRequires: libvpx-devel >= 1.0.0
+BuildRequires: libvpx-devel >= 1.3.0
+BuildRequires: virtualenv
 BuildRequires: xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXinerama-devel
 BuildRequires: xorg-lib-libXt-devel
@@ -90,14 +89,16 @@ BuildRequires:      yasm
 BuildRequires: zip
 %if %{with xulrunner}
 BuildRequires: xulrunner-devel >= %{xulrunner_ver}
-BuildRequires: xulrunner-devel < 2:25
+BuildRequires: xulrunner-devel < 2:32
 %else
 Requires:      glib2 >= 1:2.20
 %{!?with_gtk3:Requires:        gtk+2 >= 2:2.14}
 %{?with_gtk3:Requires: gtk+3 >= 3.0.0}
+Requires:      libvpx >= 1.3.0
 Requires:      myspell-common
 Requires:      nspr >= 1:%{nspr_ver}
 Requires:      nss >= 1:%{nss_ver}
+Requires:      pango >= 1:1.22.0
 Requires:      sqlite3 >= %{sqlite_build_version}
 %endif
 Requires(post):        mktemp >= 1.5-18
@@ -147,20 +148,17 @@ funkcjonalność kalendarza.
 
 %prep
 %setup -qc
-%{__mv} comm-esr31 mozilla
+%{__mv} comm-esr38 mozilla
 %setup -q -T -D -a2
 cd mozilla
-/bin/sh %{SOURCE3}
 %patch0 -p1
+%patch2 -p1
 %patch3 -p1
+%patch5 -p2
 %patch6 -p1
 %patch7 -p1
-%patch8 -p2
-%patch10 -p2
-%patch12 -p1
-%patch13 -p1
-%patch15 -p1
-%patch16 -p2
+%patch8 -p1
+%patch9 -p2
 
 %build
 cd mozilla
@@ -222,6 +220,7 @@ ac_add_options --enable-crashreporter
 ac_add_options --disable-crashreporter
 %endif
 ac_add_options --disable-elf-dynstr-gc
+ac_add_options --disable-elf-hack
 ac_add_options --disable-gnomeui
 ac_add_options --disable-gnomevfs
 ac_add_options --disable-installer
@@ -258,6 +257,7 @@ ac_add_options --with-system-libxul
 ac_add_options --with-pthreads
 ac_add_options --with-system-bz2
 ac_add_options --with-system-ffi
+ac_add_options --with-system-icu
 ac_add_options --with-system-jpeg
 ac_add_options --with-system-libevent
 ac_add_options --with-system-libvpx
@@ -296,7 +296,7 @@ cd %{objdir}
 %{__make} -C icedove/branding install \
        DESTDIR=$RPM_BUILD_ROOT
 
-cp -a mozilla/dist/icedove/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
+cp -a dist/icedove/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
  
 %if %{with xulrunner}
 # needed to find mozilla runtime
@@ -309,13 +309,9 @@ ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
 
 # Add debuginfo for crash-stats.mozilla.com
 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
-cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
+cp -a dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
 %endif
 
-# copy manually lightning files, somewhy they are not installed by make
-cp -a mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
-       $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
-
 # move arch independant ones to datadir
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
@@ -411,7 +407,6 @@ exit 0
 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
 %{?with_shared_js:%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so}
 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
-%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
 %endif
 
@@ -430,6 +425,8 @@ exit 0
 %{_desktopdir}/icedove.desktop
 
 %dir %{_datadir}/%{name}
+%dir %{_libdir}/%{name}/distribution
+%dir %{_libdir}/%{name}/distribution/extensions
 %{_datadir}/%{name}/extensions
 %{_datadir}/%{name}/searchplugins
 
@@ -451,18 +448,19 @@ exit 0
 %if %{with lightning}
 %files addon-lightning
 %defattr(644,root,root,755)
-%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
-%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
-%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
-%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
-%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
-%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
-%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
-%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
-%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
-%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
-%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
-%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
-%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
-%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
+%dir %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
+%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/app.ini
+%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.jar
+%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
+%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
+%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
+%dir %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
+%attr(755,root,root) %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
+%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
+%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*manifest
+%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
+%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
+%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
+%dir %{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones
+%{_libdir}/%{name}/distribution/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones/zones.json
 %endif
This page took 0.085705 seconds and 4 git commands to generate.