]> git.pld-linux.org Git - packages/icedove.git/blame - icedove.spec
- really try to use system xulrunner, if bcond is enabled; but it doesn't work in...
[packages/icedove.git] / icedove.spec
CommitLineData
c4ddd260 1# TODO:
c4ddd260 2# - separate spec for enigmail
283702b9 3# - build with system mozldap
c4ddd260 4#
44be9ed4 5# Conditional builds
6%bcond_without enigmail # don't build enigmail - GPG/PGP support
7%bcond_without gnomeui # disable gnomeui support
6458b220 8%bcond_without gnome # alias for gnomeui
44be9ed4 9%bcond_without ldap # disable e-mail address lookups in LDAP directories
e820c55e 10%bcond_without lightning # disable Sunbird/Lightning calendar
fac7e24d 11%bcond_with xulrunner # system xulrunner
765a3a27 12%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
88149483 13
44be9ed4 14%if %{without gnome}
15%undefine with_gnomeui
44be9ed4 16%endif
88149483 17
f4114a7f 18%if 0%{?_enable_debug_packages} != 1
765a3a27
ER
19%undefine crashreporter
20%endif
21
6864d0a2 22%define enigmail_ver 1.3.5
af42cf6d
JB
23%define nspr_ver 4.8.8
24%define nss_ver 3.12.10
44be9ed4 25
224cf96a 26# convert thunderbird release number to platform version: 9.0.x -> 9.0.x
6864d0a2
AZ
27%define xulrunner_main 10.0
28%define xulrunner_ver %(v=%{version}; echo %{xulrunner_main}${v#10.0})
4f34f106 29
7d981f69
ER
30%if %{without xulrunner}
31# The actual sqlite version (see RHBZ#480989):
32%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
33%endif
34
44be9ed4 35Summary: Icedove - email client
36Summary(pl.UTF-8): Icedove - klient poczty
37Name: icedove
1a166995 38Version: 10.0.2
eca54e0f 39Release: 3
44be9ed4 40License: MPL 1.1 or GPL v2+ or LGPL v2.1+
75c0f419 41Group: X11/Applications/Networking
cadfb931 42Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
1a166995 43# Source0-md5: 624bef982d7ac610b1175737d9905150
44be9ed4 44Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
6864d0a2 45# Source1-md5: 1b008b0d106e238c11e4bead08126bc0
44be9ed4 46Source2: %{name}-branding.tar.bz2
c105f759 47# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
44be9ed4 48Source3: %{name}-rm_nonfree.sh
49Source4: %{name}.desktop
50Source5: %{name}.sh
44be9ed4 51Patch0: %{name}-branding.patch
faa5c89d 52Patch1: %{name}-enigmail-shared.patch
fac7e24d 53Patch2: %{name}-system-xulrunner.patch
faa5c89d
SP
54Patch3: %{name}-fonts.patch
55Patch4: %{name}-install.patch
5e9bb798 56Patch5: %{name}-hunspell.patch
faa5c89d 57Patch6: %{name}-prefs.patch
9a743685 58Patch7: system-mozldap.patch
a85e0ecb 59Patch8: %{name}-makefile.patch
86ad1c27 60
ccc206fe 61Patch10: %{name}-extensiondir.patch
765a3a27 62Patch11: crashreporter.patch
268e7766 63Patch12: no-subshell.patch
5745d706 64URL: http://www.pld-linux.org/Packages/Icedove
6458b220 65BuildRequires: GConf2-devel >= 1.2.1
51a3b6db 66BuildRequires: alsa-lib-devel
44be9ed4 67BuildRequires: automake
51a3b6db 68BuildRequires: bzip2-devel
e820c55e
JB
69BuildRequires: cairo-devel >= 1.10
70BuildRequires: dbus-glib-devel >= 0.60
44be9ed4 71BuildRequires: freetype-devel >= 1:2.1.8
6458b220 72BuildRequires: glib2-devel >= 2.0
e820c55e 73BuildRequires: gtk+2-devel >= 2:2.10.0
5e9bb798 74BuildRequires: hunspell-devel
44be9ed4 75BuildRequires: libIDL-devel >= 0.8.0
6458b220 76%{?with_gnomeui:BuildRequires: libgnome-devel >= 2.0}
51a3b6db 77%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
44be9ed4 78%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
51a3b6db 79BuildRequires: libiw-devel
44be9ed4 80BuildRequires: libjpeg-devel >= 6b
51a3b6db 81BuildRequires: libnotify-devel >= 0.4
e820c55e 82BuildRequires: libpng-devel >= 1.4.1
44be9ed4 83BuildRequires: libstdc++-devel
f4114a7f
ER
84BuildRequires: nspr-devel >= 1:%{nspr_ver}
85BuildRequires: nss-devel >= 1:%{nss_ver}
44be9ed4 86BuildRequires: pango-devel >= 1:1.1.0
e820c55e 87BuildRequires: perl-base >= 1:5.6
1c62cadb 88BuildRequires: pkgconfig
e820c55e 89BuildRequires: python >= 1:2.5
44be9ed4 90BuildRequires: sed >= 4.0
9d1bfad8 91BuildRequires: sqlite3-devel >= 3.7.4
1c62cadb 92BuildRequires: startup-notification-devel >= 0.8
44be9ed4 93BuildRequires: xorg-lib-libXext-devel
44be9ed4 94BuildRequires: xorg-lib-libXinerama-devel
44be9ed4 95BuildRequires: xorg-lib-libXt-devel
5745d706 96BuildRequires: yasm
1c62cadb 97BuildRequires: zip
7d981f69 98%if %{with xulrunner}
4f34f106 99BuildRequires: xulrunner-devel >= 2:%{xulrunner_ver}
7d981f69 100%else
44be9ed4 101Requires: myspell-common
f4114a7f
ER
102Requires: nspr >= 1:%{nspr_ver}
103Requires: nss >= 1:%{nss_ver}
4b6bc367 104Requires: sqlite3 >= %{sqlite_build_version}
7d981f69 105%endif
4f34f106
ER
106Requires(post): mktemp >= 1.5-18
107%if %{with xulrunner}
108%requires_eq_to xulrunner xulrunner-devel
109%endif
44be9ed4 110Obsoletes: mozilla-thunderbird
111Obsoletes: mozilla-thunderbird-dictionary-en-US
112BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
9e366f18
AM
114%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
115
44be9ed4 116# iceweasel/icedove/iceape provide their own versions
44be9ed4 117%define _noautoprovfiles %{_libdir}/%{name}/components
118# we don't want these to satisfy xulrunner-devel
224cf96a 119%define _noautoprov libmozjs.so libxpcom.so libxul.so
44be9ed4 120# and as we don't provide them, don't require either
224cf96a 121%define _noautoreq libmozjs.so libxpcom.so libxul.so
44be9ed4 122
9e7875fc
ER
123%define topdir %{_builddir}/%{name}-%{version}
124%define objdir %{topdir}/obj-%{_target_cpu}
125
44be9ed4 126%description
6b327de6 127Icedove is an open-source, fast and portable email client.
44be9ed4 128
129%description -l pl.UTF-8
6b327de6
JB
130Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
131poczty.
44be9ed4 132
6578c165 133%package addon-lightning
134Summary: An integrated calendar for Icedove
135Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
136License: MPL 1.1 or GPL v2+ or LGPL v2.1+
137Group: Applications/Networking
138Requires: %{name} = %{version}-%{release}
139
140%description addon-lightning
141Lightning is an calendar extension to Icedove email client.
142
143%description addon-lightning -l pl.UTF-8
144Lightning to rozszerzenie do klienta poczty Icedove dodające
145funkcjonalność kalendarza.
146
44be9ed4 147%package addon-enigmail
148Summary: Extension for the authentication and encryption features provided by GnuPG
149Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
150License: MPL/LGPL
151Group: Applications/Networking
152URL: http://enigmail.mozdev.org/
cd056caa 153Requires: %{name} = %{version}-%{release}
d076d93e 154Requires: gnupg
75991bbb 155Obsoletes: mozilla-thunderbird-addon-enigmail
44be9ed4 156
157%description addon-enigmail
c5e06599 158Enigmail is an extension to the Icedove mail client which allows users
159to access the authentication and encryption features provided by
160GnuPG.
44be9ed4 161
162Main Features:
163- Encrypt/sign mail when sending, decrypt/authenticate received mail
164- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
165- Per-Account based encryption and signing defaults
166- Per-Recipient rules for automated key selection, and
167 enabling/disabling encryption and signing
168- OpenPGP key management interface
169
170%description addon-enigmail -l pl.UTF-8
c5e06599 171Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
faa5c89d
SP
172użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
173przez GnuPG.
44be9ed4 174
175Główne możliwości:
176- szyfrowanie/podpisywanie poczty przy wysyłaniu,
177 odszyfrowywanie/uwierzytelnianie poczty odebranej
178- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
179- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
180- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
181 podpisywania dla każdego adresata
182- interfejs do zarządzania kluczami OpenPGP
183
184%prep
983562b1 185%setup -qc
f4114a7f 186mv comm-release mozilla
983562b1 187%setup -q -T -D -a2
188cd mozilla
1c70899a 189%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
44be9ed4 190/bin/sh %{SOURCE3}
983562b1 191%patch0 -p1
faa5c89d 192%{?with_enigmail:%patch1 -p1}
fac7e24d 193%{?with_system_xulrunner:%patch2 -p1}
4ccc2157 194%patch3 -p1
faa5c89d 195%patch4 -p1
983562b1 196%patch6 -p1
9a743685 197%patch7 -p1
f4114a7f 198%patch8 -p2
ccc206fe 199%patch10 -p2
765a3a27 200%patch11 -p2
268e7766 201%patch12 -p1
44be9ed4 202
203%build
983562b1 204cd mozilla
cadfb931
SP
205cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
206cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
f4114a7f 207cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
44be9ed4 208
fbac75ca 209cat << EOF > .mozconfig
9e7875fc 210mk_add_options MOZ_OBJDIR=%{objdir}
cb0e4412 211
fac7e24d
JB
212export CFLAGS="%{rpmcflags}"
213# use c++0x for char16_t (like in xulrunner 10.0.x)
214export CXXFLAGS="%{rpmcflags}%{?with_system_xulrunner: -std=gnu++0x}"
765a3a27
ER
215
216%if %{with crashreporter}
217export MOZ_DEBUG_SYMBOLS=1
218%endif
219
59c5a0e8 220# Options for 'configure' (same as command-line options).
44be9ed4 221ac_add_options --prefix=%{_prefix}
222ac_add_options --exec-prefix=%{_exec_prefix}
223ac_add_options --bindir=%{_bindir}
224ac_add_options --sbindir=%{_sbindir}
225ac_add_options --sysconfdir=%{_sysconfdir}
226ac_add_options --datadir=%{_datadir}
227ac_add_options --includedir=%{_includedir}
228ac_add_options --libdir=%{_libdir}
229ac_add_options --libexecdir=%{_libexecdir}
230ac_add_options --localstatedir=%{_localstatedir}
231ac_add_options --sharedstatedir=%{_sharedstatedir}
232ac_add_options --mandir=%{_mandir}
233ac_add_options --infodir=%{_infodir}
234%if %{?debug:1}0
59c5a0e8 235ac_add_options --disable-optimize
44be9ed4 236ac_add_options --enable-debug
237ac_add_options --enable-debug-modules
59c5a0e8
SP
238ac_add_options --enable-debugger-info-modules
239ac_add_options --enable-crash-on-assert
44be9ed4 240%else
241ac_add_options --disable-debug
242ac_add_options --disable-debug-modules
59c5a0e8
SP
243ac_add_options --disable-logging
244ac_add_options --enable-optimize="%{rpmcflags} -Os"
44be9ed4 245%endif
88149483
ER
246ac_add_options --disable-strip
247ac_add_options --disable-strip-libs
44be9ed4 248%if %{with tests}
249ac_add_options --enable-tests
250%else
251ac_add_options --disable-tests
252%endif
6458b220 253ac_add_options --enable-gio
44be9ed4 254%if %{with gnomeui}
255ac_add_options --enable-gnomeui
256%else
257ac_add_options --disable-gnomeui
258%endif
44be9ed4 259ac_add_options --disable-gnomevfs
44be9ed4 260%if %{with ldap}
261ac_add_options --enable-ldap
9a743685 262ac_add_options --with-system-ldap
44be9ed4 263%else
264ac_add_options --disable-ldap
265%endif
765a3a27
ER
266%if %{with crashreporter}
267ac_add_options --enable-crashreporter
268%else
59c5a0e8 269ac_add_options --disable-crashreporter
765a3a27 270%endif
59c5a0e8 271ac_add_options --disable-xterm-updates
59c5a0e8 272ac_add_options --enable-postscript
d076d93e 273%if %{with lightning}
cb0e4412 274ac_add_options --enable-calendar
d076d93e
SP
275%else
276ac_add_options --disable-calendar
277%endif
44be9ed4 278ac_add_options --disable-installer
279ac_add_options --disable-jsd
88149483 280ac_add_options --disable-updater
44be9ed4 281ac_add_options --disable-xprint
cadfb931
SP
282ac_add_options --disable-permissions
283ac_add_options --disable-pref-extensions
44be9ed4 284ac_add_options --enable-canvas
285ac_add_options --enable-crypto
44be9ed4 286ac_add_options --enable-mathml
44be9ed4 287ac_add_options --enable-pango
288ac_add_options --enable-reorder
88149483
ER
289ac_add_options --enable-startup-notification
290ac_add_options --enable-svg
44be9ed4 291ac_add_options --enable-system-cairo
5e9bb798 292ac_add_options --enable-system-hunspell
7d981f69 293ac_add_options --enable-system-sqlite
44be9ed4 294ac_add_options --enable-xft
cadfb931
SP
295ac_add_options --enable-application=mail
296ac_add_options --enable-default-toolkit=cairo-gtk2
44be9ed4 297ac_add_options --enable-xinerama
88149483
ER
298ac_add_options --with-distribution-id=org.pld-linux
299ac_add_options --with-branding=icedove/branding
300%if %{with xulrunner}
fac7e24d
JB
301ac_add_options --enable-shared-js
302ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
f4114a7f 303ac_add_options --with-system-libxul
fbac75ca 304%else
f4114a7f 305ac_add_options --disable-xul
88149483
ER
306%endif
307ac_add_options --with-pthreads
308ac_add_options --with-system-bz2
44be9ed4 309ac_add_options --with-system-jpeg
310ac_add_options --with-system-nspr
311ac_add_options --with-system-nss
312ac_add_options --with-system-png
313ac_add_options --with-system-zlib
44be9ed4 314ac_add_options --enable-single-profile
315ac_add_options --disable-profilesharing
44be9ed4 316ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
317EOF
318
90e998ba 319%{__make} -j1 -f client.mk build \
d076d93e 320 STRIP="/bin/true" \
765a3a27 321 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
d076d93e 322 CC="%{__cc}" \
44be9ed4 323 CXX="%{__cxx}"
324
765a3a27
ER
325%if %{with crashreporter}
326# create debuginfo for crash-stats.mozilla.com
327%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
328%endif
329
44be9ed4 330%if %{with enigmail}
59c5a0e8 331cd mailnews/extensions/enigmail
9e7875fc
ER
332./makemake -r -o %{objdir}
333%{__make} -C %{objdir}/mailnews/extensions/enigmail \
d076d93e
SP
334 STRIP="/bin/true" \
335 CC="%{__cc}" \
336 CXX="%{__cxx}"
44be9ed4 337%endif
338
339%install
340rm -rf $RPM_BUILD_ROOT
765a3a27 341install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
44be9ed4 342
9e7875fc 343cd %{objdir}
ecf04393 344%{__make} -C mail/installer stage-package \
44be9ed4 345 DESTDIR=$RPM_BUILD_ROOT \
0516fc42 346 MOZ_PKG_DIR=%{_libdir}/%{name} \
44be9ed4 347 PKG_SKIP_STRIP=1
348
765a3a27
ER
349# Enable crash reporter for Firefox application
350%if %{with crashreporter}
351%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
352
353# Add debuginfo for crash-stats.mozilla.com
51a3b6db 354install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
765a3a27
ER
355cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
356%endif
357
ecf04393
ER
358# copy manually lightning files, somewhy they are not installed by make
359cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
360 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
361 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
362
44be9ed4 363# move arch independant ones to datadir
364mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
365mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
44be9ed4 366mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
9e097178 367mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
44be9ed4 368mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
eca54e0f 369mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
44be9ed4 370ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
371ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
44be9ed4 372ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
9e097178 373ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
44be9ed4 374ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
eca54e0f 375ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
44be9ed4 376
c6ec3c1c
ER
377# dir for arch independant extensions besides arch dependant extensions
378# see mozilla/xpcom/build/nsXULAppAPI.h
379# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
380install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
381
63d8f5c3 382%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
44be9ed4 383ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
384
e6bc19b3
ER
385%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
386ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
387
44be9ed4 388%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
389ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
390ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
391
52f5507d
ER
392cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
393cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
44be9ed4 394
e8f4ba81 395# files created by regxpcom -register in post
52fc61e6
ER
396touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
397touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
e8f4ba81
ER
398cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
399#!/bin/sh
400umask 022
401# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
402# dangerous if you run this with sudo with keep_env += HOME
403# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
404t=$(mktemp -d)
d50a2a28 405%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
e8f4ba81
ER
406TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
407rm -rf $t
408EOF
409chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
52fc61e6 410
44be9ed4 411%if %{with enigmail}
283702b9
ER
412ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
413install -d $ext_dir/{chrome,components,defaults/preferences}
52fc61e6 414cd mozilla/dist/bin
0516fc42 415#cp -rfLp chrome/enigmail.jar $ext_dir/chrome
416#cp -rfLp chrome/enigmime.jar $ext_dir/chrome
52fc61e6
ER
417cp -rfLp components/enig* $ext_dir/components
418cp -rfLp components/libenigmime.so $ext_dir/components
f6a43e2f 419cp -rfLp components/libipc.so $ext_dir/components
52fc61e6
ER
420cp -rfLp components/ipc.xpt $ext_dir/components
421cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
422cd -
52f5507d
ER
423cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
424cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
44be9ed4 425%endif
426
9cdc8923
ER
427# never package these. always remove
428# nss
429%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
430# nspr
431%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
283702b9 432# mozldap
9cdc8923 433%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
283702b9 434
44be9ed4 435%clean
436rm -rf $RPM_BUILD_ROOT
437
438%pretrans
439if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
440 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
441fi
eca54e0f 442for d in chrome defaults icons isp modules res searchplugins; do
44be9ed4 443 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
444 install -d %{_datadir}/%{name}
445 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
446 fi
447done
448exit 0
449
e8f4ba81
ER
450%post
451%{_libdir}/%{name}/register || :
452
44be9ed4 453%files
454%defattr(644,root,root,755)
455%attr(755,root,root) %{_bindir}/icedove
456%attr(755,root,root) %{_bindir}/mozilla-thunderbird
457%attr(755,root,root) %{_bindir}/thunderbird
458%dir %{_libdir}/%{name}
765a3a27
ER
459%{_libdir}/%{name}/application.ini
460%{_libdir}/%{name}/platform.ini
6b327de6
JB
461%{_libdir}/%{name}/blocklist.xml
462%{_libdir}/%{name}/chrome.manifest
463%{_libdir}/%{name}/greprefs.js
44be9ed4 464%dir %{_libdir}/%{name}/components
465%attr(755,root,root) %{_libdir}/%{name}/components/*.so
466%{_libdir}/%{name}/components/*.js
467%{_libdir}/%{name}/components/*.xpt
6b327de6
JB
468%{_libdir}/%{name}/components/components.manifest
469%{_libdir}/%{name}/components/interfaces.manifest
0516fc42 470%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
283702b9 471%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
0516fc42 472%attr(755,root,root) %{_libdir}/%{name}/libxul.so
44be9ed4 473%attr(755,root,root) %{_libdir}/%{name}/*.sh
474%attr(755,root,root) %{_libdir}/%{name}/*-bin
475%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
bc9cd18a 476%attr(755,root,root) %{_libdir}/%{name}/icedove
cf62736e 477%attr(755,root,root) %{_libdir}/%{name}/plugin-container
e8f4ba81 478%attr(755,root,root) %{_libdir}/%{name}/register
44be9ed4 479
480# symlinks
481%{_libdir}/%{name}/chrome
482%{_libdir}/%{name}/defaults
483%{_libdir}/%{name}/dictionaries
e6bc19b3 484%{_libdir}/%{name}/hyphenation
44be9ed4 485%{_libdir}/%{name}/isp
9e097178 486%{_libdir}/%{name}/modules
44be9ed4 487%{_libdir}/%{name}/res
eca54e0f 488%{_libdir}/%{name}/searchplugins
44be9ed4 489
224cf96a
JB
490%{_pixmapsdir}/icedove.png
491%{_desktopdir}/icedove.desktop
44be9ed4 492
493%dir %{_datadir}/%{name}
494%{_datadir}/%{name}/chrome
495%{_datadir}/%{name}/defaults
eca54e0f 496%{_datadir}/%{name}/extensions
44be9ed4 497%{_datadir}/%{name}/isp
9e097178 498%{_datadir}/%{name}/modules
44be9ed4 499%{_datadir}/%{name}/res
eca54e0f 500%{_datadir}/%{name}/searchplugins
44be9ed4 501
765a3a27
ER
502%if %{with crashreporter}
503%attr(755,root,root) %{_libdir}/%{name}/crashreporter
504%{_libdir}/%{name}/crashreporter.ini
505%{_libdir}/%{name}/Throbber-small.gif
506%endif
507
44be9ed4 508%dir %{_libdir}/%{name}/extensions
509%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
6578c165 510
52fc61e6
ER
511# files created by regxpcom -register
512%ghost %{_libdir}/%{name}/components/compreg.dat
513%ghost %{_libdir}/%{name}/components/xpti.dat
514
6578c165 515%if %{with lightning}
516%files addon-lightning
517%defattr(644,root,root,755)
f3b6d696 518%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
cf62736e 519%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
f3b6d696
ER
520%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
521%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
cf62736e 522%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
f3b6d696
ER
523%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
524%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
525%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
f3b6d696 526%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
cf62736e
JB
527%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
528%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
f3b6d696
ER
529%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
530%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
531%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
6578c165 532%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
533%endif
44be9ed4 534
535%if %{with enigmail}
536%files addon-enigmail
537%defattr(644,root,root,755)
f6a43e2f
ER
538%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
539%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
540%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
541%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
542%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
543%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
544%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
545%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
546%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
44be9ed4 547%endif
This page took 0.110684 seconds and 4 git commands to generate.