]> git.pld-linux.org Git - packages/ice.git/blame - ice.spec
- fix building with db 5.3
[packages/ice.git] / ice.spec
CommitLineData
5a9bdbd6 1# TODO
9a1d0e0d 2# - finish (pldize) -servers package
11130741
ER
3#
4# Conditional build:
d2180ca6 5%bcond_without gui # IceGrid GUI
11130741 6%bcond_without dotnet # .NET bindings
d2180ca6
ER
7%bcond_without java # Java bindings
8%bcond_without php # PHP bindings
11130741
ER
9%bcond_without python # Python bindings
10%bcond_without ruby # Ruby bindings
11130741 11
6cff1ec8
ER
12%if %{without java}
13%undefine with_gui
14%endif
15
b1a56e6f 16%{?with_java:%include /usr/lib/rpm/macros.java}
5a9bdbd6
ER
17Summary: The Ice base runtime and services
18Name: ice
1510c4e5 19Version: 3.4.2
b4620c5f 20Release: 2
5a9bdbd6 21License: GPL v2 with exceptions (see ICE_LICENSE)
85d0fae0 22Group: Applications
fa987e4c 23URL: http://www.zeroc.com/
5a9bdbd6 24Source0: http://www.zeroc.com/download/Ice/3.4/Ice-%{version}.tar.gz
b17b20e0 25# Source0-md5: e97672eb4a63c6b8dd202d0773e19dc7
11130741 26# Extracted from http://zeroc.com/download/Ice/3.4/ice-3.4.0-1.src.rpm
eef55816 27Source1: Ice-rpmbuild-3.4.0.tar.gz
11130741 28# Source1-md5: 869cc60645e7e2b4115584a5ab17d1e9
85bc9249
ER
29# Man pages courtesy of Francisco Moya's Debian packages
30Source2: Ice-3.3.0-man-pages.tbz2
31# Source2-md5: c6c17ee1be2e6b615af5b40edae88b75
32Source3: %{name}gridgui
33Source4: IceGridAdmin.desktop
85d0fae0 34Patch0: %{name}-build.patch
11130741
ER
35Patch1: dont-build-demo-test.patch
36Patch2: java-build.patch
37Patch3: jgoodies.patch
bb6d4d37
JR
38Patch4: ice-gcc46.patch
39Patch5: ice-gcc47.patch
b4620c5f 40Patch6: ice-db.patch
3470b65a 41BuildRequires: bzip2-devel
5a9bdbd6 42BuildRequires: db-cxx-devel
3470b65a 43BuildRequires: expat-devel
d2180ca6
ER
44BuildRequires: mcpp-devel
45BuildRequires: openssl-devel
d2180ca6
ER
46BuildRequires: rpmbuild(macros) >= 1.533
47%if %{with gui}
48BuildRequires: ImageMagick
49BuildRequires: ImageMagick-coder-png
50%endif
51%if %{with dotnet}
52BuildRequires: mono-csharp
53%endif
c6913b64 54%if %{with java}
55BuildRequires: ant-nodeps
56BuildRequires: db-java-devel
68d99d1f 57BuildRequires: java-jgoodies-common
c6913b64 58BuildRequires: java-jgoodies-forms
59BuildRequires: java-jgoodies-looks
5d2be73c 60BuildRequires: jdk
c6913b64 61BuildRequires: jpackage-utils
c6913b64 62BuildRequires: rpm-javaprov
15085aa5 63%endif
d2180ca6
ER
64%if %{with php}
65BuildRequires: php-devel >= 3:5.0.0
66%endif
67%if %{with python}
3470b65a 68BuildRequires: python-devel
d2180ca6
ER
69BuildRequires: rpm-pythonprov
70%endif
71%if %{with ruby}
72BuildRequires: ruby >= 1:1.8.6
3470b65a 73BuildRequires: ruby-devel
d2180ca6 74%endif
11130741
ER
75# Ice doesn't officially support ppc64 at all; sparc64 doesnt have mono
76ExcludeArch: ppc64 sparc64
85d0fae0 77BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
11130741
ER
79# Some file suffixes we need to grab the right stuff for the file lists
80%define soversion 34
81
85d0fae0 82%description
5a9bdbd6
ER
83Ice is a modern alternative to object middleware such as CORBA or
84COM/DCOM/COM+. It is easy to learn, yet provides a powerful network
85infrastructure for demanding technical applications. It features an
86object-oriented specification language, easy to use C++, C#, Java,
87Python, Ruby, PHP, and Visual Basic mappings, a highly efficient
88protocol, asynchronous method invocation and dispatch, dynamic
89transport plug-ins, TCP/IP and UDP/IP support, SSL-based security, a
90firewall solution, and much more.
85d0fae0 91
92%package devel
5a9bdbd6 93Summary: Tools for developing Ice applications in C++
85d0fae0 94Group: Development/Libraries
95Requires: %{name} = %{version}-%{release}
96
97%description devel
5a9bdbd6 98Tools for developing Ice applications in C++.
85d0fae0 99
a33c5a13
ER
100%package servers
101Summary: Ice services to run through /etc/rc.d/init.d
11130741 102Group: Development/Tools
a33c5a13
ER
103Requires(post,preun): /sbin/chkconfig
104Requires: %{name} = %{version}-%{release}
105Requires: rc-scripts
11130741 106
a33c5a13
ER
107%description servers
108Ice services to run through /etc/rc.d/init.d
11130741 109
a33c5a13 110%package -n icegrid-gui
11130741 111Summary: IceGrid Admin Tool
11130741 112Group: Development/Tools
11130741 113Requires: %{name} = %{version}-%{release}
a33c5a13
ER
114Requires: java-%{name} = %{version}-%{release}
115Requires: java-jgoodies-forms
116Requires: java-jgoodies-looks
117Requires: jpackage-utils
118
119%description -n icegrid-gui
120Graphical administration tool for IceGrid
121
122%package -n java-%{name}
123Summary: The Ice runtime for Java
124Group: Libraries/Java
11130741 125Requires: %{name} = %{version}-%{release}
a33c5a13 126Requires: db-java
11130741 127Requires: jpackage-utils
11130741 128
a33c5a13
ER
129%description -n java-%{name}
130The Ice runtime for Java
11130741 131
a33c5a13
ER
132%package -n csharp-%{name}
133Summary: The Ice runtime for C#
134Group: Libraries
135Requires: %{name} = %{version}-%{release}
136Requires: mono >= 1.2.2
11130741 137
a33c5a13
ER
138%description -n csharp-%{name}
139The Ice runtime for C#
11130741 140
a33c5a13 141%package -n ruby-%{name}
11130741 142Summary: The Ice runtime for Ruby applications
a33c5a13 143Group: Development/Languages
11130741 144Requires: %{name} = %{version}-%{release}
46b0ec3f 145%{?ruby_mod_ver_requires_eq}
11130741 146
a33c5a13 147%description -n ruby-%{name}
11130741
ER
148The Ice runtime for Ruby applications.
149
a33c5a13 150%package -n python-%{name}
11130741 151Summary: The Ice runtime for Python applications
a33c5a13 152Group: Development/Languages/Python
11130741 153Requires: %{name} = %{version}-%{release}
a33c5a13 154Requires: python >= 1:2.3.4
11130741 155
a33c5a13 156%description -n python-%{name}
11130741
ER
157The Ice runtime for Python applications.
158
a33c5a13 159%package -n php-%{name}
11130741 160Summary: The Ice runtime for PHP applications
a33c5a13 161Group: Development/Languages/PHP
11130741
ER
162Requires: %{name} = %{version}-%{release}
163%{?requires_php_extension}
164
a33c5a13 165%description -n php-%{name}
11130741
ER
166The Ice runtime for PHP applications.
167
85d0fae0 168%prep
85bc9249 169%setup -q -n Ice-%{version} -a1 -a2
85d0fae0 170%patch0 -p0
11130741
ER
171%patch1 -p1
172%patch2 -p1
173%patch3 -p1
bb6d4d37
JR
174%patch4 -p1
175%patch5 -p1
b4620c5f 176%patch6 -p1
85d0fae0 177
85bc9249
ER
178# no longer included in 3.4
179rm -f *man-pages/slice2docbook.1
180
6cff1ec8
ER
181# Fix the encoding and line-endings of all the IceGridAdmin documentation files
182cd java/resources/IceGridAdmin
62edba61 183%undos -f js,css
184
6cff1ec8
ER
185for f in helpman_topicinit.js icegridadmin_navigation.js IceGridAdmin_popup_html.js zoom_pageinfo.js; do
186 iconv -f ISO88591 -t UTF8 $f -o $f.tmp
187 mv $f.tmp $f
188done
189cd -
190
457093df
ER
191%{__sed} -i -e '1s,/usr/bin/env python,%{__python},' cpp/src/ca/iceca
192
fa987e4c
ER
193%if %{with java}
194# we nuke it only when we build new class later, as ice build system expects the file being around
6cff1ec8 195rm cpp/src/ca/ImportKey.class
fa987e4c 196%endif
11130741 197
6cff1ec8 198# update path to our install
eef55816 199sed -i -e 's,/usr/share/Ice-%{version},%{_datadir}/Ice,' cpp/src/ca/iceca Ice-rpmbuild-*/icegridregistry.conf
6cff1ec8 200
85bc9249
ER
201# force our CC/CXX as build system compares for exactly "c++" to setup other rules
202sed -i -e 's,c++,%{__cxx},g' cpp/config/Make.rules.Linux
203
6cff1ec8 204%build
11130741
ER
205# Compile the main Ice runtime
206# TODO: CC/CXX passing as make param breaks build system
9a1d0e0d
ER
207
208%if %{with java}
209# Rebuild the Java ImportKey class - need it early for main cpp build
210javac cpp/src/ca/ImportKey.java
211%endif
212
140b994f 213%{__make} -j1 -C cpp \
85bc9249
ER
214 CC="%{__cc}" \
215 CXX="%{__cxx}" \
11130741
ER
216 CFLAGS="%{rpmcflags} -fPIC" \
217 CXXFLAGS="%{rpmcxxflags} -fPIC" \
218 embedded_runpath_prefix=""
219
9a1d0e0d
ER
220%if %{with gui}
221# Create the IceGrid icon
222convert java/resources/icons/icegrid.ico temp.png
223mv temp-8.png java/resources/icons/icegrid.png
224rm temp*.png
225%endif
226
11130741 227%if %{with java}
6cff1ec8 228
11130741
ER
229# Set the CLASSPATH correctly for the Java compile
230export CLASSPATH=$(build-classpath db jgoodies-forms jgoodies-looks)
231
140b994f 232%{__make} -j1 -C java \
85bc9249
ER
233 CC="%{__cc}" \
234 CXX="%{__cxx}" \
11130741
ER
235 CFLAGS="%{rpmcflags} -fPIC" \
236 CXXFLAGS="%{rpmcxxflags} -fPIC" \
237 embedded_runpath_prefix=""
11130741
ER
238%endif
239
240%if %{with dotnet}
140b994f 241%{__make} -j1 -C cs \
85bc9249
ER
242 CC="%{__cc}" \
243 CXX="%{__cxx}" \
11130741
ER
244 CFLAGS="%{rpmcflags} -fPIC" \
245 CXXFLAGS="%{rpmcxxflags} -fPIC" \
246 embedded_runpath_prefix=""
247%endif
248
249%if %{with python}
140b994f 250%{__make} -j1 -C py \
85bc9249
ER
251 CC="%{__cc}" \
252 CXX="%{__cxx}" \
11130741
ER
253 CFLAGS="%{rpmcflags} -fPIC" \
254 CXXFLAGS="%{rpmcxxflags} -fPIC" \
255 embedded_runpath_prefix=""
256%endif
257
258%if %{with ruby}
140b994f 259%{__make} -j1 -C rb \
85bc9249
ER
260 CC="%{__cc}" \
261 CXX="%{__cxx}" \
11130741
ER
262 CFLAGS="%{rpmcflags} -fPIC" \
263 CXXFLAGS="%{rpmcxxflags} -fPIC" \
264 embedded_runpath_prefix=""
265%endif
266
267%if %{with php}
140b994f 268%{__make} -j1 -C php \
85bc9249
ER
269 CC="%{__cc}" \
270 CXX="%{__cxx}" \
11130741
ER
271 PHP_HOME=%{_prefix} \
272 CFLAGS="%{rpmcflags} -fPIC" \
273 CXXFLAGS="%{rpmcxxflags} -fPIC" \
274 embedded_runpath_prefix=""
275%endif
85d0fae0 276
277%install
278rm -rf $RPM_BUILD_ROOT
9a1d0e0d 279install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_includedir},%{_docdir}/Ice-%{version},%{_datadir}/Ice}
85d0fae0 280
6cff1ec8
ER
281%{__make} -C cpp install \
282 prefix=$RPM_BUILD_ROOT
283
457093df
ER
284# Move the ImportKey.class file
285mv $RPM_BUILD_ROOT/lib/ImportKey.class $RPM_BUILD_ROOT%{_datadir}/Ice
286
6cff1ec8 287mv $RPM_BUILD_ROOT/bin/* $RPM_BUILD_ROOT%{_bindir}
6cff1ec8 288mv $RPM_BUILD_ROOT/include/* $RPM_BUILD_ROOT%{_includedir}
d66964c1 289mv $RPM_BUILD_ROOT/%{_lib}/* $RPM_BUILD_ROOT%{_libdir}
85d0fae0 290
85bc9249 291mv $RPM_BUILD_ROOT/config/* $RPM_BUILD_ROOT%{_datadir}/Ice
85bc9249
ER
292
293# Copy the man pages into the correct directory
294install -d $RPM_BUILD_ROOT%{_mandir}/man1
295cp -a *man-pages/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
296
11130741
ER
297%if %{with java}
298%{__make} -C java install \
6cff1ec8
ER
299 prefix=$RPM_BUILD_ROOT
300
11130741
ER
301# Move Java stuff where it should be
302install -d $RPM_BUILD_ROOT%{_javadir}
11130741
ER
303mv $RPM_BUILD_ROOT/lib/Ice.jar $RPM_BUILD_ROOT%{_javadir}/Ice-%{version}.jar
304ln -s Ice-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/Ice.jar
305mv $RPM_BUILD_ROOT/lib/Freeze.jar $RPM_BUILD_ROOT%{_javadir}/Freeze-%{version}.jar
306ln -s Freeze-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/Freeze.jar
d815748a 307
308# Register ant target
309install -d $RPM_BUILD_ROOT{%{_sysconfdir}/ant.d,%{_javadir}/ant}
310mv $RPM_BUILD_ROOT/lib/ant-ice.jar $RPM_BUILD_ROOT%{_javadir}/ant/ant-ice-%{version}.jar
311ln -s ant-ice-%{version}.jar $RPM_BUILD_ROOT%{_javadir}/ant/ant-ice.jar
312echo 'ice ant/ant-ice' > $RPM_BUILD_ROOT%{_sysconfdir}/ant.d/ice
11130741
ER
313%endif
314
315%if %{with gui}
316# Install the IceGrid GUI
fa987e4c 317install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir}}
11130741 318mv $RPM_BUILD_ROOT/lib/IceGridGUI.jar $RPM_BUILD_ROOT%{_datadir}/Ice
85bc9249
ER
319cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}
320install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}
9a1d0e0d 321cp -a java/resources/icons/icegrid.png $RPM_BUILD_ROOT%{_pixmapsdir}
11130741 322mv $RPM_BUILD_ROOT/help/IceGridAdmin $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}
6cff1ec8 323%endif
11130741
ER
324
325%if %{with dotnet}
6cff1ec8
ER
326install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
327%{__make} -C cs install \
328 prefix=$RPM_BUILD_ROOT \
329 GACINSTALL=yes \
d933ee2e 330 GAC_ROOT=$RPM_BUILD_ROOT%{_prefix}/lib \
6cff1ec8 331
fa987e4c 332mv $RPM_BUILD_ROOT/bin/* $RPM_BUILD_ROOT%{_bindir}
11130741
ER
333# .NET spec files (for csharp-devel) -- convert the paths
334for f in IceGrid Glacier2 IceBox Ice IceStorm IcePatch2; do
d933ee2e 335 sed -i -e "s#/lib/#%{_prefix}/lib/#" $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc
6cff1ec8
ER
336 sed -i -e "s#mono_root}/usr#mono_root}#" $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc
337 mv $RPM_BUILD_ROOT/lib/pkgconfig/$f.pc $RPM_BUILD_ROOT%{_pkgconfigdir}/$f.pc
d933ee2e 338 mv $RPM_BUILD_ROOT%{_bindir}/$f.xml $RPM_BUILD_ROOT%{_prefix}/lib/mono/gac/$f/%{version}.*/
11130741
ER
339done
340%endif
341
342%if %{with python}
6cff1ec8
ER
343%{__make} -C py install \
344 prefix=$RPM_BUILD_ROOT
11130741
ER
345%{__sed} -i -e '1s,/usr/bin/env python,%{__python},' $RPM_BUILD_ROOT/python/Ice.py
346install -d $RPM_BUILD_ROOT%{py_sitedir}/Ice
f905d0db
ER
347mv $RPM_BUILD_ROOT/python/IcePy.so.*.*.* $RPM_BUILD_ROOT%{py_sitedir}/Ice/IcePy.so
348rm -f $RPM_BUILD_ROOT/python/IcePy.so*
11130741 349mv $RPM_BUILD_ROOT/python/* $RPM_BUILD_ROOT%{py_sitedir}/Ice
eef55816 350cp -a Ice-rpmbuild-*/ice.pth $RPM_BUILD_ROOT%{py_sitedir}
46b0ec3f
ER
351%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
352%py_comp $RPM_BUILD_ROOT%{py_sitedir}
353%py_postclean
11130741
ER
354%endif
355
356%if %{with ruby}
6cff1ec8
ER
357%{__make} -C rb install \
358 prefix=$RPM_BUILD_ROOT
11130741
ER
359%{__sed} -i -e '1s,/usr/bin/env ruby,%{__ruby},' $RPM_BUILD_ROOT/ruby/*.rb
360install -d $RPM_BUILD_ROOT%{ruby_sitearchdir}
f905d0db
ER
361mv $RPM_BUILD_ROOT/ruby/IceRuby.so.*.*.* $RPM_BUILD_ROOT%{ruby_sitearchdir}/IceRuby.so
362rm -f $RPM_BUILD_ROOT/ruby/IceRuby.so*
11130741
ER
363mv $RPM_BUILD_ROOT/ruby/* $RPM_BUILD_ROOT%{ruby_sitearchdir}
364%endif
365
366%if %{with php}
6cff1ec8
ER
367%{__make} -C php install \
368 prefix=$RPM_BUILD_ROOT
11130741 369# Put the PHP stuff into the right place
46b0ec3f 370install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{php_data_dir}}
eef55816 371cp -a Ice-rpmbuild-*/ice.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
46b0ec3f
ER
372mv $RPM_BUILD_ROOT/php/IcePHP.so $RPM_BUILD_ROOT%{php_extensiondir}
373mv $RPM_BUILD_ROOT/php/* $RPM_BUILD_ROOT%{php_data_dir}
11130741
ER
374%endif
375
d66964c1
ER
376# move as last, bindings reinstall these if missing
377mv $RPM_BUILD_ROOT/slice $RPM_BUILD_ROOT%{_datadir}/Ice
378
379# Move the license files into the documentation directory
380mv $RPM_BUILD_ROOT/ICE_LICENSE $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/ICE_LICENSE
381mv $RPM_BUILD_ROOT/LICENSE $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}/LICENSE
382# Copy in the other files too
383cp CHANGES RELEASE_NOTES $RPM_BUILD_ROOT%{_docdir}/Ice-%{version}
384
6cff1ec8
ER
385# Install the servers
386install -d $RPM_BUILD_ROOT%{_sysconfdir}
eef55816 387cp -a Ice-rpmbuild-*/*.conf $RPM_BUILD_ROOT%{_sysconfdir}
6cff1ec8
ER
388install -d $RPM_BUILD_ROOT%{_initrddir}
389for i in icegridregistry icegridnode glacier2router; do
eef55816 390 cp -a Ice-rpmbuild-*/$i.redhat $RPM_BUILD_ROOT%{_initrddir}/$i
6cff1ec8
ER
391done
392install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/icegrid
393
85d0fae0 394%clean
395rm -rf $RPM_BUILD_ROOT
396
397%post -p /sbin/ldconfig
398%postun -p /sbin/ldconfig
399
a33c5a13 400%post -n php-%{name}
46b0ec3f
ER
401%php_webserver_restart
402
a33c5a13 403%postun -n php-%{name}
46b0ec3f
ER
404if [ "$1" = 0 ]; then
405 %php_webserver_restart
406fi
407
85d0fae0 408%files
409%defattr(644,root,root,755)
fa987e4c 410%doc %{_docdir}/Ice-%{version}
85d0fae0 411%attr(755,root,root) %{_bindir}/dumpdb
412%attr(755,root,root) %{_bindir}/glacier2router
413%attr(755,root,root) %{_bindir}/icebox
414%attr(755,root,root) %{_bindir}/iceboxadmin
415%attr(755,root,root) %{_bindir}/iceca
416%attr(755,root,root) %{_bindir}/icegridadmin
417%attr(755,root,root) %{_bindir}/icegridnode
418%attr(755,root,root) %{_bindir}/icegridregistry
419%attr(755,root,root) %{_bindir}/icepatch2calc
420%attr(755,root,root) %{_bindir}/icepatch2client
421%attr(755,root,root) %{_bindir}/icepatch2server
422%attr(755,root,root) %{_bindir}/icestormadmin
423%attr(755,root,root) %{_bindir}/icestormmigrate
f905d0db 424%attr(755,root,root) %{_bindir}/slice2html
9a1d0e0d 425%attr(755,root,root) %{_bindir}/transformdb
85bc9249
ER
426%{_mandir}/man1/dumpdb.1*
427%{_mandir}/man1/glacier2router.1*
428%{_mandir}/man1/icebox.1*
429%{_mandir}/man1/iceboxadmin.1*
430%{_mandir}/man1/icegridadmin.1*
431%{_mandir}/man1/icegridnode.1*
432%{_mandir}/man1/icegridregistry.1*
433%{_mandir}/man1/icepatch2calc.1*
434%{_mandir}/man1/icepatch2client.1*
435%{_mandir}/man1/icepatch2server.1*
436%{_mandir}/man1/icestormadmin.1*
437%{_mandir}/man1/slice2html.1*
438%{_mandir}/man1/transformdb.1*
46b0ec3f
ER
439%attr(755,root,root) %{_libdir}/libFreeze.so.*.*.*
440%attr(755,root,root) %ghost %{_libdir}/libFreeze.so.%{soversion}
441%attr(755,root,root) %{_libdir}/libGlacier2.so.*.*.*
442%attr(755,root,root) %ghost %{_libdir}/libGlacier2.so.%{soversion}
443%attr(755,root,root) %{_libdir}/libIce.so.*.*.*
444%attr(755,root,root) %ghost %{_libdir}/libIce.so.%{soversion}
445%attr(755,root,root) %{_libdir}/libIceBox.so.*.*.*
446%attr(755,root,root) %ghost %{_libdir}/libIceBox.so.%{soversion}
447%attr(755,root,root) %{_libdir}/libIceDB.so.*.*.*
448%attr(755,root,root) %ghost %{_libdir}/libIceDB.so.%{soversion}
449%attr(755,root,root) %{_libdir}/libIceGrid.so.*.*.*
450%attr(755,root,root) %ghost %{_libdir}/libIceGrid.so.%{soversion}
451%attr(755,root,root) %{_libdir}/libIceGridFreezeDB.so.*.*.*
452%attr(755,root,root) %ghost %{_libdir}/libIceGridFreezeDB.so.%{soversion}
453%attr(755,root,root) %{_libdir}/libIcePatch2.so.*.*.*
454%attr(755,root,root) %ghost %{_libdir}/libIcePatch2.so.%{soversion}
455%attr(755,root,root) %{_libdir}/libIceSSL.so.*.*.*
456%attr(755,root,root) %ghost %{_libdir}/libIceSSL.so.%{soversion}
457%attr(755,root,root) %{_libdir}/libIceStorm.so.*.*.*
458%attr(755,root,root) %ghost %{_libdir}/libIceStorm.so.%{soversion}
459%attr(755,root,root) %{_libdir}/libIceStormFreezeDB.so.*.*.*
460%attr(755,root,root) %ghost %{_libdir}/libIceStormFreezeDB.so.%{soversion}
461%attr(755,root,root) %{_libdir}/libIceStormService.so.*.*.*
462%attr(755,root,root) %ghost %{_libdir}/libIceStormService.so.%{soversion}
463%attr(755,root,root) %{_libdir}/libIceUtil.so.*.*.*
464%attr(755,root,root) %ghost %{_libdir}/libIceUtil.so.%{soversion}
465%attr(755,root,root) %{_libdir}/libIceXML.so.*.*.*
466%attr(755,root,root) %ghost %{_libdir}/libIceXML.so.%{soversion}
467%attr(755,root,root) %{_libdir}/libSlice.so.*.*.*
468%attr(755,root,root) %ghost %{_libdir}/libSlice.so.%{soversion}
5a9bdbd6 469%{_datadir}/Ice
85d0fae0 470
401734e9 471%if %{with gui}
fa987e4c
ER
472# Exclude the stuff that's in IceGrid
473%exclude %{_docdir}/Ice-%{version}/IceGridAdmin
474%exclude %{_datadir}/Ice/IceGridGUI.jar
475
fa987e4c
ER
476%files -n icegrid-gui
477%defattr(644,root,root,755)
478%doc %{_docdir}/Ice-%{version}/IceGridAdmin
46b0ec3f 479%attr(755,root,root) %{_bindir}/icegridgui
fa987e4c 480%{_datadir}/Ice/IceGridGUI.jar
85bc9249 481%{_mandir}/man1/icegridgui.1*
46b0ec3f 482%{_desktopdir}/IceGridAdmin.desktop
fa987e4c 483%{_pixmapsdir}/icegrid.png
6cff1ec8 484%endif
46b0ec3f 485
85d0fae0 486%files devel
487%defattr(644,root,root,755)
f905d0db
ER
488%attr(755,root,root) %{_bindir}/slice2cpp
489%attr(755,root,root) %{_bindir}/slice2freeze
85d0fae0 490%attr(755,root,root) %{_libdir}/libFreeze.so
491%attr(755,root,root) %{_libdir}/libGlacier2.so
492%attr(755,root,root) %{_libdir}/libIce.so
493%attr(755,root,root) %{_libdir}/libIceBox.so
494%attr(755,root,root) %{_libdir}/libIceDB.so
495%attr(755,root,root) %{_libdir}/libIceGrid.so
496%attr(755,root,root) %{_libdir}/libIceGridFreezeDB.so
497%attr(755,root,root) %{_libdir}/libIcePatch2.so
498%attr(755,root,root) %{_libdir}/libIceSSL.so
499%attr(755,root,root) %{_libdir}/libIceStorm.so
500%attr(755,root,root) %{_libdir}/libIceStormFreezeDB.so
501%attr(755,root,root) %{_libdir}/libIceStormService.so
502%attr(755,root,root) %{_libdir}/libIceUtil.so
503%attr(755,root,root) %{_libdir}/libIceXML.so
504%attr(755,root,root) %{_libdir}/libSlice.so
505%{_includedir}/Freeze
506%{_includedir}/Glacier2
507%{_includedir}/Ice
508%{_includedir}/IceBox
509%{_includedir}/IceGrid
510%{_includedir}/IcePatch2
511%{_includedir}/IceSSL
512%{_includedir}/IceStorm
513%{_includedir}/IceUtil
514%{_includedir}/IceXML
515%{_includedir}/Slice
85bc9249
ER
516%{_mandir}/man1/slice2cpp.1*
517%{_mandir}/man1/slice2freeze.1*
d815748a 518%if %{with java}
fe559ddb 519%{_sysconfdir}/ant.d/ice
d815748a 520%{_javadir}/ant/ant-ice-%{version}.jar
521%{_javadir}/ant/ant-ice.jar
522%endif
f905d0db 523
6cff1ec8 524%if %{with dotnet}
46b0ec3f
ER
525%{_pkgconfigdir}/Glacier2.pc
526%{_pkgconfigdir}/Ice.pc
527%{_pkgconfigdir}/IceBox.pc
528%{_pkgconfigdir}/IceGrid.pc
529%{_pkgconfigdir}/IcePatch2.pc
530%{_pkgconfigdir}/IceStorm.pc
6cff1ec8 531%endif
f905d0db
ER
532
533# as we do not have -devel for each binding, these are in main -devel
534# -csharp
535%attr(755,root,root) %{_bindir}/slice2cs
85bc9249 536%{_mandir}/man1/slice2cs.1*
f905d0db
ER
537# -java
538%attr(755,root,root) %{_bindir}/slice2freezej
539%attr(755,root,root) %{_bindir}/slice2java
85bc9249
ER
540%{_mandir}/man1/slice2freezej.1*
541%{_mandir}/man1/slice2java.1*
f905d0db
ER
542# -php
543%attr(755,root,root) %{_bindir}/slice2php
544# -python
545%attr(755,root,root) %{_bindir}/slice2py
85bc9249 546%{_mandir}/man1/slice2py.1*
f905d0db
ER
547# -ruby
548%attr(755,root,root) %{_bindir}/slice2rb
85bc9249 549%{_mandir}/man1/slice2rb.1*
f905d0db 550
46b0ec3f
ER
551%files servers
552%defattr(644,root,root,755)
553%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/glacier2router.conf
554%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icegridnode.conf
555%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/icegridregistry.conf
556%attr(754,root,root) /etc/rc.d/init.d/glacier2router
557%attr(754,root,root) /etc/rc.d/init.d/icegridnode
558%attr(754,root,root) /etc/rc.d/init.d/icegridregistry
559
6cff1ec8 560%if %{with dotnet}
a33c5a13 561%files -n csharp-%{name}
46b0ec3f
ER
562%defattr(644,root,root,755)
563%attr(755,root,root) %{_bindir}/iceboxnet.exe
85bc9249 564%{_mandir}/man1/iceboxnet.exe.1*
d933ee2e 565%{_prefix}/lib/mono/Glacier2
566%{_prefix}/lib/mono/Ice
567%{_prefix}/lib/mono/IceBox
568%{_prefix}/lib/mono/IceGrid
569%{_prefix}/lib/mono/IcePatch2
570%{_prefix}/lib/mono/IceStorm
eef55816 571
d933ee2e 572%{_prefix}/lib/mono/gac/Glacier2
573%{_prefix}/lib/mono/gac/Ice
574%{_prefix}/lib/mono/gac/IceBox
575%{_prefix}/lib/mono/gac/IceGrid
576%{_prefix}/lib/mono/gac/IcePatch2
577%{_prefix}/lib/mono/gac/IceStorm
eef55816
ER
578
579%{_prefix}/lib/mono/gac/policy.3.4.Glacier2
580%{_prefix}/lib/mono/gac/policy.3.4.Ice
581%{_prefix}/lib/mono/gac/policy.3.4.IceBox
582%{_prefix}/lib/mono/gac/policy.3.4.IceGrid
583%{_prefix}/lib/mono/gac/policy.3.4.IcePatch2
584%{_prefix}/lib/mono/gac/policy.3.4.IceStorm
6cff1ec8 585%endif
46b0ec3f 586
6cff1ec8 587%if %{with python}
a33c5a13 588%files -n python-%{name}
46b0ec3f
ER
589%defattr(644,root,root,755)
590%{py_sitedir}/ice.pth
591%dir %{py_sitedir}/Ice
592%dir %{py_sitedir}/Ice/IceBox
593%dir %{py_sitedir}/Ice/IceGrid
594%dir %{py_sitedir}/Ice/IcePatch2
595%dir %{py_sitedir}/Ice/IceStorm
596%{py_sitedir}/Ice/*.py[co]
597%{py_sitedir}/Ice/IceBox/*.py[co]
598%{py_sitedir}/Ice/IceGrid/*.py[co]
599%{py_sitedir}/Ice/IcePatch2/*.py[co]
600%{py_sitedir}/Ice/IceStorm/*.py[co]
f905d0db 601%attr(755,root,root) %{py_sitedir}/Ice/IcePy.so
6cff1ec8 602%endif
46b0ec3f 603
6cff1ec8 604%if %{with ruby}
a33c5a13 605%files -n ruby-%{name}
46b0ec3f
ER
606%defattr(644,root,root,755)
607%{ruby_sitearchdir}/Glacier2.rb
608%{ruby_sitearchdir}/Glacier2
609%{ruby_sitearchdir}/Ice.rb
610%{ruby_sitearchdir}/Ice
611%{ruby_sitearchdir}/IceBox.rb
612%{ruby_sitearchdir}/IceBox
613%{ruby_sitearchdir}/IceGrid.rb
614%{ruby_sitearchdir}/IceGrid
615%{ruby_sitearchdir}/IcePatch2.rb
616%{ruby_sitearchdir}/IcePatch2
617%{ruby_sitearchdir}/IceStorm.rb
d0918e7e 618%dir %{ruby_sitearchdir}/IceStorm
46b0ec3f 619%{ruby_sitearchdir}/IceStorm/IceStorm.rb
f905d0db 620%attr(755,root,root) %{ruby_sitearchdir}/IceRuby.so
6cff1ec8 621%endif
46b0ec3f 622
6cff1ec8 623%if %{with java}
a33c5a13 624%files -n java-%{name}
46b0ec3f
ER
625%defattr(644,root,root,755)
626%{_javadir}/Freeze-%{version}.jar
627%{_javadir}/Freeze.jar
628%{_javadir}/Ice-%{version}.jar
629%{_javadir}/Ice.jar
6cff1ec8 630%endif
46b0ec3f 631
6cff1ec8 632%if %{with php}
a33c5a13 633%files -n php-%{name}
46b0ec3f
ER
634%defattr(644,root,root,755)
635%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/ice.ini
636%attr(755,root,root) %{php_extensiondir}/IcePHP.so
637%{php_data_dir}/Glacier2.php
638%{php_data_dir}/Glacier2
639%{php_data_dir}/Ice.php
640%{php_data_dir}/Ice
641%{php_data_dir}/IceBox.php
642%{php_data_dir}/IceBox
643%{php_data_dir}/IceGrid.php
644%{php_data_dir}/IceGrid
645%{php_data_dir}/IcePatch2.php
646%{php_data_dir}/IcePatch2
647%{php_data_dir}/IceStorm.php
648%{php_data_dir}/IceStorm
6cff1ec8 649%endif
This page took 0.206621 seconds and 4 git commands to generate.