]> git.pld-linux.org Git - packages/i2c-tools.git/blame - i2c-tools.spec
- rebuild with python 3.8
[packages/i2c-tools.git] / i2c-tools.spec
CommitLineData
87778d89
JB
1#
2# Conditional build:
a7b26859
JB
3%bcond_without python # (any) Python smbus module
4%bcond_without python2 # CPython 2.x smbus module
5%bcond_without python3 # CPython 3.x smbus module
87778d89 6#
2634c43b
JB
7%include /usr/lib/rpm/macros.perl
8Summary: I2C tools for Linux
9Summary(en.UTF-8): I²C tools for Linux
10Summary(pl.UTF-8): Narzędzia I²C dla Linuksa
11Name: i2c-tools
7940eb7d 12Version: 4.1
2e93e2de 13Release: 2
2634c43b
JB
14License: GPL v2+
15Group: Applications/System
a7b26859 16Source0: https://www.kernel.org/pub/software/utils/i2c-tools/%{name}-%{version}.tar.xz
7940eb7d 17# Source0-md5: e2981debb4a822a279be7e45a0ede988
87778d89 18Patch0: %{name}-python.patch
a7b26859 19URL: https://i2c.wiki.kernel.org/index.php/I2C_Tools
2634c43b 20BuildRequires: perl-modules >= 1:5.6
a7b26859
JB
21%if %{with python}
22%{?with_python2:BuildRequires: python-devel >= 2}
23%{?with_python3:BuildRequires: python3-devel >= 1:3.2}
24%endif
2634c43b 25BuildRequires: rpm-perlprov >= 3.0.3-16
a7b26859 26BuildRequires: rpm-pythonprov >= 1.714
2634c43b 27Requires: dev >= 2.9.0-13
a7b26859 28Requires: libi2c = %{version}-%{release}
2634c43b
JB
29Requires: uname(release) >= 2.6.5
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33I2C tools for Linux.
34
35%description -l en.UTF-8
36I²C tools for Linux.
37
38%description -l pl.UTF-8
39Narzędzia I²C dla Linuksa.
40
a7b26859
JB
41%package -n libi2c
42Summary: I2C/SMBus bus access library
43Summary(pl.UTF-8): Biblioteka dostępu do szyny I2C/SMBus
44Group: Libraries
45
46%description -n libi2c
47I2C/SMBus bus access library.
48
49%description -n libi2c -l pl.UTF-8
50Biblioteka dostępu do szyny I2C/SMBus.
51
52%package -n libi2c-devel
53Summary: Header file for libi2c library
54Summary(pl.UTF-8): Plik nagłówkowy biblioteki libi2c
55Group: Development/Libraries
56Requires: libi2c = %{version}-%{release}
57
58%description -n libi2c-devel
59Header file for libi2c library.
60
61%description -n libi2c-devel -l pl.UTF-8
62Plik nagłówkowy biblioteki libi2c.
63
64%package -n libi2c-static
65Summary: Static libi2c library
66Summary(pl.UTF-8): Statyczna biblioteka libi2c
67Group: Development/Libraries
68Requires: libi2c-devel = %{version}-%{release}
69
70%description -n libi2c-static
71Static libi2c library.
72
73%description -n libi2c-static -l pl.UTF-8
74Statyczna biblioteka libi2c.
75
87778d89 76%package -n python-smbus
a7b26859
JB
77Summary: Python 2 SMBus module
78Summary(pl.UTF-8): Moduł Pythona 2 SMBus
87778d89 79Group: Libraries/Python
a7b26859 80Requires: libi2c = %{version}-%{release}
87778d89
JB
81
82%description -n python-smbus
a7b26859 83Python 2 bindings for Linux SMBus access through i2c-dev.
87778d89
JB
84
85%description -n python-smbus -l pl.UTF-8
a7b26859
JB
86Wiązania Pythona 2 służące do dostępu do szyny SMBus spod Linuksa
87poprzez i2c-dev.
88
89%package -n python3-smbus
90Summary: Python 3 SMBus module
91Summary(pl.UTF-8): Moduł Pythona 3 SMBus
92Group: Libraries/Python
93Requires: libi2c = %{version}-%{release}
94
95%description -n python3-smbus
96Python 3 bindings for Linux SMBus access through i2c-dev.
97
98%description -n python3-smbus -l pl.UTF-8
99Wiązania Pythona 3 służące do dostępu do szyny SMBus spod Linuksa
87778d89
JB
100poprzez i2c-dev.
101
2634c43b
JB
102%prep
103%setup -q
87778d89
JB
104%patch0 -p1
105
106%{__mv} eepromer/{README,README.eeproms}
2634c43b
JB
107
108%build
dfda6803 109%{__make} -j1 \
2634c43b 110 CC="%{__cc}" \
87778d89 111 CFLAGS="%{rpmcflags}" \
a7b26859 112 EXTRA="eeprog"
87778d89
JB
113
114%{__make} -C eepromer \
115 CC="%{__cc}" \
116 CFLAGS="%{rpmcflags} -I../include -Wall"
2634c43b 117
a7b26859
JB
118%if %{with python}
119cd py-smbus
120%if %{with python2}
121%py_build
122%endif
123%if %{with python3}
124%py3_build
125%endif
126%endif
127
2634c43b
JB
128%install
129rm -rf $RPM_BUILD_ROOT
130
131%{__make} install \
132 DESTDIR=$RPM_BUILD_ROOT \
a7b26859 133 EXTRA="eeprog" \
7940eb7d
JB
134 PREFIX=%{_prefix} \
135 libdir=%{_libdir}
2634c43b 136
a7b26859
JB
137install eepromer/{eeprom,eepromer} $RPM_BUILD_ROOT%{_sbindir}
138cp -p eepromer/{eeprom,eepromer}.8 $RPM_BUILD_ROOT%{_mandir}/man8
87778d89 139
a7b26859
JB
140%if %{with python}
141cd py-smbus
142%if %{with python2}
143%py_install
144%endif
145%if %{with python3}
146%py3_install
147%endif
148%endif
2634c43b
JB
149
150%clean
151rm -rf $RPM_BUILD_ROOT
152
a7b26859
JB
153%post -n libi2c -p /sbin/ldconfig
154%postun -n libi2c -p /sbin/ldconfig
155
2634c43b
JB
156%files
157%defattr(644,root,root,755)
a7b26859 158%doc CHANGES README eeprog/README.eeprog eepromer/README.ee*
2634c43b
JB
159%attr(755,root,root) %{_bindir}/ddcmon
160%attr(755,root,root) %{_bindir}/decode-dimms
161%attr(755,root,root) %{_bindir}/decode-edid
162%attr(755,root,root) %{_bindir}/decode-vaio
87778d89
JB
163%attr(755,root,root) %{_sbindir}/eeprog
164%attr(755,root,root) %{_sbindir}/eeprom
165%attr(755,root,root) %{_sbindir}/eepromer
2634c43b
JB
166%attr(755,root,root) %{_sbindir}/i2cdetect
167%attr(755,root,root) %{_sbindir}/i2cdump
168%attr(755,root,root) %{_sbindir}/i2cget
169%attr(755,root,root) %{_sbindir}/i2cset
a7b26859 170%attr(755,root,root) %{_sbindir}/i2ctransfer
2634c43b 171%attr(755,root,root) %{_sbindir}/i2c-stub-from-dump
87778d89
JB
172%{_mandir}/man1/decode-dimms.1*
173%{_mandir}/man1/decode-vaio.1*
2634c43b 174%{_mandir}/man8/i2cdetect.8*
87778d89
JB
175%{_mandir}/man8/eeprog.8*
176%{_mandir}/man8/eeprom.8*
177%{_mandir}/man8/eepromer.8*
2634c43b
JB
178%{_mandir}/man8/i2cdump.8*
179%{_mandir}/man8/i2cget.8*
180%{_mandir}/man8/i2cset.8*
a7b26859 181%{_mandir}/man8/i2ctransfer.8*
2634c43b 182%{_mandir}/man8/i2c-stub-from-dump.8*
87778d89 183
a7b26859
JB
184%files -n libi2c
185%defattr(644,root,root,755)
186%attr(755,root,root) %{_libdir}/libi2c.so.*.*.*
187%attr(755,root,root) %ghost %{_libdir}/libi2c.so.0
188
189%files -n libi2c-devel
190%defattr(644,root,root,755)
191%attr(755,root,root) %{_libdir}/libi2c.so
192%dir %{_includedir}/i2c
193%{_includedir}/i2c/smbus.h
194
195%files -n libi2c-static
196%defattr(644,root,root,755)
197%{_libdir}/libi2c.a
198
199%if %{with python2}
87778d89
JB
200%files -n python-smbus
201%defattr(644,root,root,755)
202%doc py-smbus/README
203%attr(755,root,root) %{py_sitedir}/smbus.so
204%{py_sitedir}/smbus-1.1-py*.egg-info
205%endif
a7b26859
JB
206
207%if %{with python3}
208%files -n python3-smbus
209%defattr(644,root,root,755)
210%doc py-smbus/README
211%attr(755,root,root) %{py3_sitedir}/smbus.cpython-*.so
212%{py3_sitedir}/smbus-1.1-py*.egg-info
213%endif
This page took 0.05648 seconds and 4 git commands to generate.