]> git.pld-linux.org Git - packages/hwsd.git/commitdiff
- added Werror patch (disable stringop-truncation warning on valid use of strncpy... auto/th/hwsd-2.0.1-3
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 1 Aug 2020 05:48:37 +0000 (07:48 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 1 Aug 2020 05:48:37 +0000 (07:48 +0200)
hwsd-Werror.patch [new file with mode: 0644]
hwsd.spec

diff --git a/hwsd-Werror.patch b/hwsd-Werror.patch
new file mode 100644 (file)
index 0000000..c2281ec
--- /dev/null
@@ -0,0 +1,18 @@
+--- hwsd-2.0.1/hwsd/gpuInfo.cpp.orig   2020-08-01 07:38:16.290443380 +0200
++++ hwsd-2.0.1/hwsd/gpuInfo.cpp        2020-08-01 07:38:20.360657269 +0200
+@@ -37,7 +37,15 @@
+     , unused(0)
+ {
+     invalidatePVP();
++#if __GNUC__ >= 8
++    /* ignore "specified bound 4 equals destination size" */
++#pragma GCC diagnostic push
++#pragma GCC diagnostic ignored "-Wstringop-truncation"
++#endif
+     strncpy(reinterpret_cast<char*>(&type), name.c_str(), 4);
++#if __GNUC__ >= 8
++#pragma GCC diagnostic push
++#endif
+ }
+ void GPUInfo::invalidatePVP()
index 5e8ca74296690346843abea1e259a8f8f4064f6d..1ee1fd0a67ee4cd7a86dacd17087ed8bdc9383b4 100644 (file)
--- a/hwsd.spec
+++ b/hwsd.spec
@@ -6,13 +6,14 @@ Summary:      Local and remote ZeroConf service discovery for hardware resources
 Summary(pl.UTF-8):     Lokalne i zdalne wykrywanie usług ZeroConf dla zasobów sprzętowych
 Name:          hwsd
 Version:       2.0.1
 Summary(pl.UTF-8):     Lokalne i zdalne wykrywanie usług ZeroConf dla zasobów sprzętowych
 Name:          hwsd
 Version:       2.0.1
-Release:       2
+Release:       3
 License:       LGPL v2.1 (library), GPL v3+ (applications)
 Group:         Libraries
 #Source0Download: https://github.com/Eyescale/hwsd/releases
 Source0:       https://github.com/Eyescale/hwsd/archive/%{version}/%{name}-%{version}.tar.gz
 # Source0-md5: d2285a1d878a12905fe9a062bc158aae
 Patch0:                servus.patch
 License:       LGPL v2.1 (library), GPL v3+ (applications)
 Group:         Libraries
 #Source0Download: https://github.com/Eyescale/hwsd/releases
 Source0:       https://github.com/Eyescale/hwsd/archive/%{version}/%{name}-%{version}.tar.gz
 # Source0-md5: d2285a1d878a12905fe9a062bc158aae
 Patch0:                servus.patch
+Patch1:                %{name}-Werror.patch
 URL:           https://github.com/Eyescale/hwsd/
 BuildRequires: Eyescale-CMake
 BuildRequires: Lunchbox-devel >= 1.10
 URL:           https://github.com/Eyescale/hwsd/
 BuildRequires: Eyescale-CMake
 BuildRequires: Lunchbox-devel >= 1.10
@@ -62,7 +63,7 @@ Pliki nagłówkowe biblioteki HW-SD.
 Summary:       HW-SD API documentation
 Summary(pl.UTF-8):     Dokumentacja API biblioteki HW-SD
 Group:         Documentation
 Summary:       HW-SD API documentation
 Summary(pl.UTF-8):     Dokumentacja API biblioteki HW-SD
 Group:         Documentation
-%if "%{_rpmversion}" >= "5"
+%if "%{_rpmversion}" >= "4.6"
 BuildArch:     noarch
 %endif
 
 BuildArch:     noarch
 %endif
 
@@ -75,6 +76,7 @@ Dokumentacja API biblioteki HW-SD.
 %prep
 %setup -q
 %patch0 -p1
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 rmdir CMake/common
 ln -s %{_datadir}/Eyescale-CMake CMake/common
 
 rmdir CMake/common
 ln -s %{_datadir}/Eyescale-CMake CMake/common
This page took 0.0998520000000001 seconds and 4 git commands to generate.