]> git.pld-linux.org Git - packages/hwsd.git/blob - hwsd.spec
- new
[packages/hwsd.git] / hwsd.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 #
5 Summary:        Local and remote ZeroConf service discovery for hardware resources
6 Summary(pl.UTF-8):      Lokalne i zdalne wykrywanie usług ZeroConf dla zasobów sprzętowych
7 Name:           hwsd
8 Version:        1.1.1
9 Release:        1
10 License:        LGPL v2.1 (library), GPL v3+ (applications)
11 Group:          Libraries
12 Source0:        https://github.com/Eyescale/hwsd/archive/%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  315a8543078db1be6c1600cf5d964e93
14 Patch0:         %{name}-cmake.patch
15 URL:            https://github.com/Eyescale/hwsd/
16 BuildRequires:  Eyescale-CMake
17 BuildRequires:  Lunchbox-devel >= 1.10
18 BuildRequires:  OpenGL-GLX-devel
19 BuildRequires:  QtNetwork-devel >= 4.6
20 BuildRequires:  boost-devel >= 1.41.0
21 BuildRequires:  cmake >= 2.8
22 %{?with_apidocs:BuildRequires:  doxygen}
23 BuildRequires:  gcc-c++ >= 6:4.2
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  pkgconfig
26 BuildRequires:  xorg-lib-libX11-devel
27 Requires:       Lunchbox >= 1.10
28 Requires:       QtNetwork >= 4.6
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 HW-SD is a library and daemon for the discovery and announcement of
33 hardware resources using ZeroConf. It enables auto-configuration
34 of ad-hoc GPU clusters and multi-GPU machines.
35
36 %description -l pl.UTF-8
37 HW-SD to biblioteka i demon do wyszukiwania i rozgłaszania zasobów
38 sprzętowych przy użyciu ZeroConfa. Pozwala na automatyczną
39 konfigurację ad-hocowych klastrów GPU i maszyn o wielu GPU.
40
41 %package devel
42 Summary:        Header files for HW-SD library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki HW-SD
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       Lunchbox-devel >= 1.10
47 Requires:       libstdc++-devel
48
49 %description devel
50 Header files for HW-SD library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki HW-SD.
54
55 %package apidocs
56 Summary:        HW-SD API documentation
57 Summary(pl.UTF-8):      Dokumentacja API biblioteki HW-SD
58 Group:          Documentation
59
60 %description apidocs
61 API documentation for HW-SD library.
62
63 %description apidocs -l pl.UTF-8
64 Dokumentacja API biblioteki HW-SD.
65
66 %prep
67 %setup -q
68 %patch0 -p1
69
70 ln -s %{_datadir}/Eyescale-CMake CMake/common
71 %{__rm} .gitexternals
72
73 %build
74 install -d build
75 cd build
76 %cmake ..
77
78 %{__make}
79
80 %if %{with apidocs}
81 doxygen doc/Doxyfile
82 %endif
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} -C build install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/hwsd/doc
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post   -p /sbin/ldconfig
96 %postun -p /sbin/ldconfig
97
98 %files
99 %defattr(644,root,root,755)
100 %doc LICENSE.txt README.md doc/{AUTHORS,RelNotes.md}
101 %attr(755,root,root) %{_libdir}/libhwsd.so.*.*.*
102 %attr(755,root,root) %ghost %{_libdir}/libhwsd.so.2
103 %attr(755,root,root) %{_libdir}/libhwsd_gpu_glx.so.*.*.*
104 %attr(755,root,root) %ghost %{_libdir}/libhwsd_gpu_glx.so.1
105 %attr(755,root,root) %{_libdir}/libhwsd_net_sys.so.*.*.*
106 %attr(755,root,root) %ghost %{_libdir}/libhwsd_net_sys.so.1
107
108 %files devel
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_libdir}/libhwsd.so
111 %attr(755,root,root) %{_libdir}/libhwsd_gpu_glx.so
112 %attr(755,root,root) %{_libdir}/libhwsd_net_sys.so
113 %{_includedir}/hwsd
114 %{_pkgconfigdir}/hwsd.pc
115 %dir %{_datadir}/hwsd
116 %{_datadir}/hwsd/CMake
117
118 %if %{with apidocs}
119 %files apidocs
120 %defattr(644,root,root,755)
121 %doc build/doc/html/*
122 %endif
This page took 0.045166 seconds and 3 git commands to generate.