]> git.pld-linux.org Git - packages/hwsd.git/blame - hwsd.spec
boost rebuild
[packages/hwsd.git] / hwsd.spec
CommitLineData
c1595142
JB
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
49195896 4
c1595142
JB
5Summary: Local and remote ZeroConf service discovery for hardware resources
6Summary(pl.UTF-8): Lokalne i zdalne wykrywanie usług ZeroConf dla zasobów sprzętowych
7Name: hwsd
3a99de83 8Version: 2.0.1
e242b2ac 9Release: 5
c1595142
JB
10License: LGPL v2.1 (library), GPL v3+ (applications)
11Group: Libraries
3a99de83 12#Source0Download: https://github.com/Eyescale/hwsd/releases
c1595142 13Source0: https://github.com/Eyescale/hwsd/archive/%{version}/%{name}-%{version}.tar.gz
3a99de83 14# Source0-md5: d2285a1d878a12905fe9a062bc158aae
0fbf7f7a 15Patch0: servus.patch
32b219f8 16Patch1: %{name}-Werror.patch
c1595142
JB
17URL: https://github.com/Eyescale/hwsd/
18BuildRequires: Eyescale-CMake
19BuildRequires: Lunchbox-devel >= 1.10
20BuildRequires: OpenGL-GLX-devel
0fbf7f7a
JR
21BuildRequires: Qt5Core-devel
22BuildRequires: Qt5Network-devel
23BuildRequires: Servus-devel
3a99de83
JB
24# just to satisfy cmake projects stupidity (FIXME)
25BuildRequires: Servus-qt-devel
c1595142 26BuildRequires: boost-devel >= 1.41.0
3a99de83 27BuildRequires: cmake >= 3.1
c1595142 28%{?with_apidocs:BuildRequires: doxygen}
c1595142 29BuildRequires: libstdc++-devel
0fbf7f7a 30BuildRequires: libstdc++-devel >= 6:4.2
c1595142
JB
31BuildRequires: pkgconfig
32BuildRequires: xorg-lib-libX11-devel
33Requires: Lunchbox >= 1.10
34Requires: QtNetwork >= 4.6
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38HW-SD is a library and daemon for the discovery and announcement of
0fbf7f7a
JR
39hardware resources using ZeroConf. It enables auto-configuration of
40ad-hoc GPU clusters and multi-GPU machines.
c1595142
JB
41
42%description -l pl.UTF-8
43HW-SD to biblioteka i demon do wyszukiwania i rozgłaszania zasobów
44sprzętowych przy użyciu ZeroConfa. Pozwala na automatyczną
45konfigurację ad-hocowych klastrów GPU i maszyn o wielu GPU.
46
47%package devel
48Summary: Header files for HW-SD library
49Summary(pl.UTF-8): Pliki nagłówkowe biblioteki HW-SD
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52Requires: Lunchbox-devel >= 1.10
3a99de83 53Requires: Servus-devel
c1595142
JB
54Requires: libstdc++-devel
55
56%description devel
57Header files for HW-SD library.
58
59%description devel -l pl.UTF-8
60Pliki nagłówkowe biblioteki HW-SD.
61
62%package apidocs
63Summary: HW-SD API documentation
64Summary(pl.UTF-8): Dokumentacja API biblioteki HW-SD
65Group: Documentation
49195896 66BuildArch: noarch
c1595142
JB
67
68%description apidocs
69API documentation for HW-SD library.
70
71%description apidocs -l pl.UTF-8
72Dokumentacja API biblioteki HW-SD.
73
74%prep
75%setup -q
76%patch0 -p1
32b219f8 77%patch1 -p1
c1595142 78
3a99de83 79rmdir CMake/common
c1595142 80ln -s %{_datadir}/Eyescale-CMake CMake/common
c1595142
JB
81
82%build
83install -d build
84cd build
85%cmake ..
86
87%{__make}
88
89%if %{with apidocs}
90doxygen doc/Doxyfile
91%endif
92
93%install
94rm -rf $RPM_BUILD_ROOT
95
96%{__make} -C build install \
97 DESTDIR=$RPM_BUILD_ROOT
98
99%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/hwsd/doc
100
3a99de83
JB
101install -d $RPM_BUILD_ROOT%{_examplesdir}
102%{__mv} $RPM_BUILD_ROOT%{_datadir}/hwsd/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
103
c1595142
JB
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%post -p /sbin/ldconfig
108%postun -p /sbin/ldconfig
109
110%files
111%defattr(644,root,root,755)
cded53b3 112%doc LICENSE.txt README.md doc/Changelog.md
0fbf7f7a
JR
113%attr(755,root,root) %{_bindir}/hw_sd
114%attr(755,root,root) %{_bindir}/hw_sd_list
c1595142 115%attr(755,root,root) %{_libdir}/libhwsd.so.*.*.*
cded53b3 116%attr(755,root,root) %ghost %{_libdir}/libhwsd.so.4
c1595142 117%attr(755,root,root) %{_libdir}/libhwsd_gpu_glx.so.*.*.*
cded53b3 118%attr(755,root,root) %ghost %{_libdir}/libhwsd_gpu_glx.so.4
d65fd2cc 119%attr(755,root,root) %{_libdir}/libhwsd_gpu_dns_sd.so.*.*.*
cded53b3 120%attr(755,root,root) %ghost %{_libdir}/libhwsd_gpu_dns_sd.so.4
c1595142 121%attr(755,root,root) %{_libdir}/libhwsd_net_sys.so.*.*.*
cded53b3 122%attr(755,root,root) %ghost %{_libdir}/libhwsd_net_sys.so.4
d65fd2cc 123%attr(755,root,root) %{_libdir}/libhwsd_net_dns_sd.so.*.*.*
cded53b3 124%attr(755,root,root) %ghost %{_libdir}/libhwsd_net_dns_sd.so.4
c1595142
JB
125
126%files devel
127%defattr(644,root,root,755)
128%attr(755,root,root) %{_libdir}/libhwsd.so
129%attr(755,root,root) %{_libdir}/libhwsd_gpu_glx.so
d65fd2cc 130%attr(755,root,root) %{_libdir}/libhwsd_gpu_dns_sd.so
c1595142 131%attr(755,root,root) %{_libdir}/libhwsd_net_sys.so
d65fd2cc 132%attr(755,root,root) %{_libdir}/libhwsd_net_dns_sd.so
c1595142 133%{_includedir}/hwsd
c1595142
JB
134%dir %{_datadir}/hwsd
135%{_datadir}/hwsd/CMake
3a99de83 136%{_examplesdir}/%{name}-%{version}
c1595142
JB
137
138%if %{with apidocs}
139%files apidocs
140%defattr(644,root,root,755)
141%doc build/doc/html/*
142%endif
This page took 0.101843 seconds and 4 git commands to generate.