]> git.pld-linux.org Git - packages/hugin.git/blobdiff - hugin.spec
- release 3 (boost 1.73)
[packages/hugin.git] / hugin.spec
index b0c52ed051b2e20116529b380820611c7e14d61f..1cf6e3ed1549fbdc68fdd5b58af3325f452fdd20 100644 (file)
@@ -1,34 +1,46 @@
 Summary:       Toolchain to create panoramic images
 Summary(pl.UTF-8):     Zestaw narzędzi do tworzenia panoramicznych zdjęć
 Name:          hugin
-Version:       0.7.0
-Release:       1
+Version:       2019.2.0
+Release:       3
 License:       GPL v2+
 Group:         X11/Applications/Graphics
-Source0:       http://dl.sourceforge.net/hugin/%{name}-%{version}.tar.gz
-# Source0-md5: 6efbfc72ceba028ca3dff3c23806a7f3
-Patch0:                %{name}-pl.po-update.patch
-Patch1:                %{name}-asneeded.patch
-Patch2:                %{name}-cppflags.patch
+Source0:       http://downloads.sourceforge.net/hugin/%{name}-%{version}.tar.bz2
+# Source0-md5: 3409c3a84e1881145b5b556df63de73c
+Patch0:                %{name}-cppflags.patch
+Patch1:                python-install.patch
 URL:           http://hugin.sourceforge.net/
 BuildRequires: OpenEXR-devel
-BuildRequires: boost-devel >= 1.35.0
-BuildRequires: cmake >= 2.4
+BuildRequires: OpenGL-glut-devel
+BuildRequires: ZThread-devel
+BuildRequires: boost-devel >= 1.41.0
+BuildRequires: cmake >= 2.8
 BuildRequires: exiv2-devel
-BuildRequires: gettext-devel
+BuildRequires: flann-devel
+BuildRequires: gettext-tools
+BuildRequires: glew-devel
 BuildRequires: gtk+2-devel >= 1:2.0.3
+BuildRequires: lensfun-devel
 BuildRequires: libjpeg-devel
-BuildRequires: libpano13-devel >= 2.9.12
+BuildRequires: libpano13-devel >= 2.9.19
 BuildRequires: libpng-devel
 BuildRequires: libstdc++-devel
 BuildRequires: libtiff-devel
+BuildRequires: perl-Image-ExifTool
+BuildRequires: perl-tools-pod
 BuildRequires: pkgconfig
+BuildRequires: python3-devel
 BuildRequires: rpmbuild(macros) >= 1.471
 BuildRequires: sed >= 4.0
-BuildRequires: wxGTK2-unicode-devel >= 2.6.0
-BuildRequires: zip
+BuildRequires: swig-python >= 2.0.4
+BuildRequires: tclap
+BuildRequires: vigra-devel
+BuildRequires: wxGTK2-unicode-devel >= 2.8.10
+BuildRequires: wxGTK2-unicode-gl-devel >= 2.8.10
 BuildRequires: zlib-devel
-Suggests:      autopano-sift-C >= 2.5.0
+Requires:      libpano13 >= 2.9.19
+Requires:      wxGTK2-unicode >= 2.8.10
+Requires:      wxGTK2-unicode-gl >= 2.8.10
 Suggests:      enblend-enfuse >= 3.1
 # exiftool program
 Suggests:      perl-Image-ExifTool
@@ -39,27 +51,30 @@ With hugin you can assemble a mosaic of photographs into a complete
 immensive panorama, stitch any series of overlapping pictures and much
 more.
 
-Note: Hugin can use autopano-sift-C package to match images and
-enblend package for soft blending, so you'll probably want to install
-them too.
+Note: Hugin can use enblend and enfuse for soft blending/fusing, so
+you'll probably to install enblend-enfuse package too.
 
 %description -l pl.UTF-8
 Przy użyciu hugina można połączyć wiele fotografii w kompletną, dużą
 panoramę, skleić dowolny ciąg nakładających się zdjęć i wiele więcej.
 
-Hugin może używać pakietu autopano-sift-C do dopasowania zdjęć oraz
-pakiet enblend do wygładzenia krawędzi po łączeniu - więc warto te
-pakiety także zainstalować.
+Hugin może używać programów enblend i enfuse do wygładzania krawędzi
+i ekspozycji, więc warto zainstalować pakiet enblend-enfuse.
 
 %prep
 %setup -q
-%patch0 -p1
+%patch0 -p0
 %patch1 -p1
-%patch2 -p0
 
-mv -f src/translations/{ca_ES,ca}.po
 mv -f src/translations/{cs_CZ,cs}.po
 
+%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
+      src/hugin_script_interface/hpi.py \
+      src/hugin_script_interface/plugins-dev/dual_use.py \
+      src/hugin_script_interface/plugins-dev/plugin_skeleton.py \
+      src/hugin_script_interface/plugins/top_five.py \
+      src/hugin_script_interface/plugins/woa.py
+
 %build
 install -d build
 cd build
@@ -67,10 +82,11 @@ cd build
        -DCMAKE_BUILD_TYPE=%{?debug:Debug}%{!?debug:None} \
        -DCMAKE_INSTALL_PREFIX=%{_prefix} \
        -DCMAKE_VERBOSE_MAKEFILE=ON \
+       -DBUILD_HSI:BOOL=ON \
 %if "%{_lib}" == "lib64"
        -DLIB_SUFFIX=64 \
 %endif
-       -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-gtk2-unicode-config
+       -DwxWidgets_CONFIG_EXECUTABLE=%{_bindir}/wx-gtk2-unicode-config
 
 %{__make}
 
@@ -81,43 +97,106 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT
 
 # cmake is so great there is no way to pass proper path
-mv $RPM_BUILD_ROOT%{_iconsdir}/{gnome,hicolor}
+%{__mv} $RPM_BUILD_ROOT%{_iconsdir}/{gnome,hicolor}
+
+%{__rm} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/gnome/*x*/mimetypes/gnome-mime-application-x-ptoptimizer-script.png
 
-# not needed
-rm $RPM_BUILD_ROOT%{_libdir}/libhugin*.so
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ca_ES*
+
+%py_comp $RPM_BUILD_ROOT%{py_sitedir}
+%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
 
 %find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun        -p /sbin/ldconfig
-
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog LICENCE_JHEAD LICENCE_VIGRA README TODO
-%lang(ja) %doc README_JP
+%doc AUTHORS Changes.txt README TODO src/celeste/LICENCE_{GABOR,LIBSVM}
+%attr(755,root,root) %{_bindir}/PTBatcherGUI
 %attr(755,root,root) %{_bindir}/align_image_stack
 %attr(755,root,root) %{_bindir}/autooptimiser
+%attr(755,root,root) %{_bindir}/calibrate_lens_gui
+%attr(755,root,root) %{_bindir}/celeste_standalone
+%attr(755,root,root) %{_bindir}/checkpto
+%attr(755,root,root) %{_bindir}/cpclean
+%attr(755,root,root) %{_bindir}/cpfind
+%attr(755,root,root) %{_bindir}/deghosting_mask
 %attr(755,root,root) %{_bindir}/fulla
+%attr(755,root,root) %{_bindir}/geocpset
 %attr(755,root,root) %{_bindir}/hugin
+%attr(755,root,root) %{_bindir}/hugin_executor
 %attr(755,root,root) %{_bindir}/hugin_hdrmerge
+%attr(755,root,root) %{_bindir}/hugin_lensdb
+%attr(755,root,root) %{_bindir}/hugin_stacker
 %attr(755,root,root) %{_bindir}/hugin_stitch_project
-%attr(755,root,root) %{_bindir}/matchpoint
+%attr(755,root,root) %{_bindir}/icpfind
+%attr(755,root,root) %{_bindir}/linefind
 %attr(755,root,root) %{_bindir}/nona
-%attr(755,root,root) %{_bindir}/nona_gui
-%attr(755,root,root) %{_bindir}/pto2mk
+%attr(755,root,root) %{_bindir}/pano_modify
+%attr(755,root,root) %{_bindir}/pano_trafo
+%attr(755,root,root) %{_bindir}/pto_gen
+%attr(755,root,root) %{_bindir}/pto_lensstack
+%attr(755,root,root) %{_bindir}/pto_mask
+%attr(755,root,root) %{_bindir}/pto_merge
+%attr(755,root,root) %{_bindir}/pto_move
+%attr(755,root,root) %{_bindir}/pto_template
+%attr(755,root,root) %{_bindir}/pto_var
 %attr(755,root,root) %{_bindir}/tca_correct
+%attr(755,root,root) %{_bindir}/verdandi
 %attr(755,root,root) %{_bindir}/vig_optimize
-%attr(755,root,root) %{_libdir}/libhuginANN.so.*.*
-%attr(755,root,root) %{_libdir}/libhuginbase.so.*.*
-%attr(755,root,root) %{_libdir}/libhuginjhead.so.*.*
-%attr(755,root,root) %{_libdir}/libhuginvigraimpex.so.*.*
+%dir %{_libdir}/hugin
+%attr(755,root,root) %{_libdir}/hugin/libceleste.so.*.*
+%attr(755,root,root) %{_libdir}/hugin/libhuginbase.so.*.*
+%attr(755,root,root) %{_libdir}/hugin/libhuginbasewx.so.*.*
+%attr(755,root,root) %{_libdir}/hugin/libicpfindlib.so.*.*
+%attr(755,root,root) %{_libdir}/hugin/liblocalfeatures.so.*.*
+%attr(755,root,root) %{_libdir}/hugin/libhugin_python_interface.so.*.*
+%attr(755,root,root) %{py3_sitedir}/_hsi.so
+%{py3_sitedir}/hpi.py*
+%{py3_sitedir}/hsi.py*
 %{_datadir}/%{name}
+%{_datadir}/appdata/PTBatcherGUI.appdata.xml
+%{_datadir}/appdata/calibrate_lens_gui.appdata.xml
+%{_datadir}/appdata/hugin.appdata.xml
 %{_datadir}/mime/packages/hugin.xml
 %{_desktopdir}/hugin.desktop
-%{_desktopdir}/hugin_stitch_project.desktop
-%{_iconsdir}/hicolor/*/mimetypes/gnome-mime-application-x-ptoptimizer-script.png
-%{_pixmapsdir}/hugin.png
+%{_desktopdir}/pto_gen.desktop
+%{_desktopdir}/PTBatcherGUI.desktop
+%{_desktopdir}/calibrate_lens_gui.desktop
+%{_iconsdir}/hicolor/*x*/apps/hugin.png
+%{_iconsdir}/hicolor/*x*/apps/ptbatcher.png
+%{_iconsdir}/hicolor/scalable/apps/hugin.svg
+%{_iconsdir}/hicolor/scalable/apps/ptbatcher.svg
+%{_mandir}/man1/PTBatcherGUI.1*
+%{_mandir}/man1/align_image_stack.1*
+%{_mandir}/man1/autooptimiser.1*
+%{_mandir}/man1/calibrate_lens_gui.1*
+%{_mandir}/man1/celeste_standalone.1*
+%{_mandir}/man1/checkpto.1*
+%{_mandir}/man1/cpclean.1*
+%{_mandir}/man1/cpfind.1*
+%{_mandir}/man1/deghosting_mask.1*
 %{_mandir}/man1/fulla.1*
+%{_mandir}/man1/geocpset.1*
+%{_mandir}/man1/hugin.1*
+%{_mandir}/man1/hugin_executor.1*
+%{_mandir}/man1/hugin_hdrmerge.1*
+%{_mandir}/man1/hugin_lensdb.1*
+%{_mandir}/man1/hugin_stitch_project.1*
+%{_mandir}/man1/icpfind.1*
+%{_mandir}/man1/linefind.1*
+%{_mandir}/man1/nona.1*
+%{_mandir}/man1/pano_modify.1*
+%{_mandir}/man1/pano_trafo.1*
+%{_mandir}/man1/pto_gen.1*
+%{_mandir}/man1/pto_lensstack.1*
+%{_mandir}/man1/pto_merge.1*
+%{_mandir}/man1/pto_mask.1*
+%{_mandir}/man1/pto_move.1*
+%{_mandir}/man1/pto_template.1*
+%{_mandir}/man1/pto_var.1*
+%{_mandir}/man1/tca_correct.1*
+%{_mandir}/man1/vig_optimize.1*
+%{_mandir}/man1/verdandi.1*
This page took 0.092373 seconds and 4 git commands to generate.