]> git.pld-linux.org Git - packages/hugin.git/blob - hugin.spec
fcea2821be8518b5d7b69e90d255702aba870122
[packages/hugin.git] / hugin.spec
1 Summary:        Toolchain to create panoramic images
2 Summary(pl.UTF-8):      Zestaw narzędzi do tworzenia panoramicznych zdjęć
3 Name:           hugin
4 Version:        2020.0.0
5 Release:        2
6 License:        GPL v2+
7 Group:          X11/Applications/Graphics
8 Source0:        http://downloads.sourceforge.net/hugin/%{name}-%{version}.tar.bz2
9 # Source0-md5:  59e152871b74fb071bc086fc23a4774a
10 Patch0:         %{name}-cppflags.patch
11 Patch1:         python-install.patch
12 Patch2:         openexr3.patch
13 URL:            http://hugin.sourceforge.net/
14 BuildRequires:  OpenEXR-devel
15 BuildRequires:  OpenGL-glut-devel
16 BuildRequires:  ZThread-devel
17 BuildRequires:  boost-devel >= 1.41.0
18 BuildRequires:  cmake >= 2.8
19 BuildRequires:  exiv2-devel
20 BuildRequires:  flann-devel
21 BuildRequires:  gettext-tools
22 BuildRequires:  glew-devel
23 BuildRequires:  gtk+2-devel >= 1:2.0.3
24 BuildRequires:  lensfun-devel
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libpano13-devel >= 2.9.19
27 BuildRequires:  libpng-devel
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libtiff-devel
30 BuildRequires:  perl-Image-ExifTool
31 BuildRequires:  perl-tools-pod
32 BuildRequires:  pkgconfig
33 BuildRequires:  python3-devel
34 BuildRequires:  rpmbuild(macros) >= 1.605
35 BuildRequires:  sed >= 4.0
36 BuildRequires:  swig-python >= 2.0.4
37 BuildRequires:  tclap
38 BuildRequires:  vigra-devel
39 BuildRequires:  wxGTK2-unicode-devel >= 2.8.10
40 BuildRequires:  wxGTK2-unicode-gl-devel >= 2.8.10
41 BuildRequires:  zlib-devel
42 Requires:       libpano13 >= 2.9.19
43 Requires:       wxGTK2-unicode >= 2.8.10
44 Requires:       wxGTK2-unicode-gl >= 2.8.10
45 Suggests:       enblend-enfuse >= 3.1
46 # exiftool program
47 Suggests:       perl-Image-ExifTool
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 With hugin you can assemble a mosaic of photographs into a complete
52 immensive panorama, stitch any series of overlapping pictures and much
53 more.
54
55 Note: Hugin can use enblend and enfuse for soft blending/fusing, so
56 you'll probably to install enblend-enfuse package too.
57
58 %description -l pl.UTF-8
59 Przy użyciu hugina można połączyć wiele fotografii w kompletną, dużą
60 panoramę, skleić dowolny ciąg nakładających się zdjęć i wiele więcej.
61
62 Hugin może używać programów enblend i enfuse do wygładzania krawędzi i
63 ekspozycji, więc warto zainstalować pakiet enblend-enfuse.
64
65 %prep
66 %setup -q
67 %patch0 -p0
68 %patch1 -p1
69 %patch2 -p1
70
71 # Old, broken duplicate of the system cmake one
72 %{__rm} CMakeModules/FindZLIB.cmake
73
74 %{__mv} src/translations/{cs_CZ,cs}.po
75
76 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
77       src/hugin_script_interface/hpi.py \
78       src/hugin_script_interface/plugins-dev/dual_use.py \
79       src/hugin_script_interface/plugins-dev/plugin_skeleton.py \
80       src/hugin_script_interface/plugins/top_five.py \
81       src/hugin_script_interface/plugins/woa.py
82
83 %build
84 install -d build
85 cd build
86 %cmake .. \
87         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
88         -DCMAKE_VERBOSE_MAKEFILE=ON \
89         -DBUILD_HSI:BOOL=ON \
90 %if "%{_lib}" == "lib64"
91         -DLIB_SUFFIX=64 \
92 %endif
93         -DwxWidgets_CONFIG_EXECUTABLE=%{_bindir}/wx-gtk2-unicode-config
94
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} -C build install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 # cmake is so great there is no way to pass proper path
104 %{__mv} $RPM_BUILD_ROOT%{_iconsdir}/{gnome,hicolor}
105 %{__mv} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/gnome/48x48/* $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/
106 %{__rm} -r $RPM_BUILD_ROOT%{_iconsdir}/hicolor/gnome/48x48
107
108 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ca_ES*
109
110 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
111 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
112
113 %find_lang %{name}
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files -f %{name}.lang
119 %defattr(644,root,root,755)
120 %doc AUTHORS Changes.txt README TODO src/celeste/LICENCE_{GABOR,LIBSVM}
121 %attr(755,root,root) %{_bindir}/PTBatcherGUI
122 %attr(755,root,root) %{_bindir}/align_image_stack
123 %attr(755,root,root) %{_bindir}/autooptimiser
124 %attr(755,root,root) %{_bindir}/calibrate_lens_gui
125 %attr(755,root,root) %{_bindir}/celeste_standalone
126 %attr(755,root,root) %{_bindir}/checkpto
127 %attr(755,root,root) %{_bindir}/cpclean
128 %attr(755,root,root) %{_bindir}/cpfind
129 %attr(755,root,root) %{_bindir}/deghosting_mask
130 %attr(755,root,root) %{_bindir}/fulla
131 %attr(755,root,root) %{_bindir}/geocpset
132 %attr(755,root,root) %{_bindir}/hugin
133 %attr(755,root,root) %{_bindir}/hugin_executor
134 %attr(755,root,root) %{_bindir}/hugin_hdrmerge
135 %attr(755,root,root) %{_bindir}/hugin_lensdb
136 %attr(755,root,root) %{_bindir}/hugin_stacker
137 %attr(755,root,root) %{_bindir}/hugin_stitch_project
138 %attr(755,root,root) %{_bindir}/icpfind
139 %attr(755,root,root) %{_bindir}/linefind
140 %attr(755,root,root) %{_bindir}/nona
141 %attr(755,root,root) %{_bindir}/pano_modify
142 %attr(755,root,root) %{_bindir}/pano_trafo
143 %attr(755,root,root) %{_bindir}/pto_gen
144 %attr(755,root,root) %{_bindir}/pto_lensstack
145 %attr(755,root,root) %{_bindir}/pto_mask
146 %attr(755,root,root) %{_bindir}/pto_merge
147 %attr(755,root,root) %{_bindir}/pto_move
148 %attr(755,root,root) %{_bindir}/pto_template
149 %attr(755,root,root) %{_bindir}/pto_var
150 %attr(755,root,root) %{_bindir}/tca_correct
151 %attr(755,root,root) %{_bindir}/verdandi
152 %attr(755,root,root) %{_bindir}/vig_optimize
153 %dir %{_libdir}/hugin
154 %attr(755,root,root) %{_libdir}/hugin/libceleste.so.*.*
155 %attr(755,root,root) %{_libdir}/hugin/libhuginbase.so.*.*
156 %attr(755,root,root) %{_libdir}/hugin/libhuginbasewx.so.*.*
157 %attr(755,root,root) %{_libdir}/hugin/libicpfindlib.so.*.*
158 %attr(755,root,root) %{_libdir}/hugin/liblocalfeatures.so.*.*
159 %attr(755,root,root) %{_libdir}/hugin/libhugin_python_interface.so.*.*
160 %attr(755,root,root) %{py3_sitedir}/_hsi.so
161 %{py3_sitedir}/hpi.py*
162 %{py3_sitedir}/hsi.py*
163 %{py3_sitedir}/__pycache__/*
164 %{_datadir}/%{name}
165 %{_datadir}/metainfo/PTBatcherGUI.appdata.xml
166 %{_datadir}/metainfo/calibrate_lens_gui.appdata.xml
167 %{_datadir}/metainfo/hugin.appdata.xml
168 %{_datadir}/mime/packages/hugin.xml
169 %{_desktopdir}/hugin.desktop
170 %{_desktopdir}/pto_gen.desktop
171 %{_desktopdir}/PTBatcherGUI.desktop
172 %{_desktopdir}/calibrate_lens_gui.desktop
173 %{_iconsdir}/hicolor/*x*/apps/hugin.png
174 %{_iconsdir}/hicolor/*x*/apps/ptbatcher.png
175 %{_iconsdir}/hicolor/*x*/mimetypes/application-x-ptoptimizer-script.png
176 %{_iconsdir}/hicolor/scalable/apps/hugin.svg
177 %{_iconsdir}/hicolor/scalable/apps/ptbatcher.svg
178 %{_mandir}/man1/PTBatcherGUI.1*
179 %{_mandir}/man1/align_image_stack.1*
180 %{_mandir}/man1/autooptimiser.1*
181 %{_mandir}/man1/calibrate_lens_gui.1*
182 %{_mandir}/man1/celeste_standalone.1*
183 %{_mandir}/man1/checkpto.1*
184 %{_mandir}/man1/cpclean.1*
185 %{_mandir}/man1/cpfind.1*
186 %{_mandir}/man1/deghosting_mask.1*
187 %{_mandir}/man1/fulla.1*
188 %{_mandir}/man1/geocpset.1*
189 %{_mandir}/man1/hugin.1*
190 %{_mandir}/man1/hugin_executor.1*
191 %{_mandir}/man1/hugin_hdrmerge.1*
192 %{_mandir}/man1/hugin_lensdb.1*
193 %{_mandir}/man1/hugin_stacker.1*
194 %{_mandir}/man1/hugin_stitch_project.1*
195 %{_mandir}/man1/icpfind.1*
196 %{_mandir}/man1/linefind.1*
197 %{_mandir}/man1/nona.1*
198 %{_mandir}/man1/pano_modify.1*
199 %{_mandir}/man1/pano_trafo.1*
200 %{_mandir}/man1/pto_gen.1*
201 %{_mandir}/man1/pto_lensstack.1*
202 %{_mandir}/man1/pto_merge.1*
203 %{_mandir}/man1/pto_mask.1*
204 %{_mandir}/man1/pto_move.1*
205 %{_mandir}/man1/pto_template.1*
206 %{_mandir}/man1/pto_var.1*
207 %{_mandir}/man1/tca_correct.1*
208 %{_mandir}/man1/vig_optimize.1*
209 %{_mandir}/man1/verdandi.1*
This page took 0.047853 seconds and 2 git commands to generate.