]> git.pld-linux.org Git - packages/hugin.git/blob - hugin.spec
882bdddde15b31ac6fdd672b6e48cb814c517491
[packages/hugin.git] / hugin.spec
1 Summary:        Toolchain to create panoramic images
2 Summary(pl.UTF-8):      Zestaw narzędzi do tworzenia panoramicznych zdjęć
3 Name:           hugin
4 Version:        2019.2.0
5 Release:        1
6 License:        GPL v2+
7 Group:          X11/Applications/Graphics
8 Source0:        http://downloads.sourceforge.net/hugin/%{name}-%{version}.tar.bz2
9 # Source0-md5:  3409c3a84e1881145b5b556df63de73c
10 Patch0:         %{name}-cppflags.patch
11 Patch1:         python-install.patch
12 URL:            http://hugin.sourceforge.net/
13 BuildRequires:  OpenEXR-devel
14 BuildRequires:  OpenGL-glut-devel
15 BuildRequires:  ZThread-devel
16 BuildRequires:  boost-devel >= 1.41.0
17 BuildRequires:  cmake >= 2.8
18 BuildRequires:  exiv2-devel
19 BuildRequires:  flann-devel
20 BuildRequires:  gettext-tools
21 BuildRequires:  glew-devel
22 BuildRequires:  gtk+2-devel >= 1:2.0.3
23 BuildRequires:  lensfun-devel
24 BuildRequires:  libjpeg-devel
25 BuildRequires:  libpano13-devel >= 2.9.19
26 BuildRequires:  libpng-devel
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtiff-devel
29 BuildRequires:  perl-Image-ExifTool
30 BuildRequires:  perl-tools-pod
31 BuildRequires:  pkgconfig
32 BuildRequires:  python3-devel
33 BuildRequires:  rpmbuild(macros) >= 1.471
34 BuildRequires:  sed >= 4.0
35 BuildRequires:  swig-python >= 2.0.4
36 BuildRequires:  tclap
37 BuildRequires:  vigra-devel
38 BuildRequires:  wxGTK2-unicode-devel >= 2.8.10
39 BuildRequires:  wxGTK2-unicode-gl-devel >= 2.8.10
40 BuildRequires:  zlib-devel
41 Requires:       libpano13 >= 2.9.19
42 Requires:       wxGTK2-unicode >= 2.8.10
43 Requires:       wxGTK2-unicode-gl >= 2.8.10
44 Suggests:       enblend-enfuse >= 3.1
45 # exiftool program
46 Suggests:       perl-Image-ExifTool
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 With hugin you can assemble a mosaic of photographs into a complete
51 immensive panorama, stitch any series of overlapping pictures and much
52 more.
53
54 Note: Hugin can use enblend and enfuse for soft blending/fusing, so
55 you'll probably to install enblend-enfuse package too.
56
57 %description -l pl.UTF-8
58 Przy użyciu hugina można połączyć wiele fotografii w kompletną, dużą
59 panoramę, skleić dowolny ciąg nakładających się zdjęć i wiele więcej.
60
61 Hugin może używać programów enblend i enfuse do wygładzania krawędzi
62 i ekspozycji, więc warto zainstalować pakiet enblend-enfuse.
63
64 %prep
65 %setup -q
66 %patch0 -p0
67 %patch1 -p1
68
69 mv -f src/translations/{cs_CZ,cs}.po
70
71 %{__sed} -i -e '1s,#! \?/usr/bin/env python,#!/usr/bin/python3,' \
72         src/hugin_script_interface/hpi.py \
73         src/hugin_script_interface/plugins/*.py \
74         src/hugin_script_interface/plugins-dev/*.py
75
76 %build
77 install -d build
78 cd build
79 %cmake .. \
80         -DCMAKE_BUILD_TYPE=%{?debug:Debug}%{!?debug:None} \
81         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
82         -DCMAKE_VERBOSE_MAKEFILE=ON \
83         -DBUILD_HSI:BOOL=ON \
84 %if "%{_lib}" == "lib64"
85         -DLIB_SUFFIX=64 \
86 %endif
87         -DwxWidgets_CONFIG_EXECUTABLE=%{_bindir}/wx-gtk2-unicode-config
88
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} -C build install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 # cmake is so great there is no way to pass proper path
98 %{__mv} $RPM_BUILD_ROOT%{_iconsdir}/{gnome,hicolor}
99
100 %{__rm} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/gnome/*x*/mimetypes/gnome-mime-application-x-ptoptimizer-script.png
101
102 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ca_ES*
103
104 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
105 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
106
107 %find_lang %{name}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %files -f %{name}.lang
113 %defattr(644,root,root,755)
114 %doc AUTHORS Changes.txt README TODO src/celeste/LICENCE_{GABOR,LIBSVM}
115 %attr(755,root,root) %{_bindir}/PTBatcherGUI
116 %attr(755,root,root) %{_bindir}/align_image_stack
117 %attr(755,root,root) %{_bindir}/autooptimiser
118 %attr(755,root,root) %{_bindir}/calibrate_lens_gui
119 %attr(755,root,root) %{_bindir}/celeste_standalone
120 %attr(755,root,root) %{_bindir}/checkpto
121 %attr(755,root,root) %{_bindir}/cpclean
122 %attr(755,root,root) %{_bindir}/cpfind
123 %attr(755,root,root) %{_bindir}/deghosting_mask
124 %attr(755,root,root) %{_bindir}/fulla
125 %attr(755,root,root) %{_bindir}/geocpset
126 %attr(755,root,root) %{_bindir}/hugin
127 %attr(755,root,root) %{_bindir}/hugin_executor
128 %attr(755,root,root) %{_bindir}/hugin_hdrmerge
129 %attr(755,root,root) %{_bindir}/hugin_lensdb
130 %attr(755,root,root) %{_bindir}/hugin_stacker
131 %attr(755,root,root) %{_bindir}/hugin_stitch_project
132 %attr(755,root,root) %{_bindir}/icpfind
133 %attr(755,root,root) %{_bindir}/linefind
134 %attr(755,root,root) %{_bindir}/nona
135 %attr(755,root,root) %{_bindir}/pano_modify
136 %attr(755,root,root) %{_bindir}/pano_trafo
137 %attr(755,root,root) %{_bindir}/pto_gen
138 %attr(755,root,root) %{_bindir}/pto_lensstack
139 %attr(755,root,root) %{_bindir}/pto_mask
140 %attr(755,root,root) %{_bindir}/pto_merge
141 %attr(755,root,root) %{_bindir}/pto_move
142 %attr(755,root,root) %{_bindir}/pto_template
143 %attr(755,root,root) %{_bindir}/pto_var
144 %attr(755,root,root) %{_bindir}/tca_correct
145 %attr(755,root,root) %{_bindir}/verdandi
146 %attr(755,root,root) %{_bindir}/vig_optimize
147 %dir %{_libdir}/hugin
148 %attr(755,root,root) %{_libdir}/hugin/libceleste.so.*.*
149 %attr(755,root,root) %{_libdir}/hugin/libhuginbase.so.*.*
150 %attr(755,root,root) %{_libdir}/hugin/libhuginbasewx.so.*.*
151 %attr(755,root,root) %{_libdir}/hugin/libicpfindlib.so.*.*
152 %attr(755,root,root) %{_libdir}/hugin/liblocalfeatures.so.*.*
153 %attr(755,root,root) %{_libdir}/hugin/libhugin_python_interface.so.*.*
154 %attr(755,root,root) %{py3_sitedir}/_hsi.so
155 %{py3_sitedir}/hpi.py*
156 %{py3_sitedir}/hsi.py*
157 %{_datadir}/%{name}
158 %{_datadir}/appdata/PTBatcherGUI.appdata.xml
159 %{_datadir}/appdata/calibrate_lens_gui.appdata.xml
160 %{_datadir}/appdata/hugin.appdata.xml
161 %{_datadir}/mime/packages/hugin.xml
162 %{_desktopdir}/hugin.desktop
163 %{_desktopdir}/pto_gen.desktop
164 %{_desktopdir}/PTBatcherGUI.desktop
165 %{_desktopdir}/calibrate_lens_gui.desktop
166 %{_iconsdir}/hicolor/*x*/apps/hugin.png
167 %{_iconsdir}/hicolor/*x*/apps/ptbatcher.png
168 %{_iconsdir}/hicolor/scalable/apps/hugin.svg
169 %{_iconsdir}/hicolor/scalable/apps/ptbatcher.svg
170 %{_mandir}/man1/PTBatcherGUI.1*
171 %{_mandir}/man1/align_image_stack.1*
172 %{_mandir}/man1/autooptimiser.1*
173 %{_mandir}/man1/calibrate_lens_gui.1*
174 %{_mandir}/man1/celeste_standalone.1*
175 %{_mandir}/man1/checkpto.1*
176 %{_mandir}/man1/cpclean.1*
177 %{_mandir}/man1/cpfind.1*
178 %{_mandir}/man1/deghosting_mask.1*
179 %{_mandir}/man1/fulla.1*
180 %{_mandir}/man1/geocpset.1*
181 %{_mandir}/man1/hugin.1*
182 %{_mandir}/man1/hugin_executor.1*
183 %{_mandir}/man1/hugin_hdrmerge.1*
184 %{_mandir}/man1/hugin_lensdb.1*
185 %{_mandir}/man1/hugin_stitch_project.1*
186 %{_mandir}/man1/icpfind.1*
187 %{_mandir}/man1/linefind.1*
188 %{_mandir}/man1/nona.1*
189 %{_mandir}/man1/pano_modify.1*
190 %{_mandir}/man1/pano_trafo.1*
191 %{_mandir}/man1/pto_gen.1*
192 %{_mandir}/man1/pto_lensstack.1*
193 %{_mandir}/man1/pto_merge.1*
194 %{_mandir}/man1/pto_mask.1*
195 %{_mandir}/man1/pto_move.1*
196 %{_mandir}/man1/pto_template.1*
197 %{_mandir}/man1/pto_var.1*
198 %{_mandir}/man1/tca_correct.1*
199 %{_mandir}/man1/vig_optimize.1*
200 %{_mandir}/man1/verdandi.1*
This page took 0.05961 seconds and 2 git commands to generate.