]> git.pld-linux.org Git - packages/hugin.git/blame_incremental - hugin.spec
Up to 2012.0.0
[packages/hugin.git] / hugin.spec
... / ...
CommitLineData
1Summary: Toolchain to create panoramic images
2Summary(pl.UTF-8): Zestaw narzędzi do tworzenia panoramicznych zdjęć
3Name: hugin
4Version: 2012.0.0
5Release: 1
6License: GPL v2+
7Group: X11/Applications/Graphics
8Source0: http://downloads.sourceforge.net/hugin/%{name}-%{version}.tar.bz2
9# Source0-md5: 6a4fb2585eb3539ba6769cf4557f6e88
10Patch0: %{name}-pl.po-update.patch
11Patch1: %{name}-cppflags.patch
12URL: http://hugin.sourceforge.net/
13BuildRequires: OpenEXR-devel
14BuildRequires: OpenGL-glut-devel
15BuildRequires: boost-devel >= 1.40.0
16BuildRequires: cmake >= 2.8
17BuildRequires: exiv2-devel
18BuildRequires: gettext-devel
19BuildRequires: glew-devel
20BuildRequires: gtk+2-devel >= 1:2.0.3
21BuildRequires: lensfun-devel
22BuildRequires: libjpeg-devel
23BuildRequires: libpano13-devel >= 2.9.18
24BuildRequires: libpng-devel
25BuildRequires: libstdc++-devel
26BuildRequires: libtiff-devel
27BuildRequires: perl-tools-pod
28BuildRequires: pkgconfig
29BuildRequires: rpmbuild(macros) >= 1.471
30BuildRequires: sed >= 4.0
31BuildRequires: tclap
32BuildRequires: wxGTK2-unicode-devel >= 2.7.0
33BuildRequires: wxGTK2-unicode-gl-devel >= 2.7.0
34BuildRequires: zlib-devel
35Suggests: autopano-sift-C >= 2.5.0
36Suggests: enblend-enfuse >= 3.1
37# exiftool program
38Suggests: perl-Image-ExifTool
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
42With hugin you can assemble a mosaic of photographs into a complete
43immensive panorama, stitch any series of overlapping pictures and much
44more.
45
46Note: Hugin can use autopano-sift-C package to match images and
47enblend package for soft blending, so you'll probably want to install
48them too.
49
50%description -l pl.UTF-8
51Przy użyciu hugina można połączyć wiele fotografii w kompletną, dużą
52panoramę, skleić dowolny ciąg nakładających się zdjęć i wiele więcej.
53
54Hugin może używać pakietu autopano-sift-C do dopasowania zdjęć oraz
55pakiet enblend do wygładzenia krawędzi po łączeniu - więc warto te
56pakiety także zainstalować.
57
58%prep
59%setup -q
60%patch0 -p1
61%patch1 -p0
62
63mv -f src/translations/{ca_ES,ca}.po
64mv -f src/translations/{cs_CZ,cs}.po
65
66%build
67install -d build
68cd build
69%cmake .. \
70 -DCMAKE_BUILD_TYPE=%{?debug:Debug}%{!?debug:None} \
71 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
72 -DCMAKE_VERBOSE_MAKEFILE=ON \
73%if "%{_lib}" == "lib64"
74 -DLIB_SUFFIX=64 \
75%endif
76 -DwxWidgets_CONFIG_EXECUTABLE=%{_bindir}/wx-gtk2-unicode-config
77
78%{__make}
79
80%install
81rm -rf $RPM_BUILD_ROOT
82
83%{__make} -C build install \
84 DESTDIR=$RPM_BUILD_ROOT
85
86# cmake is so great there is no way to pass proper path
87mv $RPM_BUILD_ROOT%{_iconsdir}/{gnome,hicolor}
88
89%find_lang %{name}
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post -p /sbin/ldconfig
95%postun -p /sbin/ldconfig
96
97%files -f %{name}.lang
98%defattr(644,root,root,755)
99%doc AUTHORS ChangeLog LICENCE_VIGRA README TODO
100%lang(ja) %doc README_JP
101%attr(755,root,root) %{_bindir}/PTBatcher
102%attr(755,root,root) %{_bindir}/PTBatcherGUI
103%attr(755,root,root) %{_bindir}/align_image_stack
104%attr(755,root,root) %{_bindir}/autooptimiser
105%attr(755,root,root) %{_bindir}/autopano-noop.sh
106%attr(755,root,root) %{_bindir}/calibrate_lens_gui
107%attr(755,root,root) %{_bindir}/celeste_standalone
108%attr(755,root,root) %{_bindir}/checkpto
109%attr(755,root,root) %{_bindir}/cpclean
110%attr(755,root,root) %{_bindir}/cpfind
111%attr(755,root,root) %{_bindir}/deghosting_mask
112%attr(755,root,root) %{_bindir}/fulla
113%attr(755,root,root) %{_bindir}/hugin
114%attr(755,root,root) %{_bindir}/hugin_hdrmerge
115%attr(755,root,root) %{_bindir}/hugin_stitch_project
116%attr(755,root,root) %{_bindir}/icpfind
117%attr(755,root,root) %{_bindir}/linefind
118%attr(755,root,root) %{_bindir}/matchpoint
119%attr(755,root,root) %{_bindir}/nona
120%attr(755,root,root) %{_bindir}/nona_gui
121%attr(755,root,root) %{_bindir}/pano_modify
122%attr(755,root,root) %{_bindir}/pano_trafo
123%attr(755,root,root) %{_bindir}/pto_gen
124%attr(755,root,root) %{_bindir}/pto_merge
125%attr(755,root,root) %{_bindir}/pto2mk
126%attr(755,root,root) %{_bindir}/tca_correct
127%attr(755,root,root) %{_bindir}/vig_optimize
128%dir %{_libdir}/hugin
129%attr(755,root,root) %{_libdir}/hugin/libceleste.so.*.*
130%attr(755,root,root) %{_libdir}/hugin/libflann_cpp.so.*.*
131%attr(755,root,root) %{_libdir}/hugin/libhuginbase.so.*.*
132%attr(755,root,root) %{_libdir}/hugin/libhuginbasewx.so.*.*
133%attr(755,root,root) %{_libdir}/hugin/libhuginlines.so.*.*
134%attr(755,root,root) %{_libdir}/hugin/libhuginvigraimpex.so.*.*
135%attr(755,root,root) %{_libdir}/hugin/libicpfindlib.so.*.*
136%attr(755,root,root) %{_libdir}/hugin/liblocalfeatures.so.*.*
137%attr(755,root,root) %{_libdir}/hugin/libmakefilelib.so.*.*
138%attr(755,root,root) %{_libdir}/hugin/libhugin_python_interface.so.*.*
139%{py_sitedir}/_hsi.so
140%{py_sitedir}/hpi.py
141%{py_sitedir}/hsi.py
142%{_datadir}/%{name}
143%{_datadir}/mime/packages/hugin.xml
144%{_desktopdir}/hugin.desktop
145%{_desktopdir}/pto_gen.desktop
146%{_desktopdir}/PTBatcherGUI.desktop
147%{_desktopdir}/calibrate_lens_gui.desktop
148%{_iconsdir}/hicolor/*/mimetypes/gnome-mime-application-x-ptoptimizer-script.png
149%{_pixmapsdir}/hugin.png
150%{_pixmapsdir}/ptbatcher.png
151%{_mandir}/man1/PTBatcher.1*
152%{_mandir}/man1/PTBatcherGUI.1*
153%{_mandir}/man1/align_image_stack.1*
154%{_mandir}/man1/autooptimiser.1*
155%{_mandir}/man1/autopano-noop.sh.1*
156%{_mandir}/man1/calibrate_lens_gui.1*
157%{_mandir}/man1/celeste_standalone.1*
158%{_mandir}/man1/checkpto.1*
159%{_mandir}/man1/cpclean.1*
160%{_mandir}/man1/cpfind.1*
161%{_mandir}/man1/deghosting_mask.1*
162%{_mandir}/man1/fulla.1*
163%{_mandir}/man1/hugin.1*
164%{_mandir}/man1/hugin_hdrmerge.1*
165%{_mandir}/man1/hugin_stitch_project.1*
166%{_mandir}/man1/icpfind.1*
167%{_mandir}/man1/linefind.1*
168%{_mandir}/man1/matchpoint.1*
169%{_mandir}/man1/nona.1*
170%{_mandir}/man1/nona_gui.1*
171%{_mandir}/man1/pano_modify.1*
172%{_mandir}/man1/pano_trafo.1*
173%{_mandir}/man1/pto2mk.1*
174%{_mandir}/man1/pto_gen.1*
175%{_mandir}/man1/pto_merge.1*
176%{_mandir}/man1/tca_correct.1*
177%{_mandir}/man1/vig_optimize.1*
This page took 0.033269 seconds and 4 git commands to generate.