]> git.pld-linux.org Git - packages/hugin.git/blame_incremental - hugin.spec
- release 3 (boost 1.73)
[packages/hugin.git] / hugin.spec
... / ...
CommitLineData
1Summary: Toolchain to create panoramic images
2Summary(pl.UTF-8): Zestaw narzędzi do tworzenia panoramicznych zdjęć
3Name: hugin
4Version: 2019.2.0
5Release: 3
6License: GPL v2+
7Group: X11/Applications/Graphics
8Source0: http://downloads.sourceforge.net/hugin/%{name}-%{version}.tar.bz2
9# Source0-md5: 3409c3a84e1881145b5b556df63de73c
10Patch0: %{name}-cppflags.patch
11Patch1: python-install.patch
12URL: http://hugin.sourceforge.net/
13BuildRequires: OpenEXR-devel
14BuildRequires: OpenGL-glut-devel
15BuildRequires: ZThread-devel
16BuildRequires: boost-devel >= 1.41.0
17BuildRequires: cmake >= 2.8
18BuildRequires: exiv2-devel
19BuildRequires: flann-devel
20BuildRequires: gettext-tools
21BuildRequires: glew-devel
22BuildRequires: gtk+2-devel >= 1:2.0.3
23BuildRequires: lensfun-devel
24BuildRequires: libjpeg-devel
25BuildRequires: libpano13-devel >= 2.9.19
26BuildRequires: libpng-devel
27BuildRequires: libstdc++-devel
28BuildRequires: libtiff-devel
29BuildRequires: perl-Image-ExifTool
30BuildRequires: perl-tools-pod
31BuildRequires: pkgconfig
32BuildRequires: python3-devel
33BuildRequires: rpmbuild(macros) >= 1.471
34BuildRequires: sed >= 4.0
35BuildRequires: swig-python >= 2.0.4
36BuildRequires: tclap
37BuildRequires: vigra-devel
38BuildRequires: wxGTK2-unicode-devel >= 2.8.10
39BuildRequires: wxGTK2-unicode-gl-devel >= 2.8.10
40BuildRequires: zlib-devel
41Requires: libpano13 >= 2.9.19
42Requires: wxGTK2-unicode >= 2.8.10
43Requires: wxGTK2-unicode-gl >= 2.8.10
44Suggests: enblend-enfuse >= 3.1
45# exiftool program
46Suggests: perl-Image-ExifTool
47BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49%description
50With hugin you can assemble a mosaic of photographs into a complete
51immensive panorama, stitch any series of overlapping pictures and much
52more.
53
54Note: Hugin can use enblend and enfuse for soft blending/fusing, so
55you'll probably to install enblend-enfuse package too.
56
57%description -l pl.UTF-8
58Przy użyciu hugina można połączyć wiele fotografii w kompletną, dużą
59panoramę, skleić dowolny ciąg nakładających się zdjęć i wiele więcej.
60
61Hugin może używać programów enblend i enfuse do wygładzania krawędzi
62i ekspozycji, więc warto zainstalować pakiet enblend-enfuse.
63
64%prep
65%setup -q
66%patch0 -p0
67%patch1 -p1
68
69mv -f src/translations/{cs_CZ,cs}.po
70
71%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
72 src/hugin_script_interface/hpi.py \
73 src/hugin_script_interface/plugins-dev/dual_use.py \
74 src/hugin_script_interface/plugins-dev/plugin_skeleton.py \
75 src/hugin_script_interface/plugins/top_five.py \
76 src/hugin_script_interface/plugins/woa.py
77
78%build
79install -d build
80cd build
81%cmake .. \
82 -DCMAKE_BUILD_TYPE=%{?debug:Debug}%{!?debug:None} \
83 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
84 -DCMAKE_VERBOSE_MAKEFILE=ON \
85 -DBUILD_HSI:BOOL=ON \
86%if "%{_lib}" == "lib64"
87 -DLIB_SUFFIX=64 \
88%endif
89 -DwxWidgets_CONFIG_EXECUTABLE=%{_bindir}/wx-gtk2-unicode-config
90
91%{__make}
92
93%install
94rm -rf $RPM_BUILD_ROOT
95
96%{__make} -C build install \
97 DESTDIR=$RPM_BUILD_ROOT
98
99# cmake is so great there is no way to pass proper path
100%{__mv} $RPM_BUILD_ROOT%{_iconsdir}/{gnome,hicolor}
101
102%{__rm} $RPM_BUILD_ROOT%{_iconsdir}/hicolor/gnome/*x*/mimetypes/gnome-mime-application-x-ptoptimizer-script.png
103
104%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ca_ES*
105
106%py_comp $RPM_BUILD_ROOT%{py_sitedir}
107%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
108
109%find_lang %{name}
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%files -f %{name}.lang
115%defattr(644,root,root,755)
116%doc AUTHORS Changes.txt README TODO src/celeste/LICENCE_{GABOR,LIBSVM}
117%attr(755,root,root) %{_bindir}/PTBatcherGUI
118%attr(755,root,root) %{_bindir}/align_image_stack
119%attr(755,root,root) %{_bindir}/autooptimiser
120%attr(755,root,root) %{_bindir}/calibrate_lens_gui
121%attr(755,root,root) %{_bindir}/celeste_standalone
122%attr(755,root,root) %{_bindir}/checkpto
123%attr(755,root,root) %{_bindir}/cpclean
124%attr(755,root,root) %{_bindir}/cpfind
125%attr(755,root,root) %{_bindir}/deghosting_mask
126%attr(755,root,root) %{_bindir}/fulla
127%attr(755,root,root) %{_bindir}/geocpset
128%attr(755,root,root) %{_bindir}/hugin
129%attr(755,root,root) %{_bindir}/hugin_executor
130%attr(755,root,root) %{_bindir}/hugin_hdrmerge
131%attr(755,root,root) %{_bindir}/hugin_lensdb
132%attr(755,root,root) %{_bindir}/hugin_stacker
133%attr(755,root,root) %{_bindir}/hugin_stitch_project
134%attr(755,root,root) %{_bindir}/icpfind
135%attr(755,root,root) %{_bindir}/linefind
136%attr(755,root,root) %{_bindir}/nona
137%attr(755,root,root) %{_bindir}/pano_modify
138%attr(755,root,root) %{_bindir}/pano_trafo
139%attr(755,root,root) %{_bindir}/pto_gen
140%attr(755,root,root) %{_bindir}/pto_lensstack
141%attr(755,root,root) %{_bindir}/pto_mask
142%attr(755,root,root) %{_bindir}/pto_merge
143%attr(755,root,root) %{_bindir}/pto_move
144%attr(755,root,root) %{_bindir}/pto_template
145%attr(755,root,root) %{_bindir}/pto_var
146%attr(755,root,root) %{_bindir}/tca_correct
147%attr(755,root,root) %{_bindir}/verdandi
148%attr(755,root,root) %{_bindir}/vig_optimize
149%dir %{_libdir}/hugin
150%attr(755,root,root) %{_libdir}/hugin/libceleste.so.*.*
151%attr(755,root,root) %{_libdir}/hugin/libhuginbase.so.*.*
152%attr(755,root,root) %{_libdir}/hugin/libhuginbasewx.so.*.*
153%attr(755,root,root) %{_libdir}/hugin/libicpfindlib.so.*.*
154%attr(755,root,root) %{_libdir}/hugin/liblocalfeatures.so.*.*
155%attr(755,root,root) %{_libdir}/hugin/libhugin_python_interface.so.*.*
156%attr(755,root,root) %{py3_sitedir}/_hsi.so
157%{py3_sitedir}/hpi.py*
158%{py3_sitedir}/hsi.py*
159%{_datadir}/%{name}
160%{_datadir}/appdata/PTBatcherGUI.appdata.xml
161%{_datadir}/appdata/calibrate_lens_gui.appdata.xml
162%{_datadir}/appdata/hugin.appdata.xml
163%{_datadir}/mime/packages/hugin.xml
164%{_desktopdir}/hugin.desktop
165%{_desktopdir}/pto_gen.desktop
166%{_desktopdir}/PTBatcherGUI.desktop
167%{_desktopdir}/calibrate_lens_gui.desktop
168%{_iconsdir}/hicolor/*x*/apps/hugin.png
169%{_iconsdir}/hicolor/*x*/apps/ptbatcher.png
170%{_iconsdir}/hicolor/scalable/apps/hugin.svg
171%{_iconsdir}/hicolor/scalable/apps/ptbatcher.svg
172%{_mandir}/man1/PTBatcherGUI.1*
173%{_mandir}/man1/align_image_stack.1*
174%{_mandir}/man1/autooptimiser.1*
175%{_mandir}/man1/calibrate_lens_gui.1*
176%{_mandir}/man1/celeste_standalone.1*
177%{_mandir}/man1/checkpto.1*
178%{_mandir}/man1/cpclean.1*
179%{_mandir}/man1/cpfind.1*
180%{_mandir}/man1/deghosting_mask.1*
181%{_mandir}/man1/fulla.1*
182%{_mandir}/man1/geocpset.1*
183%{_mandir}/man1/hugin.1*
184%{_mandir}/man1/hugin_executor.1*
185%{_mandir}/man1/hugin_hdrmerge.1*
186%{_mandir}/man1/hugin_lensdb.1*
187%{_mandir}/man1/hugin_stitch_project.1*
188%{_mandir}/man1/icpfind.1*
189%{_mandir}/man1/linefind.1*
190%{_mandir}/man1/nona.1*
191%{_mandir}/man1/pano_modify.1*
192%{_mandir}/man1/pano_trafo.1*
193%{_mandir}/man1/pto_gen.1*
194%{_mandir}/man1/pto_lensstack.1*
195%{_mandir}/man1/pto_merge.1*
196%{_mandir}/man1/pto_mask.1*
197%{_mandir}/man1/pto_move.1*
198%{_mandir}/man1/pto_template.1*
199%{_mandir}/man1/pto_var.1*
200%{_mandir}/man1/tca_correct.1*
201%{_mandir}/man1/vig_optimize.1*
202%{_mandir}/man1/verdandi.1*
This page took 0.033136 seconds and 4 git commands to generate.