]> git.pld-linux.org Git - packages/hugin.git/blame_incremental - hugin.spec
- updated to 2011.4.0
[packages/hugin.git] / hugin.spec
... / ...
CommitLineData
1Summary: Toolchain to create panoramic images
2Summary(pl.UTF-8): Zestaw narzędzi do tworzenia panoramicznych zdjęć
3Name: hugin
4Version: 2011.4.0
5Release: 1
6License: GPL v2+
7Group: X11/Applications/Graphics
8Source0: http://downloads.sourceforge.net/hugin/%{name}-%{version}.tar.bz2
9# Source0-md5: 3e4866dbbc7974972604aa18580eae0e
10Patch0: %{name}-pl.po-update.patch
11Patch1: %{name}-cppflags.patch
12URL: http://hugin.sourceforge.net/
13BuildRequires: OpenEXR-devel
14BuildRequires: OpenGL-glut-devel
15BuildRequires: boost-devel >= 1.40.0
16BuildRequires: cmake >= 2.8
17BuildRequires: exiv2-devel
18BuildRequires: gettext-devel
19BuildRequires: glew-devel
20BuildRequires: gtk+2-devel >= 1:2.0.3
21BuildRequires: libjpeg-devel
22BuildRequires: libpano13-devel >= 2.9.18
23BuildRequires: libpng-devel
24BuildRequires: libstdc++-devel
25BuildRequires: libtiff-devel
26BuildRequires: perl-tools-pod
27BuildRequires: pkgconfig
28BuildRequires: rpmbuild(macros) >= 1.471
29BuildRequires: sed >= 4.0
30BuildRequires: tclap
31BuildRequires: wxGTK2-unicode-devel >= 2.7.0
32BuildRequires: wxGTK2-unicode-gl-devel >= 2.7.0
33BuildRequires: zlib-devel
34Suggests: autopano-sift-C >= 2.5.0
35Suggests: enblend-enfuse >= 3.1
36# exiftool program
37Suggests: perl-Image-ExifTool
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
41With hugin you can assemble a mosaic of photographs into a complete
42immensive panorama, stitch any series of overlapping pictures and much
43more.
44
45Note: Hugin can use autopano-sift-C package to match images and
46enblend package for soft blending, so you'll probably want to install
47them too.
48
49%description -l pl.UTF-8
50Przy użyciu hugina można połączyć wiele fotografii w kompletną, dużą
51panoramę, skleić dowolny ciąg nakładających się zdjęć i wiele więcej.
52
53Hugin może używać pakietu autopano-sift-C do dopasowania zdjęć oraz
54pakiet enblend do wygładzenia krawędzi po łączeniu - więc warto te
55pakiety także zainstalować.
56
57%prep
58%setup -q
59%patch0 -p1
60%patch1 -p0
61
62mv -f src/translations/{ca_ES,ca}.po
63mv -f src/translations/{cs_CZ,cs}.po
64
65%build
66install -d build
67cd build
68%cmake .. \
69 -DCMAKE_BUILD_TYPE=%{?debug:Debug}%{!?debug:None} \
70 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
71 -DCMAKE_VERBOSE_MAKEFILE=ON \
72%if "%{_lib}" == "lib64"
73 -DLIB_SUFFIX=64 \
74%endif
75 -DwxWidgets_CONFIG_EXECUTABLE=%{_bindir}/wx-gtk2-unicode-config
76
77%{__make}
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
82%{__make} -C build install \
83 DESTDIR=$RPM_BUILD_ROOT
84
85# cmake is so great there is no way to pass proper path
86mv $RPM_BUILD_ROOT%{_iconsdir}/{gnome,hicolor}
87
88%find_lang %{name}
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post -p /sbin/ldconfig
94%postun -p /sbin/ldconfig
95
96%files -f %{name}.lang
97%defattr(644,root,root,755)
98%doc AUTHORS ChangeLog LICENCE_VIGRA README TODO
99%lang(ja) %doc README_JP
100%attr(755,root,root) %{_bindir}/PTBatcher
101%attr(755,root,root) %{_bindir}/PTBatcherGUI
102%attr(755,root,root) %{_bindir}/align_image_stack
103%attr(755,root,root) %{_bindir}/autooptimiser
104%attr(755,root,root) %{_bindir}/autopano-noop.sh
105%attr(755,root,root) %{_bindir}/calibrate_lens_gui
106%attr(755,root,root) %{_bindir}/celeste_standalone
107%attr(755,root,root) %{_bindir}/checkpto
108%attr(755,root,root) %{_bindir}/cpclean
109%attr(755,root,root) %{_bindir}/cpfind
110%attr(755,root,root) %{_bindir}/deghosting_mask
111%attr(755,root,root) %{_bindir}/fulla
112%attr(755,root,root) %{_bindir}/hugin
113%attr(755,root,root) %{_bindir}/hugin_hdrmerge
114%attr(755,root,root) %{_bindir}/hugin_stitch_project
115%attr(755,root,root) %{_bindir}/icpfind
116%attr(755,root,root) %{_bindir}/linefind
117%attr(755,root,root) %{_bindir}/matchpoint
118%attr(755,root,root) %{_bindir}/nona
119%attr(755,root,root) %{_bindir}/nona_gui
120%attr(755,root,root) %{_bindir}/pano_modify
121%attr(755,root,root) %{_bindir}/pano_trafo
122%attr(755,root,root) %{_bindir}/pto_merge
123%attr(755,root,root) %{_bindir}/pto2mk
124%attr(755,root,root) %{_bindir}/tca_correct
125%attr(755,root,root) %{_bindir}/vig_optimize
126%dir %{_libdir}/hugin
127%attr(755,root,root) %{_libdir}/hugin/libceleste.so.*.*
128%attr(755,root,root) %{_libdir}/hugin/libflann_cpp.so.*.*
129%attr(755,root,root) %{_libdir}/hugin/libhuginbase.so.*.*
130%attr(755,root,root) %{_libdir}/hugin/libhuginbasewx.so.*.*
131%attr(755,root,root) %{_libdir}/hugin/libhuginlines.so.*.*
132%attr(755,root,root) %{_libdir}/hugin/libhuginvigraimpex.so.*.*
133%attr(755,root,root) %{_libdir}/hugin/libicpfindlib.so.*.*
134%attr(755,root,root) %{_libdir}/hugin/liblocalfeatures.so.*.*
135%attr(755,root,root) %{_libdir}/hugin/libmakefilelib.so.*.*
136%{_datadir}/%{name}
137%{_datadir}/mime/packages/hugin.xml
138%{_desktopdir}/hugin.desktop
139%{_desktopdir}/PTBatcherGUI.desktop
140%{_desktopdir}/calibrate_lens_gui.desktop
141%{_iconsdir}/hicolor/*/mimetypes/gnome-mime-application-x-ptoptimizer-script.png
142%{_pixmapsdir}/hugin.png
143%{_pixmapsdir}/ptbatcher.png
144%{_mandir}/man1/PTBatcher.1*
145%{_mandir}/man1/PTBatcherGUI.1*
146%{_mandir}/man1/align_image_stack.1*
147%{_mandir}/man1/autooptimiser.1*
148%{_mandir}/man1/autopano-noop.sh.1*
149%{_mandir}/man1/calibrate_lens_gui.1*
150%{_mandir}/man1/celeste_standalone.1*
151%{_mandir}/man1/checkpto.1*
152%{_mandir}/man1/cpclean.1*
153%{_mandir}/man1/cpfind.1*
154%{_mandir}/man1/deghosting_mask.1*
155%{_mandir}/man1/fulla.1*
156%{_mandir}/man1/hugin.1*
157%{_mandir}/man1/hugin_hdrmerge.1*
158%{_mandir}/man1/hugin_stitch_project.1*
159%{_mandir}/man1/icpfind.1*
160%{_mandir}/man1/linefind.1*
161%{_mandir}/man1/matchpoint.1*
162%{_mandir}/man1/nona.1*
163%{_mandir}/man1/nona_gui.1*
164%{_mandir}/man1/pano_modify.1*
165%{_mandir}/man1/pano_trafo.1*
166%{_mandir}/man1/pto2mk.1*
167%{_mandir}/man1/pto_merge.1*
168%{_mandir}/man1/tca_correct.1*
169%{_mandir}/man1/vig_optimize.1*
This page took 0.065694 seconds and 4 git commands to generate.