]> git.pld-linux.org Git - packages/hiredis.git/blobdiff - link.patch
- adjusted link patch to fix soname and use (preferred) direct and .so symlink
[packages/hiredis.git] / link.patch
index 8ae7bd56102ad0fd321ef2a6b9a5eff1aa5017eb..dd6effede112b2506296b3f73463a0602ce0785f 100644 (file)
@@ -1,5 +1,14 @@
 --- hiredis-0.11.0/Makefile.orig       2013-12-12 17:28:25.817204756 +0100
 +++ hiredis-0.11.0/Makefile    2013-12-12 17:33:18.150525821 +0100
+@@ -23,7 +23,7 @@
+ DYLIB_MINOR_NAME=$(LIBNAME).$(DYLIBSUFFIX).$(HIREDIS_MAJOR).$(HIREDIS_MINOR)
+ DYLIB_MAJOR_NAME=$(LIBNAME).$(DYLIBSUFFIX).$(HIREDIS_MAJOR)
+ DYLIBNAME=$(LIBNAME).$(DYLIBSUFFIX)
+-DYLIB_MAKE_CMD=$(CC) -shared -Wl,-soname,$(DYLIB_MINOR_NAME) -o $(DYLIBNAME) $(LDFLAGS)
++DYLIB_MAKE_CMD=$(CC) -shared -Wl,-soname,$(DYLIB_MAJOR_NAME) -o $(DYLIBNAME) $(LDFLAGS)
+ STLIBNAME=$(LIBNAME).$(STLIBSUFFIX)
+ STLIB_MAKE_CMD=ar rcs $(STLIBNAME)
 @@ -76,8 +76,8 @@
        $(CC) -o $@ $(REAL_CFLAGS) $(REAL_LDFLAGS) -I$(AE_DIR) $(AE_DIR)/ae.o $(AE_DIR)/zmalloc.o example-ae.c $(STLIBNAME)
  endif
  
  test: hiredis-test
        ./hiredis-test
+@@ -121,7 +121,7 @@
+       $(INSTALL) hiredis.h async.h adapters $(INSTALL_INCLUDE_PATH)
+       $(INSTALL) $(DYLIBNAME) $(INSTALL_LIBRARY_PATH)/$(DYLIB_MINOR_NAME)
+       cd $(INSTALL_LIBRARY_PATH) && ln -sf $(DYLIB_MINOR_NAME) $(DYLIB_MAJOR_NAME)
+-      cd $(INSTALL_LIBRARY_PATH) && ln -sf $(DYLIB_MAJOR_NAME) $(DYLIBNAME)
++      cd $(INSTALL_LIBRARY_PATH) && ln -sf $(DYLIB_MINOR_NAME) $(DYLIBNAME)
+       $(INSTALL) $(STLIBNAME) $(INSTALL_LIBRARY_PATH)
+ 32bit:
This page took 0.089767 seconds and 4 git commands to generate.