]> git.pld-linux.org Git - packages/hiredis.git/blobdiff - link.patch
- new URLs, updated to 0.11.0
[packages/hiredis.git] / link.patch
index 62a1a15a2b673a4684c4568505d306e7b57f5e3d..8ae7bd56102ad0fd321ef2a6b9a5eff1aa5017eb 100644 (file)
@@ -1,36 +1,13 @@
---- hiredis-0.10.0/Makefile    2011-12-20 16:34:25.025574337 +0200
-+++ hiredis-0.10.0/Makefile    2011-12-20 16:38:47.294352952 +0200
-@@ -37,7 +37,9 @@
-   DYLIBSUFFIX=so
-   STLIBSUFFIX=a
-   DYLIBNAME?=$(LIBNAME).$(DYLIBSUFFIX)
--  DYLIB_MAKE_CMD?=gcc -shared -Wl,-soname,$(DYLIBNAME) -o $(DYLIBNAME)
-+  DYLIBSONAME?=$(DYLIBNAME).0
-+  LINKLIBNAME?=$(subst lib,,$(LIBNAME))
-+  DYLIB_MAKE_CMD?=$(CC) -shared -Wl,-soname,$(DYLIBSONAME) -o $(DYLIBNAME)
-   STLIBNAME?=$(LIBNAME).$(STLIBSUFFIX)
-   STLIB_MAKE_CMD?=ar rcs $(STLIBNAME)
- endif
-@@ -88,8 +90,8 @@
-       $(CC) -o $@ $(CCOPT) $(DEBUG) -I$(AE_DIR) $(LDFLAGS) $(STLIBNAME) example-ae.c $(AE_DIR)/ae.o $(AE_DIR)/zmalloc.o
+--- hiredis-0.11.0/Makefile.orig       2013-12-12 17:28:25.817204756 +0100
++++ hiredis-0.11.0/Makefile    2013-12-12 17:33:18.150525821 +0100
+@@ -76,8 +76,8 @@
+       $(CC) -o $@ $(REAL_CFLAGS) $(REAL_LDFLAGS) -I$(AE_DIR) $(AE_DIR)/ae.o $(AE_DIR)/zmalloc.o example-ae.c $(STLIBNAME)
  endif
  
 -hiredis-%: %.o $(STLIBNAME)
--      $(CC) -o $@ $(CCOPT) $(DEBUG) $(LDFLAGS) $(STLIBNAME) $<
+-      $(CC) -o $@ $(REAL_LDFLAGS) $< $(STLIBNAME)
 +hiredis-%: %.o $(DYLIBNAME)
-+      $(CC) -o $@ $(CCOPT) $(DEBUG) -l$(LINKLIBNAME) $(LDFLAGS) $<
++      $(CC) -o $@ $(REAL_LDFLAGS) $< -l$(subst lib,,$(LIBNAME))
  
  test: hiredis-test
        ./hiredis-test
-@@ -106,7 +108,10 @@
- install: $(DYLIBNAME) $(STLIBNAME)
-       mkdir -p $(INSTALL_INCLUDE_PATH) $(INSTALL_LIBRARY_PATH)
-       $(INSTALL) hiredis.h async.h adapters $(INSTALL_INCLUDE_PATH)
--      $(INSTALL) $(DYLIBNAME) $(STLIBNAME) $(INSTALL_LIBRARY_PATH)
-+      $(INSTALL) $(STLIBNAME) $(INSTALL_LIBRARY_PATH)
-+      $(INSTALL) $(DYLIBNAME) $(INSTALL_LIBRARY_PATH)/$(DYLIBNAME).0.0.0
-+      ln -s $(DYLIBNAME).0.0.0 $(INSTALL_LIBRARY_PATH)/$(DYLIBNAME).0
-+      ln -s $(DYLIBNAME).0.0.0 $(INSTALL_LIBRARY_PATH)/$(DYLIBNAME)
- 32bit:
-       @echo ""
This page took 0.05198 seconds and 4 git commands to generate.