]> git.pld-linux.org Git - packages/highway.git/blame - highway.spec
- use system gtest
[packages/highway.git] / highway.spec
CommitLineData
a15f1265
JB
1#
2# Conditional build:
3%bcond_without apidocs # API documentation
4#
5Summary: Efficient and performance-portable SIMD
6Summary(pl.UTF-8): Wydajne i przenośne operacje SIMD
7Name: highway
8Version: 0.14.2
9Release: 1
10License: Apache v2.0
11Group: Libraries
12#Source0Download: https://github.com/google/highway/releases
13Source0: https://github.com/google/highway/archive/%{version}/%{name}-%{version}.tar.gz
14# Source0-md5: 4821b1064a35baa24ea36994c0d58c41
15URL: https://github.com/google/highway
16BuildRequires: cmake >= 3.10
8564459d 17BuildRequires: gtest-devel
a15f1265
JB
18BuildRequires: libstdc++-devel >= 6:4.7
19BuildRequires: rpm-build >= 4.6
20BuildRequires: rpmbuild(macros) >= 1.605
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24Highway is a C++ library for SIMD (Single Instruction, Multiple Data),
25i.e. applying the same operation to multiple 'lanes' using a single
26CPU instruction.
27
28%description -l pl.UTF-8
29Highway to biblioteka C++ do operacji SIMD (Single Instruction,
30Multiple Data), czyli wykonywania tej samej operacji na wielu "pasach"
31przy użyciu pojedynczej instrukcji procesora.
32
33%package devel
34Summary: Development files for Highway library
35Summary(pl.UTF-8): Pliki programistyczne biblioteki Highway
36Group: Development/Libraries
37
38%description devel
39Development files for Highway library.
40
41%description devel -l pl.UTF-8
42Pliki programistyczne biblioteki Highway.
43
44%package apidocs
45Summary: API documentation for Highway library
46Summary(pl.UTF-8): Dokumentacja API biblioteki Highway
47Group: Documentation
48BuildArch: noarch
49
50%description apidocs
51API documentation for Highway library.
52
53%description apidocs -l pl.UTF-8
54Dokumentacja API biblioteki Highway.
55
56%prep
57%setup -q
58
59%build
60install -d build
61cd build
62%cmake .. \
63 -DCMAKE_INSTALL_INCLUDEDIR=include \
8564459d
JB
64 -DCMAKE_INSTALL_LIBDIR=%{_lib} \
65 -DHWY_SYSTEM_GTEST=ON
a15f1265
JB
66
67%{__make}
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72%{__make} -C build install \
73 DESTDIR=$RPM_BUILD_ROOT
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%files devel
79%defattr(644,root,root,755)
80%doc README.md
81%{_libdir}/libhwy.a
82%{_libdir}/libhwy_contrib.a
83%{_includedir}/hwy
84%{_pkgconfigdir}/libhwy.pc
85%{_pkgconfigdir}/libhwy-contrib.pc
86%{_pkgconfigdir}/libhwy-test.pc
87
88%if %{with apidocs}
89%files apidocs
90%defattr(644,root,root,755)
91%doc g3doc/*.{md,pdf}
92%endif
This page took 0.085586 seconds and 4 git commands to generate.