]> git.pld-linux.org Git - packages/harfbuzz.git/commitdiff
- updated to 0.9.18 auto/th/harfbuzz-0.9.18-1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 6 Jun 2013 06:30:24 +0000 (08:30 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 6 Jun 2013 06:30:24 +0000 (08:30 +0200)
- icu integration (now built as separate library) moved to subpackages

harfbuzz.spec

index afd53095453e7fc2238001492750a82a4e8e6823..16da479e1b6831cd6e264c9fbaea6b47d8c6f116 100644 (file)
@@ -1,25 +1,28 @@
 #
 # Conditional build:
-%bcond_without static_libs     # don't build static libraries
+%bcond_without static_libs     # static libraries build
+%bcond_without graphite2       # Graphite2 library usage
+%bcond_without icu             # ICU integration
 #
 Summary:       HarfBuzz - internationalized text shaping library
 Summary(pl.UTF-8):     HarfBuzz - biblioteka rysująca tekst z obsługą wielu języków
 Name:          harfbuzz
-Version:       0.9.17
+Version:       0.9.18
 Release:       1
 License:       MIT
 Group:         Libraries
 Source0:       http://www.freedesktop.org/software/harfbuzz/release/%{name}-%{version}.tar.bz2
-# Source0-md5: c48827713e93539dc7285f9e86ffbdc5
+# Source0-md5: 0bff05fafef4894031b2b64a65ac1899
 URL:           http://www.freedesktop.org/wiki/HarfBuzz
 BuildRequires: cairo-devel >= 1.8.0
 BuildRequires: freetype-devel >= 2.3.8
 BuildRequires: glib2-devel >= 1:2.16
-BuildRequires: graphite2-devel
-BuildRequires: libicu-devel
+%{?with_graphite2:BuildRequires:       graphite2-devel}
+%{?with_icu:BuildRequires:     libicu-devel}
 BuildRequires: libstdc++-devel
 BuildRequires: pkgconfig >= 1:0.20
 Requires:      cairo >= 1.8.0
+Requires:      freetype >= 2.3.8
 Requires:      glib2 >= 1:2.16
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -37,8 +40,7 @@ Group:                Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      freetype-devel >= 2.3.8
 Requires:      glib2-devel >= 1:2.16
-Requires:      graphite2-devel
-Requires:      libicu-devel
+%{?with_graphite2:Requires:    graphite2-devel}
 Requires:      libstdc++-devel
 
 %description devel
@@ -70,26 +72,67 @@ API and internal documentation for HarfBuzz library.
 %description apidocs -l pl.UTF-8
 Dokumentacja API biblioteki HarfBuzz.
 
+%package icu
+Summary:       HarfBuzz text shaping library - ICU integration
+Summary(pl.UTF-8):     Biblioteka HarfBuzz do rysowania tekstu - integracja z ICU
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description icu
+HarfBuzz text shaping library - ICU integration.
+
+%description icu -l pl.UTF-8
+Biblioteka HarfBuzz do rysowania tekstu - integracja z ICU.
+
+%package icu-devel
+Summary:       Header file for HarfBuzz ICU library
+Summary(pl.UTF-8):     Plik nagłówkowy biblioteki HarfBuzz ICU
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+Requires:      %{name}-icu = %{version}-%{release}
+Requires:      libicu-devel
+
+%description icu-devel
+Header file for HarfBuzz ICU library.
+
+%description icu-devel -l pl.UTF-8
+Plik nagłówkowy biblioteki HarfBuzz ICU.
+
+%package icu-static
+Summary:       Static HarfBuzz ICU library
+Summary(pl.UTF-8):     Biblioteka statyczna HarfBuzz ICU
+Group:         Development/Libraries
+Requires:      %{name}-icu-devel = %{version}-%{release}
+
+%description icu-static
+Static HarfBuzz ICU library.
+
+%description icu-static -l pl.UTF-8
+Biblioteka statyczna HarfBuzz ICU.
+
 %prep
 %setup -q
 
+# missing dependencies
+cat >> src/harfbuzz.pc.in <<EOF
+Requires.private: glib-2.0 gobject-2.0 freetype2%{?with_graphite2: graphite2}
+EOF
+
 %build
 %configure \
        --disable-silent-rules \
-       %{?with_static_libs:--enable-static}
+       %{?with_static_libs:--enable-static} \
+       --with-cairo \
+       --with-freetype \
+       --with-glib \
+       %{?with_graphite2:--with-graphite2} \
+       --with-icu%{!?with_icu:=no}
 %{__make}
 
-# missing
-cat >> harfbuzz.pc <<EOF
-Requires.private: glib-2.0 gobject-2.0 icu-le icu-uc freetype2 graphite2
-EOF
-
 %install
 rm -rf $RPM_BUILD_ROOT
 
-# parallel install broken (hb-version.h both in pkginclude_HEADERS and
-# nodist_pkginclude_HEADERS)
-%{__make} -j1 install \
+%{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
@@ -100,9 +143,12 @@ rm -rf $RPM_BUILD_ROOT
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
+%post  icu -p /sbin/ldconfig
+%postun        icu -p /sbin/ldconfig
+
 %files
 %defattr(644,root,root,755)
-%doc COPYING ChangeLog README TODO
+%doc AUTHORS COPYING ChangeLog NEWS README THANKS TODO
 %attr(755,root,root) %{_bindir}/hb-ot-shape-closure
 %attr(755,root,root) %{_bindir}/hb-shape
 %attr(755,root,root) %{_bindir}/hb-view
@@ -112,7 +158,24 @@ rm -rf $RPM_BUILD_ROOT
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libharfbuzz.so
-%{_includedir}/harfbuzz
+%dir %{_includedir}/harfbuzz
+%{_includedir}/harfbuzz/hb.h
+%{_includedir}/harfbuzz/hb-blob.h
+%{_includedir}/harfbuzz/hb-buffer.h
+%{_includedir}/harfbuzz/hb-common.h
+%{_includedir}/harfbuzz/hb-font.h
+%{_includedir}/harfbuzz/hb-ft.h
+%{_includedir}/harfbuzz/hb-glib.h
+%{_includedir}/harfbuzz/hb-gobject.h
+%{?with_graphite2:%{_includedir}/harfbuzz/hb-graphite2.h}
+%{_includedir}/harfbuzz/hb-ot-layout.h
+%{_includedir}/harfbuzz/hb-ot-tag.h
+%{_includedir}/harfbuzz/hb-ot.h
+%{_includedir}/harfbuzz/hb-set.h
+%{_includedir}/harfbuzz/hb-shape-plan.h
+%{_includedir}/harfbuzz/hb-shape.h
+%{_includedir}/harfbuzz/hb-unicode.h
+%{_includedir}/harfbuzz/hb-version.h
 %{_pkgconfigdir}/harfbuzz.pc
 
 %if %{with static_libs}
@@ -120,3 +183,22 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libharfbuzz.a
 %endif
+
+%if %{with icu}
+%files icu
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libharfbuzz-icu.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libharfbuzz-icu.so.0
+
+%files icu-devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libharfbuzz-icu.so
+%{_includedir}/harfbuzz/hb-icu.h
+%{_pkgconfigdir}/harfbuzz-icu.pc
+
+%if %{with static_libs}
+%files icu-static
+%defattr(644,root,root,755)
+%{_libdir}/libharfbuzz-icu.a
+%endif
+%endif
This page took 0.285771 seconds and 4 git commands to generate.