]> git.pld-linux.org Git - packages/harfbuzz.git/blob - harfbuzz.spec
- updated to 0.9.19
[packages/harfbuzz.git] / harfbuzz.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static libraries build
4 %bcond_without  graphite2       # Graphite2 library usage
5 %bcond_without  icu             # ICU integration
6 #
7 Summary:        HarfBuzz - internationalized text shaping library
8 Summary(pl.UTF-8):      HarfBuzz - biblioteka rysująca tekst z obsługą wielu języków
9 Name:           harfbuzz
10 Version:        0.9.19
11 Release:        1
12 License:        MIT
13 Group:          Libraries
14 Source0:        http://www.freedesktop.org/software/harfbuzz/release/%{name}-%{version}.tar.bz2
15 # Source0-md5:  9782581ee6ef972554772e84ca448131
16 URL:            http://www.freedesktop.org/wiki/HarfBuzz
17 BuildRequires:  cairo-devel >= 1.8.0
18 BuildRequires:  freetype-devel >= 2.3.8
19 BuildRequires:  glib2-devel >= 1:2.16
20 %{?with_graphite2:BuildRequires:        graphite2-devel}
21 %{?with_icu:BuildRequires:      libicu-devel}
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  pkgconfig >= 1:0.20
24 Requires:       cairo >= 1.8.0
25 Requires:       freetype >= 2.3.8
26 Requires:       glib2 >= 1:2.16
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Internationalized OpenType text layout and rendering library.
31
32 %description -l pl.UTF-8
33 Biblioteka rozmieszczająca i rysująca tekst z fontów OpenType,
34 obsługująca wiele języków.
35
36 %package devel
37 Summary:        Header files for HarfBuzz library
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki HarfBuzz
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41 Requires:       freetype-devel >= 2.3.8
42 Requires:       glib2-devel >= 1:2.16
43 %{?with_graphite2:Requires:     graphite2-devel}
44 Requires:       libstdc++-devel
45
46 %description devel
47 Header files for HarfBuzz library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki HarfBuzz.
51
52 %package static
53 Summary:        Static HarfBuzz library
54 Summary(pl.UTF-8):      Statyczna biblioteka HarfBuzz
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static HarfBuzz library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka HarfBuzz.
63
64 %package apidocs
65 Summary:        HarfBuzz API documentation
66 Summary(pl.UTF-8):      Dokumentacja API biblioteki HarfBuzz
67 Group:          Documentation
68
69 %description apidocs
70 API and internal documentation for HarfBuzz library.
71
72 %description apidocs -l pl.UTF-8
73 Dokumentacja API biblioteki HarfBuzz.
74
75 %package icu
76 Summary:        HarfBuzz text shaping library - ICU integration
77 Summary(pl.UTF-8):      Biblioteka HarfBuzz do rysowania tekstu - integracja z ICU
78 Group:          Libraries
79 Requires:       %{name} = %{version}-%{release}
80
81 %description icu
82 HarfBuzz text shaping library - ICU integration.
83
84 %description icu -l pl.UTF-8
85 Biblioteka HarfBuzz do rysowania tekstu - integracja z ICU.
86
87 %package icu-devel
88 Summary:        Header file for HarfBuzz ICU library
89 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki HarfBuzz ICU
90 Group:          Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92 Requires:       %{name}-icu = %{version}-%{release}
93 Requires:       libicu-devel
94
95 %description icu-devel
96 Header file for HarfBuzz ICU library.
97
98 %description icu-devel -l pl.UTF-8
99 Plik nagłówkowy biblioteki HarfBuzz ICU.
100
101 %package icu-static
102 Summary:        Static HarfBuzz ICU library
103 Summary(pl.UTF-8):      Biblioteka statyczna HarfBuzz ICU
104 Group:          Development/Libraries
105 Requires:       %{name}-icu-devel = %{version}-%{release}
106
107 %description icu-static
108 Static HarfBuzz ICU library.
109
110 %description icu-static -l pl.UTF-8
111 Biblioteka statyczna HarfBuzz ICU.
112
113 %prep
114 %setup -q
115
116 # missing dependencies
117 cat >> src/harfbuzz.pc.in <<EOF
118 Requires.private: glib-2.0 gobject-2.0 freetype2%{?with_graphite2: graphite2}
119 EOF
120
121 %build
122 %configure \
123         --disable-silent-rules \
124         %{?with_static_libs:--enable-static} \
125         --with-cairo \
126         --with-freetype \
127         --with-glib \
128         %{?with_graphite2:--with-graphite2} \
129         --with-icu%{!?with_icu:=no}
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %post   icu -p /sbin/ldconfig
147 %postun icu -p /sbin/ldconfig
148
149 %files
150 %defattr(644,root,root,755)
151 %doc AUTHORS COPYING ChangeLog NEWS README THANKS TODO
152 %attr(755,root,root) %{_bindir}/hb-ot-shape-closure
153 %attr(755,root,root) %{_bindir}/hb-shape
154 %attr(755,root,root) %{_bindir}/hb-view
155 %attr(755,root,root) %{_libdir}/libharfbuzz.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libharfbuzz.so.0
157
158 %files devel
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/libharfbuzz.so
161 %dir %{_includedir}/harfbuzz
162 %{_includedir}/harfbuzz/hb.h
163 %{_includedir}/harfbuzz/hb-blob.h
164 %{_includedir}/harfbuzz/hb-buffer.h
165 %{_includedir}/harfbuzz/hb-common.h
166 %{_includedir}/harfbuzz/hb-font.h
167 %{_includedir}/harfbuzz/hb-ft.h
168 %{_includedir}/harfbuzz/hb-glib.h
169 %{_includedir}/harfbuzz/hb-gobject.h
170 %{?with_graphite2:%{_includedir}/harfbuzz/hb-graphite2.h}
171 %{_includedir}/harfbuzz/hb-ot-layout.h
172 %{_includedir}/harfbuzz/hb-ot-tag.h
173 %{_includedir}/harfbuzz/hb-ot.h
174 %{_includedir}/harfbuzz/hb-set.h
175 %{_includedir}/harfbuzz/hb-shape-plan.h
176 %{_includedir}/harfbuzz/hb-shape.h
177 %{_includedir}/harfbuzz/hb-unicode.h
178 %{_includedir}/harfbuzz/hb-version.h
179 %{_pkgconfigdir}/harfbuzz.pc
180
181 %if %{with static_libs}
182 %files static
183 %defattr(644,root,root,755)
184 %{_libdir}/libharfbuzz.a
185 %endif
186
187 %if %{with icu}
188 %files icu
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/libharfbuzz-icu.so.*.*.*
191 %attr(755,root,root) %ghost %{_libdir}/libharfbuzz-icu.so.0
192
193 %files icu-devel
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_libdir}/libharfbuzz-icu.so
196 %{_includedir}/harfbuzz/hb-icu.h
197 %{_pkgconfigdir}/harfbuzz-icu.pc
198
199 %if %{with static_libs}
200 %files icu-static
201 %defattr(644,root,root,755)
202 %{_libdir}/libharfbuzz-icu.a
203 %endif
204 %endif
This page took 0.089805 seconds and 4 git commands to generate.