]> git.pld-linux.org Git - packages/gxml.git/commitdiff
- updated to 0.14.0 (new library name) auto/th/gxml-0.14.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 16 Mar 2017 20:31:58 +0000 (21:31 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 16 Mar 2017 20:31:58 +0000 (21:31 +0100)
- updated normalize patch

gxml-normalize.patch
gxml.spec

index 6022abf43214862a4d08317333b204c2523a9036..85f44c32fa7418fd11ddee83896fd485e8227718 100644 (file)
@@ -1,11 +1,11 @@
---- gxml-0.10.0/vapi/xlibxml-1.0.vapi.orig     2016-01-30 04:42:43.000000000 +0100
-+++ gxml-0.10.0/vapi/xlibxml-1.0.vapi  2016-09-24 19:51:01.573335825 +0200
+--- gxml-0.14.0/vapi/xlibxml-1.0.vapi.orig     2017-03-15 21:27:43.639306478 +0100
++++ gxml-0.14.0/vapi/xlibxml-1.0.vapi  2017-03-15 21:31:53.455970292 +0100
 @@ -28,7 +28,7 @@
  namespace Xmlx {
    [CCode (cname = "gxml_doc_get_intsubset_entities", cheader_filename = "gxml/xlibxml.h")]
    public static Xml.HashTable doc_get_dtd_entities (Xml.Doc *doc);
 -  [CCode (cname = "gxml_validate_name", cheader_filename = "gxml//xlibxml.h")]
 +  [CCode (cname = "gxml_validate_name", cheader_filename = "gxml/xlibxml.h")]
-   public static int validate_name (string name, int space);
+   public static int validate_name ([CCode (type = "xmlChar*")] string name, int space);
    [CCode (cname = "gxml_parser_context_get_last_error", cheader_filename = "gxml/xlibxml.h")]
-   [Deprecated (replacement = "context_get_last_error", since = "0.8.1")]
+   [Version (deprecated=true, replacement = "context_get_last_error", deprecated_since = "0.8.1")]
index 32c086ed4a102c4807a6ff06abb7e78333fce218..059229200f501abc8fec33ece61a050e852519c8 100644 (file)
--- a/gxml.spec
+++ b/gxml.spec
@@ -6,12 +6,12 @@
 Summary:       GXml - GObject API that wraps around libxml2
 Summary(pl.UTF-8):     GXml - API GObject obudowujÄ…ce libxml2
 Name:          gxml
-Version:       0.12.0
+Version:       0.14.0
 Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/gxml/0.12/%{name}-%{version}.tar.xz
-# Source0-md5: 203922473ca4c37dc7fef54b32764b91
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/gxml/0.14/%{name}-%{version}.tar.xz
+# Source0-md5: 70577a8d4c6610ed8cfda9a24e54c3b0
 Patch0:                %{name}-missing.patch
 Patch1:                %{name}-normalize.patch
 URL:           https://github.com/GNOME/gxml
@@ -100,6 +100,18 @@ Dokumentacja API biblioteki GXml.
 %patch0 -p1
 %patch1 -p1
 
+# missing file (or missing in makefile rules)
+install -d docs/valadoc/gtk-doc/gtk-doc/gxml/xml
+cat >>docs/valadoc/gtk-doc/gtk-doc/gxml/xml/gtkdocentities.ent <<EOF
+<!ENTITY package "gxml">
+<!ENTITY package_bugreport "">
+<!ENTITY package_name "gxml">
+<!ENTITY package_string "gxml %{version}">
+<!ENTITY package_tarname "gxml">
+<!ENTITY package_url "">
+<!ENTITY package_version "%{version}">
+EOF
+
 %build
 %{__intltoolize}
 %{__libtoolize}
@@ -108,11 +120,10 @@ Dokumentacja API biblioteki GXml.
 %{__autoheader}
 %{__automake}
 %configure \
+       %{!?with_apidocs:--disable-docs} \
        --disable-silent-rules \
-       %{?with_static_libs:--enable-static} \
-       %{?with_apidocs:--enable-docs --enable-gtk-docs --enable-valadoc}
-# --enable-devhelp-docs is almost the same as gtk-docs html, but built with valadoc(?) and installed to devhelp dirs
-# --enable-gir-docs ???
+       %{?with_static_libs:--enable-static}
+
 %{__make}
 
 %install
@@ -123,7 +134,7 @@ rm -rf $RPM_BUILD_ROOT
        gxmlgtkdocdir=%{_gtkdocdir}/gxml
 
 # obsoleted by pkg-config
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgxml-0.12.la
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgxml-0.14.la
 # packaged as %doc
 %{__rm} -r $RPM_BUILD_ROOT%{_prefix}/doc
 
@@ -131,6 +142,9 @@ rm -rf $RPM_BUILD_ROOT
 %{__rm} -r $RPM_BUILD_ROOT%{_gtkdocdir}/gxml/*.{bottom,top,stamp,txt,types,xml}
 cp -p docs/valadoc/gtk-doc/gtk-doc/gxml/html/* $RPM_BUILD_ROOT%{_gtkdocdir}/gxml
 
+# similar to gtk-doc?
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/devhelp
+
 # "GXml" gettext domain, "gxml" gnome help
 %find_lang GXml --with-gnome --all-name
 
@@ -143,27 +157,27 @@ rm -rf $RPM_BUILD_ROOT
 %files -f GXml.lang
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README
-%attr(755,root,root) %{_libdir}/libgxml-0.12.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libgxml-0.12.so.12
-%{_libdir}/girepository-1.0/GXml-0.12.typelib
+%attr(755,root,root) %{_libdir}/libgxml-0.14.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgxml-0.14.so.14
+%{_libdir}/girepository-1.0/GXml-0.14.typelib
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libgxml-0.12.so
-%{_includedir}/gxml-0.12
-%{_datadir}/gir-1.0/GXml-0.12.gir
-%{_pkgconfigdir}/gxml-0.12.pc
+%attr(755,root,root) %{_libdir}/libgxml-0.14.so
+%{_includedir}/gxml-0.14
+%{_datadir}/gir-1.0/GXml-0.14.gir
+%{_pkgconfigdir}/gxml-0.14.pc
 
 %if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/libgxml-0.12.a
+%{_libdir}/libgxml-0.14.a
 %endif
 
 %files -n vala-gxml
 %defattr(644,root,root,755)
-%{_datadir}/vala/vapi/gxml-0.12.deps
-%{_datadir}/vala/vapi/gxml-0.12.vapi
+%{_datadir}/vala/vapi/gxml-0.14.deps
+%{_datadir}/vala/vapi/gxml-0.14.vapi
 
 %if %{with apidocs}
 %files apidocs
This page took 0.139264 seconds and 4 git commands to generate.