]> git.pld-linux.org Git - packages/gtksourceview5.git/commitdiff
- updated to 4.4.0
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 6 Oct 2019 14:25:08 +0000 (16:25 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 6 Oct 2019 14:25:08 +0000 (16:25 +0200)
gtksourceview4.spec

index 0d4facd0e91a880b1d48fece95ce05697edf1e20..f324b627e52738db0c6c7efd25d7e39421cf6669 100644 (file)
@@ -1,40 +1,43 @@
 #
 # Conditional build:
-%bcond_with    glade   # install glade catalog
-%bcond_without vala    # do not build Vala API
+%bcond_without apidocs         # API documentation
+%bcond_with    glade           # install glade catalog
+%bcond_without static_libs     # static library
+%bcond_without vala            # do not build Vala API
 
 Summary:       Text widget that extends the standard GTK+ 3.x
 Summary(pl.UTF-8):     Widget tekstowy rozszerzający standardowy z GTK+ 3.x
 Name:          gtksourceview4
-Version:       4.2.0
+Version:       4.4.0
 Release:       1
 License:       LGPL v2+ (library), GPL v2+ (some language specs files)
 Group:         X11/Libraries
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/gtksourceview/4.2/gtksourceview-%{version}.tar.xz
-# Source0-md5: c9e6913c2fd30ca2fcdd71482faf8b99
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/gtksourceview/4.4/gtksourceview-%{version}.tar.xz
+# Source0-md5: 5c47e314517692f2622a0b724c65e628
 URL:           https://wiki.gnome.org/Projects/GtkSourceView
-BuildRequires: autoconf >= 2.64
-BuildRequires: autoconf-archive >= 2015.09.25
-BuildRequires: automake >= 1:1.13
 BuildRequires: docbook-dtd412-xml
+BuildRequires: fribidi-devel >= 0.19.7
 BuildRequires: gettext-tools >= 0.19.4
 BuildRequires: glib2-devel >= 1:2.48.0
 BuildRequires: gobject-introspection-devel >= 1.42.0
-BuildRequires: gtk+3-devel >= 3.20
-BuildRequires: gtk-doc >= 1.25
+BuildRequires: gtk+3-devel >= 3.22
+%{?with_apidocs:BuildRequires: gtk-doc >= 1.25}
 BuildRequires: itstool
 %if %{with glade}
 BuildRequires: libgladeui-devel >= 3.9.0
 %endif
-BuildRequires: libtool >= 2:2.2.6
 BuildRequires: libxml2-devel >= 1:2.6.31
+BuildRequires: meson >= 0.49.0
+BuildRequires: ninja >= 1.5
 BuildRequires: pkgconfig
 BuildRequires: rpm-pythonprov
+BuildRequires: sed >= 4.0
 BuildRequires: tar >= 1:1.22
 BuildRequires: vala
 BuildRequires: xz
+Requires:      fribidi >= 0.19.7
 Requires:      glib2 >= 1:2.48.0
-Requires:      gtk+3 >= 3.20
+Requires:      gtk+3 >= 3.22
 Requires:      libxml2 >= 1:2.6.31
 # sr@Latn vs. sr@latin
 Conflicts:     glibc-misc < 6:2.7
@@ -51,28 +54,14 @@ tekstowy GtkTextView z GTK+ 3.x. Ulepsza GtkTextView poprzez
 zaimplementowanie podświetlania składni i innych możliwości typowych
 dla edytora źródeł.
 
-%package apidocs
-Summary:       GtkSourceView API documentation
-Summary(pl.UTF-8):     Dokumentacja API GtkSourceView
-Group:         Documentation
-Requires:      gtk-doc-common
-%if "%{_rpmversion}" >= "5"
-BuildArch:     noarch
-%endif
-
-%description apidocs
-GtkSourceView API documentation.
-
-%description apidocs -l pl.UTF-8
-Dokumentacja API GtkSourceView.
-
 %package devel
 Summary:       Header files for GtkSourceView
 Summary(pl.UTF-8):     Pliki nagłówkowe dla GtkSourceView
 Group:         X11/Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      fribidi-devel >= 0.19.7
 Requires:      glib2-devel >= 1:2.48.0
-Requires:      gtk+3-devel >= 3.20
+Requires:      gtk+3-devel >= 3.22
 Requires:      libxml2-devel >= 1:2.6.31
 
 %description devel
@@ -93,6 +82,21 @@ Static GtkSourceView library.
 %description static -l pl.UTF-8
 Statyczna biblioteka GtkSourceView.
 
+%package apidocs
+Summary:       GtkSourceView API documentation
+Summary(pl.UTF-8):     Dokumentacja API GtkSourceView
+Group:         Documentation
+Requires:      gtk-doc-common
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
+
+%description apidocs
+GtkSourceView API documentation.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API GtkSourceView.
+
 %package -n glade3-gtksourceview
 Summary:       Glade3 catalog entry for GtkSourceView library
 Summary(pl.UTF-8):     Wpis katalogu Glade3 dla biblioteki GtkSourceView
@@ -125,31 +129,21 @@ API GtkSourceView dla języka Vala.
 %prep
 %setup -q -n gtksourceview-%{version}
 
-# force new version from autoconf-archive (original one uses non-POSIX ${V:N} syntax)
-%{__rm} m4/ax_compiler_flags_cflags.m4
+%if %{with static_libs}
+%{__sed} -i -e 's/gtksource_lib = shared_library/gtksource_lib = library/' gtksourceview/meson.build
+%endif
 
 %build
-%{__gtkdocize}
-%{__libtoolize}
-%{__aclocal} -I m4
-%{__autoconf}
-%{__autoheader}
-%{__automake}
-%configure \
-       %{__enable glade glade-catalog} \
-       --enable-gtk-doc \
-       --disable-silent-rules \
-       --enable-static \
-       --with-html-dir=%{_gtkdocdir}
-%{__make}
+%meson build \
+       %{?with_glade:-Dglade_catalog=true} \
+       %{?with_apidocs:-Dgtk_doc=true}
+
+%ninja_build -C build
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
-
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
+%ninja_install -C build
 
 %find_lang gtksourceview-4
 
@@ -166,10 +160,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/gtksourceview-4
 %{_libdir}/girepository-1.0/GtkSource-4.typelib
 
-%files apidocs
-%defattr(644,root,root,755)
-%{_gtkdocdir}/gtksourceview-4.0
-
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libgtksourceview-4.so
@@ -181,6 +171,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libgtksourceview-4.a
 
+%if %{with apidocs}
+%files apidocs
+%defattr(644,root,root,755)
+%{_gtkdocdir}/gtksourceview-4.0
+%endif
+
 %if %{with glade}
 %files -n glade3-gtksourceview
 %defattr(644,root,root,755)
This page took 0.084615 seconds and 4 git commands to generate.