]> git.pld-linux.org Git - packages/gtksourceview5.git/blob - gtksourceview5.spec
e53cd010938b1e80995ddeb40bf78c61994432be
[packages/gtksourceview5.git] / gtksourceview5.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation (broken in 4.99)
4 %bcond_without  static_libs     # static library
5 %bcond_without  vala            # do not build Vala API
6
7 Summary:        Text widget that extends the standard GTK+ 3.x
8 Summary(pl.UTF-8):      Widget tekstowy rozszerzający standardowy z GTK+ 3.x
9 Name:           gtksourceview5
10 Version:        4.99.0
11 Release:        1
12 License:        LGPL v2+ (library), GPL v2+ (some language specs files)
13 Group:          X11/Libraries
14 Source0:        https://download.gnome.org/sources/gtksourceview/4.99/gtksourceview-%{version}.tar.xz
15 # Source0-md5:  7b7a6f74d2dc459b8687f9bf6ae13bfa
16 Patch0:         %{name}-meson.patch
17 URL:            https://wiki.gnome.org/Projects/GtkSourceView
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  fribidi-devel >= 0.19.7
20 BuildRequires:  gettext-tools >= 0.19.4
21 BuildRequires:  glib2-devel >= 1:2.62
22 BuildRequires:  gobject-introspection-devel >= 1.42.0
23 BuildRequires:  gtk4-devel >= 3.99
24 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.25}
25 BuildRequires:  itstool
26 BuildRequires:  libxml2-devel >= 1:2.6.31
27 BuildRequires:  meson >= 0.50.0
28 BuildRequires:  ninja >= 1.5
29 BuildRequires:  pcre2-8-devel >= 10.21
30 BuildRequires:  pkgconfig
31 BuildRequires:  rpm-build >= 4.6
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.736
34 BuildRequires:  sed >= 4.0
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  vala
37 BuildRequires:  xz
38 Requires:       fribidi >= 0.19.7
39 Requires:       glib2 >= 1:2.62
40 Requires:       gtk4 >= 3.99
41 Requires:       libxml2 >= 1:2.6.31
42 Requires:       pcre2-8 >= 10.21
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 GtkSourceView is a text widget that extends the standard GTK+ 3.x text
47 widget GtkTextView. It improves GtkTextView by implementing syntax
48 highlighting and other features typical of a source editor.
49
50 %description -l pl.UTF-8
51 GtkSourceView to widget tekstowy rozszerzający standardowy widget
52 tekstowy GtkTextView z GTK+ 3.x. Ulepsza GtkTextView poprzez
53 zaimplementowanie podświetlania składni i innych możliwości typowych
54 dla edytora źródeł.
55
56 %package devel
57 Summary:        Header files for GtkSourceView
58 Summary(pl.UTF-8):      Pliki nagłówkowe dla GtkSourceView
59 Group:          X11/Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       fribidi-devel >= 0.19.7
62 Requires:       glib2-devel >= 1:2.62
63 Requires:       gtk4-devel >= 3.99
64 Requires:       libxml2-devel >= 1:2.6.31
65 Requires:       pcre2-8-devel >= 10.21
66
67 %description devel
68 Header files for GtkSourceView.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe dla GtkSourceView.
72
73 %package static
74 Summary:        Static GtkSourceView library
75 Summary(pl.UTF-8):      Statyczna biblioteka GtkSourceView
76 Group:          X11/Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static GtkSourceView library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka GtkSourceView.
84
85 %package apidocs
86 Summary:        GtkSourceView API documentation
87 Summary(pl.UTF-8):      Dokumentacja API GtkSourceView
88 Group:          Documentation
89 Requires:       gtk-doc-common
90 BuildArch:      noarch
91
92 %description apidocs
93 GtkSourceView API documentation.
94
95 %description apidocs -l pl.UTF-8
96 Dokumentacja API GtkSourceView.
97
98 %package -n vala-gtksourceview5
99 Summary:        GtkSourceView API for Vala language
100 Summary(pl.UTF-8):      API GtkSourceView dla języka Vala
101 Group:          Development/Libraries
102 Requires:       %{name}-devel = %{version}-%{release}
103 Requires:       vala
104 BuildArch:      noarch
105
106 %description -n vala-gtksourceview5
107 GtkSourceView API for Vala language.
108
109 %description -n vala-gtksourceview5 -l pl.UTF-8
110 API GtkSourceView dla języka Vala.
111
112 %prep
113 %setup -q -n gtksourceview-%{version}
114 %patch0 -p1
115
116 %if %{with static_libs}
117 %{__sed} -i -e 's/gtksource_lib = shared_library/gtksource_lib = library/' gtksourceview/meson.build
118 %endif
119
120 %build
121 %meson build \
122         %{?with_apidocs:-Dgtk_doc=true}
123
124 %ninja_build -C build
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %ninja_install -C build
130
131 %find_lang gtksourceview-5
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post   -p /sbin/ldconfig
137 %postun -p /sbin/ldconfig
138
139 %files -f gtksourceview-5.lang
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libgtksourceview-5.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libgtksourceview-5.so.0
143 %{_datadir}/gtksourceview-5
144 %{_libdir}/girepository-1.0/GtkSource-5.typelib
145 %{_iconsdir}/hicolor/scalable/actions/completion-*-symbolic.svg
146 %{_iconsdir}/hicolor/scalable/actions/lang-*-symbolic.svg
147
148 %files devel
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_libdir}/libgtksourceview-5.so
151 %{_includedir}/gtksourceview-5
152 %{_pkgconfigdir}/gtksourceview-5.pc
153 %{_datadir}/gir-1.0/GtkSource-5.gir
154
155 %if %{with static_libs}
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/libgtksourceview-5.a
159 %endif
160
161 %if %{with apidocs}
162 %files apidocs
163 %defattr(644,root,root,755)
164 %{_gtkdocdir}/gtksourceview-5.0
165 %endif
166
167 %if %{with vala}
168 %files -n vala-gtksourceview5
169 %defattr(644,root,root,755)
170 %{_datadir}/vala/vapi/gtksourceview-5.deps
171 %{_datadir}/vala/vapi/gtksourceview-5.vapi
172 %endif
This page took 0.074852 seconds and 2 git commands to generate.