]> git.pld-linux.org Git - packages/gtksourceview5.git/blob - gtksourceview4.spec
f324b627e52738db0c6c7efd25d7e39421cf6669
[packages/gtksourceview5.git] / gtksourceview4.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_with     glade           # install glade catalog
5 %bcond_without  static_libs     # static library
6 %bcond_without  vala            # do not build Vala API
7
8 Summary:        Text widget that extends the standard GTK+ 3.x
9 Summary(pl.UTF-8):      Widget tekstowy rozszerzający standardowy z GTK+ 3.x
10 Name:           gtksourceview4
11 Version:        4.4.0
12 Release:        1
13 License:        LGPL v2+ (library), GPL v2+ (some language specs files)
14 Group:          X11/Libraries
15 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtksourceview/4.4/gtksourceview-%{version}.tar.xz
16 # Source0-md5:  5c47e314517692f2622a0b724c65e628
17 URL:            https://wiki.gnome.org/Projects/GtkSourceView
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  fribidi-devel >= 0.19.7
20 BuildRequires:  gettext-tools >= 0.19.4
21 BuildRequires:  glib2-devel >= 1:2.48.0
22 BuildRequires:  gobject-introspection-devel >= 1.42.0
23 BuildRequires:  gtk+3-devel >= 3.22
24 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.25}
25 BuildRequires:  itstool
26 %if %{with glade}
27 BuildRequires:  libgladeui-devel >= 3.9.0
28 %endif
29 BuildRequires:  libxml2-devel >= 1:2.6.31
30 BuildRequires:  meson >= 0.49.0
31 BuildRequires:  ninja >= 1.5
32 BuildRequires:  pkgconfig
33 BuildRequires:  rpm-pythonprov
34 BuildRequires:  sed >= 4.0
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  vala
37 BuildRequires:  xz
38 Requires:       fribidi >= 0.19.7
39 Requires:       glib2 >= 1:2.48.0
40 Requires:       gtk+3 >= 3.22
41 Requires:       libxml2 >= 1:2.6.31
42 # sr@Latn vs. sr@latin
43 Conflicts:      glibc-misc < 6:2.7
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 GtkSourceView is a text widget that extends the standard GTK+ 3.x text
48 widget GtkTextView. It improves GtkTextView by implementing syntax
49 highlighting and other features typical of a source editor.
50
51 %description -l pl.UTF-8
52 GtkSourceView to widget tekstowy rozszerzający standardowy widget
53 tekstowy GtkTextView z GTK+ 3.x. Ulepsza GtkTextView poprzez
54 zaimplementowanie podświetlania składni i innych możliwości typowych
55 dla edytora źródeł.
56
57 %package devel
58 Summary:        Header files for GtkSourceView
59 Summary(pl.UTF-8):      Pliki nagłówkowe dla GtkSourceView
60 Group:          X11/Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       fribidi-devel >= 0.19.7
63 Requires:       glib2-devel >= 1:2.48.0
64 Requires:       gtk+3-devel >= 3.22
65 Requires:       libxml2-devel >= 1:2.6.31
66
67 %description devel
68 Header files for GtkSourceView.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe dla GtkSourceView.
72
73 %package static
74 Summary:        Static GtkSourceView library
75 Summary(pl.UTF-8):      Statyczna biblioteka GtkSourceView
76 Group:          X11/Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static GtkSourceView library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka GtkSourceView.
84
85 %package apidocs
86 Summary:        GtkSourceView API documentation
87 Summary(pl.UTF-8):      Dokumentacja API GtkSourceView
88 Group:          Documentation
89 Requires:       gtk-doc-common
90 %if "%{_rpmversion}" >= "5"
91 BuildArch:      noarch
92 %endif
93
94 %description apidocs
95 GtkSourceView API documentation.
96
97 %description apidocs -l pl.UTF-8
98 Dokumentacja API GtkSourceView.
99
100 %package -n glade3-gtksourceview
101 Summary:        Glade3 catalog entry for GtkSourceView library
102 Summary(pl.UTF-8):      Wpis katalogu Glade3 dla biblioteki GtkSourceView
103 Group:          X11/Development/Libraries
104 Requires:       %{name}-devel = %{version}-%{release}
105 Requires:       libgladeui >= 3.9.0
106
107 %description -n glade3-gtksourceview
108 Glade3 catalog entry for GtkSourceView library.
109
110 %description -n glade3-gtksourceview -l pl.UTF-8
111 Wpis katalogu Glade3 dla biblioteki GtkSourceView.
112
113 %package -n vala-gtksourceview4
114 Summary:        GtkSourceView API for Vala language
115 Summary(pl.UTF-8):      API GtkSourceView dla języka Vala
116 Group:          Development/Libraries
117 Requires:       %{name}-devel = %{version}-%{release}
118 Requires:       vala
119 %if "%{_rpmversion}" >= "5"
120 BuildArch:      noarch
121 %endif
122
123 %description -n vala-gtksourceview4
124 GtkSourceView API for Vala language.
125
126 %description -n vala-gtksourceview4 -l pl.UTF-8
127 API GtkSourceView dla języka Vala.
128
129 %prep
130 %setup -q -n gtksourceview-%{version}
131
132 %if %{with static_libs}
133 %{__sed} -i -e 's/gtksource_lib = shared_library/gtksource_lib = library/' gtksourceview/meson.build
134 %endif
135
136 %build
137 %meson build \
138         %{?with_glade:-Dglade_catalog=true} \
139         %{?with_apidocs:-Dgtk_doc=true}
140
141 %ninja_build -C build
142
143 %install
144 rm -rf $RPM_BUILD_ROOT
145
146 %ninja_install -C build
147
148 %find_lang gtksourceview-4
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post   -p /sbin/ldconfig
154 %postun -p /sbin/ldconfig
155
156 %files -f gtksourceview-4.lang
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_libdir}/libgtksourceview-4.so.*.*.*
159 %attr(755,root,root) %ghost %{_libdir}/libgtksourceview-4.so.0
160 %{_datadir}/gtksourceview-4
161 %{_libdir}/girepository-1.0/GtkSource-4.typelib
162
163 %files devel
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_libdir}/libgtksourceview-4.so
166 %{_includedir}/gtksourceview-4
167 %{_pkgconfigdir}/gtksourceview-4.pc
168 %{_datadir}/gir-1.0/GtkSource-4.gir
169
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/libgtksourceview-4.a
173
174 %if %{with apidocs}
175 %files apidocs
176 %defattr(644,root,root,755)
177 %{_gtkdocdir}/gtksourceview-4.0
178 %endif
179
180 %if %{with glade}
181 %files -n glade3-gtksourceview
182 %defattr(644,root,root,755)
183 %{_datadir}/glade3/catalogs/gtksourceview.xml
184 %endif
185
186 %if %{with vala}
187 %files -n vala-gtksourceview4
188 %defattr(644,root,root,755)
189 %{_datadir}/vala/vapi/gtksourceview-4.deps
190 %{_datadir}/vala/vapi/gtksourceview-4.vapi
191 %endif
This page took 0.075912 seconds and 2 git commands to generate.