]> git.pld-linux.org Git - packages/gtksourceview5.git/blob - gtksourceview4.spec
a61bb71c57d7495051026d5177030785a01fbc8e
[packages/gtksourceview5.git] / gtksourceview4.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_with     glade           # install glade catalog
5 %bcond_without  static_libs     # static library
6 %bcond_without  vala            # do not build Vala API
7
8 Summary:        Text widget that extends the standard GTK+ 3.x
9 Summary(pl.UTF-8):      Widget tekstowy rozszerzający standardowy z GTK+ 3.x
10 Name:           gtksourceview4
11 Version:        4.8.1
12 Release:        1
13 License:        LGPL v2+ (library), GPL v2+ (some language specs files)
14 Group:          X11/Libraries
15 Source0:        https://download.gnome.org/sources/gtksourceview/4.8/gtksourceview-%{version}.tar.xz
16 # Source0-md5:  d10c624feb48412542f9e3447e75d6bc
17 URL:            https://wiki.gnome.org/Projects/GtkSourceView
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  fribidi-devel >= 0.19.7
20 BuildRequires:  gettext-tools >= 0.19.4
21 BuildRequires:  glib2-devel >= 1:2.48.0
22 BuildRequires:  gobject-introspection-devel >= 1.42.0
23 BuildRequires:  gtk+3-devel >= 3.24
24 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.25}
25 BuildRequires:  itstool
26 %if %{with glade}
27 BuildRequires:  libgladeui-devel >= 3.9.0
28 %endif
29 BuildRequires:  libxml2-devel >= 1:2.6.31
30 BuildRequires:  meson >= 0.50.0
31 BuildRequires:  ninja >= 1.5
32 BuildRequires:  pkgconfig
33 BuildRequires:  rpm-build >= 4.6
34 BuildRequires:  rpm-pythonprov
35 BuildRequires:  rpmbuild(macros) >= 1.736
36 BuildRequires:  sed >= 4.0
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  vala
39 BuildRequires:  xz
40 Requires:       fribidi >= 0.19.7
41 Requires:       glib2 >= 1:2.48.0
42 Requires:       gtk+3 >= 3.24
43 Requires:       libxml2 >= 1:2.6.31
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 GtkSourceView is a text widget that extends the standard GTK+ 3.x text
48 widget GtkTextView. It improves GtkTextView by implementing syntax
49 highlighting and other features typical of a source editor.
50
51 %description -l pl.UTF-8
52 GtkSourceView to widget tekstowy rozszerzający standardowy widget
53 tekstowy GtkTextView z GTK+ 3.x. Ulepsza GtkTextView poprzez
54 zaimplementowanie podświetlania składni i innych możliwości typowych
55 dla edytora źródeł.
56
57 %package devel
58 Summary:        Header files for GtkSourceView
59 Summary(pl.UTF-8):      Pliki nagłówkowe dla GtkSourceView
60 Group:          X11/Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       fribidi-devel >= 0.19.7
63 Requires:       glib2-devel >= 1:2.48.0
64 Requires:       gtk+3-devel >= 3.24
65 Requires:       libxml2-devel >= 1:2.6.31
66
67 %description devel
68 Header files for GtkSourceView.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe dla GtkSourceView.
72
73 %package static
74 Summary:        Static GtkSourceView library
75 Summary(pl.UTF-8):      Statyczna biblioteka GtkSourceView
76 Group:          X11/Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static GtkSourceView library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka GtkSourceView.
84
85 %package apidocs
86 Summary:        GtkSourceView API documentation
87 Summary(pl.UTF-8):      Dokumentacja API GtkSourceView
88 Group:          Documentation
89 Requires:       gtk-doc-common
90 BuildArch:      noarch
91
92 %description apidocs
93 GtkSourceView API documentation.
94
95 %description apidocs -l pl.UTF-8
96 Dokumentacja API GtkSourceView.
97
98 %package -n glade3-gtksourceview
99 Summary:        Glade3 catalog entry for GtkSourceView library
100 Summary(pl.UTF-8):      Wpis katalogu Glade3 dla biblioteki GtkSourceView
101 Group:          X11/Development/Libraries
102 Requires:       %{name}-devel = %{version}-%{release}
103 Requires:       libgladeui >= 3.9.0
104
105 %description -n glade3-gtksourceview
106 Glade3 catalog entry for GtkSourceView library.
107
108 %description -n glade3-gtksourceview -l pl.UTF-8
109 Wpis katalogu Glade3 dla biblioteki GtkSourceView.
110
111 %package -n vala-gtksourceview4
112 Summary:        GtkSourceView API for Vala language
113 Summary(pl.UTF-8):      API GtkSourceView dla języka Vala
114 Group:          Development/Libraries
115 Requires:       %{name}-devel = %{version}-%{release}
116 Requires:       vala
117 BuildArch:      noarch
118
119 %description -n vala-gtksourceview4
120 GtkSourceView API for Vala language.
121
122 %description -n vala-gtksourceview4 -l pl.UTF-8
123 API GtkSourceView dla języka Vala.
124
125 %prep
126 %setup -q -n gtksourceview-%{version}
127
128 %if %{with static_libs}
129 %{__sed} -i -e 's/gtksource_lib = shared_library/gtksource_lib = library/' gtksourceview/meson.build
130 %endif
131
132 %build
133 %meson build \
134         %{?with_glade:-Dglade_catalog=true} \
135         %{?with_apidocs:-Dgtk_doc=true}
136
137 %ninja_build -C build
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141
142 %ninja_install -C build
143
144 %find_lang gtksourceview-4
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %files -f gtksourceview-4.lang
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/libgtksourceview-4.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libgtksourceview-4.so.0
156 %{_datadir}/gtksourceview-4
157 %{_libdir}/girepository-1.0/GtkSource-4.typelib
158
159 %files devel
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/libgtksourceview-4.so
162 %{_includedir}/gtksourceview-4
163 %{_pkgconfigdir}/gtksourceview-4.pc
164 %{_datadir}/gir-1.0/GtkSource-4.gir
165
166 %if %{with static_libs}
167 %files static
168 %defattr(644,root,root,755)
169 %{_libdir}/libgtksourceview-4.a
170 %endif
171
172 %if %{with apidocs}
173 %files apidocs
174 %defattr(644,root,root,755)
175 %{_gtkdocdir}/gtksourceview-4.0
176 %endif
177
178 %if %{with glade}
179 %files -n glade3-gtksourceview
180 %defattr(644,root,root,755)
181 %{_datadir}/glade3/catalogs/gtksourceview.xml
182 %endif
183
184 %if %{with vala}
185 %files -n vala-gtksourceview4
186 %defattr(644,root,root,755)
187 %{_datadir}/vala/vapi/gtksourceview-4.deps
188 %{_datadir}/vala/vapi/gtksourceview-4.vapi
189 %endif
This page took 0.058629 seconds and 2 git commands to generate.