]> git.pld-linux.org Git - packages/gtksourceview5.git/blob - gtksourceview4.spec
fix build without static libs
[packages/gtksourceview5.git] / gtksourceview4.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_with     glade           # install glade catalog
5 %bcond_without  static_libs     # static library
6 %bcond_without  vala            # do not build Vala API
7
8 Summary:        Text widget that extends the standard GTK+ 3.x
9 Summary(pl.UTF-8):      Widget tekstowy rozszerzający standardowy z GTK+ 3.x
10 Name:           gtksourceview4
11 Version:        4.8.0
12 Release:        1
13 License:        LGPL v2+ (library), GPL v2+ (some language specs files)
14 Group:          X11/Libraries
15 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtksourceview/4.8/gtksourceview-%{version}.tar.xz
16 # Source0-md5:  5d4e599c298251691ca0fb5cb08130f0
17 URL:            https://wiki.gnome.org/Projects/GtkSourceView
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  fribidi-devel >= 0.19.7
20 BuildRequires:  gettext-tools >= 0.19.4
21 BuildRequires:  glib2-devel >= 1:2.48.0
22 BuildRequires:  gobject-introspection-devel >= 1.42.0
23 BuildRequires:  gtk+3-devel >= 3.24
24 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.25}
25 BuildRequires:  itstool
26 %if %{with glade}
27 BuildRequires:  libgladeui-devel >= 3.9.0
28 %endif
29 BuildRequires:  libxml2-devel >= 1:2.6.31
30 BuildRequires:  meson >= 0.50.0
31 BuildRequires:  ninja >= 1.5
32 BuildRequires:  pkgconfig
33 BuildRequires:  rpm-pythonprov
34 BuildRequires:  rpmbuild(macros) >= 1.736
35 BuildRequires:  sed >= 4.0
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  vala
38 BuildRequires:  xz
39 Requires:       fribidi >= 0.19.7
40 Requires:       glib2 >= 1:2.48.0
41 Requires:       gtk+3 >= 3.24
42 Requires:       libxml2 >= 1:2.6.31
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 GtkSourceView is a text widget that extends the standard GTK+ 3.x text
47 widget GtkTextView. It improves GtkTextView by implementing syntax
48 highlighting and other features typical of a source editor.
49
50 %description -l pl.UTF-8
51 GtkSourceView to widget tekstowy rozszerzający standardowy widget
52 tekstowy GtkTextView z GTK+ 3.x. Ulepsza GtkTextView poprzez
53 zaimplementowanie podświetlania składni i innych możliwości typowych
54 dla edytora źródeł.
55
56 %package devel
57 Summary:        Header files for GtkSourceView
58 Summary(pl.UTF-8):      Pliki nagłówkowe dla GtkSourceView
59 Group:          X11/Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       fribidi-devel >= 0.19.7
62 Requires:       glib2-devel >= 1:2.48.0
63 Requires:       gtk+3-devel >= 3.24
64 Requires:       libxml2-devel >= 1:2.6.31
65
66 %description devel
67 Header files for GtkSourceView.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe dla GtkSourceView.
71
72 %package static
73 Summary:        Static GtkSourceView library
74 Summary(pl.UTF-8):      Statyczna biblioteka GtkSourceView
75 Group:          X11/Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static GtkSourceView library.
80
81 %description static -l pl.UTF-8
82 Statyczna biblioteka GtkSourceView.
83
84 %package apidocs
85 Summary:        GtkSourceView API documentation
86 Summary(pl.UTF-8):      Dokumentacja API GtkSourceView
87 Group:          Documentation
88 Requires:       gtk-doc-common
89 %if "%{_rpmversion}" >= "4.6"
90 BuildArch:      noarch
91 %endif
92
93 %description apidocs
94 GtkSourceView API documentation.
95
96 %description apidocs -l pl.UTF-8
97 Dokumentacja API GtkSourceView.
98
99 %package -n glade3-gtksourceview
100 Summary:        Glade3 catalog entry for GtkSourceView library
101 Summary(pl.UTF-8):      Wpis katalogu Glade3 dla biblioteki GtkSourceView
102 Group:          X11/Development/Libraries
103 Requires:       %{name}-devel = %{version}-%{release}
104 Requires:       libgladeui >= 3.9.0
105
106 %description -n glade3-gtksourceview
107 Glade3 catalog entry for GtkSourceView library.
108
109 %description -n glade3-gtksourceview -l pl.UTF-8
110 Wpis katalogu Glade3 dla biblioteki GtkSourceView.
111
112 %package -n vala-gtksourceview4
113 Summary:        GtkSourceView API for Vala language
114 Summary(pl.UTF-8):      API GtkSourceView dla języka Vala
115 Group:          Development/Libraries
116 Requires:       %{name}-devel = %{version}-%{release}
117 Requires:       vala
118 %if "%{_rpmversion}" >= "4.6"
119 BuildArch:      noarch
120 %endif
121
122 %description -n vala-gtksourceview4
123 GtkSourceView API for Vala language.
124
125 %description -n vala-gtksourceview4 -l pl.UTF-8
126 API GtkSourceView dla języka Vala.
127
128 %prep
129 %setup -q -n gtksourceview-%{version}
130
131 %if %{with static_libs}
132 %{__sed} -i -e 's/gtksource_lib = shared_library/gtksource_lib = library/' gtksourceview/meson.build
133 %endif
134
135 %build
136 %meson build \
137         %{?with_glade:-Dglade_catalog=true} \
138         %{?with_apidocs:-Dgtk_doc=true}
139
140 %ninja_build -C build
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144
145 %ninja_install -C build
146
147 %find_lang gtksourceview-4
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   -p /sbin/ldconfig
153 %postun -p /sbin/ldconfig
154
155 %files -f gtksourceview-4.lang
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/libgtksourceview-4.so.*.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libgtksourceview-4.so.0
159 %{_datadir}/gtksourceview-4
160 %{_libdir}/girepository-1.0/GtkSource-4.typelib
161
162 %files devel
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/libgtksourceview-4.so
165 %{_includedir}/gtksourceview-4
166 %{_pkgconfigdir}/gtksourceview-4.pc
167 %{_datadir}/gir-1.0/GtkSource-4.gir
168
169 %if %{with static_libs}
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/libgtksourceview-4.a
173 %endif
174
175 %if %{with apidocs}
176 %files apidocs
177 %defattr(644,root,root,755)
178 %{_gtkdocdir}/gtksourceview-4.0
179 %endif
180
181 %if %{with glade}
182 %files -n glade3-gtksourceview
183 %defattr(644,root,root,755)
184 %{_datadir}/glade3/catalogs/gtksourceview.xml
185 %endif
186
187 %if %{with vala}
188 %files -n vala-gtksourceview4
189 %defattr(644,root,root,755)
190 %{_datadir}/vala/vapi/gtksourceview-4.deps
191 %{_datadir}/vala/vapi/gtksourceview-4.vapi
192 %endif
This page took 0.108781 seconds and 3 git commands to generate.