]> git.pld-linux.org Git - packages/gtksourceview5.git/blob - gtksourceview4.spec
052ec22a71d3647e404be65274b29b0f4a7361bb
[packages/gtksourceview5.git] / gtksourceview4.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_with     glade           # install glade catalog
5 %bcond_without  static_libs     # static library
6 %bcond_without  vala            # do not build Vala API
7
8 Summary:        Text widget that extends the standard GTK+ 3.x
9 Summary(pl.UTF-8):      Widget tekstowy rozszerzający standardowy z GTK+ 3.x
10 Name:           gtksourceview4
11 Version:        4.6.1
12 Release:        1
13 License:        LGPL v2+ (library), GPL v2+ (some language specs files)
14 Group:          X11/Libraries
15 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtksourceview/4.6/gtksourceview-%{version}.tar.xz
16 # Source0-md5:  4d4cff3a57a371bff4793e97d50404ef
17 URL:            https://wiki.gnome.org/Projects/GtkSourceView
18 BuildRequires:  docbook-dtd412-xml
19 BuildRequires:  fribidi-devel >= 0.19.7
20 BuildRequires:  gettext-tools >= 0.19.4
21 BuildRequires:  glib2-devel >= 1:2.48.0
22 BuildRequires:  gobject-introspection-devel >= 1.42.0
23 BuildRequires:  gtk+3-devel >= 3.22
24 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.25}
25 BuildRequires:  itstool
26 %if %{with glade}
27 BuildRequires:  libgladeui-devel >= 3.9.0
28 %endif
29 BuildRequires:  libxml2-devel >= 1:2.6.31
30 BuildRequires:  meson >= 0.50.0
31 BuildRequires:  ninja >= 1.5
32 BuildRequires:  pkgconfig
33 BuildRequires:  rpm-pythonprov
34 BuildRequires:  rpmbuild(macros) >= 1.736
35 BuildRequires:  sed >= 4.0
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  vala
38 BuildRequires:  xz
39 Requires:       fribidi >= 0.19.7
40 Requires:       glib2 >= 1:2.48.0
41 Requires:       gtk+3 >= 3.22
42 Requires:       libxml2 >= 1:2.6.31
43 # sr@Latn vs. sr@latin
44 Conflicts:      glibc-misc < 6:2.7
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 GtkSourceView is a text widget that extends the standard GTK+ 3.x text
49 widget GtkTextView. It improves GtkTextView by implementing syntax
50 highlighting and other features typical of a source editor.
51
52 %description -l pl.UTF-8
53 GtkSourceView to widget tekstowy rozszerzający standardowy widget
54 tekstowy GtkTextView z GTK+ 3.x. Ulepsza GtkTextView poprzez
55 zaimplementowanie podświetlania składni i innych możliwości typowych
56 dla edytora źródeł.
57
58 %package devel
59 Summary:        Header files for GtkSourceView
60 Summary(pl.UTF-8):      Pliki nagłówkowe dla GtkSourceView
61 Group:          X11/Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       fribidi-devel >= 0.19.7
64 Requires:       glib2-devel >= 1:2.48.0
65 Requires:       gtk+3-devel >= 3.22
66 Requires:       libxml2-devel >= 1:2.6.31
67
68 %description devel
69 Header files for GtkSourceView.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe dla GtkSourceView.
73
74 %package static
75 Summary:        Static GtkSourceView library
76 Summary(pl.UTF-8):      Statyczna biblioteka GtkSourceView
77 Group:          X11/Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static GtkSourceView library.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka GtkSourceView.
85
86 %package apidocs
87 Summary:        GtkSourceView API documentation
88 Summary(pl.UTF-8):      Dokumentacja API GtkSourceView
89 Group:          Documentation
90 Requires:       gtk-doc-common
91 %if "%{_rpmversion}" >= "5"
92 BuildArch:      noarch
93 %endif
94
95 %description apidocs
96 GtkSourceView API documentation.
97
98 %description apidocs -l pl.UTF-8
99 Dokumentacja API GtkSourceView.
100
101 %package -n glade3-gtksourceview
102 Summary:        Glade3 catalog entry for GtkSourceView library
103 Summary(pl.UTF-8):      Wpis katalogu Glade3 dla biblioteki GtkSourceView
104 Group:          X11/Development/Libraries
105 Requires:       %{name}-devel = %{version}-%{release}
106 Requires:       libgladeui >= 3.9.0
107
108 %description -n glade3-gtksourceview
109 Glade3 catalog entry for GtkSourceView library.
110
111 %description -n glade3-gtksourceview -l pl.UTF-8
112 Wpis katalogu Glade3 dla biblioteki GtkSourceView.
113
114 %package -n vala-gtksourceview4
115 Summary:        GtkSourceView API for Vala language
116 Summary(pl.UTF-8):      API GtkSourceView dla języka Vala
117 Group:          Development/Libraries
118 Requires:       %{name}-devel = %{version}-%{release}
119 Requires:       vala
120 %if "%{_rpmversion}" >= "5"
121 BuildArch:      noarch
122 %endif
123
124 %description -n vala-gtksourceview4
125 GtkSourceView API for Vala language.
126
127 %description -n vala-gtksourceview4 -l pl.UTF-8
128 API GtkSourceView dla języka Vala.
129
130 %prep
131 %setup -q -n gtksourceview-%{version}
132
133 %if %{with static_libs}
134 %{__sed} -i -e 's/gtksource_lib = shared_library/gtksource_lib = library/' gtksourceview/meson.build
135 %endif
136
137 %build
138 %meson build \
139         %{?with_glade:-Dglade_catalog=true} \
140         %{?with_apidocs:-Dgtk_doc=true}
141
142 %ninja_build -C build
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146
147 %ninja_install -C build
148
149 %find_lang gtksourceview-4
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post   -p /sbin/ldconfig
155 %postun -p /sbin/ldconfig
156
157 %files -f gtksourceview-4.lang
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/libgtksourceview-4.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libgtksourceview-4.so.0
161 %{_datadir}/gtksourceview-4
162 %{_libdir}/girepository-1.0/GtkSource-4.typelib
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libgtksourceview-4.so
167 %{_includedir}/gtksourceview-4
168 %{_pkgconfigdir}/gtksourceview-4.pc
169 %{_datadir}/gir-1.0/GtkSource-4.gir
170
171 %files static
172 %defattr(644,root,root,755)
173 %{_libdir}/libgtksourceview-4.a
174
175 %if %{with apidocs}
176 %files apidocs
177 %defattr(644,root,root,755)
178 %{_gtkdocdir}/gtksourceview-4.0
179 %endif
180
181 %if %{with glade}
182 %files -n glade3-gtksourceview
183 %defattr(644,root,root,755)
184 %{_datadir}/glade3/catalogs/gtksourceview.xml
185 %endif
186
187 %if %{with vala}
188 %files -n vala-gtksourceview4
189 %defattr(644,root,root,755)
190 %{_datadir}/vala/vapi/gtksourceview-4.deps
191 %{_datadir}/vala/vapi/gtksourceview-4.vapi
192 %endif
This page took 0.09466 seconds and 2 git commands to generate.