]> git.pld-linux.org Git - packages/gtksourceview3.git/blob - gtksourceview3.spec
Update to 3.20.1
[packages/gtksourceview3.git] / gtksourceview3.spec
1 #
2 # Conditional build:
3 %bcond_with     glade   # install glade catalog
4 %bcond_without  vala    # do not build Vala API
5
6 Summary:        Text widget that extends the standard GTK+ 3.x
7 Summary(pl.UTF-8):      Widget tekstowy rozszerzający standardowy z GTK+ 3.x
8 Name:           gtksourceview3
9 Version:        3.20.1
10 Release:        1
11 License:        LGPL v2+ (library), GPL v2+ (some language specs files)
12 Group:          X11/Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtksourceview/3.20/gtksourceview-%{version}.tar.xz
14 # Source0-md5:  a1764b012368c907cf203fd2cefb4565
15 URL:            http://www.gnome.org/
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  autoconf-archive >= 2015.09.25
18 BuildRequires:  automake >= 1:1.13
19 BuildRequires:  docbook-dtd412-xml
20 BuildRequires:  gettext-tools >= 0.19.4
21 BuildRequires:  glib2-devel >= 1:2.47.0
22 BuildRequires:  gnome-common >= 2.24.0
23 BuildRequires:  gobject-introspection-devel >= 1.42.0
24 BuildRequires:  gtk+3-devel >= 3.16.0
25 BuildRequires:  gtk-doc >= 1.25
26 %if %{with glade}
27 BuildRequires:  libgladeui-devel >= 3.9.0
28 %endif
29 BuildRequires:  libtool >= 2:2.2.6
30 BuildRequires:  libxml2-devel >= 1:2.6.31
31 BuildRequires:  pkgconfig
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  vala
35 BuildRequires:  xz
36 Requires:       glib2 >= 1:2.48.0
37 Requires:       gtk+3 >= 3.20.0
38 Requires:       libxml2 >= 1:2.6.31
39 # sr@Latn vs. sr@latin
40 Conflicts:      glibc-misc < 6:2.7
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 GtkSourceView is a text widget that extends the standard GTK+ 3.x text
45 widget GtkTextView. It improves GtkTextView by implementing syntax
46 highlighting and other features typical of a source editor.
47
48 %description -l pl.UTF-8
49 GtkSourceView to widget tekstowy rozszerzający standardowy widget
50 tekstowy GtkTextView z GTK+ 3.x. Ulepsza GtkTextView poprzez
51 zaimplementowanie podświetlania składni i innych możliwości typowych
52 dla edytora źródeł.
53
54 %package apidocs
55 Summary:        GtkSourceView API documentation
56 Summary(pl.UTF-8):      Dokumentacja API GtkSourceView
57 Group:          Documentation
58 Requires:       gtk-doc-common
59
60 %description apidocs
61 GtkSourceView API documentation.
62
63 %description apidocs -l pl.UTF-8
64 Dokumentacja API GtkSourceView.
65
66 %package devel
67 Summary:        Header files for GtkSourceView
68 Summary(pl.UTF-8):      Pliki nagłówkowe dla GtkSourceView
69 Group:          X11/Development/Libraries
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       glib2-devel >= 1:2.48.0
72 Requires:       gtk+3-devel >= 3.20.0
73 Requires:       libxml2-devel >= 1:2.6.31
74
75 %description devel
76 Header files for GtkSourceView.
77
78 %description devel -l pl.UTF-8
79 Pliki nagłówkowe dla GtkSourceView.
80
81 %package static
82 Summary:        Static GtkSourceView library
83 Summary(pl.UTF-8):      Statyczna biblioteka GtkSourceView
84 Group:          X11/Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86
87 %description static
88 Static GtkSourceView library.
89
90 %description static -l pl.UTF-8
91 Statyczna biblioteka GtkSourceView.
92
93 %package -n glade3-gtksourceview
94 Summary:        Glade3 catalog entry for GtkSourceView library
95 Summary(pl.UTF-8):      Wpis katalogu Glade3 dla biblioteki GtkSourceView
96 Group:          X11/Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98 Requires:       libgladeui >= 3.9.0
99
100 %description -n glade3-gtksourceview
101 Glade3 catalog entry for GtkSourceView library.
102
103 %description -n glade3-gtksourceview -l pl.UTF-8
104 Wpis katalogu Glade3 dla biblioteki GtkSourceView.
105
106 %package -n vala-gtksourceview
107 Summary:        GtkSourceView API for Vala language
108 Summary(pl.UTF-8):      API GtkSourceView dla języka Vala
109 Group:          Development/Libraries
110 Requires:       %{name}-devel = %{version}-%{release}
111 Requires:       vala
112 %if "%{_rpmversion}" >= "5"
113 BuildArch:      noarch
114 %endif
115
116 %description -n vala-gtksourceview
117 GtkSourceView API for Vala language.
118
119 %description -n vala-gtksourceview -l pl.UTF-8
120 API GtkSourceView dla języka Vala.
121
122 %prep
123 %setup -q -n gtksourceview-%{version}
124
125 # force new version from autoconf-archive (original one uses non-POSIX ${V:N} syntax)
126 %{__rm} m4/ax_compiler_flags_cflags.m4
127
128 %build
129 %{__gtkdocize}
130 %{__libtoolize}
131 %{__aclocal} -I m4
132 %{__autoconf}
133 %{__autoheader}
134 %{__automake}
135 %configure \
136         %{__enable glade glade-catalog} \
137         --enable-gtk-doc \
138         --enable-providers \
139         --disable-silent-rules \
140         --enable-static \
141         --with-html-dir=%{_gtkdocdir}
142 %{__make}
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
151
152 %find_lang gtksourceview-3.0
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post   -p /sbin/ldconfig
158 %postun -p /sbin/ldconfig
159
160 %files -f gtksourceview-3.0.lang
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so.*.*.*
163 %attr(755,root,root) %ghost %{_libdir}/libgtksourceview-3.0.so.1
164 %{_datadir}/gtksourceview-3.0
165 %{_libdir}/girepository-1.0/GtkSource-3.0.typelib
166
167 %files apidocs
168 %defattr(644,root,root,755)
169 %{_gtkdocdir}/gtksourceview-3.0
170
171 %files devel
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so
174 %{_includedir}/gtksourceview-3.0
175 %{_pkgconfigdir}/gtksourceview-3.0.pc
176 %{_datadir}/gir-1.0/GtkSource-3.0.gir
177
178 %files static
179 %defattr(644,root,root,755)
180 %{_libdir}/libgtksourceview-3.0.a
181
182 %if %{with glade}
183 %files -n glade3-gtksourceview
184 %defattr(644,root,root,755)
185 %{_datadir}/glade3/catalogs/gtksourceview.xml
186 %endif
187
188 %if %{with vala}
189 %files -n vala-gtksourceview
190 %defattr(644,root,root,755)
191 %{_datadir}/vala/vapi/gtksourceview-3.0.deps
192 %{_datadir}/vala/vapi/gtksourceview-3.0.vapi
193 %endif
This page took 0.165412 seconds and 3 git commands to generate.