]> git.pld-linux.org Git - packages/gtksourceview3.git/blob - gtksourceview3.spec
- gnome-common not required since 3.17.x
[packages/gtksourceview3.git] / gtksourceview3.spec
1 #
2 # Conditional build:
3 %bcond_with     glade   # install glade catalog
4 %bcond_without  vala    # do not build Vala API
5
6 Summary:        Text widget that extends the standard GTK+ 3.x
7 Summary(pl.UTF-8):      Widget tekstowy rozszerzający standardowy z GTK+ 3.x
8 Name:           gtksourceview3
9 Version:        3.22.0
10 Release:        1
11 License:        LGPL v2+ (library), GPL v2+ (some language specs files)
12 Group:          X11/Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtksourceview/3.22/gtksourceview-%{version}.tar.xz
14 # Source0-md5:  a94207a50072994023d83ec86ee080a3
15 URL:            http://www.gnome.org/
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  autoconf-archive >= 2015.09.25
18 BuildRequires:  automake >= 1:1.13
19 BuildRequires:  docbook-dtd412-xml
20 BuildRequires:  gettext-tools >= 0.19.4
21 BuildRequires:  glib2-devel >= 1:2.48.0
22 BuildRequires:  gobject-introspection-devel >= 1.42.0
23 BuildRequires:  gtk+3-devel >= 3.20.0
24 BuildRequires:  gtk-doc >= 1.25
25 BuildRequires:  itstool
26 %if %{with glade}
27 BuildRequires:  libgladeui-devel >= 3.9.0
28 %endif
29 BuildRequires:  libtool >= 2:2.2.6
30 BuildRequires:  libxml2-devel >= 1:2.6.31
31 BuildRequires:  pkgconfig
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  vala
35 BuildRequires:  xz
36 Requires:       glib2 >= 1:2.48.0
37 Requires:       gtk+3 >= 3.20.0
38 Requires:       libxml2 >= 1:2.6.31
39 # sr@Latn vs. sr@latin
40 Conflicts:      glibc-misc < 6:2.7
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 GtkSourceView is a text widget that extends the standard GTK+ 3.x text
45 widget GtkTextView. It improves GtkTextView by implementing syntax
46 highlighting and other features typical of a source editor.
47
48 %description -l pl.UTF-8
49 GtkSourceView to widget tekstowy rozszerzający standardowy widget
50 tekstowy GtkTextView z GTK+ 3.x. Ulepsza GtkTextView poprzez
51 zaimplementowanie podświetlania składni i innych możliwości typowych
52 dla edytora źródeł.
53
54 %package apidocs
55 Summary:        GtkSourceView API documentation
56 Summary(pl.UTF-8):      Dokumentacja API GtkSourceView
57 Group:          Documentation
58 Requires:       gtk-doc-common
59 %if "%{_rpmversion}" >= "5"
60 BuildArch:      noarch
61 %endif
62
63 %description apidocs
64 GtkSourceView API documentation.
65
66 %description apidocs -l pl.UTF-8
67 Dokumentacja API GtkSourceView.
68
69 %package devel
70 Summary:        Header files for GtkSourceView
71 Summary(pl.UTF-8):      Pliki nagłówkowe dla GtkSourceView
72 Group:          X11/Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       glib2-devel >= 1:2.48.0
75 Requires:       gtk+3-devel >= 3.20.0
76 Requires:       libxml2-devel >= 1:2.6.31
77
78 %description devel
79 Header files for GtkSourceView.
80
81 %description devel -l pl.UTF-8
82 Pliki nagłówkowe dla GtkSourceView.
83
84 %package static
85 Summary:        Static GtkSourceView library
86 Summary(pl.UTF-8):      Statyczna biblioteka GtkSourceView
87 Group:          X11/Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89
90 %description static
91 Static GtkSourceView library.
92
93 %description static -l pl.UTF-8
94 Statyczna biblioteka GtkSourceView.
95
96 %package -n glade3-gtksourceview
97 Summary:        Glade3 catalog entry for GtkSourceView library
98 Summary(pl.UTF-8):      Wpis katalogu Glade3 dla biblioteki GtkSourceView
99 Group:          X11/Development/Libraries
100 Requires:       %{name}-devel = %{version}-%{release}
101 Requires:       libgladeui >= 3.9.0
102
103 %description -n glade3-gtksourceview
104 Glade3 catalog entry for GtkSourceView library.
105
106 %description -n glade3-gtksourceview -l pl.UTF-8
107 Wpis katalogu Glade3 dla biblioteki GtkSourceView.
108
109 %package -n vala-gtksourceview
110 Summary:        GtkSourceView API for Vala language
111 Summary(pl.UTF-8):      API GtkSourceView dla języka Vala
112 Group:          Development/Libraries
113 Requires:       %{name}-devel = %{version}-%{release}
114 Requires:       vala
115 %if "%{_rpmversion}" >= "5"
116 BuildArch:      noarch
117 %endif
118
119 %description -n vala-gtksourceview
120 GtkSourceView API for Vala language.
121
122 %description -n vala-gtksourceview -l pl.UTF-8
123 API GtkSourceView dla języka Vala.
124
125 %prep
126 %setup -q -n gtksourceview-%{version}
127
128 # force new version from autoconf-archive (original one uses non-POSIX ${V:N} syntax)
129 %{__rm} m4/ax_compiler_flags_cflags.m4
130
131 %build
132 %{__gtkdocize}
133 %{__libtoolize}
134 %{__aclocal} -I m4
135 %{__autoconf}
136 %{__autoheader}
137 %{__automake}
138 %configure \
139         %{__enable glade glade-catalog} \
140         --enable-gtk-doc \
141         --disable-silent-rules \
142         --enable-static \
143         --with-html-dir=%{_gtkdocdir}
144 %{__make}
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148
149 %{__make} install \
150         DESTDIR=$RPM_BUILD_ROOT
151
152 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
153
154 %find_lang gtksourceview-3.0
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post   -p /sbin/ldconfig
160 %postun -p /sbin/ldconfig
161
162 %files -f gtksourceview-3.0.lang
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libgtksourceview-3.0.so.1
166 %{_datadir}/gtksourceview-3.0
167 %{_libdir}/girepository-1.0/GtkSource-3.0.typelib
168
169 %files apidocs
170 %defattr(644,root,root,755)
171 %{_gtkdocdir}/gtksourceview-3.0
172
173 %files devel
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so
176 %{_includedir}/gtksourceview-3.0
177 %{_pkgconfigdir}/gtksourceview-3.0.pc
178 %{_datadir}/gir-1.0/GtkSource-3.0.gir
179
180 %files static
181 %defattr(644,root,root,755)
182 %{_libdir}/libgtksourceview-3.0.a
183
184 %if %{with glade}
185 %files -n glade3-gtksourceview
186 %defattr(644,root,root,755)
187 %{_datadir}/glade3/catalogs/gtksourceview.xml
188 %endif
189
190 %if %{with vala}
191 %files -n vala-gtksourceview
192 %defattr(644,root,root,755)
193 %{_datadir}/vala/vapi/gtksourceview-3.0.deps
194 %{_datadir}/vala/vapi/gtksourceview-3.0.vapi
195 %endif
This page took 0.076925 seconds and 3 git commands to generate.