]> git.pld-linux.org Git - packages/gtksourceview3.git/blob - gtksourceview3.spec
ae35223d2be8628c5094a92afaa6b87e05efd715
[packages/gtksourceview3.git] / gtksourceview3.spec
1 #
2 # Conditional build:
3 %bcond_with     glade   # install glade catalog
4 %bcond_without  vala    # do not build Vala API
5
6 Summary:        Text widget that extends the standard GTK+ 3.x
7 Summary(pl.UTF-8):      Widget tekstowy rozszerzający standardowy z GTK+ 3.x
8 Name:           gtksourceview3
9 Version:        3.22.0
10 Release:        1
11 License:        LGPL v2+ (library), GPL v2+ (some language specs files)
12 Group:          X11/Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtksourceview/3.22/gtksourceview-%{version}.tar.xz
14 # Source0-md5:  a94207a50072994023d83ec86ee080a3
15 URL:            http://www.gnome.org/
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  autoconf-archive >= 2015.09.25
18 BuildRequires:  automake >= 1:1.13
19 BuildRequires:  docbook-dtd412-xml
20 BuildRequires:  gettext-tools >= 0.19.4
21 BuildRequires:  glib2-devel >= 1:2.48.0
22 BuildRequires:  gnome-common >= 2.24.0
23 BuildRequires:  gobject-introspection-devel >= 1.42.0
24 BuildRequires:  gtk+3-devel >= 3.20.0
25 BuildRequires:  gtk-doc >= 1.25
26 BuildRequires:  itstool
27 %if %{with glade}
28 BuildRequires:  libgladeui-devel >= 3.9.0
29 %endif
30 BuildRequires:  libtool >= 2:2.2.6
31 BuildRequires:  libxml2-devel >= 1:2.6.31
32 BuildRequires:  pkgconfig
33 BuildRequires:  rpm-pythonprov
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  vala
36 BuildRequires:  xz
37 Requires:       glib2 >= 1:2.48.0
38 Requires:       gtk+3 >= 3.20.0
39 Requires:       libxml2 >= 1:2.6.31
40 # sr@Latn vs. sr@latin
41 Conflicts:      glibc-misc < 6:2.7
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 GtkSourceView is a text widget that extends the standard GTK+ 3.x text
46 widget GtkTextView. It improves GtkTextView by implementing syntax
47 highlighting and other features typical of a source editor.
48
49 %description -l pl.UTF-8
50 GtkSourceView to widget tekstowy rozszerzający standardowy widget
51 tekstowy GtkTextView z GTK+ 3.x. Ulepsza GtkTextView poprzez
52 zaimplementowanie podświetlania składni i innych możliwości typowych
53 dla edytora źródeł.
54
55 %package apidocs
56 Summary:        GtkSourceView API documentation
57 Summary(pl.UTF-8):      Dokumentacja API GtkSourceView
58 Group:          Documentation
59 Requires:       gtk-doc-common
60 %if "%{_rpmversion}" >= "5"
61 BuildArch:      noarch
62 %endif
63
64 %description apidocs
65 GtkSourceView API documentation.
66
67 %description apidocs -l pl.UTF-8
68 Dokumentacja API GtkSourceView.
69
70 %package devel
71 Summary:        Header files for GtkSourceView
72 Summary(pl.UTF-8):      Pliki nagłówkowe dla GtkSourceView
73 Group:          X11/Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       glib2-devel >= 1:2.48.0
76 Requires:       gtk+3-devel >= 3.20.0
77 Requires:       libxml2-devel >= 1:2.6.31
78
79 %description devel
80 Header files for GtkSourceView.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe dla GtkSourceView.
84
85 %package static
86 Summary:        Static GtkSourceView library
87 Summary(pl.UTF-8):      Statyczna biblioteka GtkSourceView
88 Group:          X11/Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Static GtkSourceView library.
93
94 %description static -l pl.UTF-8
95 Statyczna biblioteka GtkSourceView.
96
97 %package -n glade3-gtksourceview
98 Summary:        Glade3 catalog entry for GtkSourceView library
99 Summary(pl.UTF-8):      Wpis katalogu Glade3 dla biblioteki GtkSourceView
100 Group:          X11/Development/Libraries
101 Requires:       %{name}-devel = %{version}-%{release}
102 Requires:       libgladeui >= 3.9.0
103
104 %description -n glade3-gtksourceview
105 Glade3 catalog entry for GtkSourceView library.
106
107 %description -n glade3-gtksourceview -l pl.UTF-8
108 Wpis katalogu Glade3 dla biblioteki GtkSourceView.
109
110 %package -n vala-gtksourceview
111 Summary:        GtkSourceView API for Vala language
112 Summary(pl.UTF-8):      API GtkSourceView dla języka Vala
113 Group:          Development/Libraries
114 Requires:       %{name}-devel = %{version}-%{release}
115 Requires:       vala
116 %if "%{_rpmversion}" >= "5"
117 BuildArch:      noarch
118 %endif
119
120 %description -n vala-gtksourceview
121 GtkSourceView API for Vala language.
122
123 %description -n vala-gtksourceview -l pl.UTF-8
124 API GtkSourceView dla języka Vala.
125
126 %prep
127 %setup -q -n gtksourceview-%{version}
128
129 # force new version from autoconf-archive (original one uses non-POSIX ${V:N} syntax)
130 %{__rm} m4/ax_compiler_flags_cflags.m4
131
132 %build
133 %{__gtkdocize}
134 %{__libtoolize}
135 %{__aclocal} -I m4
136 %{__autoconf}
137 %{__autoheader}
138 %{__automake}
139 %configure \
140         %{__enable glade glade-catalog} \
141         --enable-gtk-doc \
142         --disable-silent-rules \
143         --enable-static \
144         --with-html-dir=%{_gtkdocdir}
145 %{__make}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149
150 %{__make} install \
151         DESTDIR=$RPM_BUILD_ROOT
152
153 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
154
155 %find_lang gtksourceview-3.0
156
157 %clean
158 rm -rf $RPM_BUILD_ROOT
159
160 %post   -p /sbin/ldconfig
161 %postun -p /sbin/ldconfig
162
163 %files -f gtksourceview-3.0.lang
164 %defattr(644,root,root,755)
165 %attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so.*.*.*
166 %attr(755,root,root) %ghost %{_libdir}/libgtksourceview-3.0.so.1
167 %{_datadir}/gtksourceview-3.0
168 %{_libdir}/girepository-1.0/GtkSource-3.0.typelib
169
170 %files apidocs
171 %defattr(644,root,root,755)
172 %{_gtkdocdir}/gtksourceview-3.0
173
174 %files devel
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so
177 %{_includedir}/gtksourceview-3.0
178 %{_pkgconfigdir}/gtksourceview-3.0.pc
179 %{_datadir}/gir-1.0/GtkSource-3.0.gir
180
181 %files static
182 %defattr(644,root,root,755)
183 %{_libdir}/libgtksourceview-3.0.a
184
185 %if %{with glade}
186 %files -n glade3-gtksourceview
187 %defattr(644,root,root,755)
188 %{_datadir}/glade3/catalogs/gtksourceview.xml
189 %endif
190
191 %if %{with vala}
192 %files -n vala-gtksourceview
193 %defattr(644,root,root,755)
194 %{_datadir}/vala/vapi/gtksourceview-3.0.deps
195 %{_datadir}/vala/vapi/gtksourceview-3.0.vapi
196 %endif
This page took 0.054016 seconds and 2 git commands to generate.