]> git.pld-linux.org Git - packages/gtksourceview3.git/blame_incremental - gtksourceview3.spec
- updated to 3.18.2
[packages/gtksourceview3.git] / gtksourceview3.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with glade # install glade catalog
4%bcond_without vala # do not build Vala API
5#
6Summary: Text widget that extends the standard GTK+ 3.x
7Summary(pl.UTF-8): Widget tekstowy rozszerzający standardowy z GTK+ 3.x
8Name: gtksourceview3
9Version: 3.18.2
10Release: 1
11License: LGPL v2+ (library), GPL v2+ (some language specs files)
12Group: X11/Libraries
13Source0: http://ftp.gnome.org/pub/GNOME/sources/gtksourceview/3.18/gtksourceview-%{version}.tar.xz
14# Source0-md5: c5d2b1dfafbdbff2fde530361fba46f9
15URL: http://www.gnome.org/
16BuildRequires: autoconf >= 2.64
17BuildRequires: autoconf-archive >= 2015.09.25
18BuildRequires: automake >= 1:1.13
19BuildRequires: docbook-dtd412-xml
20BuildRequires: gettext-tools >= 0.17
21BuildRequires: glib2-devel >= 1:2.44.0
22BuildRequires: gnome-common >= 2.24.0
23BuildRequires: gobject-introspection-devel >= 1.42.0
24BuildRequires: gtk+3-devel >= 3.16.0
25BuildRequires: gtk-doc >= 1.24
26BuildRequires: intltool >= 0.40.0
27%if %{with glade}
28BuildRequires: libgladeui-devel >= 3.9.0
29%endif
30BuildRequires: libtool >= 2:2.2.6
31BuildRequires: libxml2-devel >= 1:2.6.31
32BuildRequires: pkgconfig
33BuildRequires: rpm-pythonprov
34BuildRequires: tar >= 1:1.22
35BuildRequires: vala
36BuildRequires: xz
37Requires: glib2 >= 1:2.44.0
38Requires: gtk+3 >= 3.16.0
39Requires: libxml2 >= 1:2.6.31
40# sr@Latn vs. sr@latin
41Conflicts: glibc-misc < 6:2.7
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%description
45GtkSourceView is a text widget that extends the standard GTK+ 3.x text
46widget GtkTextView. It improves GtkTextView by implementing syntax
47highlighting and other features typical of a source editor.
48
49%description -l pl.UTF-8
50GtkSourceView to widget tekstowy rozszerzający standardowy widget
51tekstowy GtkTextView z GTK+ 3.x. Ulepsza GtkTextView poprzez
52zaimplementowanie podświetlania składni i innych możliwości typowych
53dla edytora źródeł.
54
55%package apidocs
56Summary: GtkSourceView API documentation
57Summary(pl.UTF-8): Dokumentacja API GtkSourceView
58Group: Documentation
59Requires: gtk-doc-common
60
61%description apidocs
62GtkSourceView API documentation.
63
64%description apidocs -l pl.UTF-8
65Dokumentacja API GtkSourceView.
66
67%package devel
68Summary: Header files for GtkSourceView
69Summary(pl.UTF-8): Pliki nagłówkowe dla GtkSourceView
70Group: X11/Development/Libraries
71Requires: %{name} = %{version}-%{release}
72Requires: glib2-devel >= 1:2.44.0
73Requires: gtk+3-devel >= 3.16.0
74Requires: libxml2-devel >= 1:2.6.31
75
76%description devel
77Header files for GtkSourceView.
78
79%description devel -l pl.UTF-8
80Pliki nagłówkowe dla GtkSourceView.
81
82%package static
83Summary: Static GtkSourceView library
84Summary(pl.UTF-8): Statyczna biblioteka GtkSourceView
85Group: X11/Development/Libraries
86Requires: %{name}-devel = %{version}-%{release}
87
88%description static
89Static GtkSourceView library.
90
91%description static -l pl.UTF-8
92Statyczna biblioteka GtkSourceView.
93
94%package -n glade3-gtksourceview
95Summary: Glade3 catalog entry for GtkSourceView library
96Summary(pl.UTF-8): Wpis katalogu Glade3 dla biblioteki GtkSourceView
97Group: X11/Development/Libraries
98Requires: %{name}-devel = %{version}-%{release}
99Requires: libgladeui >= 3.9.0
100
101%description -n glade3-gtksourceview
102Glade3 catalog entry for GtkSourceView library.
103
104%description -n glade3-gtksourceview -l pl.UTF-8
105Wpis katalogu Glade3 dla biblioteki GtkSourceView.
106
107%package -n vala-gtksourceview
108Summary: GtkSourceView API for Vala language
109Summary(pl.UTF-8): API GtkSourceView dla języka Vala
110Group: Development/Libraries
111Requires: %{name}-devel = %{version}-%{release}
112Requires: vala
113
114%description -n vala-gtksourceview
115GtkSourceView API for Vala language.
116
117%description -n vala-gtksourceview -l pl.UTF-8
118API GtkSourceView dla języka Vala.
119
120%prep
121%setup -q -n gtksourceview-%{version}
122
123# force new version from autoconf-archive (original one uses non-POSIX ${V:N} syntax)
124%{__rm} m4/ax_compiler_flags_cflags.m4
125
126%build
127%{__gtkdocize}
128%{__intltoolize}
129%{__libtoolize}
130%{__aclocal} -I m4
131%{__autoconf}
132%{__autoheader}
133%{__automake}
134%configure \
135 %{__enable glade glade-catalog} \
136 --enable-gtk-doc \
137 --enable-providers \
138 --disable-silent-rules \
139 --enable-static \
140 --with-html-dir=%{_gtkdocdir}
141%{__make}
142
143%install
144rm -rf $RPM_BUILD_ROOT
145
146%{__make} install \
147 DESTDIR=$RPM_BUILD_ROOT
148
149%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
150
151%find_lang gtksourceview-3.0
152
153%clean
154rm -rf $RPM_BUILD_ROOT
155
156%post -p /sbin/ldconfig
157%postun -p /sbin/ldconfig
158
159%files -f gtksourceview-3.0.lang
160%defattr(644,root,root,755)
161%attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so.*.*.*
162%attr(755,root,root) %ghost %{_libdir}/libgtksourceview-3.0.so.1
163%{_datadir}/gtksourceview-3.0
164%{_libdir}/girepository-1.0/GtkSource-3.0.typelib
165
166%files apidocs
167%defattr(644,root,root,755)
168%{_gtkdocdir}/gtksourceview-3.0
169
170%files devel
171%defattr(644,root,root,755)
172%attr(755,root,root) %{_libdir}/libgtksourceview-3.0.so
173%{_includedir}/gtksourceview-3.0
174%{_pkgconfigdir}/gtksourceview-3.0.pc
175%{_datadir}/gir-1.0/GtkSource-3.0.gir
176
177%files static
178%defattr(644,root,root,755)
179%{_libdir}/libgtksourceview-3.0.a
180
181%if %{with glade}
182%files -n glade3-gtksourceview
183%defattr(644,root,root,755)
184%{_datadir}/glade3/catalogs/gtksourceview.xml
185%endif
186
187%if %{with vala}
188%files -n vala-gtksourceview
189%defattr(644,root,root,755)
190%{_datadir}/vala/vapi/gtksourceview-3.0.deps
191%{_datadir}/vala/vapi/gtksourceview-3.0.vapi
192%endif
This page took 0.052554 seconds and 4 git commands to generate.