]> git.pld-linux.org Git - packages/gtkpod.git/commitdiff
- updated to 2.1.2 auto/th/gtkpod-2.1.2-1
authorŁukasz Kieś <kiesiu@pld-linux.org>
Mon, 22 Oct 2012 19:02:56 +0000 (21:02 +0200)
committerŁukasz Kieś <kiesiu@pld-linux.org>
Mon, 22 Oct 2012 19:02:56 +0000 (21:02 +0200)
- mp4v3 dependecy was removed upstream
- updated BRs
- added patches for new anjuta API and format-security error

gtkpod.spec

index 5932d67b03b5e461028537a510a55c9802d42478..0907ef140166e824901ec9f830af9de0361c5a6d 100644 (file)
@@ -3,18 +3,20 @@
 Summary:       Graphical song management program for Apple's iPod
 Summary(pl.UTF-8):     Graficzny menadżer utworów muzycznych dla urządzeń Apple iPod
 Name:          gtkpod
-Version:       2.1.1
-Release:       3
+Version:       2.1.2
+Release:       1
 License:       GPL/LGPL
 Group:         X11/Applications/Multimedia
 Source0:       http://downloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
-# Source0-md5: 36fd0324fd1d1da00fcddacef1b09983
+# Source0-md5: 88fef3f947cbb7ae6b714080733a3b6b
 Patch0:                desktop.patch
-Patch1:                itmf_tags.patch
-Patch2:                %{name}-linguas.patch
+Patch1:                %{name}-linguas.patch
+Patch2:                anjuta-3.5.3.patch
+Patch3:                format-security-error.patch
 URL:           http://www.gtkpod.org/
 BuildRequires: autoconf >= 2.65
 BuildRequires: automake >= 1:1.9
+BuildRequires: brasero-devel >= 3.0.0
 BuildRequires: clutter-gtk-devel >= 1.0
 BuildRequires: curl-devel >= 7.10.0
 BuildRequires: flac-devel >= 1.2.1
@@ -22,17 +24,17 @@ BuildRequires:      flex
 BuildRequires: gdl-devel >= 3.0.0
 BuildRequires: gettext-devel >= 0.11.0
 BuildRequires: glib2-devel >= 1:2.28.5
-BuildRequires: gstreamer-plugins-base-devel >= 0.10.25
+BuildRequires: gstreamer0.10-plugins-base-devel >= 0.10.25
 BuildRequires: gtk+3-devel >= 3.0.11
 BuildRequires: gtk-webkit3-devel >= 1.3
 BuildRequires: intltool >= 0.33
-BuildRequires: libanjuta-devel >= 1:3.0
+BuildRequires: libanjuta-devel >= 1:3.0.0
 BuildRequires: libgpod-devel >= 0.7.0
 BuildRequires: libid3tag-devel >= 0.15
+BuildRequires: libmusicbrainz4-devel
 BuildRequires: libtool
 BuildRequires: libvorbis-devel >= 1.3.1
 BuildRequires: libxml2-devel >= 2.7.7
-BuildRequires: mp4v2-devel
 BuildRequires: perl-XML-Parser
 BuildRequires: pkgconfig
 BuildRequires: rpm-pythonprov
@@ -62,7 +64,9 @@ urządzeń Apple iPod. Pozwala wgrywać pliki i listy utworów do iPoda.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 %{__sed} -i -e 's!/usr/bin/awk!/bin/awk!g' scripts/ldif2vcf.sh
+%{__sed} -i -e '/^dist_profiles_DATA/s:=.*:=:' plugins/sjcd/data/Makefile.am
 mv -f po/cs{_CZ,}.po
 
 %build
@@ -93,6 +97,7 @@ rm -rf $RPM_BUILD_ROOT
 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}
 %{__rm} $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgtkpod.so
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libatomicparsley.so
 
 %find_lang %{name} --all-name
 
@@ -115,7 +120,9 @@ fi
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README TODO TROUBLESHOOTING
 %attr(755,root,root) %{_bindir}/%{name}
+%attr(755,root,root) %{_libdir}/libatomicparsley.so.*.*.*
 %attr(755,root,root) %{_libdir}/libgtkpod.so.*.*.*
+%ghost %{_libdir}/libatomicparsley.so.0
 %ghost %{_libdir}/libgtkpod.so.1
 %{_mandir}/man1/%{name}.1*
 %dir %{_datadir}/%{name}
@@ -124,6 +131,7 @@ fi
 %dir %{_datadir}/gtkpod/scripts
 %attr(755,root,root) %{_datadir}/gtkpod/scripts/*
 %{_datadir}/glib-2.0/schemas/org.gtkpod.gschema.xml
+%{_datadir}/glib-2.0/schemas/org.gtkpod.sjcd.gschema.xml
 %{_desktopdir}/%{name}.desktop
 %{_iconsdir}/hicolor/*/apps/%{name}.png
 %dir %{_libdir}/gtkpod
This page took 0.037301 seconds and 4 git commands to generate.