]> git.pld-linux.org Git - packages/gtkpod.git/commitdiff
- updated to 2.1.3 auto/th/gtkpod-2.1.3-1
authorŁukasz Kieś <kiesiu@pld-linux.org>
Sun, 7 Apr 2013 09:31:32 +0000 (11:31 +0200)
committerŁukasz Kieś <kiesiu@pld-linux.org>
Sun, 7 Apr 2013 09:31:32 +0000 (11:31 +0200)
- format-security patch added upstream
- added patch to build with automake >= 1.13
- added patch to build with libanjuta >= 2.7.3
- added patch to build with gdl >= 3.6.2

automake-1.13.patch [new file with mode: 0644]
desktop.patch
format-security-error.patch [deleted file]
gdl362.patch [new file with mode: 0644]
gtkpod.spec
libanjuta-3.7.3.patch [new file with mode: 0644]

diff --git a/automake-1.13.patch b/automake-1.13.patch
new file mode 100644 (file)
index 0000000..d30c01c
--- /dev/null
@@ -0,0 +1,12 @@
+diff -uNr gtkpod-2.1.3.old/configure.ac gtkpod-2.1.3/configure.ac
+--- gtkpod-2.1.3.old/configure.ac      2012-10-06 21:56:52.000000000 +0200
++++ gtkpod-2.1.3/configure.ac  2013-03-30 22:22:28.985867558 +0100
+@@ -6,7 +6,7 @@
+ AC_INIT([gtkpod], VERSION_NUMBER)
+ AC_CONFIG_SRCDIR(src/main.c)
+-AM_CONFIG_HEADER([config.h])
++AC_CONFIG_HEADERS([config.h])
+ dnl libtool versioning
+ # +1 : 0 : +1  == adds new functions to the interface
index 017a648db34789a60e64210a67c98cbe576531d8..a278c0928de3ecc7d04281986177373a68453d4b 100644 (file)
@@ -5,9 +5,9 @@ the pl comment should go to .po file really
 @@ -2,9 +2,11 @@
  _Name=gtkpod
  _GenericName=iPod Manager
 @@ -2,9 +2,11 @@
  _Name=gtkpod
  _GenericName=iPod Manager
- _Comment=Manage music and video on an Apple iPod
+ _Comment=Manage music, video and photos on an Apple iPod
 +# TODO: use add po/pl.po create pl.po-update.patch or sth, and submit it upstream
 +# TODO: use add po/pl.po create pl.po-update.patch or sth, and submit it upstream
-+Comment[pl]=Graficzny menadżer utworów muzycznych dla urządzeń Apple iPod
++Comment[pl]=Graficzny menadżer utworów muzycznych, wideo i zdjęć dla urządzeń Apple iPod
  Exec=gtkpod
  Icon=gtkpod
  Terminal=false
  Exec=gtkpod
  Icon=gtkpod
  Terminal=false
diff --git a/format-security-error.patch b/format-security-error.patch
deleted file mode 100644 (file)
index d65137f..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/plugins/clarity/clarity_cover.c
-+++ b/plugins/clarity/clarity_cover.c
-@@ -241,7 +241,7 @@ void clarity_cover_set_album_item (ClarityCover *self, AlbumItem *item) {
-     // Set cover artwork
-     gtk_clutter_texture_set_from_pixbuf (GTK_CLUTTER_TEXTURE(priv->texture), item->albumart, &error);
-     if (error) {
--        g_warning(error->message);
-+        g_warning("%s", error->message);
-         g_error_free(error);
-         return;
-     }
diff --git a/gdl362.patch b/gdl362.patch
new file mode 100644 (file)
index 0000000..ff3f4e5
--- /dev/null
@@ -0,0 +1,40 @@
+--- gtkpod-2.1.2.orig/src/anjuta-action-callbacks.c
++++ gtkpod-2.1.2/src/anjuta-action-callbacks.c
+@@ -65,7 +65,7 @@ void
+ on_layout_lock_toggle (GtkAction *action, AnjutaApp *app)
+ {
+       if (app->layout_manager)
+-              g_object_set (app->layout_manager->master, "locked",
++              g_object_set (gdl_dock_layout_get_master (app->layout_manager), "locked",
+                                         gtk_toggle_action_get_active (GTK_TOGGLE_ACTION (action)),
+                                         NULL);
+ }
+--- gtkpod-2.1.2.orig/src/anjuta-app.c
++++ gtkpod-2.1.2/src/anjuta-app.c
+@@ -252,7 +252,7 @@ static void on_gdl_style_changed(GSettin
+     else if (g_strcmp0(pr_style, "Tabs") == 0)
+         style = GDL_SWITCHER_STYLE_TABS;
+-    g_object_set(G_OBJECT(app->layout_manager->master), "switcher-style", style, NULL);
++    g_object_set(G_OBJECT(gdl_dock_layout_get_master (app->layout_manager)), "switcher-style", style, NULL);
+     g_free(pr_style);
+ }
+@@ -478,14 +478,14 @@ static void anjuta_app_instance_init(Anj
+     gtk_widget_show(app->dock);
+     gtk_box_pack_end(GTK_BOX (hbox), app->dock, TRUE, TRUE, 0);
+-    dockbar = gdl_dock_bar_new(GDL_DOCK(app->dock));
++    dockbar = gdl_dock_bar_new(G_OBJECT(app->dock));
+     gtk_widget_show(dockbar);
+     gtk_box_pack_start(GTK_BOX (hbox), dockbar, FALSE, FALSE, 0);
+-    app->layout_manager = gdl_dock_layout_new(GDL_DOCK (app->dock));
++    app->layout_manager = gdl_dock_layout_new(G_OBJECT (app->dock));
+     g_signal_connect (app->layout_manager, "notify::dirty",
+             G_CALLBACK (on_layout_dirty_notify), app);
+-    g_signal_connect (app->layout_manager->master, "notify::locked",
++    g_signal_connect (gdl_dock_layout_get_master (app->layout_manager), "notify::locked",
+             G_CALLBACK (on_layout_locked_notify), app);
+     /* UI engine */
index 0907ef140166e824901ec9f830af9de0361c5a6d..7f3161c307c6e127dcf5e144a7c151e0edb49411 100644 (file)
@@ -3,16 +3,17 @@
 Summary:       Graphical song management program for Apple's iPod
 Summary(pl.UTF-8):     Graficzny menadżer utworów muzycznych dla urządzeń Apple iPod
 Name:          gtkpod
 Summary:       Graphical song management program for Apple's iPod
 Summary(pl.UTF-8):     Graficzny menadżer utworów muzycznych dla urządzeń Apple iPod
 Name:          gtkpod
-Version:       2.1.2
+Version:       2.1.3
 Release:       1
 License:       GPL/LGPL
 Group:         X11/Applications/Multimedia
 Source0:       http://downloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
 Release:       1
 License:       GPL/LGPL
 Group:         X11/Applications/Multimedia
 Source0:       http://downloads.sourceforge.net/gtkpod/%{name}-%{version}.tar.gz
-# Source0-md5: 88fef3f947cbb7ae6b714080733a3b6b
+# Source0-md5: 57f04578de6e3262a436ec574422b144
 Patch0:                desktop.patch
 Patch1:                %{name}-linguas.patch
 Patch0:                desktop.patch
 Patch1:                %{name}-linguas.patch
-Patch2:                anjuta-3.5.3.patch
-Patch3:                format-security-error.patch
+Patch2:                automake-1.13.patch
+Patch3:                libanjuta-3.7.3.patch
+Patch4:                gdl362.patch
 URL:           http://www.gtkpod.org/
 BuildRequires: autoconf >= 2.65
 BuildRequires: automake >= 1:1.9
 URL:           http://www.gtkpod.org/
 BuildRequires: autoconf >= 2.65
 BuildRequires: automake >= 1:1.9
@@ -65,6 +66,7 @@ urządzeń Apple iPod. Pozwala wgrywać pliki i listy utworów do iPoda.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 %{__sed} -i -e 's!/usr/bin/awk!/bin/awk!g' scripts/ldif2vcf.sh
 %{__sed} -i -e '/^dist_profiles_DATA/s:=.*:=:' plugins/sjcd/data/Makefile.am
 mv -f po/cs{_CZ,}.po
 %{__sed} -i -e 's!/usr/bin/awk!/bin/awk!g' scripts/ldif2vcf.sh
 %{__sed} -i -e '/^dist_profiles_DATA/s:=.*:=:' plugins/sjcd/data/Makefile.am
 mv -f po/cs{_CZ,}.po
diff --git a/libanjuta-3.7.3.patch b/libanjuta-3.7.3.patch
new file mode 100644 (file)
index 0000000..13025e5
--- /dev/null
@@ -0,0 +1,22 @@
+diff -uNr gtkpod-2.1.3.old/src/gtkpod.c gtkpod-2.1.3/src/gtkpod.c
+--- gtkpod-2.1.3.old/src/gtkpod.c      2012-05-11 23:25:00.000000000 +0200
++++ gtkpod-2.1.3/src/gtkpod.c  2013-03-30 22:39:47.623499920 +0100
+@@ -29,6 +29,7 @@
+ #include <gtk/gtk.h>
+ #include <libanjuta/anjuta-utils.h>
+ #include <libanjuta/anjuta-shell.h>
++#include <libanjuta/anjuta-version.h>
+ #include "gtkpod.h"
+ #include "libgtkpod/directories.h"
+@@ -236,7 +237,10 @@
+     anjuta_shell_session_save(ANJUTA_SHELL(app), session_dir, NULL);
+     g_free(session_dir);
++#if ANJUTA_CHECK_VERSION(3,7,3)
++#else
+     anjuta_shell_notify_exit(ANJUTA_SHELL(app), NULL);
++#endif
+     if (!gtkpod_cleanup_quit()) {
+         // Dont want to quit so avoid signalling any destroy event
This page took 0.141722 seconds and 4 git commands to generate.