]> git.pld-linux.org Git - packages/gtkmm4.git/blob - gtkmm4.spec
- unconditional noarch subpackages
[packages/gtkmm4.git] / gtkmm4.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 %define         atkmm_ver       2.29.1
6 %define         cairomm_ver     1.15.4
7 %define         glibmm_ver      2.68.0
8 %define         gtk4_ver        4.0.0
9 %define         pangomm_ver     2.48.0
10 Summary:        A C++ interface for the GTK+ (a GUI library for X)
11 Summary(pl.UTF-8):      Wrapper C++ dla GTK+
12 Name:           gtkmm4
13 Version:        4.0.1
14 Release:        1
15 License:        LGPL v2+
16 Group:          X11/Libraries
17 Source0:        https://download.gnome.org/sources/gtkmm/4.0/gtkmm-%{version}.tar.xz
18 # Source0-md5:  69774cc079b34dd006b7bc49d81fe324
19 URL:            https://www.gtkmm.org/
20 BuildRequires:  atkmm2.36-devel >= %{atkmm_ver}
21 BuildRequires:  autoconf >= 2.59
22 BuildRequires:  automake >= 1:1.11
23 BuildRequires:  cairomm1.16-devel >= %{cairomm_ver}
24 BuildRequires:  doxygen >= 1:1.8.9
25 BuildRequires:  gdk-pixbuf2-devel >= 2.36.0
26 BuildRequires:  glibmm2.68-devel >= %{glibmm_ver}
27 BuildRequires:  gtk4-devel >= %{gtk4_ver}
28 BuildRequires:  libepoxy-devel >= 1.2
29 BuildRequires:  libsigc++3-devel >= 3.0
30 BuildRequires:  libstdc++-devel >= 6:7
31 BuildRequires:  libtool >= 2:2.0
32 BuildRequires:  mm-common >= 0.9.12
33 BuildRequires:  pangomm2.48-devel >= %{pangomm_ver}
34 BuildRequires:  perl-base >= 1:5.6.0
35 BuildRequires:  pkgconfig
36 BuildRequires:  rpmbuild(macros) >= 1.752
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  xz
39 Requires:       atkmm2.36 >= %{atkmm_ver}
40 Requires:       cairomm1.16 >= %{cairomm_ver}
41 Requires:       gdk-pixbuf2 >= 2.36.0
42 Requires:       glibmm2.68 >= %{glibmm_ver}
43 Requires:       gtk4 >= %{gtk4_ver}
44 Requires:       pangomm2.48 >= %{pangomm_ver}
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
49 library. The interface provides a convenient interface for C++
50 programmers to create GUIs with GTK+'s flexible object-oriented
51 framework. Features include type safe callbacks, widgets that are
52 extensible using inheritance and over 110 classes that can be freely
53 combined to quickly create complex user interfaces.
54
55 %description -l pl.UTF-8
56 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
57 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
58 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
59
60 %package devel
61 Summary:        gtkmm and gdkmm header files
62 Summary(pl.UTF-8):      Pliki nagłówkowe gtkmm i gdkmm
63 Group:          X11/Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       atkmm2.36-devel >= %{atkmm_ver}
66 Requires:       cairomm1.16-devel >= %{cairomm_ver}
67 Requires:       gdk-pixbuf2-devel >= 2.36.0
68 Requires:       glibmm2.68-devel >= %{glibmm_ver}
69 Requires:       gtk4-devel >= %{gtk4_ver}
70 Requires:       libstdc++-devel >= 6:7
71 Requires:       pangomm2.48-devel >= %{pangomm_ver}
72
73 %description devel
74 Header files for gtkmm library.
75
76 %description devel -l pl.UTF-8
77 Pliki nagłówkowe biblioteki gtkmm.
78
79 %package static
80 Summary:        gtkmm and gdkmm static libraries
81 Summary(pl.UTF-8):      Biblioteki statyczne gtkmm i gdkmm
82 Group:          X11/Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 gtkmm and gdkmm static libraries.
87
88 %description static -l pl.UTF-8
89 Biblioteki statyczne gtkmm i gdkmm.
90
91 %package apidocs
92 Summary:        Reference documentation for gtkmm and gdkmm
93 Summary(pl.UTF-8):      Szczegółowa dokumentacja gtkmm i gdkmm
94 Group:          Documentation
95 Requires:       devhelp
96 BuildArch:      noarch
97
98 %description apidocs
99 Reference documentation for gtkmm and gdkmm.
100
101 %description apidocs -l pl.UTF-8
102 Szczegółowa dokumentacja gtkmm i gdkmm.
103
104 %prep
105 %setup -q -n gtkmm-%{version}
106
107 # missing in release tarball, not needed for Linux
108 mkdir win32_installer
109 touch win32_installer/filelist.am \
110         win32_installer/gtkmm-installer.nsi.in
111
112 %build
113 mm-common-prepare --copy --force
114 %{__libtoolize}
115 %{__aclocal} -I build
116 %{__autoconf}
117 %{__autoheader}
118 %{__automake}
119 %configure \
120         --enable-maintainer-mode \
121         --disable-silent-rules \
122         %{?with_static_libs:--enable-static}
123
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %post   -p /sbin/ldconfig
138 %postun -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %doc AUTHORS ChangeLog NEWS README
143 %attr(755,root,root) %{_libdir}/libgtkmm-4.0.so.*.*.*
144 %attr(755,root,root) %ghost %{_libdir}/libgtkmm-4.0.so.0
145
146 %files devel
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_libdir}/libgtkmm-4.0.so
149 %{_libdir}/gtkmm-4.0
150 %{_includedir}/gtkmm-4.0
151 %{_pkgconfigdir}/gtkmm-4.0.pc
152
153 %if %{with static_libs}
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/libgtkmm-4.0.a
157 %endif
158
159 %files apidocs
160 %defattr(644,root,root,755)
161 %{_docdir}/gtkmm-4.0
162 %{_datadir}/devhelp/books/gtkmm-4.0
This page took 0.091798 seconds and 3 git commands to generate.