]> git.pld-linux.org Git - packages/gtkmm4.git/blob - gtkmm3.spec
- updated to 3.16.0
[packages/gtkmm4.git] / gtkmm3.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 %define         glibmm_ver      2.44.0
6 %define         gtk3_ver        3.16.0
7 Summary:        A C++ interface for the GTK+ (a GUI library for X)
8 Summary(pl.UTF-8):      Wrapper C++ dla GTK+
9 Name:           gtkmm3
10 Version:        3.16.0
11 Release:        1
12 License:        LGPL v2+
13 Group:          X11/Libraries
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtkmm/3.16/gtkmm-%{version}.tar.xz
15 # Source0-md5:  daa0c2407e50ff0602236c334c775717
16 URL:            http://www.gtkmm.org/
17 BuildRequires:  atkmm-devel >= 2.22.2
18 BuildRequires:  autoconf >= 2.59
19 BuildRequires:  automake >= 1:1.11
20 BuildRequires:  cairomm-devel >= 1.9.2
21 BuildRequires:  gdk-pixbuf2-devel >= 2.26.0
22 BuildRequires:  glibmm-devel >= %{glibmm_ver}
23 BuildRequires:  gtk+3-devel >= %{gtk3_ver}
24 BuildRequires:  libsigc++-devel
25 BuildRequires:  libstdc++-devel >= 5:3.3.1
26 BuildRequires:  libtool >= 2:2.0
27 BuildRequires:  mm-common >= 0.9.7
28 BuildRequires:  pangomm-devel >= 2.28.0
29 BuildRequires:  perl-base >= 1:5.6.0
30 BuildRequires:  pkgconfig
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  xz
33 Requires:       atkmm >= 2.22.2
34 Requires:       cairomm >= 1.9.2
35 Requires:       gdk-pixbuf2 >= 2.26.0
36 Requires:       glibmm >= %{glibmm_ver}
37 Requires:       gtk+3 >= %{gtk3_ver}
38 Requires:       pangomm >= 2.28.0
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
43 library. The interface provides a convenient interface for C++
44 programmers to create GUIs with GTK+'s flexible object-oriented
45 framework. Features include type safe callbacks, widgets that are
46 extensible using inheritance and over 110 classes that can be freely
47 combined to quickly create complex user interfaces.
48
49 %description -l pl.UTF-8
50 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
51 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
52 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
53
54 %package devel
55 Summary:        gtkmm and gdkmm header files
56 Summary(pl.UTF-8):      Pliki nagłówkowe gtkmm i gdkmm
57 Group:          X11/Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       atkmm-devel >= 2.22.2
60 Requires:       cairomm-devel >= 1.9.2
61 Requires:       gdk-pixbuf2-devel >= 2.26.0
62 Requires:       glibmm-devel >= %{glibmm_ver}
63 Requires:       gtk+3-devel >= %{gtk3_ver}
64 Requires:       pangomm-devel >= 2.28.0
65
66 %description devel
67 Header files for gtkmm library.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe biblioteki gtkmm.
71
72 %package static
73 Summary:        gtkmm and gdkmm static libraries
74 Summary(pl.UTF-8):      Biblioteki statyczne gtkmm i gdkmm
75 Group:          X11/Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 gtkmm and gdkmm static libraries.
80
81 %description static -l pl.UTF-8
82 Biblioteki statyczne gtkmm i gdkmm.
83
84 %package apidocs
85 Summary:        Reference documentation for gtkmm and gdkmm
86 Summary(pl.UTF-8):      Szczegółowa dokumentacja gtkmm i gdkmm
87 Group:          Documentation
88 Requires:       devhelp
89 %if "%{_rpmversion}" >= "5"
90 BuildArch:      noarch
91 %endif
92
93 %description apidocs
94 Reference documentation for gtkmm and gdkmm.
95
96 %description apidocs -l pl.UTF-8
97 Szczegółowa dokumentacja gtkmm i gdkmm.
98
99 %prep
100 %setup -q -n gtkmm-%{version}
101
102 %build
103 %{__libtoolize}
104 %{__aclocal} -I build
105 %{__autoconf}
106 %{__autoheader}
107 %{__automake}
108 %configure \
109         %{?with_static_libs:--enable-static}
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %files
128 %defattr(644,root,root,755)
129 %doc AUTHORS ChangeLog NEWS PORTING README
130 %attr(755,root,root) %{_libdir}/libgdkmm-3.0.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/libgdkmm-3.0.so.1
132 %attr(755,root,root) %{_libdir}/libgtkmm-3.0.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libgtkmm-3.0.so.1
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/libgdkmm-3.0.so
138 %attr(755,root,root) %{_libdir}/libgtkmm-3.0.so
139 %{_libdir}/gdkmm-3.0
140 %{_libdir}/gtkmm-3.0
141 %{_includedir}/gdkmm-3.0
142 %{_includedir}/gtkmm-3.0
143 %{_pkgconfigdir}/gdkmm-3.0.pc
144 %{_pkgconfigdir}/gtkmm-3.0.pc
145
146 %if %{with static_libs}
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libgdkmm-3.0.a
150 %{_libdir}/libgtkmm-3.0.a
151 %endif
152
153 %files apidocs
154 %defattr(644,root,root,755)
155 %{_docdir}/gtkmm-3.0
156 %{_datadir}/devhelp/books/gtkmm-3.0
This page took 0.075216 seconds and 3 git commands to generate.