]> git.pld-linux.org Git - packages/gtkmm4.git/blame - gtkmm4.spec
- updated to 4.0.1
[packages/gtkmm4.git] / gtkmm4.spec
CommitLineData
33bee831
AF
1#
2# Conditional build:
65b7ef8d 3%bcond_without static_libs # static library
222a6ef9 4
65b7ef8d
JB
5%define atkmm_ver 2.29.1
6%define cairomm_ver 1.15.4
7%define glibmm_ver 2.68.0
8%define gtk4_ver 4.0.0
9%define pangomm_ver 2.48.0
33bee831
AF
10Summary: A C++ interface for the GTK+ (a GUI library for X)
11Summary(pl.UTF-8): Wrapper C++ dla GTK+
65b7ef8d 12Name: gtkmm4
4019aba0 13Version: 4.0.1
70058bc0 14Release: 1
33bee831
AF
15License: LGPL v2+
16Group: X11/Libraries
65b7ef8d 17Source0: https://download.gnome.org/sources/gtkmm/4.0/gtkmm-%{version}.tar.xz
4019aba0 18# Source0-md5: 69774cc079b34dd006b7bc49d81fe324
7c1d0224 19URL: https://www.gtkmm.org/
65b7ef8d 20BuildRequires: atkmm2.36-devel >= %{atkmm_ver}
33bee831 21BuildRequires: autoconf >= 2.59
31a8d119 22BuildRequires: automake >= 1:1.11
65b7ef8d 23BuildRequires: cairomm1.16-devel >= %{cairomm_ver}
c6e33ff3 24BuildRequires: doxygen >= 1:1.8.9
ef8910d5 25BuildRequires: gdk-pixbuf2-devel >= 2.36.0
65b7ef8d
JB
26BuildRequires: glibmm2.68-devel >= %{glibmm_ver}
27BuildRequires: gtk4-devel >= %{gtk4_ver}
70058bc0 28BuildRequires: libepoxy-devel >= 1.2
65b7ef8d
JB
29BuildRequires: libsigc++3-devel >= 3.0
30BuildRequires: libstdc++-devel >= 6:7
e3273d66 31BuildRequires: libtool >= 2:2.0
65b7ef8d
JB
32BuildRequires: mm-common >= 0.9.12
33BuildRequires: pangomm2.48-devel >= %{pangomm_ver}
33bee831
AF
34BuildRequires: perl-base >= 1:5.6.0
35BuildRequires: pkgconfig
c6e33ff3 36BuildRequires: rpmbuild(macros) >= 1.752
e3273d66
JB
37BuildRequires: tar >= 1:1.22
38BuildRequires: xz
65b7ef8d
JB
39Requires: atkmm2.36 >= %{atkmm_ver}
40Requires: cairomm1.16 >= %{cairomm_ver}
ef8910d5 41Requires: gdk-pixbuf2 >= 2.36.0
65b7ef8d
JB
42Requires: glibmm2.68 >= %{glibmm_ver}
43Requires: gtk4 >= %{gtk4_ver}
44Requires: pangomm2.48 >= %{pangomm_ver}
33bee831
AF
45BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47%description
48This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
49library. The interface provides a convenient interface for C++
50programmers to create GUIs with GTK+'s flexible object-oriented
51framework. Features include type safe callbacks, widgets that are
52extensible using inheritance and over 110 classes that can be freely
53combined to quickly create complex user interfaces.
54
55%description -l pl.UTF-8
56gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
57służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
58także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
59
60%package devel
61Summary: gtkmm and gdkmm header files
62Summary(pl.UTF-8): Pliki nagłówkowe gtkmm i gdkmm
63Group: X11/Development/Libraries
64Requires: %{name} = %{version}-%{release}
65b7ef8d
JB
65Requires: atkmm2.36-devel >= %{atkmm_ver}
66Requires: cairomm1.16-devel >= %{cairomm_ver}
ef8910d5 67Requires: gdk-pixbuf2-devel >= 2.36.0
65b7ef8d
JB
68Requires: glibmm2.68-devel >= %{glibmm_ver}
69Requires: gtk4-devel >= %{gtk4_ver}
70Requires: libstdc++-devel >= 6:7
71Requires: pangomm2.48-devel >= %{pangomm_ver}
33bee831
AF
72
73%description devel
74Header files for gtkmm library.
75
76%description devel -l pl.UTF-8
77Pliki nagłówkowe biblioteki gtkmm.
78
79%package static
80Summary: gtkmm and gdkmm static libraries
81Summary(pl.UTF-8): Biblioteki statyczne gtkmm i gdkmm
82Group: X11/Development/Libraries
83Requires: %{name}-devel = %{version}-%{release}
84
85%description static
86gtkmm and gdkmm static libraries.
87
88%description static -l pl.UTF-8
89Biblioteki statyczne gtkmm i gdkmm.
90
91%package apidocs
92Summary: Reference documentation for gtkmm and gdkmm
93Summary(pl.UTF-8): Szczegółowa dokumentacja gtkmm i gdkmm
94Group: Documentation
95Requires: devhelp
c6e33ff3 96%{?noarchpackage}
33bee831
AF
97
98%description apidocs
99Reference documentation for gtkmm and gdkmm.
100
101%description apidocs -l pl.UTF-8
102Szczegółowa dokumentacja gtkmm i gdkmm.
103
104%prep
105%setup -q -n gtkmm-%{version}
106
c6e33ff3
JB
107# missing in release tarball, not needed for Linux
108mkdir win32_installer
109touch win32_installer/filelist.am \
110 win32_installer/gtkmm-installer.nsi.in
111
33bee831 112%build
c6e33ff3 113mm-common-prepare --copy --force
33bee831
AF
114%{__libtoolize}
115%{__aclocal} -I build
116%{__autoconf}
117%{__autoheader}
118%{__automake}
119%configure \
c6e33ff3 120 --enable-maintainer-mode \
ef8910d5 121 --disable-silent-rules \
33bee831
AF
122 %{?with_static_libs:--enable-static}
123
124%{__make}
125
126%install
127rm -rf $RPM_BUILD_ROOT
128
129%{__make} install \
130 DESTDIR=$RPM_BUILD_ROOT
131
132%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
133
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137%post -p /sbin/ldconfig
138%postun -p /sbin/ldconfig
139
140%files
141%defattr(644,root,root,755)
3f8d9ad2 142%doc AUTHORS ChangeLog NEWS README
65b7ef8d
JB
143%attr(755,root,root) %{_libdir}/libgtkmm-4.0.so.*.*.*
144%attr(755,root,root) %ghost %{_libdir}/libgtkmm-4.0.so.0
33bee831
AF
145
146%files devel
147%defattr(644,root,root,755)
65b7ef8d
JB
148%attr(755,root,root) %{_libdir}/libgtkmm-4.0.so
149%{_libdir}/gtkmm-4.0
150%{_includedir}/gtkmm-4.0
151%{_pkgconfigdir}/gtkmm-4.0.pc
33bee831
AF
152
153%if %{with static_libs}
154%files static
155%defattr(644,root,root,755)
65b7ef8d 156%{_libdir}/libgtkmm-4.0.a
33bee831
AF
157%endif
158
159%files apidocs
160%defattr(644,root,root,755)
65b7ef8d
JB
161%{_docdir}/gtkmm-4.0
162%{_datadir}/devhelp/books/gtkmm-4.0
This page took 0.10483 seconds and 4 git commands to generate.