]> git.pld-linux.org Git - packages/gtk-webkit3.git/blame - gtk-webkit3.spec
- added TODO
[packages/gtk-webkit3.git] / gtk-webkit3.spec
CommitLineData
7200a9cd
AF
1# TODO:
2# - optflags
3# - review BR and R
4# - review configure options
f8e56294
AF
5#
6# Conditional build:
7%bcond_without introspection # disable introspection
8#
9Summary: Port of WebKit embeddable web component to GTK+
10Summary(pl.UTF-8): Port osadzalnego komponentu WWW WebKit do GTK+
11Name: gtk-webkit3
12Version: 1.3.11
7200a9cd 13Release: 0.1
f8e56294
AF
14License: BSD-like
15Group: X11/Libraries
16Source0: http://webkitgtk.org/webkit-%{version}.tar.gz
17# Source0-md5: 6d4506086fb0d274d1a2c871fcaf851e
18URL: http://webkitgtk.org/
19BuildRequires: autoconf >= 2.59
20BuildRequires: automake
21BuildRequires: bison
22BuildRequires: cairo-devel >= 1.6
23BuildRequires: enchant-devel >= 0.22
24BuildRequires: flex >= 2.5.33
25BuildRequires: fontconfig-devel >= 2.4.0
26BuildRequires: freetype-devel >= 1:2.1.8
27BuildRequires: geoclue-devel
28BuildRequires: gettext-devel
29BuildRequires: glib2-devel >= 1:2.22.0
30BuildRequires: glibc-misc
31%{?with_introspection:BuildRequires: gobject-introspection-devel >= 0.9.5}
32BuildRequires: gperf
33BuildRequires: gstreamer-devel >= 0.10
34BuildRequires: gstreamer-plugins-base-devel >= 0.10.25
35BuildRequires: gtk+2-devel >= 2:2.20.0
36BuildRequires: gtk-doc >= 1.10
37BuildRequires: libicu-devel >= 4.2.1
38BuildRequires: libjpeg-devel
39BuildRequires: libpng-devel
40BuildRequires: libsoup-devel >= 2.33.4
41BuildRequires: libstdc++-devel
42BuildRequires: libtool >= 2:1.5
43BuildRequires: libxml2-devel >= 1:2.6.30
44BuildRequires: libxslt-devel >= 1.1.7
45BuildRequires: pango-devel >= 1:1.12
46BuildRequires: pkgconfig
47BuildRequires: sqlite3-devel
48BuildRequires: xorg-lib-libXft-devel >= 2.0.0
49BuildRequires: xorg-lib-libXt-devel
50Requires: cairo >= 1.6
51Requires: enchant >= 0.22
52Requires: gstreamer-plugins-base >= 0.10.25
53Requires: gtk+2 >= 2:2.20.0
54Requires: libsoup >= 2.30.0
55Requires: libxml2 >= 1:2.6.30
56Requires: libxslt >= 1.1.7
57Requires: pango >= 1:1.12
58%{?with_introspection:Conflicts: gir-repository < 0.6.5-7}
59BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61%description
62webkit is a port of the WebKit embeddable web component to GTK+.
63
64%description -l pl.UTF-8
65webkit to port osadzalnego komponentu WWW WebKit do GTK+.
66
67%package devel
68Summary: Development files for WebKit
69Summary(pl.UTF-8): Pliki programistyczne WebKit
70Group: X11/Development/Libraries
71Requires: %{name} = %{version}-%{release}
72Requires: cairo-devel >= 1.6
73Requires: enchant-devel >= 0.22
74Requires: fontconfig-devel >= 2.4.0
75Requires: freetype-devel >= 1:2.1.8
76Requires: geoclue-devel
77Requires: glib2-devel >= 1:2.22.0
78Requires: gstreamer-devel >= 0.10
79Requires: gstreamer-plugins-base-devel >= 0.10.25
80Requires: gtk+2-devel >= 2:2.20.0
81Requires: libicu-devel >= 4.2.1
82Requires: libjpeg-devel
83Requires: libpng-devel
84Requires: libsoup-devel >= 2.30.0
85Requires: libstdc++-devel
86Requires: libxml2-devel >= 1:2.6.30
87Requires: libxslt-devel >= 1.1.7
88Requires: pango-devel >= 1:1.12
89Requires: sqlite3-devel
90Requires: xorg-lib-libXt-devel
91
92%description devel
93Development files for WebKit.
94
95%description devel -l pl.UTF-8
96Pliki programistyczne WebKit.
97
98%prep
99%setup -q -n webkit-%{version}
100
101%build
102%{__gtkdocize}
103%{__aclocal} -I Source/autotools
104%{__libtoolize}
105%{__autoheader}
106%{__automake}
107%{__autoconf}
108%configure \
109 --with-gtk=3.0 \
110 --disable-silent-rules \
111 --enable-3D-transforms \
112 --enable-dom-storage \
113 --enable-geolocation \
114 --enable-icon-database \
115 %{__enable_disable introspection} \
116 --enable-video \
117 --with-font-backend=freetype
118
119%{__make}
120
121%install
122rm -rf $RPM_BUILD_ROOT
123
124%{__make} install \
125 DESTDIR=$RPM_BUILD_ROOT
126
127: > webkit-3.0.lang
128#find_lang webkit-3.0
129
130%clean
131rm -rf $RPM_BUILD_ROOT
132
133%post -p /sbin/ldconfig
134%postun -p /sbin/ldconfig
135
136%files -f webkit-3.0.lang
137%defattr(644,root,root,755)
138%doc ChangeLog
139%attr(755,root,root) %{_bindir}/jsc-3
140%attr(755,root,root) %{_libdir}/libwebkitgtk-3.0.so.*.*.*
141%attr(755,root,root) %ghost %{_libdir}/libwebkitgtk-3.0.so.0
142%if %{with introspection}
143%{_libdir}/girepository-1.0/JSCore-3.0.typelib
144%{_libdir}/girepository-1.0/WebKit-3.0.typelib
145%endif
146%dir %{_datadir}/webkit-3.0
147%{_datadir}/webkitgtk-3.0/images
148%{_datadir}/webkitgtk-3.0/webinspector
149%{_datadir}/webkit-3.0/resources
150/usr/share/glib-2.0/schemas/org.webkitgtk-3.0.gschema.xml
151
152%files devel
153%defattr(644,root,root,755)
154%attr(755,root,root) %{_libdir}/libwebkitgtk-3.0.so
155%{_libdir}/libwebkitgtk-3.0.la
156%if %{with introspection}
157%{_datadir}/gir-1.0/JSCore-3.0.gir
158%{_datadir}/gir-1.0/WebKit-3.0.gir
159%endif
160%{_includedir}/webkit-3.0
161%{_pkgconfigdir}/webkitgtk-3.0.pc
This page took 0.088128 seconds and 4 git commands to generate.