]> git.pld-linux.org Git - packages/gtk+3.git/commitdiff
- added cloudproviders bcond to enable cloud providers in sidebar
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 25 Oct 2018 15:50:34 +0000 (17:50 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 25 Oct 2018 15:50:34 +0000 (17:50 +0200)
- added cloudproviders patch (libgtk uses libcloudproviders, not libgdk)

gtk+3-cloudproviders.patch [new file with mode: 0644]
gtk+3.spec

diff --git a/gtk+3-cloudproviders.patch b/gtk+3-cloudproviders.patch
new file mode 100644 (file)
index 0000000..71260a3
--- /dev/null
@@ -0,0 +1,20 @@
+--- gtk+-3.24.1/configure.ac.orig      2018-09-19 03:42:49.000000000 +0200
++++ gtk+-3.24.1/configure.ac   2018-10-25 16:43:10.987060909 +0200
+@@ -1375,7 +1375,7 @@
+ LDFLAGS="$saved_ldflags"
+ GDK_PACKAGES="$PANGO_PACKAGES gdk-pixbuf-2.0 >= gdk_pixbuf_required_version cairo >= cairo_required_version cairo-gobject >= cairo_required_version"
+-GDK_PRIVATE_PACKAGES="$GDK_GIO_PACKAGE $X_PACKAGES $WAYLAND_PACKAGES $MIR_PACKAGES $cairo_backends epoxy >= epoxy_required_version $CLOUDPROVIDER_PACKAGES"
++GDK_PRIVATE_PACKAGES="$GDK_GIO_PACKAGE $X_PACKAGES $WAYLAND_PACKAGES $MIR_PACKAGES $cairo_backends epoxy >= epoxy_required_version"
+ PKG_CHECK_MODULES(GDK_DEP, $GDK_PACKAGES $GDK_PRIVATE_PACKAGES)
+ GDK_DEP_LIBS="$GDK_EXTRA_LIBS $GDK_DEP_LIBS $MATH_LIB"
+@@ -1409,7 +1409,7 @@
+ PKG_CHECK_MODULES(ATK, $ATK_PACKAGES)
+ GTK_PACKAGES="atk >= atk_required_version cairo >= cairo_required_version cairo-gobject >= cairo_required_version gdk-pixbuf-2.0 >= gdk_pixbuf_required_version gio-2.0 >= glib_required_version"
+-GTK_PRIVATE_PACKAGES="$ATK_PACKAGES $WAYLAND_PACKAGES $MIR_PACKAGES epoxy >= epoxy_required_version"
++GTK_PRIVATE_PACKAGES="$ATK_PACKAGES $WAYLAND_PACKAGES $MIR_PACKAGES epoxy >= epoxy_required_version $CLOUDPROVIDER_PACKAGES"
+ if test "x$enable_x11_backend" = xyes -o "x$enable_wayland_backend" = xyes; then
+   GTK_PRIVATE_PACKAGES="$GTK_PRIVATE_PACKAGES pangoft2"
+ fi
index 34dff1e46c97a537d6d957f772e82f146308b97c..afc34008a01b465c0911bfb24ab0a372c1067f4e 100644 (file)
@@ -1,4 +1,3 @@
-# TODO: cloudproviders >= 0.2.5 or --disable-cloudproviders
 #
 # Conditional build:
 %bcond_without apidocs         # gtk-doc build
@@ -9,6 +8,7 @@
 %bcond_with    mir             # Mir target
 %bcond_with    typeahead       # Typeahead in open dialog
 %bcond_without wayland         # Wayland target
+%bcond_with    cloudproviders  # libcloudproviders integration
 %bcond_without static_libs     # static library build
 
 Summary:       The GIMP Toolkit
@@ -28,6 +28,7 @@ Source0:      http://ftp.gnome.org/pub/GNOME/sources/gtk+/3.24/gtk+-%{version}.tar.xz
 # Source0-md5: 9dfe16f486573815f242fa400763feb7
 Patch0:                %{name}-papi.patch
 Patch1:                typeahead.patch
+Patch2:                %{name}-cloudproviders.patch
 URL:           http://www.gtk.org/
 BuildRequires: at-spi2-atk-devel >= 2.6.0
 BuildRequires: atk-devel >= 1:2.16.0
@@ -54,6 +55,7 @@ BuildRequires:        gtk-doc-automake >= 1.20
 BuildRequires: harfbuzz-devel >= 0.9
 BuildRequires: iso-codes
 %{?with_cloudprint:BuildRequires:      json-glib-devel >= 1.0}
+%{?with_cloudproviders:BuildRequires:  libcloudproviders-devel >= 0.2.5}
 BuildRequires: libepoxy-devel >= 1.4
 BuildRequires: libstdc++-devel
 BuildRequires: libtool >= 2:2.2.6
@@ -96,6 +98,7 @@ Requires:     atk >= 1:2.16.0
 Requires:      cairo-gobject >= 1.14.0
 Requires:      gdk-pixbuf2 >= 2.31.0
 Requires:      glib2 >= 1:2.50.0
+%{?with_cloudproviders:Requires:       libcloudproviders >= 0.2.5}
 Requires:      libepoxy >= 1.4
 Requires:      pango >= 1:1.41.0
 Requires:      xorg-lib-libXi >= 1.3.0
@@ -286,6 +289,7 @@ ModuĊ‚ GTK+ do drukowania przez PAPI.
 %if %{with typeahead}
 %patch1 -p1
 %endif
+%patch2 -p1
 
 # for packaging clean examples
 # TODO: add am patch to do it like demos/gtk-demo via some configurable dir
@@ -309,7 +313,8 @@ CPPFLAGS="%{rpmcppflags}%{?with_papi: -I/usr/include/papi}"
        %{!?with_cloudprint:--disable-cloudprint} \
        %{__disable cups} \
        %{!?with_papi:--disable-papi} \
-       %{?debug:--enable-debug=yes} \
+       %{?with_cloudproviders:--enable-cloudproviders} \
+       %{?debug:--enable-debug} \
        %{__enable_disable apidocs gtk-doc} \
        --enable-man \
        %{__enable_disable static_libs static} \
This page took 0.432073 seconds and 4 git commands to generate.